XML Author
Oxygen XML Author 19.0 User Guide
  • Getting Started
    • What is Oxygen XML Author
    • Getting Familiar with the Layout
    • Supported Document Types
    • Resources to Help You Get Started Using Oxygen XML Author
    • Your First Document or Project
      • Your First XML Document
      • Your First DITA Topic
      • Creating a New Project
    • Getting Help
      • Help Menu
    • Frequently Used Shortcut Keys
  • Editing Documents
    • Working with Unicode
      • Opening and Saving Documents with Unsupported Characters
      • Inserting Symbols
      • Unicode Fallback Font Support
    • Creating and Working with Documents
      • Creating New Documents and Templates
      • Opening Documents
      • Saving Documents
      • Opening and Saving Remote Documents
      • Switching and Moving File Tabs
      • Closing Documents
      • Contextual Menu of the Current Editor Tab
      • Viewing File Properties
    • Searching Documents
      • Open/Find Resource View
      • Open/Find Resource Dialog Box
      • Searching in Content
      • Searching in File Paths
      • Searching in Reviews
      • Technical Aspects
    • Using Projects to Group Documents
      • Creating a New Project
      • Project View
      • Sharing a Project - Team Collaboration
      • Master Files Support
    • Editing XML Documents
      • Editing XML Documents in Text Mode
      • Editing XML Documents in Grid Mode
      • Editing XML Documents in Author Mode
      • Validating XML Documents
      • XML Quick Fixes
      • Associating a Schema to XML Documents
      • Finding and Replacing Text in the Current File
      • Finding and Replacing Text in Multiple Files
      • Search and Refactoring Actions for IDs and IDREFS
      • Working with Modular XML Files in the Master Files Context
      • XML Resource Hierarchy/Dependencies View
      • Working with XML Catalogs
      • Editing Large XML Documents with DTD Entities or XInclude
      • Viewing Status Information
      • Making a Persistent Copy of Results
      • Editor Highlights
      • Printing a Document
      • Refactoring XML Documents
    • Editing CSS Stylesheets
      • Validating CSS Stylesheets
      • Content Completion in CSS Stylesheets
      • Syntax Highlighting in CSS Files
      • CSS Outline View
      • Folding in CSS Stylesheets
      • Formatting and Indenting CSS Stylesheets (Pretty Print)
      • Minifying CSS Stylesheets
    • Editing LESS Stylesheets
      • Validating LESS Stylesheets
      • Content Completion in LESS Stylesheets
      • Syntax Highlighting in LESS Files
      • Compiling LESS Stylesheets to CSS
    • Editing StratML Documents
    • Editing XLIFF Documents
    • Editing JavaScript Documents
      • JavaScript Editing Actions
      • Validating JavaScript Files
      • Content Completion in JavaScript Documents
      • Syntax Highlighting in JavaScript Documents
      • JavaScript Outline View
    • Editing SVG Files
      • Standalone SVG Viewer
      • Integrated SVG Viewer in the Results Panel
    • Editing XHTML Documents
    • Editing Markdown Documents
      • Markdown Editor
      • Creating New Markdown Documents
      • Actions Available in the Markdown Editor
      • Syntax Highlighting in the Markdown Editor
      • Automatic Validation in Markdown Documents
      • Working with Markdown Documents in DITA
      • Markdown Editor Syntax Rules and Specifications
    • Editing Non-XML Files
    • Spell Checking
      • Spell Check Dictionaries and Term Lists
      • Learned Words
      • Ignored Words (Elements)
      • Automatic Spell Check
      • Spell Check Multiple Files
    • AutoCorrect Misspelled Words
      • Add Dictionaries for the AutoCorrect Feature
    • Loading Large Documents
      • File Sizes Smaller than 300 MB
      • File Sizes Greater than 300 MB
    • Scratch Buffer
    • Handling Read-Only Files
    • Editing Documents with Long Lines
    • XML Digital Signatures
      • Digital Signatures Overview
      • Certificates
      • Canonicalizing Files
      • Signing Files
      • Verifying Signature
      • Example of How to Digitally Sign XML Files or Content
    • Compare Files or Directories
      • Compare Files
      • Compare Directories
      • Compare Directories Against a Base (3-Way)
  • Publishing
    • Transformation Scenarios
      • Built-in Transformation Scenarios
      • Creating New Transformation Scenarios
      • Editing a Transformation Scenario
      • Duplicating a Transformation Scenario
      • Configure Transformation Scenario(s) Dialog Box
      • Apply Batch Transformations
      • Sharing Transformation Scenarios
      • Transformation Scenarios View
      • Debugging PDF Transformations
      • Configuring Calabash with XEP
      • Integration of an External XProc Engine
      • XSLT Processors
      • XSL-FO Processors
    • WebHelp System Output
      • WebHelp Responsive System
      • WebHelp Classic System
      • WebHelp Classic Mobile System (Deprecated)
      • Using the Oxygen XML WebHelp Plugin to Automate Output
  • Databases and CMS
    • Working with Databases
      • Data Source Explorer View
      • Table Explorer View
      • Database Connection Support
      • WebDAV Connections
      • SQL Execution Support
    • Content Management System (CMS) Integration
      • Integration with Documentum (CMS) (deprecated)
      • Integration with Microsoft SharePoint
Index
  1. Home
  2. Databases and CMS
  3. Working with Databases
  4. Database Connection Support
  5. MySQL Database Connections
  6. Configuring a MySQL Database Connection

Configuring a MySQL Database Connection

To configure the support for a MySQL database, follow this procedure:

  1. Configure MySQL Data Source drivers.
  2. Configure a MySQL Connection.
  3. To view your connection, go to the Data Source Explorer view (if the view is not displayed, it can be opened by selecting it from the Window > Show View menu) or switch to the Database perspective.
  1. How to Configure MySQL Data Source Drivers
  2. How to Configure a MySQL Connection
  • Databases and CMS
    • Working with Databases
      • Data Source Explorer View
      • Table Explorer View
      • Database Connection Support
        • IBM DB2 Database Connections
        • Microsoft SQL Server Database Connections
        • Oracle Database Connections
        • PostgreSQL Database Connections
        • Berkeley DB XML Database Connections
        • eXist Database Connections
        • MarkLogic Database Connections
        • Documentum xDB (X-Hive/DB) 10 Database Connections
        • MySQL Database Connections
          • Configuring a MySQL Database Connection
            • How to Configure MySQL Data Source Drivers
            • How to Configure a MySQL Connection
        • Generic JDBC Database Connections
        • JDBC-ODBC Database Connections
        • BaseX Database Connections
      • WebDAV Connections
      • SQL Execution Support
    • Content Management System (CMS) Integration