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Chapter 1. Introduction
Welcome to the User Manual of the <oXygen/> XML Author 10.3 ! This book explains how to use the 10.3 version
of the <oXygen/> XML Author effectively to author XML documents visually in a WYSIWYG like way quickly and
easily.

The <oXygen/> XML Author is a cross-platform application for authors who want to edit XML documents visually
without extensive knowledge about XML and XML related technologies. The WYSIWYG like editor is driven by CSS
stylesheets associated with the XML documents and offers the option to switch off XML tags completely when editing
an XML document.

Key Features and Benefits
The <oXygen/> XML Author offers the following key features and benefits.

Multilanguage support: English, German, French, Dutch,
Italian and Japanese

Multiplatform availability: Windows, Mac OS X, Linux,
Solaris

Visual DITA Map editorVisual WYSIWYG XML editing mode based on W3C
CSS stylesheets.

Support for latest versions of document frameworks:
DocBook and TEI.

Closely integrate with the DITA Open Toolkit for gener-
ating DITA output

Non blocking operations, you can perform validation and
transformation operations in background

Can be used as standalone desktop application, run
through Java Web Start or as an Eclipse plugin

Support for XML, CSS, XSLT, XSL-FO.

Multiple built-in XSLT transformers (Saxon 6.5, Saxon
B, Saxon SA, Saxon.NET, Xalan, libxslt, MSXML 3.0 /

Multiple built-in validation engines (Xerces, libxml,
Saxon SA, MSXML 4.0, MSXML.NET) and support for
custom validation engines (XSV, SQC). 4.0, Microsoft .NET 1.0, Microsoft .NET 2.0), support

for custom JAXP transformers.

Compare and merge files and directoriesSupport for latest versions of document frameworks:
DocBook and TEI.

XInclude supportReady to use FOP support to generate PDF or PS docu-
ments

Easy error tracking - locate the error source by clicking
on it

Support for editing remote files over FTP, SFTP, HT-
TP/WebDAV and HTTPS/WebDAV

Context sensitive content assistant driven by XML
Schema, Relax NG, DTD, NVDL or by the edited docu-
ment structure enhanced with schema annotation presenter

New XML document wizards to easily create documents
specifying a schema or a DTD

Unicode supportXML Catalog support

Easy configuration for external FO ProcessorsPretty-printing of XML files

XPath search and evaluation supportApply XSLT and FOP transformations

Support for document templates to easily create and share
documents

Preview transformation results as XHTML or XML or in
your browser

XML project managerCanonicalize and sign documents

Fully-fledged client for the Subversion (SVN) versioning
system with support for SVN 1.3 and SVN 1.4 repositor-
ies.

Batch validate selected files in project
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Configurable actions key bindingsConfigurable external tools

Special viewer for very large files (up to 2 GB file size).Multi-line find and replace support allows regular expres-
sions, is XML aware, is incremental, handles multiple
files

Bookmark supportAssociate extensions on Windows

Print documentsMac OS X ready

Attributes ViewModel View

SVG ViewerMultidocument environment

XPath 2.0 supportXSLT 2.0 full support

Document foldingDockable views and editors

Custom protocol plugin supportSpell checking supporting English, German and French
including locals

Drag&drop supportAll the usual editor capabilities (cut, copy, paste, find,
replace, windows management)

Outline view in sync with a non well-formed documentSupport for editing, modifying and using files directly
from ZIP-type archives
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Chapter 2. Installation
This section explains platform requirements and installation procedures. It also provides instructions on how to obtain
and register a license key, how to perform upgrades and uninstall the application if required.

If you need help at any point during these procedures please send email to <support@oxygenxml.com>

Installation Requirements

Platform Requirements
Minimum run-time requirements are listed below.

• Pentium Class Platform

• 256 MB of RAM

• 300 MB free disk space

Operating System,Tools and Environment Requirements

Operating System

Windows Windows 98 or later.

Mac OS minimum Mac OS X 10.4

UNIX/Linux All versions/flavors

Tools

Installation packages are supplied in compressed archives. Ensure you have installed a suitable archive extraction
utility with which to extract the archive. The MD5 sum is available on the Download page
[http://www.oxygenxml.com/download.html] for every archive. You should check the MD5 sum of the downloaded
archive with a MD5 checking tool available on your platform.

Environment Prerequisites

Prior to installation ensure that your Operating System environment complies with the following:

• <oXygen/> XML Author supports only official and stable Java virtual machine versions 1.5.0 and later from Sun
Microsystems (available at http://java.sun.com) and from Apple Computer (pre-installed on Mac OS X). For Mac
OS X, Java VM updates are available at http://www.apple.com/macosx/features/java/. <oXygen/> XML Author
may work very well with JVM implementations from other vendors but the eventual incompatibilities will not be
solved in further <oXygen/> XML Author releases. <oXygen/> XML Author does not work with the GNU libgcj
Java virtual machine [http://www.oxygenxml.com/forum/ftopic1887.html].

• The PATH environment variable is set to the most current Java VM installation.

• References to older Java VM installations are removed from the PATH.
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Installation Instructions
Prior to proceeding with the following instructions, please ensure that your system complies with the prerequisites
detailed in the installation requirements.

Note

The following instructions assume that a Java Runtime Environment (JRE) is installed. If you have downloaded
an installation package that contains the JRE, please note that the package will automatically install a JRE prior
to execution of the application but this JRE will be used on your computer only for running <oXygen/> XML
Author , it will be invisible to other applications.

Note

The installation kits and the executable files packaged inside the installation kits were checked before publication
with an antivirus program to make sure they are not infected with viruses, trojan horses or other malicious software.

Procedure 2.1. Windows Installation

1. Download the author.exe  installation kit and run it.

2. Follow the instructions presented in the installation program. The user preferences are stored in the subfolder
com.oxygenxml.author of the folder that is the value of the APPDATA Windows variable for the user that
starts the application.

Note

In order to specify another Java virtual machine to be used by <oXygen/> XML Author you have to set the
home folder of the desired JVM in the Windows variable JAVA_HOME or in the Windows variable
JDK_HOME. If JAVA_HOME and JDK_HOME are not set the application launcher will try to detect a
JVM installed in a standard location on the computer and use it for running the application. If you installed
the kit which includes a Java virtual machine you have to rename of remove the jre subfolder of the install
folder in order for the variable JAVA_HOME or JDK_HOME to have an effect.

Procedure 2.2. Mac OS X Installation

1. Create a folder called author on your local disk.

2. Within the author folder, create child folder named in accordance with the version number of the application.
The directory structure looks as follows: /../author/10.3/

3. Download the Mac OS X Installation package ( author.tar.gz ) to this folder.

4. Extract the archive to the same folder.

5. Execute the file named author

Note

<oXygen/> XML Author uses the first JVM from the list of preferred JVM versions set on your Mac computer
that has the version number not less than 1.5.0. To change the version of the Java virtual machine that runs
the application you must move your desired JVM version up in the preferred list by dragging it with the

4

Installation



mouse on the first position in the list of JVMs available from Applications -> Utilities -> Java -> Java
Preferences.

Procedure 2.3. Linux Installation

1. Download the author.sh  installation kit and run it.

2. Follow the instructions presented in the installation program.

Note

In order to specify another Java virtual machine to be used by <oXygen/> XML Author you have to set the
home folder of the desired JVM in the environment variable JAVA_HOME or in the environment variable
JDK_HOME. If JAVA_HOME and JDK_HOME are not set the application launcher will try to detect a
JVM installed in a standard location on the computer and use it for running the application.

Procedure 2.4. All Platforms Installation

1. Create a folder called author on your local disk.

2. Within the author folder, create child folder named in accordance with the application version number. The
directory structure looks as follows: /../author/10.3/

3. Download the All Platforms Installation package ( author.tar.gz ) to this folder.

4. Extract the archive to the same folder.

5. Run from a command line the script author.bat on Windows, authorMac.sh on Mac OS X, author.sh
on Unix/Linux.

Note

To change the version of the Java virtual machine that runs the application you have to specify the full path
to the java executable of the desired JVM version in the Java command at the end of the script file, for ex-
ample:

"C:\Program Files\Java\jre1.5.0_13\bin\java" -Xmx256m 
 -Dsun.java2d.noddraw=true ...

on Windows,

/System/Library/Frameworks/JavaVM.framework/Versions/
1.5.0/Home/bin/java "-Xdock:name=Author" ...

on Mac OS X.

Procedure 2.5. Windows NT Terminal Server

1. Install the application on the server, making its shortcuts available to all users.

2. Edit the author.vmoptions file located in the install folder, adding the parameter -Dcom.oxygenxml.Mul-
tipleInstances=true so that the file content looks like:
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 -Xmx256m
 -Dcom.oxygenxml.MultipleInstances=true

The "-Xmx" value represents the maximum memory for each application instance. Please make sure you tune
them in a way that the multiple editor instances won't use all the available physical memory.

Procedure 2.6. Unix/Linux Server

1. Install the editor on the server, making sure the author.sh script is executable and the installation directory is
in the PATH of the users that need to use the editor.

2. Create a file called author.vmoptions in the <oXygen/> XML Author install folder where the author10.3
file is located. The content of the file must be:

-Xmx256m -Dcom.oxygenxml.MultipleInstances=true

The "-Xmx" value represents the maximum memory for each editor instance. Please make sure you tune it in a
way that the multiple editor instances won't use all the available physical memory.

3. Make sure the X server processes located on the workstations allow connections from the server host. For this
use the xhost command.

4. Telnet (or ssh) on the server host.

5. Start an xterm process, with display on the workstation. Ex:  xterm -display workstationip:0.0

6. Start the application by typing author.sh

Unattended installation
Unattended installation is possible only on Windows and Linux by running the installer executable from command
line and passing the -q parameter. The installer executable is called author.exe on Windows and author.sh on
Linux

In unattended mode the installer does not overwrite files with the same name if a previous version of the application
is installed in the same folder. The -overwrite parameter added after -q forces overwriting these files.

If the installer is executed in silent (unattended) mode and -console is passed as a second parameter after -q a console
will be allocated on Windows that displays the output of the installer. The command for running the installer is in this
case:

start /wait author.exe  -q -console

By default an unattended installation applies the default settings of the installer. If you want to install the application
on a large number of computers but you need to change the default values of some settings (like the install folder on
disk, whether a desktop icon or a quick launch shortcut are created, the file associations created in the operating system,
the name of the program group on the Start menu, etc.) then you should use a special settings file which specifies the
new values for these settings. To generate the settings file you have to run the installer in normal attended mode once
on a test computer and specify the exact options that you want for the unattended installation. When the installation is
completed a file called response.varfile and containing your selected options is created in the .install4j
subfolder of the installation folder, by default C:\Program Files\Oxygen XML Author 10\.install4j
on Windows. This is a one time process. After that for applying these options on all the computers where an unattended
installation is performed you have to specify this file in the command line, for example copy the file in the same location
as the installer program and use the command:
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- on Windows: author.exe -q -varfile response.varfile

- on Linux: author.sh   -q -varfile response.varfile

Setting a parameter in the startup script
On the Windows platform if you start the application by double-clicking on the Start menu shortcut/Desktop shortcut
in order to set a startup parameter you have to add a line with the parameter to the file author.vmoptions located
in the installation directory together with the launcher file called author.exe. If the file author.vmoptions
does not exist yet in the folder of the launcher file you have to create it there. For example for setting the maximum
amount of Java memory to 600 MB the content of the file author.vmoptions must be:

-Xmx600m

If you start the application with the script author.bat you have to add or modify the parameter to the java command
at the end of the script. For example for setting the maximum amount of Java memory to 600 MB the java command
should start with:

java -Xmx600m -Dsun.java2d.noddraw=true ...

On the Mac OS X platform to add or modify a startup parameter you have to right-click on the <oXygen/> XML Author
application icon in Finder, in the pop-up menu select Show Package Contents, then in the Contents  directory you edit
the file Info.plist: in the key VMOptions you modify the parameter if it already exists in that key or you add it
after the model of the existing parameters inside that key.

On the Linux platform you have to create a file called author.vmoptions if it does not exist already and specify
the parameter exactly as in the case of the .vmoptions file on the Windows platform.

If you use the All platforms distribution you have to add or modify the startup parameter that you want to set in the
java command line at the end of the startup script author.bat on Windows, authorMac.sh on Mac OS X and
author.sh on Linux. All these files are located in the installation directory. For example for setting the maximum
amount of Java memory to 600 MB on Windows the -Xmx parameter must be modified in the java command at the
end of author.bat like this:

java -Xmx600m -Dsun.java2d.noddraw=true ...

on Mac OS X the java command at the end of authorMac.sh should look like:

java "-Xdock:name=Author"\
 -Dcom.oxygenxml.editor.plugins.dir="$AUTHOR_HOME/plugins"\
 -Xmx600m\

and on Linux the java command at the end of author.sh should look like:

java -Xmx600m\
 "-Dcom.oxygenxml.editor.plugins.dir=$AUTHOR_HOME/plugins"\

Starting the application
As a Java based application, the <oXygen/> XML Author can run on all Operating Systems that support the Java
Runtime Environment (JRE version 1.5.0 or later). The following instructions assume that JRE and the appropriate
<oXygen/> XML Author distribution package for your Operating System are installed.
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To start the application follow the instructions for the installed package:

Procedure 2.7. Windows

• From the Windows Explorer double-click author.exe .

Procedure 2.8. Linux

• At the prompt type:   sh author.sh .

Procedure 2.9. Mac OS X

• Double-click the author icon.

Procedure 2.10. All Platforms

• On Windows run author.bat . On Mac OS X run authorMac.sh . On Linux/Unix run author.sh

Obtaining and registering a license key
The <oXygen/> XML Author is not free software and requires a license in order to enable the application.

For demonstration and evaluation purposes a time limited license is available upon request from the <oXygen/>
[http://www.oxygenxml.com/register.html] web site. This license is supplied at no cost for a period of 30 days from
date of issue. During this period the <oXygen/> XML Author is fully functional enabling you to test all aspects of the
application. Thereafter, the application is disabled and a permanent license must be purchased in order to use the ap-
plication. For special circumstances, if a trial period of greater than 30 days is required, please contact
<support@oxygenxml.com> . All licenses are obtained from the <oXygen/> web site [http://www.oxygenxml.com]
.

For definitions and legal details of the license types available for <oXygen/> XML Author you should consult the End
User License Agreement received with the license key and available also on the <oXygen/> XML Author website at
http://www.oxygenxml.com/eula_author.html

Note

Starting with version 10.0 <oXygen/> accepts a license key for a newer version in the license registration dialog,
e.g. version 10.0 accepts a license key for version 11 or a license key for version 12.

Once you have obtained a license key the installation procedure is described below.

Named User license registration
1. Save a backup copy of the message containing the new license key.

2. Start the application.

3. Copy to the clipboard the license text as explained in the message.

4. If this is a new install of the application then it will display automatically the registration dialog when it is started.
In the case you already used the application and obtained a new license, use the menu option Help/Register to
make the registration dialog appear.
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Figure 2.1. Registration Dialog

5. Paste the license text in the registration dialog, and press OK.

You have the following alternative for the procedure of license install:

1. Save the license key in a file named licensekey.txt.

2. Copy the file in the application folder. In that way the license will not be asked when the application will start.

3. Start the <oXygen/> XML Author application.

How floating (concurrent) licenses work
If all the floating licenses are used in the same local network the installation procedure of floating licenses is the same
as for the Named User licenses. Within the same network the license management is done by communication between
the instances of <oXygen/> XML Author that are connected to the same local network and that run at the same time.
Any new instance of <oXygen/> XML Author that is started after the number of running instances is equal with the
number of purchased licenses will display a warning message and will disable the open file action.

If the floating licenses are used on machines connected to different local networks a separate license server must be
started and the licenses deployed on it.
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Procedure 2.11. Floating license server setup

1. Download the license server from one of the download URLs included in the registration email message with
your floating license key.

2. Run the downloaded Windows 32 bit installer or Windows 64 bit installer or unzip the all platforms zip archive
kit on your server machine. The Windows installer installs the license server as a Windows service, it provides
the option to start the Windows service automatically at Windows startup and it creates shortcuts in the Start menu
group for starting and stopping the Windows service manually. If you use the zip archive on Windows you have
to run the scripts provided in the archive for installing, starting, stopping and uninstalling the server as a Windows
service.

3. If you start the server with the script licenseServer.bat / licenseServer.sh you can leave the default
values for the parameters for the licenses folder and server port or you can set these two parameters to other values.
The default folder for the floating license file is [license-server-install-dir]/license and the
default TCP/IP server port is 12346.

To change the default values of the license server the following parameters have to be used:

• -licenseDir followed by the path of the directory where the license files will be placed;

• -port followed by the port number used to communicate with <oXygen/> XML Author instances.

Important

The license folder must contain a text file called license.txt which must contain a single floating license
key corresponding to the set of purchased floating licenses. If you have more than one floating license key
for the same <oXygen/> version obtained from different purchases please contact us at support@oxy-
genxml.com to merge your license keys into a single one.

After the floating license server is set up the <oXygen/> XML Author application can be started and configured to
request a license from it:

Procedure 2.12. Request a floating license from the license server

1. Start the application.

2. Go to Help -> Register... . The license dialog is displayed.

3. Check the Use a license server checkbox.

4. Fill-in the Host text field with the host name or IP address of the license server.

5. Fill-in the Port text field with the port number used for communicating with the license server. Default is 12346.

6. Click the OK button. If the maximum number of available licenses was not exceeded a license key is received
from the floating license server and registered in <oXygen/> XML Author. The license details are displayed in
the About dialog opened from menu Help. If the maximum number of licenses was exceeded a warning dialog
will pop up letting the user know about the problem.
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Figure 2.2. Floating license number exceeded

The error message contains information about the users who requested and successfully received the floating li-
censes.

How to install the <oXygen/> XML Author license server as a Windows
service

In order to install the <oXygen/> XML Author license server as a Windows service you should run the Windows installer
downloaded from the URL provided in the registration email message containing your floating license key.

If you want to install, start and uninstall yourself the server as a Windows service you can run the scripts created in
the install folder from a command line console with the install folder of the license server as the current folder (on
Windows Vista you have to run the console as Administrator). For installing the Windows service:

installWindowsService.bat

After installing the server as a Windows service, use the following two commands to start and stop the license server:

startWindowsService.bat

stopWindowsService.bat

Uninstalling the Windows service requires the following command:

uninstallWindowsService.bat

The installWindowsService.bat script installs the <oXygen/> XML Author license server as a Windows
service with the name "oXygenLicenseServer" and accepts two parameters: the path of the folder containing the
floating license key files and the local port number on which the server accepts connections from instances of the
<oXygen/> XML Author. The parameters are optional. The default values are:

license for the license file folder

12555 for the local port number

The JAVA_HOME variable must point to the home folder of a Java runtime environment installed on your Windows
system.

The startService.bat script starts the Windows service so that the license server can accept connections from <oXygen/>
XML Author clients.

The stopService.bat script stops the Windows service. The license server is shut down and it cannot accept connections
from <oXygen/> XML Author clients.

The uninstallService.bat script uninstalls the Windows service created by the installService.bat script.
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When the license server is used as a Windows service the output messages and the error messages cannot be viewed
as for a command line script so that they are redirected automatically to the following log files created in the directory
where the license server is installed:

outLicenseServer.log the standard output stream of the server

errLicenseServer.log the standard error stream of the server

On Windows Vista if you want to start or stop the Windows service with the Start menu shortcut called Start Windows
service / Stop Windows service you have to run the shortcut as Administrator. This is a standard option for running
Start menu shortcuts on Windows Vista and is necessary for giving the required permission to the command that starts
/ stops the Windows service.

How to release a floating license

The floating license key registered for the current <oXygen/> XML Author instance will be released automatically
when the <oXygen/> XML Author instance is closed. If you do not have Internet access to connect to the floating license
server and you own also an individual license which you want to use in this case instead of the floating license, you
have to open the license registration dialog again by going to Help -> Register, uncheck the Use a license server
checkbox, press the Paste button to paste the individual license and press OK to switch from the floating license to
the pasted individual license.

License registration with a registration code
If you have only a registration code and you want to register the associated license key you must request this license
key by filling the registration code and other details associated with your license in a request form on the <oXygen/>
website. The button Request license for registration code in the registration dialog available from menu Help →
Register opens this request form in the default Web browser on your computer.

Unregistering the license key
Sometimes you need to unregister your license key, for example to release a floating license to be used by other user
and still use the current <oXygen/> XML Author instance with an individual, Named User license, or to transfer your
license key to other computer before other user starts using your current computer. This is done by going to Help →
Register to display the license registration dialog, making sure the text area for the license key is empty and the
checkbox Use a license server is unchecked, and pressing the OK button of the dialog. This brings up a confirmation
dialog in which you select between falling back to the license key entered previously (for the case of releasing a
floating license and reverting to the individual license entered previously in the Register dialog) and removing your
license key from your user account of the computer.

Figure 2.3. Unregister a license key
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Upgrading the <oXygen/> XML Author application
From time to time, upgrade and patch versions of <oXygen/> XML Author are released to provide enhancements that
rectify problems, improve functionality and the general efficiency of the application.

This section explains the procedure for upgrading <oXygen/> XML Author while preserving any personal configuration
settings and customizations.

Unless otherwise stated by instructions supplied with a patch or upgrade kit, the following procedure is recommended:

Procedure 2.13. Upgrade Procedure

1. Create a new folder under /../author e.g. /../author/10.3

2. Download and extract the upgrade to the new folder.

3. If you have defined <oXygen/> XML Author in the system PATH, modify it to the new installation folder.

4. Start <oXygen/> XML Author to ensure that the application can start and that your license is recognized by the
upgrade installation.

5. If you are upgrading to a major version, for example from 8.3 to 9.0, then you will need to enter the new license
text into the registration dialog that is shown when the application is started.

6. Select Help → About to determine the version number. If the previous version was 8.3, the About dialog should
now show version 9.0.

Checking for new versions
<oXygen/> XML Author offers the option of checking for new versions at the http://www.oxygenxml.com site when
the application is started. If this option is enabled a message dialog will notify the user when new versions are released.

You can check for new versions manually at any time by going to menu Help → Check for New Versions

Uninstalling the application
Caution

The following procedure will remove <oXygen/> XML Author from your system. Please ensure that all valuable
data is saved to another location prior to performing this procedure.

Procedure 2.14. Uninstall Procedure

1. Backup all valuable data from the <oXygen/> XML Author installation folder.

2. On Windows use the appropriate uninstaller shortcut provided with your OS.

On Mac OS X and Unix manually delete the installation folder and all its contents.

3. If you wish to completely remove the application directory and any work saved in it, you will have to delete this
directory manually. To remove the application configuration and any personal customizations remove the %APP-
DATA%\com.oxygenxml.author directory on Windows (usually %APPDATA% has the value [user-home-
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dir]\Application Data) / .com.oxygenxml.author on Linux / Library/Preferences/com.oxy-
genxml.author on Mac OS X from the user home directory.

Unattended uninstall
If you want to run an unattended uninstall this is possible only on Windows and Linux by running the uninstaller ex-
ecutable from command line and passing the -q parameter. The uninstaller executable is called uninstall.exe on
Windows and uninstall on Linux and is located in the install folder of the application.

Performance problems

Large documents
When started from the icon created on the Start menu or the Desktop on Windows and from the shortcut created on
the Linux desktop the maximum memory available to <oXygen/> XML Author is set by default to 40% of the amount
of physical RAM but not more than 700 MB. When started from the command line scripts the maximum memory is
256 MB. If large documents (more than 10 MB) are edited in <oXygen/> XML Author and you see that performance
slows down considerably after some time then a possible cause is that it needs more memory in order to run properly.
You can increase the maximum amount of memory available to <oXygen/> XML Author by setting the -Xmx parameter
in a configuration file specific to the platform that runs the application. For example if your file has a size of 50 MB
setting a parameter -Xmx800m should be enough for opening and editing the file in <oXygen/> XML Author

Warning

The maximum amount of memory should not be equal to the physical amount of memory available on the machine
because in that case the operating system and other applications will have no memory available.

Note

You can use the Large File Viewer to view huge XML files (up to two gigabytes) which would be otherwise be
impossible to open in the editor.

When installed on a multi-user environment such as Windows Terminal Server or Unix/Linux, to each instance of
<oXygen/> XML Author will be allocated the amount stipulated in the memory value. To avoid depreciating the gen-
eral performance of the host system, please ensure that the amount of memory available is optimally apportioned for
each of the expected instances.

External processes
The amount of memory allocated for generating PDF output with the built-in Apache FOP processor is controlled by
a different setting available in <oXygen/> XML Author Preferences: Memory available to the built-in FOP. In case
of Out Of memory errors this is the setting that must be modified for allowing more memory for the built-in FOP.

For external XSL-FO processors configured in Preferences -> XML -> XSLT/FO/XQuery -> FO Processors and for
external XSLT processors configured in Preferences -> XML -> XSLT/FO/XQuery -> Custom Enginesand for external
tools configured in Preferences -> External Tools the maximum memory must be set in the command line of the tool
with a parameter -Xmx set to the Java virtual machine.
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Display problems on Linux/Solaris
Display problems like screen freeze or momentary menu pop-ups during mouse movements over screen on Linux or
Solaris can be solved by specifying the parameter

-Dsun.java2d.pmoffscreen=false
for the Java virtual machine. This parameter disables off-screen pixmap support and must be added to the Java command
line which starts the Java virtual machine at the end of the file oxygen10.3 located in the install directory.
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Chapter 3. Getting started
Supported types of documents
The <oXygen/> XML Author provides a rich set of features for working with:

• XML documents and applications

• CSS documents

Getting help
Online help is available at any time while working in <oXygen/> XML Author by going to menu Help → Help ...
which opens the Help dialog.

Figure 3.1. The Help dialog

Context sensitive help is available from any dialog or view by pressing the F1 key which opens the same Help dialog
directly on a relevant page for the current view or dialog which has the editing focus.
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The Help dialog is modal so it does not allow other editing actions in the <oXygen/> XML Author editors, views and
dialogs. The same help content is available in the view Perspective → Show View → Dynamic Help (also available
from menu Help → Dynamic Help ) which allows editing actions when it is visible on screen and which switches
automatically to the relevant help page for the focused editor, view or dialog..

Figure 3.2. The Dynamic Help View

The name and version of the third-party libraries and frameworks used by <oXygen/> XML Author are listed in the
About dialog box: Help → About ... Also you can see here the values of system properties like the version of the Java
virtual machine, the location of the user home directory, the Java classpath, etc.

Perspectives
The <oXygen/> XML Author interface uses standard interface conventions and components to provide a familiar and
intuitive editing environment across all operating systems.

In <oXygen/> XML Author you can work with documents in one of the perspectives:
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Editor perspective Editing of documents is supported by specialized and synchronized editors and
views.

Database perspective Multiple connections to both relational databases and native XML ones can be
managed at the same time in this perspective: database browsing, SQL execution,
XQuery execution and data export to XML.

Editor perspective
The Editor perspective is used for editing the content of your documents. The space is organized in:

Figure 3.3. Editor perspective

When two or more panels are displayed, the application provides divider bars. By selecting a divider bar, it can be
dragged to a new position, therefore increasing the space occupied by one panel while decreasing it for the other.

As majority of the work process centers around the Editor panel, other panels can be hidden from view using the expand
and collapse controls located on the divider bars.

This perspective organizes the workspace in the following panels:

Main menu Provides menu driven access to all the features and functions available within <oXygen/>.

Main toolbar Provides easy access to common and frequently used functions. Each icon is a button that
acts as a shortcut to a related function.
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Editor panel The place where you spend most of your time, reading, editing, applying markup and
checking the validity and form of your documents.

Outline view Provides the following functions: XML document overview, modification follow-up, docu-
ment structure change, document tag selection.

Model view panel Presents the structure of the current edited tag and additional tag documentation.

Results panel Displays result messages returned from user operations. The following actions are available:

• Hierarchical view  - that allows you to see the results in tree-like manner. Clicking on
a tree leaf highlights the corresponding line in the document.

• Flat view  - that will present the errors in a table-like manner. Clicking on a table row
highlights the corresponding line in the document.

• Remove selected  - removes the currently selected message from the list.

• Remove all  - clears the message list.

Navigation to the previous and next message is possible from the contextual menu or by
using the assigned shortcut keys. The default shortcut keys are Ctrl + Shift + ] for navigating
to the next and Ctrl + Shift + [ for navigating to the previous message.

Project view Enables the definition of projects and logical management of the documents it contains.

Database perspective
The Database perspective is similar to the Editor perspective. It allows you to manage a database, offering support for
browsing multiple connections at the same time, both relational and native XML databases, SQL execution, XQuery
execution and data export to XML.

This perspective offers database specific support for:

• Sleepycat Berkeley DB XML Database

• eXist XML Database

• IBM DB2 (Enterprise edition only)

• JDBC-ODBC Bridge (Enterprise edition only)

• MarkLogic (Enterprise edition only, XQuery support only)

• Microsoft SQL Server 2005 and Microsoft SQL Server 2008 (Enterprise edition only)

• MySQL (Enterprise edition only)

• Oracle 11g (Enterprise edition only)

• PostgreSQL 8.3 (Enterprise edition only)

• Software AG Tamino (Enterprise edition only)

• TigerLogic (Enterprise edition only, XQuery support only)

• Documentum xDb (X-Hive/DB) XML Database (Enterprise edition only)
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The XML capabilities of the databases marked in this list with "Enterprise edition only" are available only in the En-
terprise edition of <oXygen/>. The non-XML capabilities of any database listed here are available also in the Academic
and Professional editions of <oXygen/> by registering the database driver as a generic JDBC driver (the Generic JDBC
type in the list of driver types) when defining the data source for accessing the database in <oXygen/>. The non-XML
capabilities are browsing the structure of the database instance, opening a table in the Table Explorer view, handling
the values from columns of type XML Type as String values. The XML capabilities are: displaying an XML Schema
node in the tree of the database structure (for databases with such an XML specific structure) with actions for open-
ing/editing/validating the schemas in an <oXygen/> editor panel, handling the values from columns of type XML Type
as XML instance documents that can be opened and edited in an <oXygen/> editor panel, validating an XML instance
document added to an XML Type column of a table, etc.

For a detailed feature matrix that compares the Academic, Professional and Enterprise editions of <oXygen/> please
go to the <oXygen/> website [http://www.oxygenxml.com/feature_matrix.html].

Note

Only connections configured on relational data sources can be used to import to XML or to generate XML
schemas.

Figure 3.4. Database perspective

Main menu Provides menu driven access to all the features and functions available within <oXygen/>.

Main toolbar Provides easy access to common and frequently used functions. Each icon is a button that
acts as a shortcut to a related function.
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Editor panel The place where you spend most of your time, reading, editing, applying markup and
checking the validity and form of your documents.

Database explorer Provides browsing support for the configured connections.

Table explorer Provides table content editing support: insert a new row, delete a table row, cell value
editing, export to XML file.

Dockable views and editors
All the <oXygen/> views available in the Editor Perspective are dockable. You can drag them to any margin of another
view or editor inside the <oXygen/> window to form any desired layout. Also a view can be set to a floating state to
enable it to hover over other views and editors.

For gaining more editing space in the <oXygen/> window you should set one or more views to the auto hide state:
only the title will remain always visible, attached to one of the margins of the <oXygen/> window, the rest of the view
will be restored only by the mouse pointer hovering over the title or clicking the title. The view will become hidden
again when the mouse pointer goes out of the screen area covered by that view.

The editing area can be divided vertically in several editing panels by dragging the title of an editor inside the editing
area and dropping it when the frame of the dragged editor is painted in the desired position. In the attached figure you
can see how to unsplit the editing area by dragging the title of the personal.xml editor panel over personal-
schema.xml until the drop frame painted in dark grey covers all the personal-schema.xml editor panel and then
dropping it.
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Figure 3.5. Split the editing area by drag and drop of the editor title

Also the editing area can be divided vertically and horizontally with the split / unsplit actions available on the Split

toolbar and the Window menu:  Split horizontally,  Split vertically,  Unsplit.

Any <oXygen/> view or toolbar can be opened at any time from the menu items available in the menus Perspective
→ Show View and Perspective → Show Toolbar
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Chapter 4. Editing documents
Working with Unicode
Unicode provides a unique number for every character, no matter what the platform, no matter what the program, no
matter what the language. Unicode is an internationally recognized standard, adopted by industry leaders. The Unicode
is required by modern standards such as XML, Java, ECMAScript (JavaScript), LDAP, CORBA 3.0, WML, etc., and
is the official way to implement ISO/IEC 10646.

It is supported in many operating systems, all modern browsers, and many other products. The emergence of the Unicode
Standard, and the availability of tools supporting it, are among the most significant recent global software technology
trends. Incorporating Unicode into client-server or multi-tiered applications and websites offers significant cost savings
over the use of legacy character sets.

As a modern XML Editor, <oXygen/> provides support for the Unicode standard enabling your XML application to
be targeted across multiple platforms, languages and countries without re-engineering. Internally, the <oXygen/> XML
Editor uses 16bit characters covering the Unicode Character set.

As a Java application <oXygen/> comes with a default Java input method for typing characters with Unicode codes.
However the default input method does not cover all the Unicode codes, for example the codes for some accented
characters or characters of East Asian languages. Such characters can be inserted in the editor panel of <oXygen/>
either with the Character Map dialog available from menu Edit → Insert from Character Map or by installing a Java
input method that supports the insertion of the needed characters. The installation of a Java input method
[http://java.sun.com/products/jfc/tsc/articles/InputMethod/inputmethod.html] depends on the platform on which
<oXygen/> runs (Windows, Mac OS X, Linux, etc) and is the same for any Java application.

Opening and saving Unicode documents
On loading documents <oXygen/> reads the document prolog to determine the specified encoding type. This is then
used to instruct the Java Encoder to load support for and save using the code chart specified. In the event that the en-
coding type cannot be determined, <oXygen/> will prompt and display the Available Java Encodings dialog. This
dialog provides a list of all encodings supported by the Java platform.

Figure 4.1. Available Java encodings dialog

If the opened document contains a character which cannot be represented with the encoding detected from the document
prolog or selected from the Available Java Encodings dialog <oXygen/> applies the policy specified for handling such
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errors. If the policy is set to REPORT <oXygen/> displays an error dialog about the character not allowed by the en-
coding. If the policy is set to IGNORE the character is removed from the document displayed in the editor panel. If
the policy is set to REPLACE the character will be replaced with a standard replacement character for that encoding.

While in most cases you will use UTF-8, simply changing the encoding name will cause the file to be saved using the
new encoding. The appendix Unicode Character Encoding provides a matrix that matches common names with Java
Names. It also explains what you should type in the XML prolog to cause the document to be saved as the required
encoding.

On saving the edited document if it contains characters not included in the encoding declared in the document prolog
<oXygen/> will detect the problem and will signal it to the user who is required to resolve the conflict before he is
able to save the document.

Figure 4.2. Save with wrong encoding error

To edit document written in Japanese or Chinese, you will need to change the font to one that supports the specific
characters (a Unicode font). For the Windows platform, use of Arial Unicode MS or MS Gothic is recommended. Do
not expect Wordpad or Notepad to handle these encodings. Use Internet Explorer or Word to eventually examine XML
documents.

When a document with a UTF-16 encoding is edited and saved in <oXygen/>, the saved document will have a byte
order mark (BOM) which will specify the byte order of the document's content. The default byte order is platform de-
pendent. That means that a UTF-16 document created on a Windows platform (where the default byte order mark is
UnicodeLittle) will have a different BOM than a UTF-16 document created on a Mac OS platform (where the byte
order mark is UnicodeBig). The byte order and the BOM of an existing document will be preserved by <oXygen/>
when the document is edited and saved. This behavior can be changed in <oXygen/> from the Encoding preferences
panel.

Note

The naming convention used under Java does not always correspond to the common names used by the Unicode
standard. For instance, while in XML you will use encoding="UTF-8", in Java the same encoding has the name
"UTF8".

The Unicode toolbar
The display of the Unicode toolbar is switched on and off from Perspective → Show Toolbar → Unicode and contains

the actions  Change text orientation with the default shortcut Ctrl + Shift + O  and  Insert from Character Map

The  Change text orientation action enables editing documents in languages with right to left writing (Hebrew, Ar-
abic, etc.) by moving the caret to the left when new characters are inserted in the document. Please note that you may
have to set an appropriate Unicode aware font for the editor panel, able to render the characters of the language of the
edited file.
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The  Insert from Character Map action opens a dialog in which you can select one character in the matrix of all
characters available in a font and insert it in the edited document. The action is available also in the Edit menu.

Figure 4.3. The Character Map dialog

The character selected in the character table or an entity with the decimal code or the hexadecimal code of that character
can be inserted in the current editor. You will see it in the editor if the font is able to render it. The Insert button inserts
the selected character in the editor. The Copy button copies it to the clipboard without inserting it in the editor.

The Character Map dialog cannot be used to insert Unicode characters in the grid version of a document editor. Ac-
cordingly the Insert button of the dialog will be disabled if the current document is edited in grid mode.

Opening and closing documents
As with most editing applications, <oXygen/> lets you open existing documents, save your changes and close them
as required.

Creating new documents

The New dialog

<oXygen/> supports a large number of document types. This dialog presents the default associations between a file
extension and the type of editor which opens the file for editing. You can override these default associations in the File
Types user preferences panel.

The New dialog only creates a skeleton document containing the document prolog, a root element and possibly other
child elements depending on the options specific for each schema type.

Use the following procedure to create documents.
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Procedure 4.1. Creating new documents

1.
Select File → New (Ctrl+N) or press the  New toolbar button. The New dialog is displayed which contains
the supported Document Types: XML, CSS File, Text File, PHP File, JavaScript File.

Figure 4.4. The New dialog

2. Select a document type, then click OK. If XML was selected the "Create an XML Document" dialog is displayed
otherwise a new document is opened in the Editor Panel.

3. The Create an XML Document dialog enables definition of a XML Document Prolog using the system identifier
of a XML Schema, DTD, Relax NG (full or compact syntax) schema, NRL (Namespace Routing Language) or
NVDL (Namespace-based Validation Dispatching Language) schema. As not all XML documents are required
to have a Prolog, you may choose to skip this step by clicking OK. If the prolog is required complete the fields
as the following.
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Figure 4.5. The Create an XML Document Dialog - XML Schema Tab

Complete the dialog as follows:

Use a DTD or a schema When checked enables selection between DTD, XML Schema, Relax NG
schema, NRL or NVDL schema.

URL Specifies the location of an XML Schema Document (XSD). >

You can also specify an URI if it is solved by the <oXygen/> catalog.

Example 4.1. DITA XSD URI

urn:oasis:names:tc:dita:xsd:topic.xsd:1.1

Namespace Specifies the document namespace.

Prefix Specifies the prefix for the namespace of the document root.

Document Root Populated from the elements defined in the specified XSD, enables selection
of the element to be used as document root.

Description Shows a small definition for the currently selected element.

Add optional content If it is selected the elements and attributes that are defined in the XML
Schema as optional are generated in the skeleton XML document created
in a new editor panel when the OK button is pressed.

Add first Choice particle If it is selected the first element of an xs:choice schema element is generated
in the skeleton XML document created in a new editor panel when the OK
button is pressed.
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Figure 4.6. The Create an XML Document Dialog - DTD Tab

Complete the dialog as follows:

Use a DTD or a schema When checked enables selection between DTD, XML Schema, Relax NG
schema, NRL or NVDL schema.

System ID Specifies the location of a Document Type Definition (DTD).

Public ID Specifies the PUBLIC identifier declared in the Prolog.

Document Root Populated from the elements defined in the specified DTD, enables selection
of the element to be used as document root.

Description Shows a small definition for the currently selected element.
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Figure 4.7. The Create an XML Document Dialog - Relax NG Tab

Complete the dialog as follows:

Use a DTD or a schema When checked enables selection between DTD, XML Schema, Relax NG
schema NRL or NVDL schema.

URL Specifies the location of a Relax NG schema in XML or compact syntax
(RNG/RNC).

XML syntax When checked the specified URL refers to a Relax NG schema in XML syntax.
It will be checked automatically if the user selects a document with the .rng
extension.

Compact syntax When checked the specified URL refers to a Relax NG schema in compact
syntax. It will be checked automatically if the user selects a document with the
.rnc extension.

Namespace Specifies the document namespace.

Prefix Specifies the prefix for the namespace of the document root.

Document Root Populated from the elements defined in the specified RNG or RNC document,
enables selection of the element to be used as document root.

Description Shows a small definition for the currently selected element.
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Figure 4.8. The Create an XML Document Dialog - NRL Tab

Complete the dialog as follows:

Use a DTD or a schema When checked enables selection between DTD, XML Schema, Relax NG
schema, NRL or NVDL schema.

URL Specifies the location of a NRL schema (NRL).

Figure 4.9. The Create an XML Document Dialog - NVDL Tab

Complete the dialog as follows:

Use a DTD or a schema When checked enables selection between DTD, XML Schema, Relax NG
schema, NRL or NVDL schema.
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URL Specifies the location of a Namespace-based Validation Dispatching Language
schema (NVDL).

Namespace Specifies the document namespace.

Prefix Specifies the prefix for the namespace of the document root.

Document Root Populated from the elements defined in the specified NVDL document, enables
selection of the element to be used as document root.

Description Shows a small definition for the currently selected element.

Creating Documents based on Templates

Templates are documents containing a predefined structure. They provide starting points on which one can rapidly
build new documents that repeat the same basic characteristics. <oXygen/> installs a rich set of templates for a number
of XML applications. You may also create your own templates and share them with other users.

The Templates tab in New dialog enables you to select predefined templates or templates that have already been created
in previous sessions or by other users. Open a template using the following options:

Figure 4.10. The Templates tab

The templates presented in the dialog are:

Document Types templates Templates supplied with the defined document types.

User defined templates The user can add template files in the templates folder of the <oXygen/>
install directory. Also in the option page Options → Preferences+Editor / Tem-
plates / Document TemplatesWindow → Preferences+oXygen/Editor / Templates
/ Document Templates can be specified a custom templates folder to be scanned.

Procedure 4.2. Creating Documents based on Templates

1. Select File → New / From Templates. The Templates tab is displayed and is used to select and open a new document
based on an existing template document. Template documents act as starting points that have predefined properties
such as file type, prolog, root element, containers and even existing content.
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2. Scroll the Templates list and select the required Template Type.

3. Click OK. A new document is opened that already contains structure and content provided in the template starting
point.

Saving documents
The edited document can be saved with one of the actions:

•
File → Save (Ctrl+S)  or press the Save toolbar button to save the current document. If the document does not
have a file, displays the Save As dialog.

• File → Save As: Displays the Save As dialog, used to name and save an open document to a file; or save an existing
file with a new name.

•
File → Save To URL or press the Save To URL ... toolbar button  to display the Save to URL dialog, used to
name and save an open document to a file; or saves an existing file with a new name, using FTP/SFTP/WebDAV.

• File → Save All: Saves all open documents. If any document does not have a file, displays the Save As dialog.

Opening existing documents
Documents can be opened using one of the actions:

•
File → Open (Ctrl+O) or press the  Open toolbar button to display the Open dialog used to discover, select and
open one or more files. The start folder of the Open dialog can be either the last folder visited by the Open dialog
the last time it was used in <oXygen/> XML Author or the folder of the currently edited file. This can be configured
in the user preferences.

•
File → Open URL ... or press the  Open URL ... toolbar button to display the Open URL dialog used to open a
document using FTP/SFTP/WebDAV.

• File → Revert: Loads the last saved file content. All unsaved modifications are lost.

• File → Reopen: Displays a list of recently opened document files. Select a file to open.

• Project view contextual menu → Open : Opens the selected file from the Project view.

• From the command line when the <oXygen/> XML Author application is launched. If launched from the command
line with the startup script installed by the installation wizard you can specify local file names as optional parameters:

• multiple XML files to be opened automatically at startup in separate editor panels:

scriptName [pathToXMLFile1] [pathToXMLFile2] ...

where scriptName is the name of the startup script for your platform ( author.bat on Windows, author.sh
on Unix/Linux, authorMac.sh on Mac OS) and pathToXMLFileN  is the name of a local XML file

The two possibilities of opening files at startup by specifying them in the command line are explained also if the
startup script receives one of the -h or --help parameters.
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Note

When more files are opened you can change the tab order by clicking and dragging a tab in the desired position.

In addition <oXygen/> XML Author supports direct opening of files from the command prompt. Use the following
command syntax:

• On Windows:

author.bat FileToOpen.xml

• On Unix/Linux:

sh ./author.sh FileToOpen.xml

• On Mac OS X:

sh ./authorMac.sh FileToOpen.xml

Also when the Tree Editor perspective is activated the current document in the Editor perspective will be opened and
displayed as a tree of XML elements.

Opening and Saving Remote Documents via
FTP/SFTP/WebDAV
<oXygen/> supports editing remote files, using the FTP, SFTP and WebDAV protocols. The remote opened files can
be edited exactly as the local ones. They can be added to the project, and can be subject to XSL and FO transformations.

33

Editing documents



Figure 4.11. Open URL dialog

Note

The FTP part is using passive access to the FTP servers. Make sure the server you are trying to connect to is
supporting passive connections. Also the UTF-8 encoding is supported and can be configured for communication
with the FTP server if the server supports it.

Files can be opened through the Secure FTP (SFTP) protocol using the regular user/password mechanism or
using a private key file and a passphrase. The user/password mechanism has precedence so for using the private
key and passphrase you have to remove the password from the dialog used to browse the server repository and
leave only the user name. The private key file and the passphrase must be set in the SFTP user preferences.

The WebDAV access is implemented using the Slide package of the Apache Software Foundation.

The HTTP/WebDAV capabilities have been extensively tested with various servers running on Windows (IIS),
Mac OS X and Linux (Apache).

Note

If you have set a proxy server to be used by <oXygen/>, make sure it supports the WebDAV protocol. If it does
not, make sure your connections do not pass through this server, otherwise you will not be able to connect to a
WebDAV server. If the server requires NTLM authentication <oXygen/> will display an authentication dialog
where the user and password for passing through the NTLM server must be entered. If the user is from a domain
you can specify the user as DOMAIN\user.
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To open the remote files, choose from the main menu File → Open URL ... The displayed dialog is composed of sev-
eral parts:

• The editable combo box, in which it can be specified directly the URL to be opened or saved.

URLs that can be directly opened

You can type in here an URL like http://some.site/test.xml, in case the file is accessible through normal HTTP
protocol, or ftp://anonymous@some.site/home/test.xml if the file is accessible through anonymous FTP.

This combo box is also displaying the current selection when the user changes selection by browsing the tree of
folders and files on the server.

• The Identification section contains the access credentials. If you want to browse for a file on a server, you have to
specify the user and password. This information is bound to the selected URL displayed in the "File URL" combo
box, and used further in opening/saving the file. If the check box "Save" is selected, then the user and password are
saved between editing sessions. The password is kept encrypted into the options file.

Note

Your password is well protected. In the case the options file is used on other machine by a user with a different
username the password will become unreadable, since the encryption is username dependent. This is also true
if you add URLs having user and password to your project.

• The Browse for remote file section contains the server combo and the "Autoconnect" check box. Into the server
combo it may be specified the protocol (HTTP, HTTPS or FTP), the name or IP of the server and, in case of WebDAV,
the path to the WebDAV directory.

Server URLs

When accessing a FTP server, you need to specify only the protocol and the host, like: ftp://server.com,
ftp://ftp.apache.org, or if using a nonstandard port: ftp://server.com:7800/ etc.

When accessing a WebDAV server, along with the protocol and the host, it must be specified also the directory
of the WebDAV repository.

Important

Make sure that the repository directory ends in a slash "/".

Ex: https://www.some-webdav-server.com:443/webdav-repository/, http://devel:9090/webdav/

By pressing the "Browse" button the directory listing will be shown in the component below. When "Autoconnect"
is selected then at every time the dialog is shown, the browse action will be performed.

• The tree view of the documents stored on the server. You can browse the directories, and make multiple selections.
Additionally, you may use the "Rename", "Delete", and "New Folder" to manage the file repository.

The file names are sorted in a case-insensitive way.

A WebDAV resource can be locked when it is opened in <oXygen/> by checking the option Lock WebDAV files on
open to protect it from concurrent modifications on the server by other users. If other user tries to edit the same resource
he will receive an error message and the name of the lock owner. The lock is released automatically when the editor
for that resource is closed in <oXygen/>.
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GZIP compression is handled correctly for the content received/sent from/to a HTTP server or a WebDAV server. The
built-in client of <oXygen/> notifies the server when the connection is established that GZIP compression is supported.

Changing file permissions on a remote FTP server

Some FTP servers allow the modification of file permissions on the file system for the files that they serve over the
FTP protocol. This feature of the protocol is accessible directly in the FTP/WebDAV file browser dialog by right-
clicking on a tree node and selecting the Change permissions menu item which brings up the following dialog:

Figure 4.12. FTP server - change file permissions

The usual Unix file permissions Read, Write and Execute are granted or denied in this dialog for the owner of the file,
the group of the owner and the rest of the users. The aggregate number of the current state of the permissions is updated
in the Permissions text field when a permission is modified with one of the check boxes.

WebDAV over HTTPS

If you want to access a WebDAV repository across an insecure network <oXygen/> allows you to load and save the
documents over the HTTPS protocol (if the server understands this protocol) so that any data exchange with the
WebDAV server is encrypted.

When a WebDAV repository is first accessed over HTTPS the server hosting the repository will present a security
certificate to <oXygen/> as part of the HTTPS protocol, without any user intervention. <oXygen/> will use this certi-
ficate to decrypt any data stream received from the server. For the authentication to succeed you should make sure the
security certificate of the server hosting the repository can be read by <oXygen/>. This means that <oXygen/> can
find the certificate in the key store of the Java Runtime Environment in which it runs. You know the server certificate
is not in the JRE's key store if you get the error "No trusted certificate found" when trying to access the WebDAV re-
pository:
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Figure 4.13. The server certificate is not available

You can add a certificate to the key store by exporting it to a local file using any HTTPS-capable Web browser (for
example Internet Explorer) and then importing this file into the JRE using the keytool executable bundled with the
JRE. The steps are the following using Internet Explorer (if you use other browser the procedure is similar):

Procedure 4.3. Import a HTTPS server certificate

1. Export the certificate into a local file

a. Point your HTTPS-aware Web browser to the repository URL. If this is your first visit to the repository it
will be displayed a security alert stating that the security certificate presented by the server is not trusted.

Figure 4.14. Security alert - untrusted certificate

b. Press the button "View Certificate".

c. Select the "Details" tab.
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d. Press the button "Copy to file ...". This will start the Certificate Export Wizard on Windows

e. Follow the indications of the wizard to save the certificate to a local file, for example server.cer .

2. Import the local file into the JRE running <oXygen/>

a. Open a text-mode console.

b. Go to the lib/security subdirectory of your JRE directory, that is of the directory where it is installed the JRE
running <oXygen/>, for example on Windows C:\Program Files\Java\jre1.5.0_09\lib\security

c. Run the following command:..\..\bin\keytool.exe -import -trustcacerts -file local-file.cer -keystore cacerts
where local-file.cer is the file containing the server certificate, created during the previous step.
keytool requires a password before adding the certificate to the JRE keystore. The default password is
"changeit". If somebody changed the default password then he is the only one who can perform the import.
As a workaround you can delete the cacerts file, re-type the command and enter as password any combination
of at least 6 characters. This will set the password for future operations with the key store.

3. Restart <oXygen/>

Opening the current document in a Web browser
To open the current document in the default Web browser installed on the computer use the action Open in browser
available on menu Document → XML Document and also on the Document toolbar. It is useful for seeing the effect
of applying an XSLT stylesheet or a CSS stylesheet on a document which specifies the stylesheet using an xml-stylesheet
processing instruction.

Closing documents
To close documents use one of the following methods:

• File → Close (Ctrl+W) : Closes only the selected tab. All other tab instances remain.

• File → Close All: Closes all opened documents. If a document is modified or has no file, a prompt to save, not to
save, or cancel the save operation is displayed.

• Close - accessed by right-clicking on an editor tab: Closes the selected editor.

• Close Other Files - accessed by right-clicking on an editor tab: Closes the other files except the selected tab.

• Close All - accessed by right-clicking on an editor tab: Closes all open editors within the panel.

Viewing file properties
In the Properties view you can quickly access information about the current edited document like the character encoding,
full path on the file system, schema used for content completion and document validation, document type name and
path, associated transformation scenario, if the file is read-only, document's total number of characters, line width, if
indent with tabs is enabled and the indent size. The view can be accessed by going to Perspective+Show View →
Properties
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Figure 4.15. The Properties View

To copy a value from the Properties View in the clipboard, for example the full file path, use the Copy action available
on the right-click menu of the view.

Editing XML documents

Associate a schema to a document

Setting a schema for the Content Completion

In case you are editing document fragments, for instance the chapters from a book each one in a separate file, you can
activate the Content Completion for these fragments in two ways:

Setting a default schema

The list of document types available at Options → Preferences -> Document Type Association contains a set of rules
for associating a schema with the current document when no schema is specified within the document. The schema is
one of the types: XML Schema, XML Schema with embedded Schematron rules, Relax NG, Relax NG with embedded
Schematron rules, Schematron, DTD, NRL, NVDL.

The rules are applied in the order they appear in the table and take into account the local name of the root element, the
default namespace and the file name of the document.

Important

The editor is creating the Content Completion lists by analysing the specified schema and the current context
(the position in the editor). If you change the schema you can observe that the list of tags to be inserted is changing.
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Figure 4.16. Content completion driven by a DocBook DTD

Adding a Processing Instruction

The same effect is obtained by configuring a processing instruction that specifies the schema to be used. The advantage
of this method is that you can configure the Content Completion for each file. The processing instruction must be added
at the beginning of the document, just after the XML prologue:

<?oxygen RNGSchema="file:/C:/work/relaxng/personal.rng" type="xml"?>

Select menu Document+XML Document → Associate schema... or click the toolbar button Associate schema to
open a dialog for selecting a schema used for Content Completion and document validation. The schema is one of the
types: XML Schema (with or without embedded Schematron rules), DTD, Relax NG (with or without embedded
Schematron rules), NRL, NVDL, Schematron.

This is a dialog helping the user to easily associate a schema file with the edited document . Enables definition of a
XML Document Prolog using the system identifier of a XML Schema, DTD, Relax NG (full or compact syntax)
schema, NRL (Namespace Routing Language) schema, NVDL (Namespace-based Validation Dispatching Language)
schema or Schematron schema. If you associate an XML Schema with embedded Schematron rules or a Relax NG
schema with embedded Schematron rules you have to check the Embedded Schematron rules checkbox available for
these two types of schemas.

Figure 4.17. Associate schema dialog

When associating a XML Schema to the edited document if the root element of the document defines a default namespace
URI with a "xmlns" attribute the "Associate schema" action adds a xsi:schemaLocation attribute. Otherwise it adds a
xsi:noNamespaceSchemaLocation attribute.

The URL combo box contains a predefined set of schemas that are used more often and it also keeps a history of the
last used schemas.
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<oXygen/> logs the URL of the detected schema in the Information view.

The oxygen processing instruction has the following attributes:

RNGSchema specifies the path to the Relax NG schema associated with the current document

type specifies the type of Relax NG schema, is used together with the RNGSchema attribute and can have
the value "xml" or "compact".

NRLSchema specifies the path to the NRL schema associated with the current document

NVDLSchema specifies the path to the NVDL schema associated with the current document

SCHSchema specifies the path to the SCH schema associated with the current document

Learning document structure

When working with documents that do not specify a schema, or for which the schema is not known or does not exist,
<oXygen/> is able to learn and translate it to a DTD, which in turn can be saved to a file in order to provide a DTD
for Content Completion and document validation. In addition to being useful for quick creation of a DTD that will be
capable of providing an initialization source for the Content Completion assistant. This feature can also be used to
produce DTDs for documents containing personal or custom element types.

When it is opened a document that does not specify a schema <oXygen/> automatically learns the document structure
and uses it for Content Completion. To disable this feature uncheck the checkbox Learn on open document from
Preferences.

Procedure 4.4. To create a DTD:

1. Open the structured document from which a DTD will be created.

2. Select menu Document+XML Document → Learn Structure (Ctrl+Shift+L) to read the mark-up structure of the
current document so that it can be saved as a DTD using the Save Structure option. <oXygen/> will learn the
document structure, when finished displaying words Learn Complete in the Message Pane of the Editor Status
bar.

3. Select menu Document+XML Document → Save Structure (Ctrl+Shift+S) to display the Save Structure dialog,
used to name and create DTD documents learnt by the Learn Structure function.

Note

The resulting DTD is only valid for documents containing the elements and structures defined by the document
used as the input for creating the DTD. If new element types or structures are defined in a document, they must
be added to the DTD in order for successful validation.

Streamline with Content Completion
<oXygen/>'s intelligent Content Completion feature is a content assistant that enables rapid, in-line identification and
insertion of structured language elements, attributes and in some cases their parameter options.
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Figure 4.18. Content Completion Assistant

If the Content Completion assistant is enabled in user preferences (the option Use Content Completion) it is automat-
ically displayed whenever the < character is entered into a document or by pressing CTRL+Space  on a partial element
or attribute name. Moving the focus to highlight an element and pressing the Enter key or the Tab  key, inserts both
the start and end tags of the highlighted element into the document.

The DTD, XML Schema, Relax NG, NRL or NVDL schema used to populate the Content Completion assistant is
specified in the following methods, in order of precedence:

• The schema specified explicitly in the document. In this case <oXygen/> reads the beginning of the document and
resolves the location of the DTD, XML Schema, Relax NG schema, NRL or NVDL schema.

Note

Limitation: In case of XML Schema the content completion takes into account only the schema declarations
from the root element of the document. If a schema declaration is attached to other element of the XML doc-
ument it is ignored.

• The default schema rule declared in the Document Type Association preferences panel which matches the edited
document.

After inserting, the cursor is positioned directly before the > character of the start tag, if the element has attributes, in
order to enable rapid insertion of any attributed supported by the element, or after the > char of the start tag if the element
has no attributes. Pressing the space bar, directly after element insertion will again display the assistant. In this instance
the attributes supported by that element will be displayed. If an attribute supports a fix set of parameters, the assistant
will display the list of valid parameter. If the parameter setting is user defined and therefore variable, the assistant will
be closed to enable manual insertion. The values of the attributes can be learned from the same elements in the current
document.

If you press CTRL + Enter instead of Enter or Tab after inserting the start and end tags in the document <oXygen/>
will insert an empty line between the start and end tag and the cursor will be positioned between on the empty line on
an indented position with regard to the start tag.

If the feature Add Element Content of Content Completion is enabled all the elements that the new element must
contain, as specified in the DTD or XML Schema, are inserted automatically in the document. The Content Completion
assistant can also add optional content and first choice particle, as specified in the DTD or XML Schema, for the element
if the two options are enabled.

The content assistant can be started at any time by pressing CTRL+Space Also it can be started with the action Start
Content Completion (default shortcut is CTRL + Slash) which can be configured in Preferences → Menu Shortcut
Keys  : category Content Completion, description Start Content Completion. The effect is that the context-sensitive
list of proposals will be shown in the current position of the caret in the edited document if element, attribute or attribute
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value insertion makes sense. Such positions are: anywhere within a tag name or at the beginning of a tag name in an
XML document, XML Schema, DTD or Relax NG (full or compact syntax) schema, anywhere within an attribute
name or at the beginning of an attribute name in any XML document with an associated schema, and within attribute
values or at the beginning of attribute values in XML documents where lists of possible values have been defined for
that element in the schema associated with the document.

The content of the Content Completion assistant is dependent on the element structure specified in the DTD, XML
Schema, Relax NG (full or compact syntax) schema or NRL, NVDL schema associated to the edited document.

The number and type of elements displayed by the assistant is dependent on the current position of the cursor in the
structured document . The child elements displayed within a given element are defined by the structure of the specified
DTD, XML Schema, Relax NG (full or compact syntax) schema or NRL, NVDL schema. All elements that can't be
child elements of the current element according to the specified schema are not displayed.

Inside Relax NG documents the Content Completion assistant is able to present element values if such values are
specified in the Relax NG schema. Also in Relax NG documents the Content Completion assistant presents additional
values of type ID for an anyURI data type. It presents also pattern names defined in the Relax NG schema as possible
values for pattern references. For example if the schema defines an enumValuesElem element

<element name="enumValuesElem">
    <choice>
        <value>value1</value>
        <value>value2</value>
        <value>value3</value>
    </choice>
</element>

in documents based on the schema the Content Completion assistant offers the list of values:

Figure 4.19. Content Completion assistant - element values in Relax NG documents

If the schema for the edited document defines attributes of type ID and IDREF the content assistant will display for
IDREF attributes a list of all the ID values already present in the document for an easy insertion of a valid ID value at
the cursor position in the document. This is available for documents that use DTD, XML Schema and Relax NG
schema.

Also values of all the xml:id attributes are treated as ID attributes and collected and displayed by the content completion
assistant as possible values for anyURI attributes defined in the schema of the edited document. This works only for
XML Schema and Relax NG schemas.

For documents that use an XML Schema or Relax NG schema the content assistant offers proposals for attributes and
elements values that have as type an enumeration of tokens. Also if a default value or a fixed value is defined in the
XML Schema used in validation for an attribute or element then that value is offered in the content completion window.
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If the edited document is not associated with a schema explicitly using the usual mechanisms for associating a DTD
or XML Schema with a document or using a processing instruction introduced by the Associate schema action the
content assistant will extract the elements presented in the pop-up window from the default schema.

If the schema for the document is of type XML Schema, Relax NG (full syntax), NVDL or DTD and it contains element,
attributes or attributes values annotations, these will be presented when the content completion window is displayed,
if the option Show annotations  is enabled. Also the annotation is presented in a small tooltip window displayed
automatically when the mouse hovers over an element or attribute annotated in the associated schema of the edited
document. The tooltip window can be invoked at any time using the F2 shortcut.

In an XML Schema annotations are put in an <xs:annotation> element:

    <xs:annotation>
        <xs:documentation>
            Description of the element.
        </xs:documentation> 
    </xs:annotation> 

If the current element / attribute in the edited document does not have an annotation in the schema and that schema is
of the type XML Schema <oXygen/> seeks an annotation in the type definition of the element / attribute or, if no an-
notation is found there, in the parent type definition of that definition, etc.

In a Relax NG schema any element outside the Relax NG namespace (http://relaxng.org/ns/structure/1.0) is handled
as annotation and the text content is displayed in the annotation window together with the content completion window:

For NVDL schemas annotations for the elements / attributes in the referred schemas (XML Schema, RNG, etc) are
presented

Figure 4.20. Schema annotations displayed at Content Completion

The following HTML tags are recognized inside the text content of an XML Schema annotation: p, br, ul, li. They are
rendered as in an HTML document loaded in a web browser: p begins a new paragraph, br breaks the current line, ul
encloses a list of items, li encloses an item of the list.

For DTD <oXygen/> defines a custom mechanism for annotation using comments enabled from the option Use DTD
comments as annotations . The text of a comment with the following format will be presented on content completion:
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 <!--doc:Description of the element. --> 

The operation of the Content Completion assistant is configured by the options available in the options group called
Content Completion.

Code templates

You can define short names for predefined blocks of code called code templates. The short names are displayed in the
content completion window if the word at cursor position is a prefix of such a short name. <oXygen/> comes with a
lot of predefined code templates but you can define your own code templates for any type of editor.

Content Completion helper panels

Information about the current element being edited are also available in the Model panel and Attributes panel, located
on the left-hand side of the main window. The Model panel and the Attributes panel combined with the powerful
Outline view provide spacial and insight information on the edited document.

The Model panel

The Model panel presents the structure of the current edited tag and tag documentation defined as annotation in the
schema of the current document.

Figure 4.21. The Model View

The Model panel is comprised of:

• An element structure panel.
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• An annotation panel.

The Element Structure panel

The element structure panel shows the structure of the current edited or selected tag in a Tree format.

The information includes the name, model and attributes the currently edited tag may have. The allowed attributes are
shown along with any restrictions they might possess.

Figure 4.22. The Element Structure panel

The Annotation panel

The Annotation panel shows the annotations that are present in the used schema for the currently edited or selected
tag.

This information can be very useful to persons learning XML because it has small available definitions for each used
tag.

Figure 4.23. The Annotation panel

The Attributes panel

The Attributes panel presents all the possible attributes of the current element and allows to insert attributes in the
current element or change the value of the attributes already used in the element. The attributes already present in the
document are painted with a bold font. Clicking on the Value column of a table row will start editing the value of the
attribute from the selected row. If the possible values of the attribute are specified as list in the schema associated with

46

Editing documents



the edited document the Value column works as a combo box where you can select one of the possible values to be
inserted in the document. The attributes table is sortable, 3 sorting orders being available by clicking on the columns'
names. Thus the table's contents can be sorted in ascending order, in descending order or in a custom order, where the
used attributes are placed at the beginning of the table as they appear in the element followed by the rest of the allowed
elements as they are declared in the associated schema.

Figure 4.24. The Attributes panel

The Elements view

Figure 4.25. The Elements View

Presents a list of all defined elements that you can insert at the current caret position according to the schema used for
content completion. Double-clicking any of the listed elements will insert that element in the edited document. All
elements from a sequence are presented but the invalid proposals (which cannot be inserted in the current context) are
grayed-out.

The Entities View

This view displays a list with all entities declared in the current document as well as built-in ones. Double clicking
one of the entities will insert it at the current cursor position.
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Figure 4.26. The Entities View

Validating XML documents
The W3C XML specification states that a program should not continue to process an XML document if it finds a val-
idation error. The reason is that XML software should be easy to write, and that all XML documents should be com-
patible. With HTML it was possible to create documents with lots of errors (like when you forget an end tag). One of
the main reasons that HTML browsers are so big and incompatible, is that they have their own ways to figure out what
a document should look like when they encounter an HTML error. With XML this should not be possible.

However, when creating an XML document, errors are very easily introduced. When working with large projects or
many files, the probability that errors will occur is even greater. Determining that your project is error free can be time
consuming and even frustrating. For this reason <oXygen/> provides functions that enable easy error identification
and rapid error location.

Checking XML well-formedness

A Well-Formed XML document is a document that conforms to the XML syntax rules.

A Namespace Well-Formed XML document is a document that is Well-Formed XML and is also namespace-wellformed
and namespace-valid.

The XML Syntax rules for Well-Formed XML are:

• All XML elements must have a closing tag.

• XML tags are case sensitive.

• All XML elements must be properly nested.

• All XML documents must have a root element.

• Attribute values must always be quoted.

• With XML, white space is preserved.

The namespace-wellformed rules are:

• All element and attribute names contain either zero or one colon

• No entity names, processing instruction targets, or notation names contain any colons.

The namespace-valid rules are:

• The prefix xml is by definition bound to the namespace name http://www.w3.org/XML/1998/namespace. It MAY,
but need not, be declared, and MUST NOT be undeclared or bound to any other namespace name. Other prefixes
MUST NOT be bound to this namespace name.
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• The prefix xmlns is used only to declare namespace bindings and is by definition bound to the namespace name ht-
tp://www.w3.org/2000/xmlns/. It MUST NOT be declared or undeclared. Other prefixes MUST NOT be bound to
this namespace name.

• All other prefixes beginning with the three-letter sequence x, m, l, in any case combination, are reserved. This means
that users SHOULD NOT use them except as defined by later specifications and processors MUST NOT treat them
as fatal errors.

• The namespace prefix, unless it is xml or xmlns, MUST have been declared in a namespace declaration attribute in
either the start-tag of the element where the prefix is used or in an ancestor element (i.e. an element in whose content
the prefixed markup occurs). Furthermore, the attribute value in the innermost such declaration MUST NOT be an
empty string.

If you select menu Document+Validate → Check Document Form (Ctrl+Shift+W) or click the toolbar button 
Check Document Form <oXygen/> checks if your document is Namespace Well-Formed XML. If any error is found
the result is returned to the Message Panel. Each error is one record in the Result List and is accompanied by an error
message. Clicking the record will open the document containing the error and highlight the approximate location.

Example 4.2. Document which is not Well-Formed XML

<root><tag></root>

When "Check document form" is performed the following error is raised:

The element type "tag" must be terminated by the matching end-tag "</tag>"

To resolve the error, click in the result list record which will locate and highlight the errors approximate position.
Identify which start tag is missing an end tag and insert </tag>.

Example 4.3. Document which is not namespace-wellformed

<x::y></x::y>

When "Check document form" is performed the following error is raised:

Element or attribute do not match QName production: QName::=(NCName':')?NCName.

Example 4.4. Document which is not namespace-valid

<x:y></x:y>

When "Check document form" is performed the following error is raised:

The prefix "x" for element "x:y" is not bound.

Also the files contained in the current project and selected with the mouse in the Project view can be checked for well-

formedness with one action available on the popup menu of the Project view :  Check well form

Validating XML documents against a schema

A Valid XML document is a Well Formed XML document, which also conforms to the rules of a schema which defines
the legal elements of an XML document. The schema type can be: XML Schema, Relax NG (full or compact syntax),
Schematron, Document Type Definition (DTD), Namespace Routing Language (NRL) or Namespace-based Validation
Dispatching Language (NVDL).
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The purpose of the schema is to define the legal building blocks of an XML document. It defines the document structure
with a list of legal elements.

The <oXygen/> Validate document function ensures that your document is compliant with the rules defined by an
associated DTD, XML Schema, Relax NG or Schematron schema. XML Schema or Relax NG Schema can embed
Schematron rules. For Schematron it is possible to select the validation phase.

Note

Validation of an XML document against a W3C XML Schema containing a type definition with a minOccurs
or maxOccurs attribute having a value larger than 256 limits the value to 256 and issues a warning about this
restriction in the Message panel at the bottom of the <oXygen/> window. Otherwise for large values of the
minOccurs and maxOccurs attributes the validator fails with an OutOfMemory error which practically makes
<oXygen/> unusable without a restart of the entire application.

Note

Validation of an XML document against a deeply recursive Relax NG schema may fail with a stack overflow
error. It happens very rarely and the cause is the unusual depth of the Relax NG pattern recursion needed to
match an element of the document against the schema and the depth exceeds the default stack size allocated by
the Java virtual machine. The error can be overcome by simply setting a larger stack size to the JVM at startup
using the -Xss parameter, for example -Xss1m.

Note

Validation of an XML document against a W3C XML Schema or Relax NG Schema with embedded ISO
Schematron rules allows XPath 2.0 in the expressions of the ISO Schematron rules. This ensures that both XPath
1.0 and XPath 2.0 expressions are accepted in the embedded ISO Schematron rules and are enforced by the val-
idation operation. For embedded Schematron 1.5 rules the version of XPath is set with a user preference.

Marking Validation Errors

A line with a validation error or warning will be marked in the editor panel by underlining the error region with a red
color. Also a red sign will mark the position in the document of that line on the right side ruler of the editor panel. The
same will happen for a validation warning, only the color will be yellow instead of red.

The ruler on the right of the document is designed to display the errors found during the validation process and also
to help the user to locate them more easily. The ruler contains the following areas:

• top area containing a success validation indicator that will turn green in case the validation succeeded or red otherwise.

A more detailed report of the errors is displayed in the tool tip. In case there are errors, only the first three of them
will be presented in the tool tip;

• middle area where the errors markers are depicted in red (with a darker color tone for the current selected one). The
number of markers shown can be limited by modifying the setting Options → Preferences+Editor / Document
checking+Limit error markers to

Clicking on a marker will highlight the corresponding text area in the editor. The error message is displayed both
in the tool tip and in the error area on the bottom of the editor panel.

The Document checking user preferences are easily accessible from the button displayed at the beginning of the error
message on the bottom of the editor panel.
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• bottom area containing two navigation arrows that will go to the next or to the previous error and a button for
clearing all the error markers from the ruler. The same actions can be triggered from Document → Validate as you
type (Ctrl + .)-> Next error and Document → Validate as you type (Ctrl + ,)-> Previous error.

The validation status area is the line at the bottom of the editor panel that presents the message of the current validation

error. Clicking on  opens the  document checking page in <oXygen/> user preferences.

Status messages from every validation action are logged into the Information view.

Validation Example

Example 4.5. Validation error messages

In our example we will use the case where a DocBook listitem element does not match the rules of the docbookx.dtd.
In this case running Validate Document  will return the following error:

  E The content of element type "listitem" must
  match"(calloutlist|glosslist|itemizedlist|orderedlist|segmentedlist|
  simplelist|variablelist| caution|important|note|tip|warning|
  literallayout|programlisting|programlistingco|screen|
  screenco|screenshot|synopsis|cmdsynopsis|
  funcsynopsis|classsynopsis|fieldsynopsis| constructorsynopsis|
  destructorsynopsis|methodsynopsis|formalpara|para|simpara|
  address|blockquote|graphic|graphicco|mediaobject|
  mediaobjectco|informalequation| informalexample|
  informalfigure|informaltable|equation|example|
  figure|table|msgset|procedure|sidebar|qandaset|anchor|
  bridgehead|remark|highlights|abstract|authorblurb|epigraph|
  indexterm|beginpage)+".

As you can see, this error message is a little more difficult to understand, so understanding of the syntax or processing
rules for the DocBook XML DTD's "listitem" element is required. However, the error message does give us a clue as
to the source of the problem, but indicating that "The content of element type "listitem" must match".

Luckily most standards based DTD's, XML Schema's and Relax NG schemas are supplied with reference documentation.
This enables us to lookup the element and read about it. In this case we would want to learn about the child elements
of "listitem" and their nesting rules. Once we have correctly inserted the required child element and nested it in accord-
ance with the XML rules, the document will become valid on the next validation test.

Caching the Schema Used for Validation

If you don't change the active editor and you don't switch to other application the schema associated to the current
document is parsed and cached at the first validate action and is reused by the next Validate document actions without
re parsing it. This increases the speed of the validate action starting with the second execution if the schema is large

or is located on a remote server on the Web. To reset the cache and re parse the schema you have to use the  Reset
cache and validate action. This action will also re parse the catalogs and reset the schema used for content completion.

Validate As You Type

<oXygen/> can be configured to mark validation errors in the edited document as you modify it using the keyboard.
If you enable the Validate as you type option any validation errors and warnings will be highlighted automatically in
the editor panel after the configured delay from the last key typed, with underline markers in the editor panel and small
rectangles on the right side ruler of the editor panel, in the same way as for manual validation invoked by the user.
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Figure 4.27. Validate as you type on the edited document

If the error message is long and it is not displayed completely in the error line at the bottom of the editing area double-
clicking on the error icon at the left of the error line or on the error line displays an information dialog with the full
error message. The arrow buttons of the dialog enable the navigation to other errors issued by the validation as you
type feature.

Figure 4.28. Full error message for validate as you type errors

Custom validation of XML documents

If you need to validate the edited document with other validation engine than the built-in one you have the possibility
to configure external validators as custom validation engines in <oXygen/>. After such a custom validator is properly
configured in Preferences it can be applied on the current document with just one click on the External Validation
toolbar. The document is validated against the schema declared in the document.
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Figure 4.29. External validation toolbar

Some validators are configured by default but they are third party processors which do not support the output message
format for linked messages described above:

LIBXML included in <oXygen/> (Windows edition), associated to XML Editor, able to
validate the edited document against XML Schema, Relax NG schema full
syntax, internal DTD (included in the XML document) or a custom schema type.
XML catalogs support(--catalogs) and XInclude processing(--xinclude) are
enabled by default in the preconfigured LIBXML validator. The --postvalid
flag is set as default allowing LIBXML to validate correctly the main document
even if the XInclude fragments contain IDREFS to ID's located in other frag-
ments.

For validation against an external DTD specified by URI in the XML document
the parameter --dtdvalid ${ds} must be added manually to the DTD validation
command line. ${ds} represents the detected DTD declaration in the XML
document.

Note

Known problem: file paths containing spaces are not handled correctly in
the LIBXML processor. For example the built-in XML catalog files of
the predefined document types (DocBook, TEI, DITA, etc) are not handled
by LIBXML if <oXygen/> is installed in the default location on Windows
(C:\Program Files) because the built-in XML catalog files are stored in
the frameworks subdirectory of the installation directory which in this
case contains at least a space character.

Note

On Mac OS X if the full path to the LIBXML executable file is not spe-
cified in the Executable path text field some errors may occur on validation
against a W3C XML Schema like:

Unimplemented block at ... xmlschema.c

These errors can be avoided by specifying the full path to the LIBXML
executable file.

Saxon SA included in <oXygen/>. It is associated to XML Editor and XSD Editor. It is
able to validate XML Schema schemas and XML documents against XML
Schema schemas. The validation is done according to the W3C XML Schema
1.0 specification or according to the W3C XML Schema 1.1 one. This can be
configured in Preferences.
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MSXML 4.0 included in <oXygen/> (Windows edition). It is associated to XML Editor, XSD
Editor and XSL Editor. It is able to validate the edited document against XML
Schema, internal DTD (included in the XML document), external DTD or a
custom schema type.

MSXML.NET included in <oXygen/> (Windows edition). It is associated to XML Editor, XSD
Editor and XSL Editor. It is able to validate the edited document against XML
Schema, internal DTD (included in the XML document), external DTD or a
custom schema type.

XSV not included in <oXygen/>. A Windows distribution of XSV can be downloaded
from:  ftp://ftp.cogsci.ed.ac.uk/pub/XSV/XSV31.EXE
[ftp://ftp.cogsci.ed.ac.uk/pub/XSV/XSV31.EXE] A Linux distribution can be
downloaded from  ftp://ftp.cogsci.ed.ac.uk/pub/XSV/XSV-3.1-1.noarch.rpm
[ftp://ftp.cogsci.ed.ac.uk/pub/XSV/XSV-3.1-1.noarch.rpm] The executable path
is configured already in <oXygen/> for the installation directory [oXygen-
install-dir]/xsv. If it is installed in a different directory the predefined
executable path must be corrected in Preferences. It is associated to XML Editor
and XSD Editor. It is able to validate the edited document against XML Schema
or a custom schema type.

SQC (Schema Quality Checker from
IBM)

not included in <oXygen/>. It can be downloaded from here
[http://www.alphaworks.ibm.com/tech/xmlsqc?open&l=xml-dev,t=grx,p=shecheck]
(it comes as a .zip file, at the time of this writing SQC2.2.1.zip is about 3
megabytes). The executable path and working directory are configured already
for the SQC installation directory [oXygen-install-dir]/sqc. If it is
installed in a different directory the predefined executable path and working
directory must be corrected in Preferences. It is associated to XSD Editor.

A custom validator cannot be applied on files loaded through an <oXygen/> custom protocol plugin developed inde-
pendently and added to <oXygen/> after installation.

Linked output messages of an external engine

The output messages of the validation engines are displayed in an output view at the bottom of the <oXygen/> window.
If an output message of the external validation engine (warnings, errors, fatal errors, etc) spans between three to five
lines of text and has the following format then the message is linked to a location in the validated document so that a
click on the message in the output view highlights the location of the message in an editor panel containing the file
referred in the message. This behavior is similar to the linked messages generated by the default built-in validator. The
format for linked messages is:

• Type:[F|E|W] (the string "Type:" followed by a letter for the type of the message: fatal error, error, warning - this
line is optional in a linked message)

• SystemID: a system ID of a file (the string "SystemID:" followed by the system ID of the file that will be opened
for highlighting when the message is clicked in the output message - usually the validated file, the schema file or
an included file)

• Line: a line number (the string "Line:" followed by the number of the line that will be highlighted)

• Column: a column number (the string "Column:" followed by the number of the column where the highlight will
start on the highlighted line - this line is optional in a linked message)

• Description: the text of the message (the string "Description:" followed by the text content of the message that will
be displayed in the output view)
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Validation Scenario

A complex XML document is usually split in smaller interrelated modules which do not make much sense individually
and which cannot be validated in isolation due to interdependencies with the other modules. A mechanism is needed
to set the main module of the document which in fact must be validated when an imported module needs to be checked
for errors.

A typical example is the chunking DocBook XSL stylesheet which has chunk.xsl as the main module and which
imports a stylesheet module called param.xsl which only defines XSLT parameters and other modules called
chunk-common.xsl and chunk-code.xsl. The module chunk-common.xsl defines a named XSLT template
with the name "chunk" which is called by chunk-code.xsl. The parameters defined in param.xsl are used in
the other modules without being redefined.

Validation of chunk-code.xsl as an individual XSLT stylesheet issues a lot of misleading errors referring to
parameters and templates used but undefined which are only caused by ignoring the context in which this module is
used in real XSLT transformations and in which it should be validated. To validate such a module properly a validation
scenario must be defined which sets the main module of the stylesheet and also the validation engine used to find the
errors. Usually this is the engine which applies the transformation in order to detect by validation the same errors that
would be issued by transformation.

To define a validation scenario first open the Configure Validation Scenario dialog. You do this with the Configure
Validation Scenario action available on the menu Document → Validate and on the Validate toolbar, . You can use
the default engine set in Preferences, or use a custom validation scenario. The list of reusable scenarios for documents
of the same type as the current document is displayed.

Figure 4.30. Configure Validation Scenarios

A validation scenario is created or edited in a special dialog opened with the New button or with the Edit one.
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Figure 4.31. Edit a Validation Scenario

The table columns are:

URL of the file to validate The URL of the main module which includes the current module and which is
the entry module of the validation process when the current module is validated.

Validation engine One of the engines available in <oXygen/> for validation of the type of document to which
the current module belongs.

Validate as you type If this option is checked then the validation operation defined by this row of the table
is applied also by the Validate as you type feature. If the Validate as you type feature
is disabled in Preferences then this option does not take effect as the Preference setting
has higher priority.

Extensions A list of Java jar files or classes which implement extensions of the language of the
current module. For example when the current module is an XSLT stylesheet an ex-
tension jar contains the implementation of the XSLT extension functions or the XSLT
extension elements used in the stylesheet which includes the current module.

A row of the table is created or edited in the following dialog:

Figure 4.32. Edit a Validation Unit

The components of the dialog are the same as the columns of the table displayed in the scenario edit dialog. The URL

of the main module can be specified with the help of a file browser for the local file system (the  button), with the

help of the Open FTP / SFTP / WebDAV dialog opened by the  button or by inserting an editor variable from the
following pop-up menu:
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Figure 4.33. Insert an editor variable

A second benefit of a validation scenario is that the stylesheet can be validated with several engines to make sure that
it can be used in different environments with the same results. For example an XSLT stylesheet needs to be applied
with Saxon 6.5, Xalan and MSXML 4.0 in different production systems.

Other examples of documents which can benefit of a validation scenario are a complex XQuery with a main module
which imports modules developed independently but validated in the context of the main module of the query and an
XML document in which the master file includes smaller fragment files using XML entity references. In an XQuery
validation scenario the default validator of <oXygen/> (Saxon 9) or any connection to a database that supports validation
(Oracle 11g, Berkeley DB XML Database, IBM DB2, eXist XML Database, MarkLogic, Microsoft SQL Server,
Software AG Tamino, Documentum xDb (X-Hive/DB) XML Database, TigerLogic, MySQL) can be set as validation
engine.

Validation Actions in the User Interface

Use one of the actions for validating the current document:

• Select menu Document+Validate → Validate Document (Ctrl+Shift+V) or click the button Validate Document
available in the Validate toolbar to return an error result-list in the Message panel. Mark-up of current document is
checked to conform with the specified DTD, XML Schema or Relax NG schema rules. It caches the schema and
the next execution of the action uses the cached schema.

• Select menu Document+Validate → Reset Cache and Validate or click the button  Reset Cache and Validate
available in the Validate toolbar to reset the cache with the schema and validate the document. This action will also
re parse the catalogs and reset the schema used for content completion. It returns an error result-list in the Message
panel. Mark-up of current document is checked to conform with the specified DTD, XML Schema or Relax NG
schema rules.

• Select menu Document+Validate → External Validation or click the button  External Validation available in the
Validate toolbar to display the External Validation dialog, used to select the external schemas (XML Schema, DTD,
Relax NG, NRL, NVDL, Schematron schema) and to execute the Validation operation on the current document using
the selected schemas. Returns an error result-list in the Message panel. Mark-up of current document is checked to
conform with the specified schemas rules. The External Validation action does not work for files loaded through an
<oXygen/> custom protocol plugin developed independently and added to <oXygen/> after installation.
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Figure 4.34. The External validation dialog

• Select menu Document+XML Document → Open External Schema or click the button  Open External Schema
available in the Document toolbar to open the schema used for validating the current document in a new editor.

• Select contextual menu of Project Panel,Validate Selection to validate all selected files with their declared schemas.

• Select contextual menu of Project Panel,Validate Selection with ... to select a schema and validate all selected files
with that schema.

The button Validation options available on the Validate toolbar allows quick access to the validation options of
the built-in validator in the <oXygen/> user preferences.

Also you can select several files in the Project panel and validate them with one click by selecting the action Validate
selection or the action Validate selection with ... available from the contextual menu of the Project view.

If there are too many validation errors and the validation process is long you can limit the maximum number of reported
errors.

References to XML Schema specification

If validation is done against XML Schema <oXygen/> indicates a specification reference relevant for each validation
error. The error messages contain an Info field that when clicked will open the browser on the "XML Schema Part
1:Structures" specification at exactly the point where the error is described thus allowing you to understand the reason
for that error.

Figure 4.35. Link to specification for XML Schema errors
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Resolving references to remote schemas with an XML Catalog

When a reference to a remote schema must be used in the validated XML document for interoperability purposes but
a local copy of the schema should be actually used for validation for performance reasons the reference can be resolved
to the local copy of the schema with an XML catalog. For example if the XML document contains a reference to a remote
schema docbook.rng

<?oxygen RNGSchema="http://www.oasis-open.org/docbook/xml/5.0/rng/docbook.rng" 
    type="xml"?>

it can be resolved to a local copy with a catalog entry:

<system systemId="http://www.oasis-open.org/docbook/xml/5.0/rng/docbook.rng" 
    uri="rng/docbook.rng"/>

An XML catalog can be used also to map a W3C XML Schema specified with an URN in the xsi:schemaLocation at-
tribute of an XML document to a local copy of the schema. For example if the XML document specifies the schema
with:

<topic xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xsi:noNamespaceSchemaLocation="urn:oasis:names:tc:dita:xsd:topic.xsd:1.1">

the URN can be resolved to a local schema file with a catalog entry like:

<system systemId="urn:oasis:names:tc:dita:xsd:topic.xsd:1.1"
    uri="topic.xsd"/>

Document navigation
Navigating between XML elements located in various parts of the currently edited document is easy due to several
powerful features.

Quick document browsing using bookmarks

The concept of bookmark is the same as in other IDEs: the user can mark a position in one edited document so that he
can quickly return after further editing and browsing through one or more documents opened at the same time. Up to
nine distinct bookmarks can be placed in any opened document. Configurable shortcut key strokes are available for
placing bookmarks and for quick return to any of the marked positions.

Figure 4.36. Editor Bookmarks

The key strokes can be configured from Options → Preferences->Menu shortcut keys.
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A bookmark can be placed from Edit → Bookmarks->Create, from Edit → Bookmarks (F7)->Bookmarks quick creation,

by clicking the toolbar button  Bookmarks quick creation and by clicking in the margin of the editing area, to the
left of the line number area, reserved for bookmarks.

Quickly switching to a position marked by a bookmark can be done by Edit → Bookmarks->Go to.

Folding of the XML elements

XML documents are organized as a tree of elements. When working on a large document you can collapse some elements
leaving in the focus only the ones you need to edit. Expanding and collapsing works on individual elements: expanding
an element leaves the child elements unchanged.

Figure 4.37. Folding of the XML Elements

An unique feature of <oXygen/> is the fact that the folds are persistent: the next time you will open the document the
folds are restored to the last state so you won't have to collapse the uninteresting parts again.

To toggle the folded state of an element click on the special mark displayed in the left part of the document editor next
to the start tag of that element or click on the action Toggle fold available from the context menu or from the menu
Document+Folding → Toggle fold The element extent is marked with a grey line displayed in the left part of the edited
document. The grey line covers always the lines of text comprised between the start tag and end tag of the element
where it is positioned the cursor.

Other menu actions related to folding of XML elements are available from the context menu of the current editor or
from the menu Document → Folding:

• Document+Folding+  → Close Other Folds (Ctrl+NumPad+/) Fold all the sections except the current element.

• Document+Folding+  → Collapse Child Folds (Ctrl+Decimal): Fold the sections indented with one level inside
the current element.

• Document+Folding+  → Expand Child Folds (Ctrl+Equals): Unfold the sections indented with one level inside
the current element.

• Document+Folding+  → Expand All (Ctrl+NumPad+*): Unfold all the sections inside the current element.

• Document+Folding+  → Toggle Fold: Toggles the state of the current fold.
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Outline View

The Outline view has the following available functions:

• the section called “XML Document Overview”

• the section called “Outliner filters”

• the section called “Modification Follow-up”

• the section called “Document Structure Change”

• the section called “Document Tag Selection”

Figure 4.38. The Outline View

XML Document Overview

The Outline view displays a general tag overview of the current edited XML Document. It also shows the correct
hierarchical dependencies between the tag elements, making it easier for the user to be aware of the document's structure
and the way tags are nested.

The Expand more and Collapse all items of the popup menu available on the outline tree enlarge or reduce the set of
nodes of the edited document currently visible in the view. The tree expansion action is a faster alternative to mouse
clicks on the plus signs of the tree when one wants to access quickly a node deeply nested in the hierarchy of document
nodes. When a large number of nodes become expanded and the document structure is not clear any more the collapsing
action clears the view quickly by reducing the depth of the expanded nodes to only one child of the currently selected
node.

Outliner filters

Show comments/Processing Instruc-
tions

Show/Hide Comments and Processing instructions in the outliner.

Show text Show/Hide additional text content for the displayed elements.
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Show attributes Show/Hide attribute values for the displayed elements.

The displayed attribute values can be changed from the Outline preferences
panel.

The content of the Outline view can also be filtered with patterns typed in the text field of the view. The patterns can
include the wildcard characters * and ?. If more than one pattern is used they must be separated by comma. Any pattern
is a prefix filter, that is a * is appended automatically at the end of every pattern.

Modification Follow-up

When editing, the Outline view dynamically follows the modifications introduced by the user, showing in the middle
of the panel the node which is currently being modified .This gives the user better insight on location where in the
document one is positioned and how the structure of the document is affected by one's modifications.

Document Structure Change

Entire XML elements can be moved or copied in the edited document using only the mouse in the Outline view in
drag-and-drop operations. If you drag an XML element in the Outline view and drop it on another one in the same
panel then the dragged element will be moved after the drop target element. If you hold the mouse pointer over the
drop target for a short time before the drop then the drop target element will be expanded first and the dragged element
will be moved inside the drop target element after its opening tag. You can also drop an element before or after another
element if you hold the mouse pointer towards the upper or lower part of the targeted element. A marker will indicate
whether the drop will be performed before or after the target element. If you hold down the CTRL key the performed
operation will be copy instead of move.

The drag and drop action in the Outline view can be disabled and enabled from the Preferences dialog.
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The popup menu of the Outline tree

Figure 4.39. Popup menu of the Outline tree

The Append Child, Insert Before and Insert After submenus of the outline tree popup menu allow to quickly insert new
tags in the document at the place of the element currently selected in the Outline tree. The Append Child submenu lists
the names of all the elements which are allowed by the schema associated with the current document as child of the
current element. The Insert Before and Insert After submenus of the Outline tree popup menu list the elements which
are allowed by the schema associated with the current document as siblings of the current element inserted immediately
before respectively after the current element.

Edit attributes for the selected node. A dialog is presented allowing the user to see and edit the attributes of the selected
node. See here for more details about editing attributes.

The Toggle comment item of the outline tree popup menu is the same item as in the editor popup menu with the same
name. It encloses the currently selected element of the outline tree in an XML comment, if the element is not commented,
or un comments it if it is commented.

The Cut, Copy and Delete items of the popup menu execute the same actions as the Edit menu items with the same
name on the elements currently selected in the outline tree.

Document Tag Selection

The Outline view can also be used to search for a specific tag's location and contents in the edited document. Intuitively,
by selecting with the left mouse button the desired tag in the Outline view, the document is scrolled to the position of
the selected tag. Moreover, the tag's contents are selected in the document, making it easy to notice the part of the
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document contained by that specific tag and furthermore to easily copy and paste the tag's contents in other parts of
the document or in other documents.

You can double click the tag in the Outliner tree to move focus to the editor.

You can also use key search to look for a particular tag name in the Outliner tree.

Navigation buttons

These buttons are available in editor's main toolbar:

•  Go to last modification : Moves the caret to the last modification in any opened document.

•  Back :Moves the caret to the previous position.

•  Forward :Moves the caret to the next position. Enabled after at least one press of "Back" button.

Using the Go To dialog

The "Go to" dialog available from Find → Go to ... (Ctrl+L (Cmd+L on Mac)) enables you to go to a precise location
in the current edited file specified by line and column or by offset relative to the beginning of the file.

Figure 4.40. Go to

Complete the dialog as follows:

Line The destination line in the current document.

Column The destination column in the current document.

Offset The destination offset relative to the beginning of document.

Grouping documents in XML projects

Large Documents

Let's consider the case of documenting a large project. It is likely to be several people involved. The resulting document
can be few megabytes in size. How to deal with this amount of data in such a way the work parallelism would not be
affected ?

Fortunately, XML provides a solution for this. It can be created a master document, with references to the other document
parts, containing the document sections. The users can edit individually the sections, then apply FOP or XSLT over
the master and obtain the result files, let say PDF or HTML.
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Two conditions must be fulfilled:

• The master should declare the DTD to be used and the external entities - the sections. A sample document is:

<?xml version="1.0" encoding="UTF-8"?> 
<!DOCTYPE book SYSTEM "../xml/docbookx.dtd" [ 
<!ENTITY testing SYSTEM "testing.xml" > ]
> 
<book> 
<chapter> ...                

At a certain point in the master document there can be inserted the section "testing.xml" entity:

... &testing; ...

• The document containing the section must not define again the DTD.

<section> ... here comes the section content ... </section>

Note

The indicated DTD and the element names ( "section", "chapter" ) are used here only for illustrating the inclusion
mechanism. You can use any DTD and element names you need.

When splitting a large document and including the separate parts in the master file using external entities, only the
master file will contain the Document Type Definition (the DTD) or other type of schema. The included sections can't
define again the schema because the main document will not be valid. If you want to validate the parts separately you
have to use XInclude for assembling the parts together with the master file.

Creating an included part

Open a new document of type XML, with no associated schema.

You can type in the edited document the root element of your section. For example, if you are using DocBook it can
be "<chapter></chapter>" or "<section></section>". Now if you are moving the cursor between the tags and press
"<", you will see the list of element names that can be inserted.

Figure 4.41. Content Completion list over a document with no schema
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Note

The validation will not work on a included file, as no DTD is set. The validation can be done only from the
master file. At this point you can only check the document to be well-formed.

Using the Project view

The Project view, located on the left-hand side of the main window, is designed to assist the user in organizing and
managing related files grouped in the same XML project. The actions available on the context menu and toolbar asso-
ciated to this panel enable the creation of XML projects and shortcuts to various operations on the project documents.
On Windows the context menu can be displayed with the mouse on a right click or with the keyboard by pressing the
special context menu key available on Windows keyboards.

Figure 4.42. The Project View

The default layout initialized by the Perspective → Reset Layout menu item arranges the Project view on the left side
of the <oXygen/> window, above the Outline view. If you closed the view at some time to get more editing space you
can reopen it quickly at any time with the Project → Show Project View menu item.

To create a new project select File → New Project or click the toolbar button  New Project

To open an existing project select File → Open Project ... (Ctrl+F2) or click the toolbar button  Open Project or
select File → Reopen Project (displays a list of recently opened project files, select a project file to open). You can
also drop an <oXygen/> XPR project file from the file explorer in the Project panel.

To save a project on disk select File → Save Project (Ctrl+F3) or click the toolbar button  Save Project

The files are organized in a XML project usually as a collection of folders. There are two types of folders:

• Logical folders - they are marked with a blue icon and do not have any connection with folders on the disk, creating
and deleting them in <oXygen/> does not affect the file system on disk.

• Linked folders - they are marked with a yellow icon and their name and content mirror a real folder existing in the
file system on disk.

To create a new logical or physical folder (depending on the selected resource) select in the contextual menu New

Folder or Import Folders or Import Remote Folders or click the Project view toolbar button  New Folder

You can create linked folders by dragging and dropping a folder from the Windows Explorer / Mac OS X Finder over
the project tree or by selecting in the contextual menu Link to External Folders Also the structure of the project tree
can be changed with drag and drop operations on the files and folders of the tree.
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To create a new linked folder inside another linked folder, or inside one of its children, right click on the linked folder
where you want to create it and select New Folder from the contextual menu.

To add one or more files to a folder, right click on it, and choose Add files or Add Edited File or click the toolbar

button Add Edited File or right-click on the title of an opened editor and select from the pop-up menu Add to project
or Add all to project.

The default target when adding files to a project is the project root. Selecting a folder changes the target to the selected
folder. Files may have multiple instances, within the folder system but cannot appear twice within the same folder.

To remove one or more files and/or folders select them with the mouse in the project tree, right-click to invoke the
contextual menu and select the Remove action or press the DELETE key.

To create a new file inside a linked folder choose the New File action from the contextual menu.

A child (folder or file) of a linked folder can be renamed by right-clicking on it and accessing the Rename action from
the contextual menu. The file or folder will be renamed both in the <oXygen/> Project view and on the local disk.

If a project folder contains many documents a certain document can be quickly located in the project tree if the user
selects with the mouse the folder containing the desired document (or some arbitrary document in this folder) and types
the first characters of the document name. The desired document will be automatically selected as soon as the typed
characters uniquely identify its name in the folder. The selected document can be opened by pressing the ENTER key,
by double-clicking on it and with one of the Open actions from the popup menu. For opening a file of known type with
other editor than the default use the Open as action. Also the selected document can be deleted by pressing the DELETE
key or by choosing Remove from the context menu.

The currently selected files in the Project view can be validated against a schema of type Schematron, XML Schema,
Relax NG, NRL, NVDL, or a combination of the later with Schematron with one of the actions Validate Selection and
Validate Selection with ... available on the right-click menu of the Project view. This together with the logical folder
support of the project allows you to group your files and validate them very easily.

If the resources from a linked folder in the project have been changed outside the view you can refresh the content of
the folder by using the Refresh action from the contextual menu. The action is also performed when selecting the linked
resource and pressing F5 key

A list of useful file properties similar to the ones available in the Properties view can be obtained with the Properties
action of the popup menu invoked on a file node of the Project view tree, in a dialog like below:
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Figure 4.43. The Properties dialog

The full path to the project files is hidden by default. Click the toolbar button  Show/Hide Path to toggle the file
path on or off.

The files and folders that appear as visible in the Project view can be filtered. Click the toolbar button  Filters to set
filter patterns for the files you want or do NOT want to show.

Figure 4.44. Project filters dialog

In the dialog you can introduce filter patterns for the files that will be shown, files that will be hidden and filter patterns
for the linked directories of the Project view that will be hidden.

Right-clicking any object in the tree-view displays the Project menu with functions that can be performed on, or from
the selected object. Options available from the Project menu are specific to the object type selected in the tree-view.

You can also use drag and drop to arrange the files in logical folders(but not in linked folders). Also, dragging and
dropping files from the project tree to the editor area results in the files being opened.
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Team Collaboration - Subversion

There is a SVN (Subversion) Client application embedded in <oXygen/>. You may start it from the Tools menu and
use it for synchronizing your working copy with a central repository.

Another way of starting it is by using the contextual menu of the project tree: Team → Open in SVN Client. This action
displays the Syncro SVN Client and shows the selected project file in the working copy view.

Project Level Settings

You can store into the project not only lists of files and directories, but also transformation scenarios and other setting.
For more information see the Preference Sharing and Sharing the Transformation Scenarios sections.

Including document parts with XInclude
XInclude is a standard for assembling XML instances into another XML document through inclusion. It enables larger
documents to be dynamically created from smaller XML documents without having to physically duplicate the content
of the smaller files in the main file. XInclude is targeted as the replacement for External Entities. The advantage of
using XInclude is that, unlike the entities method, each of the assembled documents is permitted to contain a Document
Type Declaration (DOCTYPE Decl.). This means that each file is a valid XML instance and can be independently
validated. It also means that the main document to which smaller instances are included can be validated without
having to remove or comment the DOCTYPE Decl. as is the case with External Entities. This is makes XInclude a
more convenient and effective method for managing XML instances that need to be stand-alone documents and part
of a much larger work.

The main application for XInclude is in the document orientated content frameworks such as manuals and Web pages.
Employing XInclude enables authors and content managers to manage content in a modular fashion that is akin to
Object Orientated methods used in languages such as Java, C++ or C#.

The advantages of modular documentation include: reusable content units, smaller file units that are easier to edited,
better version control and distributed authoring.

An example: create a chapter file and an article file in the samples folder of the <oXygen/> install folder and include
the chapter file in the article file using XInclude.

Chapter file introduction.xml:

<?xml version="1.0"?>
<!DOCTYPE chapter PUBLIC "-//OASIS//DTD DocBook XML V4.3//EN"
"http://www.oasis-open.org/docbook/xml/4.3/docbookx.dtd">
<chapter>
    <title>Getting started</title>
    <section>
        <title>Section title</title>
        <para>Para text</para>
    </section>
</chapter>

Main article file:

<?xml version="1.0"?>
<!DOCTYPE article PUBLIC "-//OASIS//DTD DocBook XML V4.3//EN"
"http://www.docbook.org/xml/4.3/docbookx.dtd"
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[ <!ENTITY % xinclude SYSTEM "../frameworks/docbook/dtd/xinclude.mod">
%xinclude;
]>
<article>
    <title>Install guide</title>
    <para>This is the install guide.</para>
    <xi:include xmlns:xi="http://www.w3.org/2001/XInclude" 
                    href="introduction.xml">
      <xi:fallback>
        <para>
          <emphasis>FIXME: MISSING XINCLUDE CONTENT</emphasis>
        </para>
      </xi:fallback>
    </xi:include>
</article>

In this example the following is of note:

• The DOCTYPE Decl. defines an entity that references a file containing the information to add the xi namespace to
certain elements defined by the DocBook DTD.

• The href attribute of the xi:include element specifies that the introduction.xml file will replace the xi:include
element when the document is parsed.

• If the introduction.xml file cannot be found the parse will use the value of the xi:fallback element - a message
to FIXME.

If you want to include only a fragment of other file in the master file the fragment must be contained in a tag having
an xml:id attribute and you must use an XPointer expression pointing to the xml:id value. For example if the master
file is:

<?xml version="1.0" encoding="UTF-8"?>
<?oxygen RNGSchema="test.rng" type="xml"?>
<test>
    <xi:include href="a.xml" xpointer="a1" 
        xmlns:xi="http://www.w3.org/2001/XInclude"/>
</test>

and the a.xml file is:

<?xml version="1.0" encoding="UTF-8"?>
<test>
    <a xml:id="a1">test</a>
</test>

after resolving the XPointer reference the document is:

<?xml version="1.0" encoding="UTF-8"?>
<?oxygen RNGSchema="test.rng" type="xml"?>
<test>
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    <a xml:id="a1" xml:base="a.xml">test</a>
</test>

The XInclude support in <oXygen/> is turned on by default. You can toggle it by going to the entry Enable XInclude
processing in the menu Options → Preferences ...+XML / XML Parser When enabled <oXygen/> will be able to val-
idate and transform documents comprised of parts added using XInclude.

Working with XML Catalogs
When Internet access is not available or the Internet connection is slow the OASIS XML catalogs
[http://www.oasis-open.org/committees/entity/spec.html] present in the list maintained in the XML Catalog Preferences
panel will be scanned trying to map a remote system ID (at document validation) or a URI reference (at document
transformation) pointing to a resource on a remote Web server to a local copy of the same resource. If a match is found
then <oXygen/> will use the local copy of the resource instead of the remote one. This enables the XML author to
work on his XML project without Internet access or when the connection is slow and waiting until the remote resource
is accessed and fetched becomes unacceptable. Also XML catalogs make documents machine independent so that they
can be shared by many developers by modifying only the XML catalog mappings related to the shared documents.

<oXygen/> supports any XML catalog file that conforms to one of:

• t h e  O A S I S  X M L  C a t a l o g s  C o m m i t t e e  S p e c i fi c a t i o n  v 1 . 1
[http://www.oasis-open.org/committees/download.php/14809/xml-catalogs.html]

• the OASIS Technical Resolution 9401:1997 [http://www.oasis-open.org/specs/a401.htm] including the plain-text
flavor described in that resolution

The version 1.1 of the OASIS XML Catalog specification introduces the possibility to map a system ID, a public ID
or a URI to a local copy using only a suffix of the ID or URI used in the actual document. This is done using the new
c a t a l o g  e l e m e n t s  s y s t e m S u f fi x
[http://www.oasis-open.org/committees/download.php/14809/xml-catalogs.html#s.systemsuffix] and uriSuffix
[http://www.oasis-open.org/committees/download.php/14809/xml-catalogs.html#s.urisuffix].

An XML catalog can be used also to map a W3C XML Schema specified with an URN in the xsi:schemaLocation at-
tribute of an XML document to a local copy of the schema. For example if the XML document specifies the schema
with:

<topic xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:noNamespaceSchemaLocation="urn:oasis:names:tc:dita:xsd:topic.xsd:1.1">

the URN can be resolved to a local schema file with a catalog entry like:

<system systemId="urn:oasis:names:tc:dita:xsd:topic.xsd:1.1"
    uri="topic.xsd"/>

An XML Catalog file can be created quickly in <oXygen/> starting from the two XML Catalog document templates
called OASIS XML Catalog 1.0 and OASIS XML Catalog 1.1 and available in the document templates dialog
[creating-from-templates].

User preferences related to XML Catalogs can be configured from Options → Preferences ... +XML / XML Catalog

Formatting and indenting documents (pretty print)
In structured markup languages, the whitespace between elements that is created by use of the Space bar, Tab or
multiple line breaks insertion from use of the Enter, is not recognized by the parsing tools. Often this means that when
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structured markup documents are opened, they are arranged as one long, unbroken line, what seems to be a single
paragraph.

While this is perfectly acceptable practice, it makes editing difficult and increases the likelihood of errors being intro-
duced. It also makes the identification of exact error positions difficult. Formatting and Indenting, also called Pretty
Print, enables such documents to be neatly arranged, in a manner that is consistent and promotes easier reading on
screen and in print output.

Pretty print is in no way associated with the layout or formatting that will be used in the transformed document. This
layout and formatting is supplied by the XSL stylesheet specified at the time of transformation.

Procedure 4.5. To format and indent a document:

1. Open or focus on the document that is to be formatted and indented.

2. Select menu Document → XML Document → Format and Indent (Ctrl+Shift+P (Cmd+Shift+F on Mac OS))

or click the toolbar button  Format and indent . While in progress the Status Panel will indicate Pretty print in
progress. On completion, this will change to Pretty print successful and the document will be arranged.

Note

Pretty Print can format empty elements as an auto-closing markup tag (ex. <a/>) or as a regular tag (ex. <a></a>
). It can preserve the order or attributes or order them alphabetically. Also the user may specify a list of elements
for which white spaces are preserved exactly as before Pretty print and one with elements for which white space
is stripped. These can be configured from Options → Preferences+Editor / Format.

Pretty Print requires that the structured document is Well-Formed XML. If the document is not Well-Formed XML an
error message is displayed. The message will usually indicate that a problem has been found in the form and will hint
to the problem type. It will not highlight the general position of the error, to do this run the well formed action by se-
lecting Document → Check document form (Ctrl+Shift+W).

Note

If the document is not well-formed because some XML elements contain code in a specific language, for example
JavaScript:

    <script language="JavaScript" type="text/javascript"> 
        var javawsInstalled = 0; 
        var javaws12Installed = 0; 
        var javaws142Installed=0; 
        isIE = "false";

        if (navigator.mimeTypes && navigator.mimeTypes.length) { 
            x = navigator.mimeTypes['application/x-java-jnlp-file']; 
            if (x) { 
                javawsInstalled = 1; 
                javaws12Installed=1; 
                javaws142Installed=1; 
            } 
        } else { 
            isIE = "true"; 
        }
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</script>

this code can be enclosed in an XML comment to make the document well-formed before applying the Format
and Indent action:

  <script language="JavaScript" type="text/javascript"> 
    <!--
        var javawsInstalled = 0; 
        var javaws12Installed = 0; 
        var javaws142Installed=0; 
        isIE = "false";

        if (navigator.mimeTypes && navigator.mimeTypes.length) { 
            x = navigator.mimeTypes['application/x-java-jnlp-file']; 
            if (x) { 
                javawsInstalled = 1; 
                javaws12Installed=1; 
                javaws142Installed=1; 
            } 
        } else { 
            isIE = "true"; 
        }
    -->
</script>

To change the formatting of just one XML element see the action  Pretty print element . To change the indenting of
the current selected text see the action  Indent selection .

For user preferences related to formatting and indenting like Detect indent on open and Indent on paste see the corres-
ponding Preferences panel.

XML elements can be excepted from the reformatting performed by the pretty-print operation by including them in
the Preserve space elements (XPath) list. That means that when the Format and Indent (pretty-print) action encounters
in the document an element with the name contained in this list the whitespace is preserved inside that element. This
is useful when most of the elements must be reformatted with the exception of a few ones which are listed here.

For the situation when whitespace should be preserved in most elements with the exception of a few elements, the
names of these elements must be added to the Strip space elements (XPath) list.

In addition to simple element names both the Preserve space elements (XPath) list and the Strip space elements (XPath)
one accept a restricted set of XPath expressions for covering a pattern of XML elements with only one expression.
The allowed types of expressions are:

//xs:documentation the XPath descendant axis can be used only at the beginning of the expression;
the namespace prefix can be attached to any namespace, no namespace binding
check is performed when applying the pretty-print operation

/chapter/abstract/title note the use of the XPath child axis

//section/title the descendant axis can be followed by the child axis
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The value of an xml:space attribute present in the XML document on which the pretty-print operation is applied always
takes precedence over the Preserve space elements (XPath) and the Strip space elements (XPath) lists.

Viewing status information
Status information generated by the Schema Detection, Validation, Validate as you type and Transformation threads
are fed into the Information view allowing the user to monitor how the operation is being executed.

Figure 4.45. Information view messages

Messages contain a timestamp, the name of the thread that generated it and the actual status information. The number
of displayed messages can be controlled from the options panel.

In order to make the view visible go to Perspective+Show View → Information

Image preview
Images and SVG files from the Project view can be previewed in a separate panel.
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Figure 4.46. The Preview panel

To preview an image one has to either double click the image name or click the Preview action from the Project's tree
contextual menu. Supported image types are GIF, JPEG/JPG, PNG, BMP. Once the image is displayed in the Preview
panel using the actions from the contextual menu one can scale the image at its original size (1:1 action) or scale it
down to fit in the view's available area (Scale to fit action).

Making a persistent copy of results
To make a persistent copy of the results displayed in the Results panel from operations like document validation,
checking the form of documents, XSLT or FO transformation, find all occurrences of a string, applying an XPath ex-
pression to the current document use one of the actions:

• File → Save Results - displays the Save Results dialog, used to save the result-list of the current message tab. The
action is also available on the right click menu of the Results panel.

• File → Print Results - displays the Page Setup dialog used to define the page size and orientation properties for
printing the result-list of the current Results panel. The action is also available on the right click menu of the Results
panel.

• Save Results as XML on the right click menu - saves the content of the Results panel in an XML file with the format:

<Report>
    <Incident>
        <engine>The engine who provide the error.<engine>
        <severity>The severity level<severity> 
        <Description>Description of output message.</Description>
        <SystemID>The location of the file linked to the message.</SystemID>
        <Location>
           <start>
                <line>Start line number in file.<line>
                <column>Start column number in file<column>
           </start>
           <end>
                <line>End line number in file.<line>
                <column>End column number in file<column>
           </start>
        </Location>
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    </Incident>
</Report>                                

Locking and unlocking XML markup
For documents with fixed markup such as forms in which the XML tags are not allowed to be modified but only their
text content, editing of the XML tag names can be disabled and re-enabled with an action available from Docu-

ment+Source → Locks/Unlocks the XML Tags or from the toolbar button  Locks/Unlocks the XML tags

There is a default lock state for all opened editors in the Preferences XML Editor Format page.

Adjusting the transparency of XML markup
Most of the time you want the content of a document displayed on screen with zero transparency. When you want to
focus your attention only on editing text content inside XML tags <oXygen/> offers the option of reducing the visibility
of the tags by increasing their transparency when they are displayed. There are two levels of tag transparency: semi-
transparent markup and transparent markup. For the opposite case, when you want to focus on the tag names, the text
transparency can be set to one of two levels: semi-transparent text and transparent text. To change the level of transpar-
ency:

•
Click the toolbar button Adjust contrast available on the Edit toolbar to adjust the contrast of markup in Editor
perspective. If the Edit toolbar is not visible right-click in the toolbar area and select Edit from the popup menu.

On Windows XP and Windows Vista, depending on antialiasing settings and JVM used, this functionality could have
no effect.

XML editor specific actions
<oXygen/> offers groups of actions for working on single XML elements. They are available from the Document menu
and the context menu of the main editor panel. On Windows the context menu can be displayed with the mouse on a
right click or with the keyboard by pressing the special context menu key available on Windows keyboards.

Split actions

Also the editing area can be divided vertically and horizontally with the split / unsplit actions available on the Split

toolbar, the Document → Split menu and the popup menu of the editor panel for XML files:  Split horizontally, 

Split vertically,  Unsplit.

Edit actions

• Document+Edit → Toggle Line Wrap (Ctrl + Shift + Y): Turns on line wrapping in the editor panel if it was off
and vice versa. It has the same effect as the Line wrap preference.

• Document+Edit → Toggle comment (Ctrl + Shift + ,): Comment the current selection of the current editor. If the
selection already contains a comment the action removes the comment from around the selection. If there is no se-
lection in the current editor and the cursor is not positioned inside a comment the current line is commented. If the
cursor is positioned inside a comment then the commented text is uncommented. The action is also available on the
popup menu of the editor panel.
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Select actions

The Select actions are enabled when the caret is positioned inside a tag name.

• Document+Select → Element: Selects the entire current element;

• Document+Select → Content: Selects the content of the current element, excluding the start tag and end tag;

• Document+Select → Attributes: Selects all the attributes of the current element;

• Document+Select → Parent: Selects the parent element of the current element;

Source actions

• Document+Source+Locks / Unlocks the XML Tags  : Disable / Enable editing of XML tags

• Document+Source → To lower case: Converts the selection's content to lower case characters.

• Document+Source → To upper case: Converts the selection's content to upper case characters.

• Document+Source → Capitalize lines: Converts to upper case the first character of every selected line.

• Document+Source+Shift Right  (Tab): Shifts the selected block to the right;

• Document+Source+Shift Left  (Shift+Tab): Shifts the selected block to the left;

• Document+Source+Escape Selection ...  : Escapes a range of characters by replacing them with the corresponding
character entities.

Figure 4.47. Escape selection

• Document+Source+Unescape Selection ...  : Replaces the character entities with the corresponding characters;
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Figure 4.48. Unescape selection

• Document+Source+Indent selection  (Ctrl + I):Corrects the indentation of the selected block of lines.

• Document+Source+Format and Indent Element  (Ctrl + I): Pretty prints the element that surrounds the caret
position;

• Document+Source+Import entities list  : Shows a dialog that allows you to select a list of files as sources for
external entities. The DOCTYPE section of your document will be updated with the chosen entities. For instance,
if choosing the file chapter1.xml, and chapter2.xml, the following section is inserted in the DOCTYPE:

<!ENTITY chapter1 SYSTEM "chapter1.xml">

<!ENTITY chapter2 SYSTEM "chapter2.xml">

• Triple click on an element or processing instruction - If the triple click is done before the start tag of an element or
after the end tag of an element then all the element is selected by the triple click action. If it is done after the start
tag or before the end tag then only the element content without the start tag and end tag is selected.

• Document+Source → To Lower Case : The action works on the selection converting all upper case letters to lower
case.

• Document+Source → To Upper Case : The action works on the selection converting all lower case letters to upper
case.

• Document+Source → Capitalize lines: It capitalizes the first letter found on every new line that is selected. Only
the first letter is affected, the rest of the line remains the same. If the first character on the new line is not a letter
then no changes are made.

• Document+Source → Join and normalize: The action works on the selection. It joins the lines by replacing the line
separator with a single space character. It also normalizes the whitespaces by replacing a sequence of such characters
with a single space.

XML document actions

• Document+XML Document → Show Definition (also available on the contextual menu of the editor panel) : move
the cursor to the definition of the current element in the schema associated with the edited XML document (DTD,
XML Schema, Relax NG schema, NRL schema).

• Document+XML Document → Copy XPath (Ctrl+Alt+.): Copy XPath expression of current element from current
editor to clipboard.
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• Document+XML Document+Go to the matching tag  (Ctrl+Shift+G): Moves the cursor to the end tag that matches
the start tag, or vice versa.

• Document+XML Document → Go after Next Tag (Ctrl+Close Bracket): Moves the cursor to the end of the next
tag.

• Document+XML Document → Go after Previous Tag (Ctrl+Open Bracket): Moves the cursor to the end of the
previous tag.

• Document+XML Document+Associate XSLT/CSS Stylesheet  : Inserts an xml-stylesheet processing instruction
at the beginning of the document referencing either an XSLT or a CSS file depending on the user selection. Either
reference is useful for rendering the document in a Web browser when the action Open in browser is executed.
Referencing the XSLT file is also useful for automatic detection of the transformation stylesheet when there is no
scenario associated with the current document

Figure 4.49. Associate XSLT/CSS stylesheet dialog

When associating the CSS, the user can also specify the title and if the stylesheet is an alternate one. Setting a Title
for the CSS makes it the author's preferred stylesheet. Checking the Alternate checkbox makes the CSS an alternate
stylesheet.

oXygen Author fully implements the W3C recommendation regarding "Associating Style Sheets with XML docu-
ments". For more information see: http://www.w3.org/TR/xml-stylesheet/http://www.w3.org/TR/REC-
html40/present/styles.html#h-14.3.2

XML Refactoring actions

• Document+XML Refactoring+Surround with tag...  (Ctrl+E): Selected Text in the editor is marked with the
specified start and end tags.

• Document+XML Refactoring+Surround with last <tag>  (Ctrl+/): Selected Text in the editor is marked with
start and end tags of the last 'Surround in' action.

• Document+XML Refactoring+Rename element  (Alt+Shift+R): The element from the caret position and the
elements that have the same name as the current element can be renamed according with the options from the Rename
dialog.

• Document+XML Refactoring+Rename prefix  (Alt+Shift+P): The prefix of the element from the caret position
and the elements that have the same prefix as the current element can be renamed according with the options from
the Rename dialog.
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Figure 4.50. Rename Prefix Dialog

Selecting the Rename current element prefix option the application will recursively traverse the current element and
all its children.

For example, to change the xmlns:p1="ns1" association existing in the current element to xmlns:p5="ns1" just select
this option and press OK. If the association xmlns:p1="ns1" is applied on the parent of the current element, then
<oXygen/> will introduce a new declaration xmlns:p5="ns1" in the current element and will change the prefix from
p1 to p5. If p5 is already associated in the current element with another namespace, let's say ns5, then a dialog
showing the conflict will be displayed. Pressing the OK button, the prefix will be modified from p1 to p5 without
inserting a new declaration xmlns:p5="ns1". On Cancel no modification is made.

Selecting the "Rename current prefix in all document" option the application will apply the change on the entire
document.

To apply the action also inside attribute values one must check the Rename also attribute values that start with the
same prefix checkbox.

• Document+XML Refactoring+Split element  (Ctrl+Alt+D): Split the element from the caret position in two
identical elements. The caret must be inside the element

• Document+XML Refactoring+Join elements  (Ctrl+Alt+J): Joins the left and the right elements relative to the
current caret position. The elements must have the same name, attributes and attributes values.

• Document+XML Refactoring+Delete element tags  (Ctrl+Alt+X): Deletes the start tag and end tag of the current
element.

Smart editing

Closing tag auto-expansion If you want to insert content into an auto closing tag like <tag/> deleting the /
character saves some keystrokes by inserting a separate closing tag automatically
and placing the cursor between the start and end tags: <tag></tag>

Auto-rename matching tag When you edit the name of the start tag, <oXygen/> will mirror-edit the name
of the matching end tag. This feature can be controlled from the Content Com-
pletion option page.

Auto-breaking the edited line The Hard line wrap option breaks the edited line automatically when its length
exceeds the maximum line length defined for the pretty-print operation.

Indent on Enter The Indent on Enter option indents the new line inserted when Enter is pressed.
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Smart Enter The Smart Enter option inserts an empty line between the start and end tags and
places the cursor in an indented position on the empty line automatically when
the cursor is between the start and end tag and Enter is pressed.

Triple click A triple click with the left mouse button selects a different region of text of the
current document depending on the position of the click in the document:

• if the click position is inside a start tag or an end tag then the entire element
enclosed by that tag is selected

• if the click position is immediately after a start tag or immediately before an
end tag then the entire content of the element enclosed by that tag is selected,
including all the child elements but excluding the start tag and the end tag of
the element

• otherwise the triple click selects the entire current line of text

Syntax highlight depending on namespace prefix

The syntax highlight scheme of an XML file type allows the configuration of a color per each type of token which can
appear in an XML file. Distinguishing between the XML tag tokens based on the namespace prefix brings additional
visual help in editing some XML file types. For example in XSLT stylesheets elements from different namespaces
like XSLT, XHTML, XSL:FO or XForms are inserted in the same document and the editor panel can become cluttered.
Marking tags with different colors based on the namespace prefix allows easier identification of the tags.

Figure 4.51. Example of coloring XML tags by prefix

Editing DITA Maps
DITA Maps organize topics for output to a specific deliverable, including generating navigation files and links to related
topics. <oXygen/> provides a special DITA Maps editing view.

The DITA Maps Manager view presents maps in a simplified table-of-contents manner allowing the user to easily
navigate the referred topics, make changes and perform transformations to various output formats using the DITA-OT
framework bundled with <oXygen/>.
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Figure 4.52. The DITA Maps Manager view

The Maps Manager view supports opening multiple documents at the same time.

All files which have the extension .ditamap and are opened in the application will be opened in the DITA Maps
Manager view. In additional you can right click the file in the Project view and select Open with. After the map is
opened in the Manager you can open it in the main editor for further customization using the Open map in editor
toolbar action.

Tip

If you want to transform your DITA topics to various formats using the DITA Open Toolkit you can open them
in the DITA Maps Manager view using the "Open" button located on the internal toolbar and transform them
from here.

Note

A map opened from WebDAV can be locked when it is opened in DITA Maps Manager by checking the option
Lock WebDAV files on open to protect it from concurrent modifications on the server by other users. If other
user tries to edit the same map he will receive an error message and the name of the lock owner. The lock is re-
leased automatically when the map is closed from <oXygen/> DITA Maps Manager.

In additional to being available on the toolbar and on the contextual menu, more navigation actions and all edit actions
appear in the DITA Maps menu. The menu is only available when the view is active on screen.
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Figure 4.53. DITA Maps menu

The following general actions can be performed on an opened DITA Map :

Open
Allows opening the DITA Map in the DITA Maps Manager view. You can also
open a DITA Map by dragging it in the DITA Maps Manager from the file
system explorer.

Open URL
Allows opening remote DITA Maps in the DITA Maps Manager view. See Open
URL for details.

Save
Allows saving the currently opened DITA Map.

Apply Transformation Scenario Allows the user to start the DITA ANT Transformation scenario associated with
the opened map. For more transformation details see here.

Configure Transformation Scen-
ario

Allows the user to configure a DITA ANT Transformation scenario for the
opened map. For more transformation details see here.

Refresh References Sometimes after a topic was edited and its title changed the topic's title needs
to be also updated in the DITA Maps manager view. You can use this action to
refresh and update titles for all referred topics.

Open map in editor For complex operations which cannot be performed in the simplified DITA
Maps view (like editing a relationship table) you can open the map in the main
editing area. See more about editing a map in the main edit area here.

Tip

The additional edit toolbar can be shown by clicking the "Show/Hide additional toolbar" expand button located
on the general toolbar.

The following edit actions can be performed on an opened DITA Map:

Insert Topic Reference Inserts a reference to a topic file. See more about this action here.
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Insert Topic Heading Inserts a topic heading. See more about this action here

Insert Topic Group Inserts a topic group. See more about this action here.

Edit properties Edit the properties of a selected node. See more about this action here.

Edit other attributes Edits all the attributes of a selected node. A dialog is presented allowing the
user to see and edit the attributes of the selected node. See here for more details
about editing attributes.

Delete Deletes the selected nodes.

Move Up Moves the selected nodes in front of their respective previous siblings.

Move Down Moves the selected nodes after their next respective siblings.

Promote Moves the selected nodes after their respective parents as a siblings.

Demote Moves the selected nodes as children to their respective previous siblings.

The contextual menu contains, in addition to the edit actions described above, the following actions:

Open in editor Open in the editor the resources referred by the selected nodes

Cut, Copy, Paste, Undo, Redo Common edit actions with the same functionality as those found in the text ed-
itor

Paste before, Paste after Will paste the content of the clipboard before respectively after the selected
node.

Append Child/Insert After Append/Insert a topic reference as a
child/sibling of the selected node

Topic reference

Topic reference to the current edited
file

Append/Insert a topic reference to the
current edited file as a child/sibling of
the selected node

Topic heading Append/Insert a topic heading as a
child/sibling of the selected node

Topic group Append/Insert a topic group as a
child/sibling of the selected node

You can also arrange the nodes by dragging and dropping one or more nodes at a time. Drop operations can be performed
before, after or as child of the targeted node. The relative location of the drop is indicated while hovering the mouse
over a node before releasing the mouse button for the drop.

Drag and drop operations allow you to:

Copy Select the nodes you want to copy and start dragging them. Before dropping them in the
appropriate place, press and hold the CTRL key(META key on Mac). The mouse pointer
should change to indicate that a copy operation will be performed.

Move Select the nodes you want to move and drag and drop them in the appropriate place.
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Promote / Demote You can move nodes between child and parent nodes which ensures both Promote and Demote
operations.

Tip

You can open and edit linked topics easily by double clicking the references or by right-clicking and choosing
"Open in editor". If the referenced file does not exist you will be allowed to create it.

By right clicking the map root element you can open and edit it in the main editor area for more complex opera-
tions.

You can decide to open the reference directly in the Author page and keep this setting as a default.

Note

Some of the common actions from the main application menu/toolbar also apply to the DITA Maps Manager
when it has focus. These actions are:

File actions Save, Save As, Save to URL, Save All, Print, Print preview, Close, Close others, Close all

Edit actions Undo, Redo, Cut, Copy, Paste, Delete

The Save all action applies to all editors opened in either <oXygen/> work area or the DITA Maps Manager.

Advanced operations

Inserting a Topic Reference

The topicref element identifies a topic (such as a concept, task, or reference) or other resource. A topicref can contain
other topicref elements, allowing you to express navigation or table-of-contents hierarchies, as well as implying rela-
tionships between the containing topicref and its children. You can set the collection-type of a container topicref to
determine how its children are related to each other. You can also express relationships among topicref's using group
and table structures (using topicgroup and reltable). Relationships end up expressed as links in the output (with each
participant in a relationship having links to the other participants by default).

A reference to a topic file may be inserted both from the toolbar action and the contextual node actions. The same
dialog can be used to insert references to maps or links to non-dita files like pdf's.
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Figure 4.54. Insert Topic Reference Dialog

By using the Insert Topic Reference Dialog you can easily browse for and select the source topic file. The Target
combo box shows all available topics that can be targeted in the file. Selecting a target modifies the Href value to point
to it. The Format and Scope combos are automatically filled based on the selected file. You can specify and enforce
a custom navigation title by checking the Navigation title checkbox and entering the desired title.

The file chooser located in the dialog allows you to easily select the desired topic. The selected topic file will be added
as a child/sibling of the current selected topic reference. You can easily insert multiple topic references by keeping the
dialog opened and changing the selection in the DITA Maps Manager tree. You can also select multiple resources in
the file explorer and then insert them all as topic references.

Another easy way to insert a topic reference is to directly drag and drop topic files from the Oxygen Project or the
Explorer right in the DITA Maps tree.

Inserting a Topic Heading

The topichead element provides a title-only entry in a navigation map, as an alternative to the fully-linked title provided
by the topicref element.

A topic heading can be inserted both from the toolbar action and the contextual node actions.
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Figure 4.55. Insert Topic Heading Dialog

By using the Insert Topic Heading Dialog you can easily insert a topichead element. The Navigation title is required
but other attributes can be specified as well from the dialog.

Inserting a Topic Group

The topicgroup element identifies a group of topics (such as a concepts, tasks, or references) or other resources. A
topicgroup can contain other topicgroup elements, allowing you to express navigation or table-of-contents hierarchies,
as well as implying relationships between the containing topicgroup and its children. You can set the collection-type
of a container topicgroup to determine how its children are related to each other. Relationships end up expressed as
links in the output (with each participant in a relationship having links to the other participants by default).

A topic group may be inserted both from the toolbar action and the contextual node actions.

Figure 4.56. Insert Topic Group Dialog

By using the Insert Topic Group Dialog you can easily insert a topicgroup element. The Type, Format, Scope and
Collection type attributes can be specified from the dialog.

Edit properties

The Edit properties action, available both on the toolbar and on the contextual menu, is used to edit the properties of
the selected node. Depending on the selected node, the action will perform the following tasks:

• If a topicref element is selected, the action will show a dialog similar with the Insert Topic Reference dialog allowing
the editing of some important attributes.
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• If a topichead element is selected, the action will show a dialog similar with the Insert Topic Heading dialog allowing
the editing of some important attributes.

• If a topicgroup element is selected, the action will show a dialog similar with the Insert Topic Group dialog allowing
the editing of some important attributes.

• If the map's root element is selected then the user will be able to easily edit the map's title using the Edit Map title
dialog:

Figure 4.57. Edit Map Title Dialog

By using this dialog you can also specify whether the title will be specified as the title attribute to the map or as a title
element (for DITA-OT 1.1) or specified in both locations.

Transforming DITA Maps
<oXygen/> uses the DITA Open Toolkit (DITA-OT) to transform XML content into an output format. For this purpose
both the DITA Open Toolkit 1.4.3 and ANT 1.7 come bundled in <oXygen/>.

Available Output Formats

You can publish DITA-based documents in any of the following formats:

XHTML DITA Map to XHTML

PDF - DITA OT DITA Map to PDF using the DITA OT default PDF target

PDF2 - IDIOM FO Plugin DITA Map to PDF using the DITA OT IDIOM PDF plugin

HTML Help (CHM) DITA Map to HTML Help. If you have installed HTML Help Workshop, <oXy-
gen/> detect and use this. At the end of the transformation the chm file will be
open. Otherwise an error message is displayed, but the hhp(HTML Help Project)
file will be generated and you have to compile to obtain a chm file.

Note that HTML Help Workshop fails when the files used for transformation con-
tains diacritics in name. This problem appear because the hhp file is generated with
UTF8 encoding, and the hhc file read this file with another encoding.

JavaHelp DITA Map to JavaHelp

Eclipse Help DITA Map to Eclipse Help

Eclipse Content DITA Map to Eclipse Content

RTF DITA Map to Rich Text Format

TROFF DITA Map to Text Processor for Typesetters
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Docbook DITA Map to Docbook

Configuring a DITA transformation

Creating DITA Map transformation scenarios is similar to creating scenarios in the main editing area. See here for
more details.

When creating a new scenario you can choose the type of output the DITA-OT ANT scenario will generate:

Figure 4.58. Select DITA Transformation type

Depending on the chosen type of output <oXygen/> will generate values for the default ANT parameters so that you
can execute the scenario right away without further customization.

Tip

If you want to transform your DITA topics to various formats using the DITA Open Toolkit you can open them
in the DITA Maps Manager view using the "Open" button located on the internal toolbar and transform them
from here.

Customizing the DITA scenario

The Parameters tab

In the Scenario Edit Parameters Tab you can customize all the parameters which will be sent to the DITA-OT build
file.
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Figure 4.59. Edit DITA Ant transformation parameters

All the parameters that can be set to the DITA-OT build files for the chosen type of transformation (eg: XHTML) are
listed along with their description. The values for some important parameters are already filled in. You can find more
i n f o r m a t i o n  a b o u t  e a c h  p a r a m e t e r  i n  t h e  D I TA  OT  D o c u m e n t a t i o n
[http://dita-ot.sourceforge.net/doc/DITA-antscript.html]

Using the toolbar buttons you can Add, Edit or Remove a parameter.

Figure 4.60. Edit DITA parameters dialog

Depending on the parameter type the parameter value will be a simple text field for simple parameter values, a combo
box with some predefined values or will have a file chooser and an editor variables selector to simplify setting a file
path as value to a parameter.

The Filters tab

In the Scenario Filters Tab you can add filters to remove certain content elements from the generated output.
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Figure 4.61. Edit Filters tab

You have two ways in which to define filters:

Use DITAVAL file If you already have a DITAVAL file associated with the transformed map you
can specify the path to it and it will be used when filtering content. You can find
out more about constructing a DITAVAL file in the DITA OT Documentation
[http://docs.oasis-open.org/dita/v1.1/CD01/langspec/common/about-ditaval.html].

Exclude from output all elements
with any of the following attributes

You can configure a simple list of attribute (name, value) pairs which when
present on an element in the input will remove it from output.

The Advanced tab

In the Advanced Tab you can specify advanced options for the transformation.
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Figure 4.62. Advanced settings tab

You have several parameters that you can specify here:

Custom build file If you use a custom DITA-OT build file you can specify the path to the customized build
file. If empty, the build.xml file from the dita.dir directory configured in the
Parameters tab will be used.

Build target You can specify a build target to the build file. By default no target is necessary and the
default "init" target is used.

Ant Home You can specify a custom ANT installation to run the DITA Map transformation. By default
it is the ANT installation bundled with <oXygen/>.

Java Home You can specify a custom Java Virtual Machine to run the ANT transformation. By default
it is the Java Virtual Machine used by <oXygen/>.

JVM Arguments This parameter allows you to set specific parameters to the Java Virtual Machine used by
ANT. By default it is set to -Xmx256m which means the transformation process is allowed
to use 256 megabytes of memory.

Example 4.6. Increasing the memory for the ANT process

Sometimes, when performing a large DITA map transformation you may want to increase
the memory allocated to the Java Virtual Machine from the default value (64 MB) to a
higher value (256MB). You can do this easily by setting the value '-Xmx256m' without
quotes to the "JVM Arguments" text field. In this way you can avoid the Out of Memory
( OutOfMemoryError ) messages received from the ANT process.
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Libraries You can specify all the additional libraries (jar files or additional class paths) which will
be used by the ANT transformer.

Example 4.7. Additional jars specified for XHTML

For example the additional jars specified for XHTML are the DITA-OT dost and resolver
jars, xerces and saxon 6 jars.

The Output tab

In the Output Tab you can configure options related to the place where the output will be generated.

Figure 4.63. Output settings tab

You have several parameters that you can specify here:

Base directory All the relative paths which appear as values in parameters are considered relative
to the base directory. The default value is the directory where the transformed
map is located.

Temporary files directory This directory will be used to store pre-processed temporary files until the final
output is obtained.

Output folder The folder where the final output content will be copied.

Output file options The transformation output can then be opened in a browser or even in the editor
if specified.
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The FO Processor tab

This tab appears only when selecting to generate PDF output using the IDIOM FO Plugin and allows you to choose
the FO Processor.

Figure 4.64. FO Processor configuration tab

You can choose between two processors:

Built-in (Apache FOP) This processor comes bundled with <oXygen/>. You can find more information
about it here.

XEP The RenderX [http://www.renderx.com/] XEP processor. You can add it very easy
from here.

If you select XEP in the combo and XEP was already installed in <oXygen/> you
can see the detected installation path appear under the combo.

XEP is considered as installed if it was detected from one of the following sources:

XEP was added as an external FO Processor in the <oXygen/> preferences. See here.
The system property "com.oxygenxml.xep.location" was set to point to the XEP
executable file for the platform (eg: xep.bat on Windows).
XEP was installed in the frameworks/dita/DITA-OT/demo/fo/lib direct-
ory of the <oXygen/> installation directory.

Tip

The DITA-OT contributors recommend the use of the IDIOM FO Plugin to transform DITA Maps to PDF as
opposed to using the standard PDF target in the DITA-OT framework.

94

Editing documents

http://www.renderx.com/
http://www.renderx.com/


As IDIOM is also bundled with <oXygen/> the PDF2 - IDIOM FO Plugin output format should be your first
choice in transforming your map to PDF. If you do not have a XEP licence you can transform using Apache FO
Processor.

Set a font for PDF output generated with Apache FOP

When a DITA map is transformed to PDF using the Apache FOP processor and it contains some Unicode characters
that cannot be rendered by the default PDF fonts then a font that is capable to render these characters must be configured
and embedded in the PDF result.

The settings that must be modified for configuring a font for the Apache FOP processor are detailed in this section.

Running a DITA Map ANT transformation

The transformation is run as an external ANT process so you can continue using the application as the transformation
unfolds. All output from the process appears in the DITA Transformation tab.

Tip

The HTTP proxy settings from <oXygen/> are also used for the ANT transformation so if the transformation
fails because it cannot connect to an external location you can check the HTTP/Proxy Configuration.

DITA OT customization support

Support for transformation customizations

You can change all DITA transformation parameters to customize your needs. See here for more details.In addition,
you can specify a custom build file, parameters to the JVM and many more for the transformation.

Using your own DITA OT toolkit from <oXygen/>

The DITA-OT toolkit which comes with <oXygen/> is located in the {INSTALLATION_DIRECTORY}/frame-
works/dita/DITA-OT directory.

You can configure another DITA-OT toolkit directory for use in <oXygen/> To do this you must edit the transformation
scenario that you are using and in the Parameters tab change the "dita.dir" parameter to your custom DITA-OT install-
ation directory. Also in the Advanced tab (the Libraries button) you have to add:

• the dost.jar and resolver.jar libraries as file paths that point to the libraries from your custom DITA-OT
installation directory

• the installation directory of your custom DITA-OT and the lib subdirectory of that installation directory as directory
paths

Using your custom build file

You can specify a custom build file to be used in DITA-OT ANT transformations by editing the transformation scenario
that you are using and in the Advanced tab change the Custom build file path to point to the custom build file.

Customizing the <oXygen/> Ant tool

The ANT 1.7 tool which comes with <oXygen/> is located in the {INSTALLATION_DIRECTORY}/tools/ant
directory. Any additional libraries for ANT must be copied to the <oXygen/> ANT lib directory.
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Example 4.8. Enabling JavaScript in ANT build files

If you are using Java 1.6 to run <oXygen/> the ANT tool should need to additional libraries to process JavaScript in
build files.

If you are using Java 1.5 you have to copy the bsf.jar [http://jakarta.apache.org/bsf/] and js.jar
[http://www.mozilla.org/rhino/download.html] libraries in the <oXygen/> ANT lib directory.

Upgrading to a new version of DITA OT

The DITA OT framework bundled in <oXygen/> is located in the {INSTALLATION_DIRECTORY}/frame-
works/dita/DITA-OT directory.

Important

There are a couple of modifications made to the DITA OT framework which will be overwritten if you choose
to copy the new DITA-OT version over the bundled one:

The DTD's in the framework have been enriched with documentation for each element. If you overwrite you
will lose the documentation which is usually shown when hovering an element or in the Model View
The IDIOM FO Plugin comes pre-installed in the bundled DITA-OT framework
Several build files from the IDIOM plugin have been modified to allow transformation using the <oXygen/>
Apache Built-in FOP libraries and usage of the <oXygen/> classpath while transforming.

Increasing the memory for the Ant process

You can give custom JVM Arguments to the ANT process. See here for more details.

Resolving topic references through an XML catalog

If you customized your map to refer topics using URI's instead of local paths or you have URI content references in
your DITA topic files and you want to resolve the URIs with an XML catalog when the DITA map is transformed then
you have to add the catalog to <oXygen/>. The DITA Maps Manager view will solve the displayed topic refs through
the added XML catalog and also the DITA map transformations (for PDF output, for XHTML output, etc) will solve
the URI references through the added XML catalog.

DITA specializations support

Important

If you are using DITA specializations we recommend that you to activate the Enable DTD processing in document
type detection checkbox in the Document Type Association page.

Support for editing DITA Map specializations

In addition to recognizing the default DITA map formats: map and bookmap the DITA Maps Manager can also be
used to open and edit specializations of DITA Maps.

All advanced edit actions available for the map like insertion of topic refs, heads, properties editing, allow the user to
specify the element to insert in an editable combo. Moreover the elements which appear initially in the combo are all
the elements which are allowed to appear at the insert position for the given specialization.
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The topic titles rendered in the DITA Maps Manager are collected from the target files by matching the class attribute
and not a specific element name.

When editing DITA specializations of maps in the main editor the insertions of topic reference, topic heading, topic
group and conref actions should work without modification. For the table actions you have to modify each action by
hand to insert the correct element name at caret position. You can go to the DITA Map document type from the Document
Type Association page and edit the table actions to insert the element names as specified in your specialization. See
this section for more details.

Support for editing DITA Topic specializations

In addition to recognizing the default DITA topic formats: topic, task, concept, reference and composite, topic special-
izations can also be edited in the Author page.

The Content Completion should work without additional modifications and you can choose the tags which are allowed
at the caret position.

The CSS styles in which the elements are rendered should also work on the specialized topics without additional
modifications.

The toolbar/menu actions should be customized to insert the correct element names if this is the case. You can go to
the DITA document type from the Document Type Association page and edit the actions to insert the element names
as specified in your specialization. See this section for more details.

Editing CSS stylesheets
<oXygen/> provides special support for developing CSS stylesheet documents.

Validating CSS stylesheets
<oXygen/> includes a built-in CSS validator integrated with the general validation support. This brings the usual val-
idation features to CSS stylesheets.

Content Completion in CSS stylesheets
A content completion assistant similar to the one of XML documents offers the CSS properties and the values available
for each property. It is activated on the CTRL + Space shortcut and it is context sensitive when it is invoked for the
value of a property.

Figure 4.65. Content Completion in CSS stylesheets
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The properties and the values offered as proposals are dependent on the CSS Profile selected in the  Options → Pref-
erences+CSS Validator  page, Profile combo box. The CSS 2.1 set of properties and property values is used for most
of the profiles, excepting CSS 1 and CSS 3 for which specific proposal sets are used.

CSS Outline View
The CSS Outline View presents the import declarations of other stylesheet files and all the selectors defined in the
current CSS document. The selector entries can be presented in the order they appear in the document or sorted by
element name used in the selector or the entire selector string representation. The selection in the outline view can be
synchronized with the caret moves or the changes made in the stylesheet document. When selecting an entry from the
outline view the corresponding import or selector will be highlighted in the CSS editor.

Figure 4.66. CSS Outline View

The selectors presented in the CSS Outline View can be quickly found using key search. When you press a sequence
of character keys while the focus is in the outline view the first selector that starts with that sequence will be selected.

Folding in CSS stylesheets
In a large CSS stylesheet document some styles may be collapsed so that only the needed styles remain in focus. The
same folding features available for XML documents are also available in CSS stylesheets.

Figure 4.67. Folding in CSS stylesheets
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Formatting and indenting CSS stylesheets (pretty print)
If the edited CSS stylesheet becomes unreadable because of the bad alignment of the text lines the pretty-print operation
available for XML documents is also available for CSS stylesheets. It works in the same way as for XML documents
and is available as the same menu and toolbar action.

Other CSS editing actions
The CSS editor type offers a reduced version of the popup menu available in the XML editor type, that means only
the folding actions,the edit actions and a part of the source actions (only the actions To lower case, To upper case,
Capitalize lines).

Integrating external tools
When your XML project requires to run an external tool different than a FO processor and which can be launched from
the command line <oXygen/> offers you the option of integrating the tool by specifying just the command line for
starting the executable file of the tool and its working directory. To integrate such a tool go to Options → Preferences+Ex-
ternal Tools

If the external tool is applied on one of the files opened in <oXygen/> you should enable the option for saving all edited
files automatically when an external tool is applied.

External tools can be launched from the External tools toolbar or from the submenu Tools → External tools. While

the action is running its icon is a stop icon:  . When the tool has finished running it will change the icon back to the

original run icon:  . Please note that even though you can stop the external tool by invoking the action again while
it is running, that doesn't mean you can also stop the processes spawned by that external tool. This is especially a lim-
iting factor when running a batch file as the batch will be stopped but without actually stopping the processes that the
batch was running at the time.

Integrating the Ant tool
As example let us integrate the Ant build tool [http://ant.apache.org/] in <oXygen/>. The procedure for this purpose
is:

1. Download [http://ant.apache.org/bindownload.cgi] and install [http://ant.apache.org/manual/install.html] Ant on
your computer.

2. Test your Ant installation from the command line in the directory where you want to use Ant from <oXygen/>,
for example run the clean target of your build.xml file C:\projects\XMLproject\build.xml: ant
clean

3. Go to Options → Preferences+External Tools

4. Create a new external tool entry with the name Ant tool, the working directory C:\projects\XMLproject
and the command line "C:\projects\XMLproject\ant.bat" clean obtained by browsing to the ant.bat file
from directory C:\projects\XMLproject

5. Run the tool from Tools → External Tools → Ant tool. You can see the output in the Command results panel:

    Started: "C:\projects\XMLproject\ant.bat" clean
    Buildfile: build.xml
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    clean:
    [echo] Delete output files.
    [delete] Deleting 5 files from C:\projects\XMLproject

    BUILD SUCCESSFUL
    Total time: 1 second

Large File Viewer
XML files tend to become larger and larger mostly because they are frequently used as a format for database export
or for porting between different database formats. Traditional XML text editors simply cannot handle opening these
huge export files, some having sizes exceeding one gigabyte, because of the necessity that all the file content must be
loaded in memory before the user can actually view it.

The best performance of the viewer is obtained for encodings that use a fixed number of bytes per character, like UTF-
16 or ASCII. The performance for UTF-8 is very good for documents that use mostly characters of the European lan-
guages. For the same encoding the rendering performance is high for files consisting of long lines (up to few thousands
characters ) and may degrade for short lines. In fact the maximum size of a file that can be rendered in the Large File
Viewer decreases when the total number of the text lines of the file increases. Trying to open a very large file, for example
a file of 4 GB with a very high number of short lines (100 or 200 characters per line) may produce an OutOfMemory
error which would require either increasing the Java heap memory with the -Xmx startup parameter or decreasing the
total number of lines in the file.

The powerful Large File Viewer is available from the Tools menu or as a standalone application. You can also right
click a file in your project and choose to open it with the viewer. It uses an efficient structure for indexing the opened
document. No information from the file is stored in the main memory, just a list of indexes in the file. In this way the
viewer is capable of opening very large files, up to two gigabytes. If the opened file is XML, the encoding used to
display the text is detected from the XML prolog of the file. In case of other files, the encoding is taken from the
<oXygen/> options. See Encoding for non XML files
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Figure 4.68. The Large File Viewer

Large File Viewer components:

• The menu bar provides menu driven access to all the features and functions available in Large File Viewer.

• File → Open provides access for opening files in the viewer (also available in the contextual pop-up menu).

• File → Close provides access for closing the viewer.

• Edit → Copy provides means to copy the selected text to clipboard (also available in the contextual pop-up menu).

• Find → Find provides access to the Find Dialog.

Figure 4.69. The Find Dialog

The find dialog provides some basic search options like:

Case sensitive When checked, operations are case sensitive.

Regular Expression When checked allows using any regular expression in PERL syntax.

Wrap around Continues the find from the start (end) of the document after reaching the end (start)
if the search is in forward (backward) direction.

• Help → Help provides access to this User Manual.
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• The status bar provides information about the current opened file path, the unicode representation of the character
at caret position and the line and column in the opened document where the caret is located.

Warning

For faster computation the Large File Viewer uses a fixed font (plain, monospace font of size 12) for displaying
characters. The font is not configurable from the <oXygen/> Preferences.

Tip

The best performance of the viewer is accomplished for encodings that use a fixed number of bytes per character,
like UTF-16 or ASCII. The performance for UTF-8 is very good for documents that use mostly characters of
the European languages. For the same encoding the rendering performance is high for files consisting of short
lines (Up to a few thousand characters) and may degrade for long lines.

Scratch Buffer
A handy addition to the document editing is the Scratch Buffer view used for storing fragments of arbitrary text during
the editing process. It can be used to drop bits of paragraphs (including arbitrary xml markup fragments) while rearranging
and editing the document and also to drag and drop fragments of text from the scratch buffer to the editor panel. The
Scratch Buffer is basically a text area offering XML syntax highlight. The view contextual menu contains basic edit
actions: Cut, Copy, Paste a. o.

Changing the user interface language
<oXygen/> comes with the user interface translated in English, French, German, Italian, Japanese and Dutch. If you
want to use <oXygen/> in other language you have to translate all the messages and labels available in the user interface
(menu action names, button names, checkbox texts, view titles, error messages, status bar messages, etc.) and provide
a text file with all the translated messages to <oXygen/> in the form of a Java properties file. Such a file contains pairs
of the form message key - translated message displayed in the user interface. In order to install the new set of translated
messages you must copy this file to the [oXygen-install-folder]/lib folder, restart <oXygen/> and set the new language
in the <oXygen/> preferences. You can get the keys of all the messages that must be translated from the properties file
containing the English translation used in <oXygen/>. To get this file contact us at support@oxygenxml.com.

Handling read-only files
If a file marked as read-only by the operating system is opened in <oXygen/> you will not be able to make modifications
to it regardless of the page the file was opened in. You can check out the read-only state of the file by looking in the
Properties view. If you modify the file's properties from the operating system and the file becomes writable you will
be able to make modifications to it on the spot without having to reopen it.

The read-only state is also marked by a lock decoration which appears in the editor tab and specified in the tooltip for
a certain tab.
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Chapter 5. Authoring in the tagless editor
Authoring XML documents without the XML tags
Once the structure of the XML document and the required restrictions on the elements and attributes are fixed with an
XML schema the editing of the document is easier in a WYSIWYG (what-you-see-is-what-you-get) editor in which
the XML markup is not visible.

This tagless editor is available as the Author mode of the XML editor. The Author mode is activated by pressing the
Author button at the bottom of the editing area where the mode switches of the XML editor are available: Text, Grid
and Author (see the following screenshot). The Author mode renders the content of the XML document visually based
on a CSS stylesheet associated with the document. Many of the actions and features available in Text mode are also
available in Author mode.

Figure 5.1. oXygen Author Editor

The tagless rendering of the XML document in the Author mode is driven by a CSS stylesheet which conforms to the
version 2.1 of the CSS specification [http://www.w3.org/TR/CSS21/] from the W3C consortium. Also some CSS 3
features like namespaces and custom extensions of the CSS specification are supported.

The CSS specification is convenient for driving the tagless rendering of XML documents as it is an open standard
maintained by the W3C consortium. A stylesheet conforming to this specification is very easy to develop and edit in
<oXygen/> as it is a plain text file with a simple syntax.
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The association of such a stylesheet with an XML document is also straightforward: an xml-stylesheet XML processing
instruction with the attribute type="text/css" must be inserted at the beginning of the XML document. If it is an XHTML
document, that is the root element is a html element, there is a second method for the association of a CSS stylesheet:
an element link with the href and type attributes in the head child element of the html element as specified in the
CSS specification [http://www.w3.org/TR/REC-html40/present/styles.html#h-14.3.2].

There are two main types of users of the Author mode: developers and content authors. A developer is a technical
person with advanced XML knowledge who defines the framework for authoring XML documents in the tagless editor.
Once the framework is created or edited by the developer it is distributed as a deliverable component ready to plug
into the application to the content authors. A content author does not need to have advanced knowledge about XML
tags or operations like validation of XML documents or applying an XPath expression to an XML document. He just
plugs the framework set up by the developer into the application and starts editing the content of XML documents
without editing the XML tags directly.

The framework set up by the developer is called document type and defines a type of XML documents by specifying
all the details needed for editing the content of XML documents in tagless mode: the CSS stylesheet which drives the
tagless visual rendering of the document, the rules for associating an XML schema with the document which is needed
for content completion and validation of the document, transformation scenarios for the document, XML catalogs,
custom actions available as buttons on the toolbar of the tagless editor.

The tagless editor comes with some ready to use predefined document types for XML frameworks largely used today
like DocBook, DITA, TEI, XHTML.

The Content Author role
A content author edits the content of XML documents in tagless mode disregarding the XML tags as they are not visible
in the editor. If he edits documents conforming to one of the predefined types he does not need to configure anything
as the predefined document types are already configured when the application is installed. Otherwise he must plug the
configuration of the document type into the application. This is as easy as unzipping an archive directly in the frameworks
subfolder of the application's install folder.

In case the edited XML document does not belong to one of the document types set up in Preferences you can specify
the CSS files to be used by inserting an xml-stylesheet processing instructions. You can insert the processing instruction

by editing the document or by using the Associate XSLT/CSS stylesheet action.

The syntax of such a processing instruction is:

<?xml-stylesheet type="text/css" media="media type" title="title" 
href="URL" alternate="yes|no"?>

You can read more about associating a CSS to a document, the syntax and the use of the xml-stylesheet processing in-
struction in the section Author CSS Settings.

When the document has no CSS association or the referred stylesheet files cannot be loaded a default one will be used.
A warning message will also be displayed at the beginning of the document presenting the reason why the CSS cannot
be loaded.

Note

In general it is recommended to associate a CSS while in Text mode so that the whitespace normalization rules
specified in the stylesheets will be properly applied when switching to Author mode.
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Figure 5.2. Document with no CSS association default rendering

Author views
The content author is supported by special views which are automatically synchronized with the current editing context
of the editor panel and which present additional information about this context thus helping the author to see quickly
the current location in the overall document structure and the available editing options.

Outline view

The Outline view has the following available functions:

• the section called “XML Document Overview”

• the section called “Modification Follow-up”

• the section called “Document Structure Change”

Figure 5.3. The Outline View
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XML Document Overview

The Outline view displays a general tag overview of the current edited XML Document. It also shows the correct
hierarchical dependencies between the tag elements, making it easier for the user to be aware of the document's structure
and the way tags are nested. It also allows the user to insert or delete nodes using pop-up menu actions.

Modification Follow-up

When editing, the Outline view dynamically follows the modifications introduced by the user, showing in the middle
of the panel the node which is currently being modified. This gives the user a better insight on location inside the
document and how the structure of the document is affected by one's modifications.

Document Structure Change

Entire XML elements can be moved or copied in the edited document using only the mouse in the Outline view in
drag-and-drop operations. If you drag an XML element in the Outline view and drop it on another one in the same
panel then the dragged element will be moved after the drop target element. If you hold the mouse pointer over the
drop target for a short time before the drop then the drop target element will be expanded first and the dragged element
will be moved inside the drop target element after its opening tag. You can also drop an element before or after another
element if you hold the mouse pointer towards the upper or lower part of the targeted element. A marker will indicate
whether the drop will be performed before or after the target element. If you hold down the CTRL key after dragging,
there will be performed a copy operation instead of a move one.

The drag and drop action in the Outline view can be disabled and enabled from the Preferences dialog.

Tip

You can select and drag multiple nodes in the Author Outliner tree.

The popup menu of the Outline tree

Figure 5.4. Popup menu of the Outline tree

Edit attributes for the selected node. A dialog is presented allowing the user to see and edit the attributes of the selected
node. See here for more details about editing attributes.
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The Append child, Insert before and Insert after submenus of the outline tree popup menu allow to quickly insert new
tags in the document at the place of the element correctly selected in the Outline tree. The Append child submenu lists
the names of all the elements which are allowed by the schema associated with the current document as child of the
current element. The effect is the same as typing the '<' character and selecting an element name from the popup menu
offered by the content completion assistant. The Insert before and Insert after submenus of the Outline tree popup
menu list the elements which are allowed by the schema associated with the current document as siblings of the current
element inserted immediately before respectively after the current element.

The Cut, Copy and Delete items of the popup menu execute the same actions as the Edit menu items with the same
name on the elements currently selected in the outline tree. You can insert a well-formed element before, after or as a
child of the currently selected element by accessing the Paste before, Paste after or Paste as Child actions.

The Toggle Comment item of the outline tree popup menu encloses the currently selected element of the outline tree
in an XML comment, if the element is not commented, or removes the comment if it is commented.

Using the Rename Element action the element from the caret position and the elements that have the same name as the
current element can be renamed according with the options from the Rename dialog.

Tip

You can Copy/Cut or Delete multiple nodes in the Outliner by using the contextual menu after selecting all the
nodes in the tree.

Elements view

Figure 5.5. The Elements View

Presents a list of all defined elements that you can insert in your document. All elements from a sequence are presented
but the invalid proposals (which cannot be inserted in the current context) are grayed-out. The upper part of the view
features a combo box that contains the current element's ordered ancestors. Selecting a new element in this combo box
will update the list of the allowed elements in Before and After tabs.

Three tabs present information relative to the caret location:

• Caret shows a list of all the elements allowed at the current caret location. Double-clicking any of the listed elements
will insert that element at the caret position.

• Before shows a list of all elements that can be inserted before the element selected in the combo box. Double-
clicking any of the listed elements will insert that element before the element at the caret position.
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• After shows a list of all elements that can be inserted after the element selected in the combo box. Double-clicking
any of the listed elements will insert that element after the element at the caret position.

Double clicking an element name in the list surrounds the current selection in the editor panel with the start tags and
end tags of the element. If there is no selection just an empty element is inserted in the editor panel at the cursor position.

Attributes view

The Attributes panel presents all the possible attributes of the current element allowed by the schema of the document
and allows to insert attributes in the current element or change the value of the attributes already used in the element.
The attributes already present in the document are painted with a bold font. Default values are painted with an italic
font. Clicking on the Value column of a table row will start editing the value of the attribute from the selected row. If
the possible values of the attribute are specified as list in the schema associated with the edited document the Value
column works as a combo box where you can select one of the possible values to be inserted in the document. The at-
tributes table is sortable by clicking on the column names. Thus the table's contents can be sorted in ascending order,
in descending order or in a custom order, where the used attributes are placed at the beginning of the table as they appear
in the element followed by the rest of the allowed elements as they are declared in the associated schema.

Figure 5.6. The Attributes View

A combo box located in the upper part of the view allows you to edit the attributes of the ancestors of the current element.

The contextual menu of the view allows you to insert a new element (Add action) or delete an existing one (Delete
action). Delete action can be invoked on a selected table entry by pressing DEL or BACKSPACE.

The attributes of an element can be edited also in place in the editor panel by pressing the shortcut Alt + Enter which
pops up a small window with the same content of the Attributes view. In the initial form of the popup only the two
text fields Name and Value are displayed, the list of all the possible attributes is collapsed.
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Figure 5.7. Edit attributes in place

The small arrow button next to the Cancel button expands the list of possible attributes allowed by the schema of the
document as in the Attributes panel.

Figure 5.8. Edit attributes in place - full version

The Name field auto-completes the name of the attribute: the complete name of the attribute is suggested based on the
prefix already typed in the field as the user types in the field.

Entities view

This view displays a list with all entities declared in the current document as well as built-in ones. Double clicking
one of the entities will insert it at the current cursor position.

Figure 5.9. The Entities View
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The Author editor
In order to view the XML file in Author view, the XML document must be associated with a CSS file that defines the
way the XML file is rendered. The document can be edited as text, the XML markup being hidden by default.

A non-technical author may prefer to set the Author editing mode as the initial editing mode for each new XML file
that is opened in the application, instead of the default editing mode which is the Text one. This is done by setting the
Author mode as the initial mode of the XML Editor in Preferences.

Navigating the document content

Fast navigating the document content can be done using the Tab/Shift + Tab for advancing forward / backwards. The
caret will be moved to the next/previous editable position. Entities and hidden elements will be skipped.

A left-hand side stripe paints a vertical thin light blue bar indicating the vertical span of the element found at caret
position. Also a top stripe indicates the path from document root to the current element.

Figure 5.10. Top stripe in Editor view

The last element is also highlighted by a thin light blue bar for easier identification. Clicking one element from the top
stripe selects the entire element in the Editor view.

Figure 5.11. The top stripe pop-up menu

The Append child, Insert before and Insert after submenus allow to quickly insert new tags in the document at the
place of the selected element. The Append child submenu lists the names of all the elements which are allowed by the
schema associated with the current document as child of the current element. The effect is the same as typing the '<'
character and selecting an element name from the popup menu offered by the content completion assistant. The Insert
before and Insert after submenus list the elements which are allowed by the schema associated with the current document
as siblings of the current element inserted immediately before respectively after the current element.

The Cut, Copy, Paste and Delete items of the popup menu execute the same actions as the Edit menu items with the
same name on the elements currently selected in the stripe. The styles of the copied content is preserved by the Cut
and Copy operations, for example the display:block property or the tabular format of the data from a set of table cells.
The Paste before, Paste after and Paste as Child actions allow the user to insert an well-formed element before, after
or as a child of the currently selected element.

The Toggle Comment item of the outline tree popup menu encloses the currently selected element of the top stripe in
an XML comment, if the element is not commented, or removes the comment if it is commented.
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Using the Rename Element action the selected element and the elements that have the same name as the current element
can be renamed according with the options from the Rename dialog.

When working on a large document the folding support can be used to collapse some elements content leaving in focus
only the ones you need to edit. Foldable elements are marked with a small triangle painted in the upper left corner.
Hovering with the mouse pointer over that marker, the entire content of the element is highlighted by a dotted border
for quick identification of the foldable area.

When working on a suite of documents that refer to one another(references, external entities, XInclude, DITA conref,
etc), the linking support is useful for navigating between the documents. In the predefined customizations that are
bundled with <oXygen/> XML Author links are marked with an icon representing a chain link:  . When hovering
with the mouse pointer over the marker, the mouse pointer will change to indicate that the link can be followed and a
tooltip will present the destination location. Clicking on a followable link will result in the referred resource being
opened in an editor. The same effect can be obtained by using the action Open file at caret when the caret is in a fol-
lowable link element.

To position the cursor at the beginning or at the end of the document you can use Ctrl+Home and Ctrl+End, respectively.

Displaying the markup

In Author view, the amount of displayed markup can be controlled using the following dedicated actions:

•  Full Tags with Attributes - displays full name tags with attributes for both block level as well as in-line level
elements.

•  Full Tags - displays full name tags without attributes for both block level as well as in-line level elements.

•  Block Tags - displays full name tags for block level elements and simple tags without names for in-line level
elements.

•  Inline Tags - displays full name tags for in-line level elements, while block level elements are not displayed.

•  Partial Tags - displays simple tags without names for in-line level elements, while block level elements are not
displayed.

•  No Tags - none of the tags is displayed. This is the most compact mode.

The default tags display mode can be configured in the Author options page. However, if the document opened in
Author editor does not have an associated CSS stylesheet, then the Full Tags mode will be used.

Block-level elements are those elements of the source document that are formatted visually as blocks (e.g., paragraphs),
while the inline level elements are distributed in lines (e.g., emphasizing pieces of text within a paragraph, in-line images,
etc). The graphical format of the elements is controlled from the CSS sources via the display property.

Bookmarks

A position in a document can be marked with a bookmark. Later the cursor can go quickly to the marked position with
a keyboard shortcut or with a menu item. This is useful for easy navigation in a large document or for working on more
than one document at a moment when the cursor must move between several marked positions.

A bookmark can be placed with one of the menu items available on the menu Edit → Bookmarks → Create or with
the menu item Edit → Bookmarks → Bookmarks Quick Creation or with the keyboard shortcuts associated with these
menu items and visible on the menu Edit → Bookmarks. A bookmark can be removed when a new bookmark is placed
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in the same position as an old one or with the action Edit → Bookmarks → Remove All. The cursor can go to a
bookmark with one of the actions available on the menu Edit → Bookmarks → Go to.

Position information tooltip

When the caret is positioned next to an element tag, a tooltip will be shown for a couple of seconds displaying the po-
sition of the caret relative to the current element context.

Here are the common situations that can be encountered:

• The caret is positioned before the first children of the current node.

Figure 5.12. Before first child

• The caret is positioned between the start and end of two sibling nodes.

Figure 5.13. Between two siblings

• The caret is positioned after the last child of the current node.

Figure 5.14. After last child

• The caret is positioned in an empty node.

Figure 5.15. Empty node

The nodes in the previous cases are displayed in the tooltip window using their names. When one of them is a text
node it will be presented using "..." sequence.

You can deactivate this feature by unchecking Options → Preferences+Editor / Author+Show caret positioned info
checkbox. Even if this option is disabled, you can trigger the display of the position tooltip by pressing Shift+F2.
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Note

The position information tooltip is not displayed if one of the modes Full Tags with Attributes or Full Tags is
selected.

Displaying referred content

The referred content (entities, XInclude, DITA conref, etc) will be resolved and displayed by default. You can control
this behavior from the Author options page.

The referred resources are loaded and displayed inside the element or entity that refers them, however the displayed
content cannot be modified directly.

Figure 5.16. XInclude reference

Figure 5.17. External entity reference

When the referred resource cannot be resolved, an error will be presented inside the element that refers them instead
of the content.

Figure 5.18. Unresolvable XInclude reference

If you want to make modifications to the referred content, you must open the referred resource in an editor. The referred
resource can be opened quickly by clicking on the link (marked with the icon  ) which is displayed before the referred
content. The referred resource is resolved through the XML Catalog set in Preferences.

To update the displayed referred content so that it reflects the latest modifications of the referred resource, you can
use the Refresh references action. Please note that the content of the expanded external entities can only be refreshed
by using the Reload action.
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Finding and replacing text

The Find/Replace dialog can be used in the Author page in the same way as in the Text page. However, there are some
features which are disabled:

• search in XPath

• search in selection

• search in tags

These limitations can be compensated by using the Find All Elements dialog.

Contextual menu

More powerful support for editing the XML markup is offered via actions included in the contextual menu. Two types
of actions are available: generic actions(actions that not depends on a specific document type) and document type
actions(actions that are configured for a specific document type).

Figure 5.19. Contextual menu

The generic actions are:

• Cut, Copy, Paste - common edit actions with the same functionality as those found in the text editor.

• Paste As XML - similar to Paste operation, except that the clipboard's content is considered to be XML.

• Select - contains the following actions:

• Select -> Select Element - selects the entire element at the current caret position.

• Select -> Select Content - selects the entire content of the element at the current caret position, excluding the
start and end tag. Performing this action repeatedly will result in the selection of the content of the ancestor of
the currently selected element content.
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• Select -> Select Parent - selects the parent of the element at the current caret position.

Note

You can select an element by triple clicking inside its content. If the element is empty you can select it by
double clicking it.

• Refactoring - contains a series of actions designed to alter the document's structure:

• Toggle Comment - encloses the currently selected text in an XML comment, or removes the comment if it is
commented;

• Split Element - splits the content of the closest element that contains the caret's position. Thus, if the caret is
positioned at the beginning or at the end of the element, the newly created sibling will be empty;

• Join Elements - joins two adjacent elements that have the same name. The action is available only when the caret
position is between the two adjacent elements. Also, joining two elements can be done by pressing the Delete or
Backspace keys and the caret is positioned between the boundaries of these two elements.

• Surround with Tag... - selected text in the editor is marked with the specified tag.

• Surround with '<Tag name>' - selected text in the editor is marked with start and end tags of the last 'Surround
with Tag...' action.

• Rename Element - the element from the caret position and the elements that have the same name as the current
element can be renamed according with the options from the Rename dialog.

• Delete Element Tags - deletes the tags of the closest element that contains the caret's position. This operation is
also executed if the start or end tags of an element are deleted by pressing the Delete or Backspace keys.

• Insert Entity - allows the user to insert a predefined entity or a character entity. Surrogate character entities (range
#x10000 to #x10FFFF) are also accepted.

Character entities can be entered in one of the following forms:

• #<decimal value> - e.g. #65

• &#<decimal value>; - e.g. &#65;

• #x<hexadecimal value> - e.g. #x41

• &#x<hexadecimal value>; - e.g. &#x41;

• Open File at Cursor - opens in a new editor panel the file with the name under the current position of the caret in
the current document. If the file does not exist at the specified location the error dialog that is displayed contains a
Create new file action which displays the New file dialog. This allows you to choose the type or the template for
the file. If the action succeeds, the file is created with the referred location and name and is opened in a new editor
panel. This is useful when you decide first on the file name and after that you want to create it in the exact location
specified at the current cursor position.

Document type actions are specific to some document type. Examples of such actions can be found in section Predefined
document types.

115

Authoring in the tagless editor



Editing XML in <oXygen/> Author

Editing the XML markup

One of the most useful feature in Author editor is the content completion support. The fastest way to invoke it is to
press Ctrl + Space (on Mac OS X the shortcut is Meta + Space).

Content completion window offers the following types of actions:

• inserting allowed elements for the current context according to the associated schema, if any;

• inserting element values if such values are specified in the schema for the current context;

• inserting new undeclared elements by entering their name in the text field;

• inserting CDATA sections, comments, processing instructions.

Figure 5.20. Content completion window

If you press Enter the displayed content completion window will contain as first entry the Split <Element name> item.
Selecting it splits the content of the closest element that contains the caret's position. Thus, if the caret is positioned at
the beginning or at the end of the element, the newly created sibling will be empty.

If the caret is positioned inside a space preserve element the first choice in the content completion window is Enter
which inserts a new line in the content of the element. If there is a selection in the editor and you invoke content
completion, a Surround with operation can be performed. The tag used will be the selected item from the content
completion window.

Joining two elements. You can choose to join the content of two sibling elements with the same name by using the
Join elements action from the editor contextual menu.

The same action can be triggered also in the next situations:

• The caret is located before the end position of the first element and Delete key is pressed.

• The caret is located after the end position of the first element and Backspace key is pressed.

• The caret is located before the start position of the second element and Delete key is pressed.

• The caret is located after the start position of the second element and Backspace key is pressed.

In either of the described cases, if the element has no sibling or the sibling element has a different name, Unwrap op-
eration will be performed automatically.

Unwrapping the content of an elementYou can unwrap the content of an element by deleting its tags using the Delete
element tags action from the editor contextual menu.

The same action can be triggered in the next situations:
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• The caret is located before the start position of the element and Delete key is pressed.

• The caret is located after the start position of the element and Backspace key is pressed.

• The caret is located before the end position of the element and Delete key is pressed.

• The caret is located after the end position of the element and Backspace key is pressed.

Removing all the markup of an element You can remove the markup of the current element and keep only the text

content with the action Remove All Markup available on the submenu Refactoring of the contextual menu and on
the toolbar XML Refactoring.

When you press Delete or Backspace in the presented cases a dialog will be displayed allowing you to choose between
Join or Unwrap operations. If the current element is empty, no dialog will be presented and the element tags will be
deleted.

Figure 5.21. Join/Unwrap dialog

When you click on a marker representing the start or end tag of an element, the entire element will be selected. The
contextual menu displayed when you right-click on the marker representing the start or end tag of an element contains
Append child, Insert Before and Insert After submenus as first entries.

Editing the XML content

Entire sections or chunks of data can be moved or copied by using the Drag and Drop support. The following situations
can be encountered:

• when both the drag and drop sources are Author pages, an well-formed XML fragment is transferred. The section
will be balanced before dropping it by adding matching tags when needed.

• when the drag source is the Author page but the drop target is a text based editor only the text inside the selection
will be transferred as it is.

• the text dropped from another text editor or another application into the Author page will be inserted without changes.

The font size of the current WYSIWYG-like editor can be increased and decreased on the fly with the same actions
as in the Text editor:

Ctrl-NumPad+ or Ctrl-+ or Ctrl-
mouse wheel

increase font size

Ctrl-NumPad- or Ctrl-- or Ctrl-mouse
wheel

decrease font size

Ctrl-NumPad0 or Ctrl-0 restore font size to the size specified in Preferences

117

Authoring in the tagless editor



Removing the text content of the current element You can remove the text content of the current element and keep

only the markup with the action Remove Text available on the submenu Refactoring of the contextual menu and
on the toolbar XML Refactoring. This is useful when the markup of an element must be preserved, for example a
table structure but the text content must be replaced.

Table layout and resizing

The support for editing data in tabular form can manage table width and column width specifications from the source
document. The specified widths will be considered when rendering the tables and when visually resizing them using
mouse drag gestures. These specifications are supported both in fixed and proportional dimensions. The predefined
frameworks (DITA, DocBook and XHTML) already implement support for this feature. The layout of the tables from
these types of documents takes into account the table width and the column width specifications particular to them.
The tables and columns widths can be visually adjusted by dragging with the mouse their edges and the modifications
will be committed back into the source document.

Figure 5.22. Resizing a column in <oXygen/> Author editor

DocBook

The DocBook table layout supports two models: CALS and HTML.

In the CALS model only column widths can be specified by using the colwidth attribute of the associated colspec
element. The values can be fixed or proportional.

Figure 5.23. CALS table
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XHTML

The HTML table model accepts both table and column widths by using the width attribute of the table element and
the col element associated with each column. The values can be represented in fixed units, proportional units or per-
centages.

Figure 5.24. HTML table

DITA

The DITA table layout accepts CALS tables and simple tables.

The simple tables accept only relative column width specifications by using the relcolwidth attribute of the sim-
pletable element.

Figure 5.25. DITA simple table

Refreshing the content

On occasion you may need to reload the content of the document from the disk or reapply the CSS. This can be performed

by using the Reload action.

For refreshing the content of the referred resources you can use the action Refresh references. This action affects
the displayed referred content, such as: references, XInclude, DITA conref, etc. However, this action will not refresh
the expanded external entities, to refresh those you will need to use the Reload action.

Validation and error presenting

You can validate or check the XML form of the documents while editing them in Author Editor. Validate as you type
as well as validate on request operations are available. Author editor offers validation features and configuring possib-
ilities similar to text editor. You can read more about checking the XML form of documents in section Checking XML
form. A detailed description of the document validation process and its configuration is described in section Validating
Documents.
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Figure 5.26. Error presenting in <oXygen/> Author editor

A fragment with a validation error or warning will be marked in the editor panel by underlining the error region with
a red color. The same will happen for a validation warning, only the color will be yellow instead of red.

The ruler on the right of the document is designed to display the errors found during the validation process and also
to help the user to locate them more easily. The ruler contains the following areas:

• top area containing a success validation indicator that will turn green in case the validation succeeded or red otherwise.

A more detailed report of the errors is displayed in the tool tip. In case there are errors, only the first three of them
will be presented in the tool tip;

• middle area where the errors markers are depicted in red (with a darker color tone for the current selected one). The
number of markers shown can be limited by modifying the setting Options → Preferences+Editor / Document
checking+Limit error markers to

Clicking on a marker will highlight the corresponding text area in the editor. The error message is displayed both
in the tool tip and in the error area on the bottom of the editor panel.

The Document checking user preferences are easily accessible from the button displayed at the beginning of the error
message on the bottom of the editor panel.

• bottom area containing two navigation arrows that will go to the next or to the previous error and a button for
clearing all the error markers from the ruler. The same actions can be triggered from Document → Validate as you
type (Ctrl + .)-> Next error and Document → Validate as you type (Ctrl + ,)-> Previous error.

The validation status area is the line at the bottom of the editor panel that presents the message of the current validation

error. Clicking on  opens the  document checking page in <oXygen/> user preferences.

Status messages from every validation action are logged into the Information view.

Whitespace handling

There are several major aspects of white-space handling in the <oXygen/> Author editor when opening documents or
switching to Author mode, saving documents or switching from Author mode to another one and editing documents.

Open documents When deciding if the white-spaces from a text node are to be preserved, normalized or
stripped, the following rules apply:

• If the text node is inside an element context where the xml:space="preserve" is set then
the white-spaces are preserved.
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• If the CSS property white-space is set to "pre" for the node style then the white-spaces
are preserved.

• If the text node contains other non-white-space characters then the white-spaces are
normalized.

• If the text node contains only white-spaces:

• If the node has a parent element with the CSS display property set to inline then the
white-spaces are normalized.

• If the left or right sibling is an element with the CSS display property set to inline
then the white-spaces are normalized.

• If one of its ancestors is an element with the CSS display property set to table then
the white-spaces are striped.

• Otherwise the white-spaces are ignored.

Save documents The Author editor will try to format and indent the document while following the white-
space handling rules:

• If text nodes are inside an element context where the xml:space="preserve" is set then
the white-spaces are written without modifications.

• If the CSS property white-space is set to "pre" for the node style then the white-spaces
are written without any changes.

• In other cases the text nodes are wrapped.
Also, when formatting and indenting an element that is not in a space-preserve context,
additional Line Separators and white-spaces are added as follows:

• Before a text node that starts with a white-space.

• After a text node that ends with a white-space.

• Before and after CSS block nodes.

• If the current node has an ancestor that is a CSS table element.

Editing documents You can insert space characters in any text nodes. Line breaks are permitted only in space-
preserve elements. Tabs are marked in the space-preserve elements with a little marker.

Note

CDATA sections, comments, processing instructions have by default the white-space CSS property set to "pre"
unless overridden in the CSS file you are using. Also they are considered to be block nodes.

Minimize differences between versions saved on different computers

The number of differences between versions of the same file saved by different content authors on different computers
can be minimized by imposing the same set of formatting options when saving the file, for all the content authors. An
example for a procedure that minimizes the differences is:

1. Create an <oXygen/> project file that will be shared by all content authors.
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2. Set your own preferences in the following panels of the Preferences dialog: Editor / Format and Editor / Format
/ XML.

3. Save the preferences of these two panels in the <oXygen/> project by selecting the button Project Options in
these two panels.

4. Save the project and commit the project file to your versioning system so all the content authors can use it.

5. Make sure the project is opened in the Project view and open your XML files in the Author mode and save them.

6. Commit the saved XML files to your versioning system.

When other content authors will change the files only the changed lines will be displayed in your diff tool instead of
one big change that does not allow to see the changes between two versions of the file.

Change Tracking
Track Changes is a way to keep track of the changes you make to a document. You can activate change tracking for
the current document by choosing Edit+Track Changes or by clicking the Track Changes button located on the Author
toolbar. When Track Changes is enabled your modifications will be highlighted using a distinctive color. The name
of the author who is currently making changes and the colors can be customized from the Track Changes preferences
page.

Figure 5.27. Change Tracking in <oXygen/> Author

When hovering a change the tooltip will display information about the author and modification time.

If the selection in the Author contains track changes and you Copy it the clipboard will contain the selection with all
the changes accepted. This filtering will happen only if the selection is not entirely inside a tracked change.

Tip

For each change the author name and the modification time are preserved. The changes are stored in the document
as processing instructions and they do not interfere with validating and transforming it.
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Managing changes

You can review the changes made by you or other authors and then accept or reject them using the Track Changes

toolbar buttons  or the similar actions from the Edit menu.

Track Changes Enable or disable track changes for the current document.

Accept Change Accept the change located at the caret position. For an insert change this means
keeping the inserted text and for a delete change this means removing the content
from the document. The action is also available in the Author page contextual
menu.

Reject Change Reject the change located at the caret position. For an insert change this means re-
moving the inserted text and for a delete change this preserving the original content
from the document. The action is also available in the Author page contextual
menu.

Manage Tracked Changes This is a way to find and manage all changes in the current document.

Figure 5.28. Manage Tracked Changes

The dialog offers the following actions:

Next Find the next change in the document.

Previous Find the previous change in the document.

Accept Accept the current change.

Reject Reject the current change.

Accept All Accept all changes in the document.

Reject All Reject all changes in the document.
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Chapter 6. Predefined document types
A document type is associated to an XML file according to its defined rules and it specifies many settings used to improve
editing the category of XML files it applies for. These settings include specifying a default grammar used for validation
and content completion, default scenarios used for transformation, specifying directories with file templates, specifying
catalogs and a lot of settings which can be used to improve editing in the Tagless editor.

The tagless editor comes with some predefined document types already configured when the application is installed
on the computer. These document types describe well-known XML frameworks largely used today for authoring XML
documents. Editing a document which conforms to one of these types is as easy as opening it or creating it from one
of the predefined document templates which also come with the application.

Figure 6.1. Document Type preferences page

The DocBook V4 document type
DocBook is a very popular set of tags for describing books, articles, and other prose documents, particularly technical
documentation.

Association rules
A file is considered to be a DocBook document when either of the following occurs:

• root element name is a book or article;
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• public id of the document contains -//OASIS//DTD DocBook XML.

Schema
The schema used for DocBook documents is in ${frameworks}/docbook/dtd/docbookx.dtd, where ${frameworks} is a
subdirectory of the <oXygen/> install directory.

Author extensions
The CSS file used for rendering DocBook content is located in ${frameworks}/docbook/css/docbook.css.

Specific actions for DocBook documents are:

• Bold emphasized text - emphasizes the selected text by surrounding it with <emphasis role="bold"/> tag.

• Italic emphasized text - emphasizes the selected text by surrounding it with <emphasis role="italic"/> tag.

• Underline emphasized text - emphasizes the selected text by surrounding it with <emphasis role="italic"/> tag.

Note

For all of the above actions if there is no selection then a new 'emphasis' tag with specific role will be inserted.
These actions are available in any document context.

These actions are grouped under the Emphasize toolbar actions group.

• link - inserts a hypertext link.

• ulink - inserts a link that address its target by means of an URL (Universal Resource Locator).

• olink - inserts a link that address its target indirectly, using the targetdoc and targetptr values which are
present in a Targetset file.
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Figure 6.2. Insert OLink Dialog

After you choose the Targetset URL the structure of the target documents is presented. For each target document
(targetdoc) the content is displayed allowing for easy identification of the targetptr for the olink element
which will be inserted. You can use the Search fields to quickly identify a target. If you already know the values for
the targetdoc and targetptr you can insert them directly in the corresponding fields. You have also the
possibility to edit an olink using the action Edit OLink available on the contextual menu. The action make sense
only if the dialog was already displayed with a proper Targetset.

• uri - inserts an URI element. The URI identifies a Uniform Resource Identifier (URI) in content.

• xref - inserts a cross reference to another part of the document. The initial content of the xref is automatically detected
from the target.

Note

These actions are grouped under the Link toolbar actions group.

• Insert Section - inserts a new section/subsection in the document, depending on the current context. For example
if the current context is sect1 then a sect2 will be inserted and so on.
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• Insert Paragraph - inserts a new paragraph depending on the current context. If current context is a paragraph
context(one of the ancestors of the element at caret position is 'para') then a new paragraph will be inserted after the
paragraph at caret. Otherwise a new paragraph is inserted at caret position.

• Insert Graphic - inserts a graphic object at the caret position. This is done by inserting either <figure> or <in-
linegraphic> element depending on the current context. The following graphical formats are supported: GIF, JPG,
JPEG, BMP, PNG and SVG.

• Insert Ordered List - inserts an ordered list with one list item.

• Insert Itemized List - inserts an itemized list with one list item.

• Insert Variable List - inserts a DocBook variable list with one list item.

• Insert List Item - inserts a new list item for in any of the above three list types.

• Insert Table - opens a dialog that allows you to configure the table to be inserted.

Figure 6.3. Insert Table Dialog

The dialog allows the user to configure the number of rows and columns of the table, if the header and footer will
be generated and how the table will be framed. Also, CALS or HTML table model can be selected.

Note

Unchecking the Title checkbox an 'informaltable' element will be inserted.

• Insert Row - inserts a new table row with empty cells. The action is available when the caret position is inside a
table.

• Insert Column - inserts a new table column with empty cells after the current column. The action is available
when the caret position is inside a table.
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• Insert Cell - inserts a new empty cell depending on the current context. If the caret is positioned between two
cells, a new one will be inserted at caret's position. If the caret is inside a cell, then the new one will be created after
the current cell.

• Delete Column - deletes the table column where the caret is located.

• Delete Row - deletes the table row where the caret is located.

• Join Row Cells - joins the content of the selected cells. The operation is available if the selected cells are from
the same row and they have the same row span. The action is also available when the selection is missing, but the
caret is positioned between two cells.

• Join Cell Above - joins the content of cell from current caret position with that of the cell above it. Note that this
action works only if both cells have the same column span.

• Join Cell Below - joins the content of cell from current caret position with that of the cell below it. Note that this
action works only if both cells have the same column span.

• Split Cell To The Left - splits the cell from current caret position in two, inserting a new empty table cell to the
left. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.

• Split Cell To The Right - splits the cell from current caret position in two, inserting a new empty table cell to the
right. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.

• Split Cell Above - splits the cell from current caret position in two, inserting a new empty table cell above. Note
that this action works only if the current cell spans over more than one row. The row span of the source cell will be
decreased with one.

• Split Cell Below - splits the cell from current caret position in two, inserting a new empty table cell below. Note
that this action works only if the current cell spans over more than one row. The row span of the source cell will be
decreased with one.

Note

DocBook v4 supports only CALS table model. HTML table model is supported in DocBook v5.

Caution

Column specifications are required for table actions to work properly.

• Generate IDs -allows you to generate ID for the current selection or for the element at caret position if the element
appears in ID Generation dialog.
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Figure 6.4. ID Generation dialog

In this dialog you can specify the elements for which <oXygen/> should generate an ID. You can choose to automat-
ically generate an ID for these elements by selecting Auto generate ID's for elements. You can choose a pattern for
the generated ID using the field ID Pattern. If the element already has an ID, this ID is preserved.

All actions described above are available in the contextual menu, main menu (Docbook4 submenu) and in the Author
custom actions toolbar.

Templates

Default templates are available for DocBook 4. They are stored in ${frameworksDir}/docbook/templates/Docbook
4 folder and they can be used for easily creating a book or article with or without XInclude.

These templates are available when creating new documents from templates.

Docbook 4 - Article New Docbook 4 Article

Docbook 4 - Article with XInclude New Docbook 4 XInclude-aware Article

Docbook 4 -Book New Docbook 4 Book

Docbook 4 -Book with XInclude New Docbook 4 XInclude-aware Book

Catalogs

The default catalog is stored in ${frameworksDir}/docbook/catalog.xml.

Transformation Scenarios

The following default transformation scenarios are available:

• DocBook4 -> DocBook5 Conversion - converts a DocBook4-compliant document to DocBook5;
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• DocBook HTML - transforms a DocBook document into a HTML document;

• DocBook PDF - transforms a DocBook document into a PDF document.

• DocBook HTML - chunk - transforms a DocBook document in multiple HTML documents.

The DocBook V5 document type
Customization for DocBook V.5 is similar with that for DocBook V.4 with the following exceptions:

Association rules
A file is considered to be a DocBook V.5 document when the namespace is 'http://docbook.org/ns/docbook'.

Schema
DocBook v5 documents use a RelaxNG and Schematron schema located in ${frameworks}/docbook/5.0/rng/doc-
bookxi.rng, where ${frameworks} is a subdirectory of the <oXygen/> install directory.

Author extensions
DocBook 5 extensions contain all DocBook 4 extensions plus support for HTML table.

Templates

Default templates are available for DocBook 5. They are stored in ${frameworksDir}/docbook/templates/Docbook
5 folder and they can be used for easily creating a book or article with or without XInclude.

These templates are available when creating new documents from templates.

Docbook 5 - Article New Docbook 5 Article

Docbook 5 - Article with XInclude New Docbook 5 XInclude-aware Article

Docbook 5 -Book New Docbook 5 Book

Docbook 5 -Book with XInclude New Docbook 5 XInclude-aware Book

Catalogs

The default catalog is stored in ${frameworksDir}/docbook/5.0/catalog.xml.

Transformation Scenarios

The following default transformation scenarios are available:

• DocBook HTML - transforms a DocBook document into HTML document;

• DocBook PDF - transforms a DocBook document into a PDF document.

• DocBook HTML - chunk - transforms a DocBook document in multiple HTML documents.
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The DocBook Targetset document type
This document type is provided to edit or create a targetset file which is used to resolve cross references with olinks.

Association rules
A file is considered to be a DocBook Targetset document when the root name is 'targetset'.

Schema
DocBook Targetset documents use a DTD and schema located in ${frameworks}/docbook/xsl/common/targetdatabase.dtd,
where ${frameworks} is a subdirectory of the <oXygen/> install directory.

Author extensions

Templates

A default template is available for DocBook Targetset. It is stored in ${frameworksDir}/docbook/templates/Targetset
folder and can be used for easily creating a targetset.

This template is available when creating new documents from templates.

Docbook Targetset - Map New Targetset Map

The DITA Topics document type
The Darwin Information Typing Architecture (DITA) is an XML-based architecture for authoring, producing, and
delivering technical information. It divides content into small, self-contained topics that can be reused in different de-
liverables. The extensibility of DITA permits organizations to define specific information structures and still use
standard tools to work with them.

Association rules
A file is considered to be a dita topic document when either of the following occurs:

• root element name is one of the following: concept, task, reference, dita, topic;

• public id of the document is one of the public id's for the elements above.

• the root element of the file has an attribute named "DITAArchVersion" attribute from the "http://dita.oasis-
open.org/architecture/2005/" namespace. This enhanced case of matching is only applied when the Enable DTD
processing option from the Document Type Detection option page is enabled.

Schema
The default schema used for DITA topic documents is located in ${frameworks}/dita/dtd/ditabase.dtd, where
${frameworks} is a subdirectory of the <oXygen/> install directory.
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Author extensions
The CSS file used for rendering DITA content is located in ${frameworks}/dita/css/dita.css.

Specific actions for DITA topic documents are:

• Bold - surrounds the selected text with b tag.

• Italic - surrounds the selected text with i tag.

• Underline - surrounds the selected text with u tag.

Note

For all of the above actions if there is no selection then a new specific tag will be inserted. These actions are
available in any document context.

• Cross Reference - inserts an xref element with the value of attribute format set to "dita". The target of the xref is
selected in a dialog which lists all the IDs available in a file selected by the user.

Figure 6.5. Insert a cross reference in a DITA document

• File Reference - inserts an xref element with the value of attribute format set to "xml".

• Web Link - inserts an xref element with the value of attribute format set to "html", and scope set to "external".

• Related Link to Topic - inserts a link element inside a related-links parent.
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• Related Link to File - inserts a link element with the format attribute set to "xml" inside a related-links parent.

• Related Link to Web Page - inserts a link element with the attribute format set to "html" and scope set to "external"
inside a related-links parent.

Note

The actions for inserting references described above are grouped inside link toolbar actions group.

• Insert Section/Step - inserts a new section/step in the document, depending on the current context. A new section
will be inserted in either one of the following contexts:

• section context, when the value of 'class' attribute of the current element or one of its ancestors contains 'topic' or
'section'.

• topic's body context, when the value of 'class' attribute of the current element contains 'topic/body'.

A new step will be inserted in either one of the following contexts:

• task step context, when the value of 'class' attribute of the current element or one of its ancestors contains 'task/step'.

• task steps context, when the value of 'class' attribute of the current element contains 'task/steps'.

• Insert Paragraph - inserts a new paragraph depending on the current context. If current context is a paragraph
context (the value of 'class' attribute of the current element or one of its ancestors contains 'topic/p') then a new
paragraph will be inserted after this paragraph. Otherwise a new paragraph is inserted at caret position.

• Insert Concept - inserts a new concept. Concepts provide background information that users must know before
they can successfully work with a product or interface. This action is available in one of the following contexts:

• concept context, one of the current element ancestors is a concept. In this case an empty concept will be inserted
after the current concept.

• concept or dita context, current element is a concept or dita. In this case an empty concept will be inserted at
current caret position.

• dita topic context, current element is a topic child of a dita element. In this case an empty concept will be inserted
at current caret position.

• dita topic context, one of the current element ancestors is a dita's topic. In this case an empty concept will be in-
serted after the first topic ancestor.

• Insert Task - inserts a new task. Tasks are the main building blocks for task-oriented user assistance. They generally
provide step-by-step instructions that will enable a user to perform a task. This action is available in one of the fol-
lowing contexts:

• task context, one of the current element ancestors is a task. In this case an empty task will be inserted after the
last child of the first concept's ancestor.

• task context, the current element is a task. In this case an empty task will be inserted at current caret position.

• topic context, the current element is a dita's topic. An empty task will be inserted at current caret position.
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• topic context, one of the current element ancestors is a dita's topic. An empty task will be inserted after the last
child of the first ancestor that is a topic.

• Insert Reference - inserts a new reference in the document. A reference is a top-level container for a reference
topic. This action is available in one of the following contexts:

• reference context, one of the current element ancestors is a reference. In this case an empty reference will be in-
serted after the last child of the first ancestor that is a reference.

• reference or dita context, the current element is either a dita or a reference. An empty reference will be inserted
at caret position.

• topic context, the current element is topic descendant of dita element. An empty reference will be inserted at caret
position.

• topic context, the current element is descendant of dita element and descendant of topic element. An empty reference
will be inserted after the last child of the first ancestor that is a topic.

• Insert Graphic - inserts a graphic object at the caret position. This is done by inserting either <figure> or
<inlinemediaobject> element depending on the current context.. The following graphical formats are supported:
GIF, JPG, JPEG, BMP, PNG and SVG.

• Insert Content Reference - inserts a content reference at the caret position.

The DITA conref attribute provides a mechanism for reuse of content fragments. The conref attribute stores a reference
to another element and is processed to replace the referencing element with the referenced element. The element
containing the content reference acts as a placeholder for the referenced element. The identifier for the referenced
element must be either absolute or resolvable in the context of the referencing element. See here
[http://docs.oasis-open.org/dita/v1.0/archspec/conref.html] for more details.

<oXygen/> will display the referred content of a DITA conref if it can resolve it to a valid resource. If you use URI's
instead of local paths and you have a catalog used in the DITA OT transformation you can add the catalog to
<oXygen/> and if the URI's can be resolved the referred content will be displayed.

A content reference is inserted with the action Insert a DITA Content Reference available on the toolbar Author
custom actions and on the menu DITA → Insert.
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Figure 6.6. Insert Content Reference Dialog

In the URL chooser you can choose the file from which you want to reuse content. Depending on the Target type
filter you will see a tree of elements which can be referred (which have id's). For each element the XML content is
shown in the preview area. The Conref value is computed automatically for the selected tree element. After pressing
OK an element with the same name as the target element and having the attribute conref with the value specified in
the Conref value field will be inserted at caret position.

• Replace conref with content - Replace the content reference fragment at caret position with the referenced content.
This action is useful when you want to make changes to the content but decide to keep the referenced fragment un-
changed.

• Insert Ordered List - inserts an ordered list with one list item.

• Insert Unordered List - inserts an unordered list with one list item.

• Insert List Item - inserts a new list item for in any of the above two list types.

• Insert Table - opens a dialog that allows you to configure the table to be inserted.
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Figure 6.7. Insert Table Dialog

The dialog allows the user to configure the number of rows and columns of the table, if the header will be generated,
if the title will be added and how the table will be framed.

• Insert Row - inserts a new table row with empty cells. The action is available when the caret position is inside a
table.

• Insert Column - inserts a new table column with empty cells after the current column. The action is available
when the caret position is inside a table.

• Insert Cell - inserts a new empty cell depending on the current context. If the caret is positioned between two
cells, a new one will be inserted at caret's position. If the caret is inside a cell, then the new one will be created after
the current cell.

• Delete Column - deletes the table column where the caret is located.

• Delete Row - deletes the table row where the caret is located.

• Join Row Cells - joins the content of the selected cells. The operation is available if the selected cells are from
the same row and they have the same row span. The action is also available when the selection is missing, but the
caret is positioned between two cells.

• Join Cell Above - joins the content of cell from current caret position with that of the cell above it. Note that this
action works only if both cells have the same column span.

• Join Cell Below - joins the content of cell from current caret position with that of the cell below it. Note that this
action works only if both cells have the same column span.

• Split Cell To The Left - splits the cell from current caret position in two, inserting a new empty table cell to the
left. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.

• Split Cell To The Right - splits the cell from current caret position in two, inserting a new empty table cell to the
right. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.
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• Split Cell Above - splits the cell from current caret position in two, inserting a new empty table cell above. Note
that this action works only if the current cell spans over more than one row. The row span of the source cell will be
decreased with one.

• Split Cell Below - splits the cell from current caret position in two, inserting a new empty table cell below. Note
that this action works only if the current cell spans over more than one row. The row span of the source cell will be
decreased with one.

Note

DITA supports CALS table model similar with DocBook document type in addition to the simpletable element
specific for DITA.

Caution

Column specifications are required for table actions to work properly.

• Generate IDs - allows you to generate ID for the current selection or for the element at caret position if the element
appears in ID Generation dialog.

Figure 6.8. ID Generation dialog

In this dialog you can specify the elements for which <oXygen/> should generate an ID. You can choose to automat-
ically generate an ID for these elements by selecting Auto generate ID's for elements. You can choose a pattern for
the generated ID using the field ID Pattern. If the element already has an ID, this ID is preserved.

All actions described above are available in the contextual menu, main menu (DITA submenu) and in the Author
custom actions toolbar.

Templates

Default templates available for DITA topics are stored in ${frameworksDir}/dita/templates/topic folder. They can
be used for easily creating a DITA's concept, reference, task or topic.
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These templates are available when creating new documents from templates.

DITA - Composite New DITA Composite

DITA - Concept New DITA Concept

DITA - Glossentry New DITA Glossentry

DITA - Reference New DITA Reference

DITA - Task New DITA Task

DITA - Topic New DITA Topic

Catalogs

The default catalog is stored in ${frameworks}/dita/catalog-dita.xml.

Transformation Scenarios

The following default transformation scenarios are available for DITA Topics:

• DITA Topic to DocBook - converts a DITA topic document into a DocBook document;

• DITA Topic to HTML - transforms a DITA topic document into HTML document;

• DITA to PDF - transforms a DITA document into a PDF document.

The DITA MAP document type
DITA maps are documents that collect and organize references to DITA topics to indicate the relationships among the
topics. They can also serve as outlines or tables of contents for DITA deliverables and as build manifests for DITA
projects.

Maps allow scalable reuse of content across multiple contexts. They can be used by information architects, writers,
and publishers to plan, develop, and deliver content.

Association rules
A file is considered to be a dita map document when either of the following occurs:

• root element name is one of the following: map, bookmap;

• public id of the document is -//OASIS//DTD DITA Map or -//OASIS//DTD DITA BookMap.

• the root element of the file has an attribute named "class" which contains the value "map/map" and a "DITAArchVer-
sion" attribute from the "http://dita.oasis-open.org/architecture/2005/" namespace. This enhanced case of matching
is only applied when the Enable DTD processing option from the Document Type Detection option page is enabled.

Schema
The default schema used for DITA Map documents is located in ${frameworks}/dita/DITA-OT/dtd/map.dtd, where
${frameworks} is a subdirectory of the <oXygen/> install directory.
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Author extensions
The CSS file used for rendering DocBook content is located in ${frameworks}/dita/css/dita.css.

Specific actions for DITA Map documents are:

• Insert Topic Reference - inserts a reference to a topic. You can find more information about this action here.

• Insert Topic Heading - inserts a topic heading. You can find more information about this action here.

• Insert Topic Group - inserts a topic group. You can find more information about this action here.

• Insert Content Reference - inserts a content reference at the caret position. See more about this action here [134].

• Insert Table - opens a dialog that allows you to configure the relationship table to be inserted.

Figure 6.9. Insert Relationship Table Dialog

The dialog allows the user to configure the number of rows and columns of the relationship table, if the header will
be generated and if the title will be added.

• Insert Row - inserts a new table row with empty cells. The action is available when the caret position is inside a
table.

• Insert Column - inserts a new table column with empty cells after the current column. The action is available
when the caret position is inside a table.

• Insert Cell - inserts a new empty cell depending on the current context. If the caret is positioned between two
cells, a new one will be inserted at caret's position. If the caret is inside a cell, then the new one will be created after
the current cell.

• Delete Column - deletes the table column where the caret is located.

• Delete Row - deletes the table row where the caret is located.

• Join Row Cells - joins the content of the selected cells. The operation is available if the selected cells are from
the same row and they have the same row span. The action is also available when the selection is missing, but the
caret is positioned between two cells.
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• Join Cell Above - joins the content of cell from current caret position with that of the cell above it. Note that this
action works only if both cells have the same column span.

• Join Cell Below - joins the content of cell from current caret position with that of the cell below it. Note that this
action works only if both cells have the same column span.

• Split Cell To The Left - splits the cell from current caret position in two, inserting a new empty table cell to the
left. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.

• Split Cell To The Right - splits the cell from current caret position in two, inserting a new empty table cell to the
right. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.

All actions described above are available in the contextual menu, main menu (DITA submenu) and in the Author
custom actions toolbar.

Templates

Default templates available for DITA Maps are stored in ${frameworksDir}/dita/templates/map folder. They can
be used for easily creating a DITA map and bookmap files.

These templates are available when creating new documents from templates.

DITA Map - Bookmap New DITA Bookmap

DITA Map - Map New DITA Map

Catalogs

The default catalog is stored in ${frameworks}/dita/catalog-dita.xml.

Transformation Scenarios

To configure and run DITA-OT ANT transformations on a DITA Map you have to open it in the DITA Maps Manager
view.

The XHTML document type
The Extensible HyperText Markup Language, or XHTML, is a markup language that has the same depth of expression
as HTML, but also conforms to XML syntax.

Association rules
A file is considered to be a XHTML document when the root element name is a html.

Schema
The schema used for these documents is located in ${frameworks}/xhtml/dtd/xhtml1-strict.dtd, where ${frameworks}
is a subdirectory of the <oXygen/> install directory.
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CSS
The default CSS options for the XHTML document type are set to merge the CSSs specified in the document with the
CSSs defined in the XHTML document type.

Author extensions
The CSS file used for rendering XHTML content is located in ${frameworks}/xhtml/css/xhtml.css.

Specific actions are:

• Bold - changes the style of the selected text to bold by surrounding it with b tag.

• Italic - changes the style of the selected text to italic by surrounding it with i tag.

• Underline - changes the style of the selected text to underline by surrounding it with u tag.

Note

For all of the above actions if there is no selection then a new specific tag will be inserted. These actions are
available in any document context.

• Headings - groups actions for inserting h1, h2, h3, h4, h5, h6 elements.

• Insert Paragraph - inserts a new paragraph depending on the current context. If current context is a paragraph
context (one of the ancestors of the element at caret position is p) then a new paragraph will be inserted after the
paragraph at caret. Otherwise a new paragraph is inserted at caret position.

• Insert Graphic - inserts a graphic object at the caret position. This is done by inserting an img element regardless
of the current context. The following graphical formats are supported: GIF, JPG, JPEG, BMP, PNG and SVG.

• Insert Ordered List - inserts an ordered list (ol element) with one list item (li child element).

• Insert Unordered List - inserts an unordered list (ul element) with one list item (li child element).

• Insert Definition List - inserts a definition list (dl element) with one list item (a dt child element and a dd child
element).

• Insert List Item - inserts a new list item for in any of the above two list types.

• Insert Table - opens a dialog that allows you to configure the table to be inserted.
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Figure 6.10. Insert Table Dialog

The dialog allows the user to configure the number of rows and columns of the table, if the header and footer will
be generated and how the table will be framed.

• Insert Row - inserts a new table row with empty cells. The action is available when the caret position is inside a
table.

• Insert Column - inserts a new table column with empty cells after the current column. The action is available
when the caret position is inside a table.

• Insert Cell - inserts a new empty cell depending on the current context. If the caret is positioned between two
cells, a new one will be inserted at caret's position. If the caret is inside a cell, then the new one will be created after
the current cell.

• Delete Column - deletes the table column where the caret is located.

• Delete Row - deletes the table row where the caret is located.

• Join Row Cells - joins the content of the selected cells. The operation is available if the selected cells are from
the same row and they have the same row span. The action is also available when the selection is missing, but the
caret is positioned between two cells.

• Join Cell Above - joins the content of cell from current caret position with that of the cell above it. Note that this
action works only if both cells have the same column span.

• Join Cell Below - joins the content of cell from current caret position with that of the cell below it. Note that this
action works only if both cells have the same column span.

• Split Cell To The Left - splits the cell from current caret position in two, inserting a new empty table cell to the
left. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.

• Split Cell To The Right - splits the cell from current caret position in two, inserting a new empty table cell to the
right. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.
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• Split Cell Above - splits the cell from current caret position in two, inserting a new empty table cell above. Note
that this action works only if the current cell spans over more than one row. The row span of the source cell will be
decreased with one.

• Split Cell Below - splits the cell from current caret position in two, inserting a new empty table cell below. Note
that this action works only if the current cell spans over more than one row. The row span of the source cell will be
decreased with one.

All actions described above are available in the contextual menu, main menu (XHTML submenu) and in the Author
custom actions toolbar.

Templates

Default templates are available for XHTML. They are stored in ${frameworksDir}/xhtml/templates folder and they
can be used for easily creating basic XHTML documents.

These templates are available when creating new documents from templates.

XHTML - 1.0 Strict New Strict XHTML 1.0

XHTML - 1.0 Transitional New Transitional XHTML 1.0

XHTML - 1.1 DTD Based New DTD-based XHTML 1.1

XHTML - 1.1 DTD Based + Math-
ML 2.0 + SVG 1.1

New XHTML 1.1 with MathML and SVG insertions.

XHTML - 1.1 Schema based New XHTML 1.1 XML Schema based.

Catalogs

There are three default catalogs for XHTML document type: ${frameworks}/xhtml/dtd/xhtmlcatalog.xml, ${frame-
works}/xhtml11/dtd/xhtmlcatalog.xml and ${frameworks}/xhtml11/schema/xhtmlcatalog.xml.

Transformation Scenarios

The following default transformation scenarios are available for XHTML:

• XHTML to DITA concept - converts an XHTML document to a DITA concept document;

• XHTML to DITA reference - converts an XHTML document to a DITA reference document;

• XHTML to DITA task - converts an XHTML document to a DITA task document;

• XHTML to DITA topic - converts an XHTML document to a DITA topic document;

The TEI P4 document type
The Text Encoding Initiative (TEI) Guidelines is an international and interdisciplinary standard that enables libraries,
museums, publishers, and individual scholars to represent a variety of literary and linguistic texts for online research,
teaching, and preservation.
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Association rules
A file is considered to be a TEI P4 document when either of the following occurs:

• the root's local name is TEI.2

• the document's public id is -//TEI P4

Schema
The DTD schema used for these documents is located in ${frameworks}/tei/tei2xml.dtd, where ${frameworks} is a
subdirectory of the <oXygen/> install directory.

Author extensions
The CSS file used for rendering TEI P4 content is located in ${frameworks}/tei/xml/tei/css/tei_oxygen.css.

Specific actions are:

• Bold - changes the style of the selected text to bold by surrounding it with hi tag and setting the rend attribute to
bold.

• Italic - changes the style of the selected text to italic by surrounding it with hi tag and setting the rend attribute
to italic.

• Underline - changes the style of the selected text to underline by surrounding it with hi tag and setting the rend
attribute to ul.

Note

For all of the above actions if there is no selection then a new specific tag will be inserted. These actions are
available in any document context.

• Insert Section - inserts a new section/subsection, depending on the current context. For example if the current
context is div1 then a div2 will be inserted and so on.

• Insert Paragraph - inserts a new paragraph depending on the current context. If current context is a paragraph
context (one of the ancestors of the element at caret position is p) then a new paragraph will be inserted after the
paragraph at caret. Otherwise a new paragraph is inserted at caret position.

• Insert Image - inserts a graphic object at the caret position. The following dialog is displayed allowing the user
to specify the entity that refers the image itself:
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Figure 6.11. Insert image entity dialog

• Insert Ordered List - inserts an ordered list (list element with type attribute set to ordered) with one list item (item
element).

• Insert Itemized List - inserts an unordered list (list element with type attribute set to bulleted) with one list item
(item element).

• Insert List Item - inserts a new list item for in any of the above two list types.

• Insert Table - opens a dialog that allows you to configure the table to be inserted.

Figure 6.12. Insert Table Dialog

The dialog allows the user to configure the number of rows and columns of the table and if the header will be gen-
erated.

• Insert Row - inserts a new table row with empty cells. The action is available when the caret position is inside a
table.

• Insert Column - inserts a new table column with empty cells after the current column. The action is available
when the caret position is inside a table.

• Insert Cell - inserts a new empty cell depending on the current context. If the caret is positioned between two
cells, a new one will be inserted at caret's position. If the caret is inside a cell, then the new one will be created after
the current cell.

• Delete Column - deletes the table column where the caret is located.

• Delete Row - deletes the table row where the caret is located.
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• Join Row Cells - joins the content of the selected cells. The operation is available if the selected cells are from
the same row and they have the same row span. The action is also available when the selection is missing, but the
caret is positioned between two cells.

• Join Cell Above - joins the content of cell from current caret position with that of the cell above it. Note that this
action works only if both cells have the same column span.

• Join Cell Below - joins the content of cell from current caret position with that of the cell below it. Note that this
action works only if both cells have the same column span.

• Split Cell To The Left - splits the cell from current caret position in two, inserting a new empty table cell to the
left. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.

• Split Cell To The Right - splits the cell from current caret position in two, inserting a new empty table cell to the
right. Note that this action works only if the current cell spans over more than one column. The column span of the
source cell will be decreased with one.

• Split Cell Above - splits the cell from current caret position in two, inserting a new empty table cell above. Note
that this action works only if the current cell spans over more than one row. The row span of the source cell will be
decreased with one.

• Split Cell Below - splits the cell from current caret position in two, inserting a new empty table cell below. Note
that this action works only if the current cell spans over more than one row. The row span of the source cell will be
decreased with one.

• Generate IDs - allows you to generate ID for the current selection or for the element at caret position if the element
appears in ID Generation dialog.

Figure 6.13. ID generation dialog
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In this dialog you can specify the elements for which <oXygen/> should generate an ID. You can choose to automat-
ically generate an ID for these elements by selecting Auto generate ID's for elements. You can choose a pattern for
the generated ID using the field ID Pattern. If the element already has an ID, this ID is preserved.

All actions described above are available in the contextual menu, main menu (TEI P4 submenu) and in the Author
custom actions toolbar.

Templates

Default templates are available for XHTML. They are stored in ${frameworksDir}/tei/templates/TEI P4 folder and
they can be used for easily creating basic TEI P4 documents.

These templates are available when creating new documents from templates.

TEI P4 - Lite New TEI P4 Lite.

TEI P4 - New Document New TEI P4 standard document.

Catalogs

There are two default catalogs for TEI P4 document type: ${frameworks}/tei/xml/teip4/schema/dtd/catalog.xml and
${frameworks}/tei/xml/teip4/custom/schema/dtd/catalog.xml.

Transformation Scenarios

The following default transformations are available:

• TEI HTML - transforms a TEI document into a HTML document;

• TEI P4 -> TEI P5 Conversion - convert a TEI P4 document into a TEI P5 document;

• TEI PDF - transforms a TEI document into a PDF document.

The TEI P5 document type
Customization for TEI P5 is similar with that for TEI P4 with the following exceptions:

Association rules
A file is considered to be a TEI P5 document when the namespace is http://www.tei-c.org/ns/1.0.

Schema
The RNG schema used for these documents is located in ${frameworks}/tei/xml/tei/custom/schema/relaxng/tei_all-
Plus.rng, where ${frameworks} is a subdirectory of the <oXygen/> install directory.

Author extensions
The CSS file used for rendering TEI P5 content and custom actions are the same with those configured for TEI P4.
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Templates

Default templates are available for TEI P5. They are stored in ${frameworksDir}/tei/templates/TEI P5 folder and
they can be used for easily creating basic TEI P5 documents.

These templates are available when creating new documents from templates.

TEI P5 - All New TEI P5 All.

TEI P5 - Bare New TEI P5 Bare.

TEI P5 - Lite New TEI P5 Lite.

TEI P5 - Math New TEI P5 Math.

TEI P5 - Speech New TEI P5 Speech.

TEI P5 - SVG New TEI P5 with SVG extensions.

TEI P5 - XInclude New TEI P5 XInclude aware.

Catalogs

XML catalogs used for TEI P4 are used also for TEI P5.

Transformation Scenarios

The following default transformations are available:

• TEI P5(experimental) HTML - transforms a TEI document into a HTML document;

• TEI P5(experimental) PDF - transforms a TEI document into a PDF document.

The MathML document type
Mathematical Markup Language (MathML) is an application of XML for describing mathematical notations and cap-
turing both its structure and content. It aims at integrating mathematical formulae into World Wide Web documents.

<oXygen/> offers support for editing and validating MathML 2.0 documents.

Association rules
A file is considered to be a MathML document when the root element name is a math or it's namespace is ht-
tp://www.w3.org/1998/Math/MathML.

Schema
The schema used for these documents is located in ${frameworks}/mathml2/dtd/mathml2.dtd, where ${frameworks}
is a subdirectory of the <oXygen/> install directory.

Templates
Default templates are available for MathML. They are stored in the ${frameworksDir}/mathml2/templates folder.

148

Predefined document types



These templates are available when creating new documents from templates.

MathML - Equation Simple MathML template file.

The Microsoft Office OOXML document type
Office Open XML (also referred to as OOXML or OpenXML) is a free and open Ecma
[http://www.ecma-international.org/publications/standards/Ecma-376.htm] international standard document format,
and a proposed ISO/IEC standard for representing spreadsheets, charts, presentations and word processing documents.

OOXML uses a file package conforming to the Open Packaging Convention. This format uses the ZIP file format and
contains the individual files that form the basis of the document. In addition to Office markup, the package can also
include embedded files such as images, videos, or other documents.

<oXygen/> offers support for editing, transforming and validating documents composing the OOXML package directly
through the archive support.

Figure 6.14. Editing OOXML packages in <oXygen/>

Association rules
A file is considered to be an OOXML document when it has one of the following namespaces:

• http://schemas.openxmlformats.org/wordprocessingml/2006/main

• http://schemas.openxmlformats.org/package/2006/content-types

• http://schemas.openxmlformats.org/drawingml/2006/main

• http://schemas.openxmlformats.org/package/2006/metadata/core-properties

• http://schemas.openxmlformats.org/package/2006/relationships

• http://schemas.openxmlformats.org/presentationml/2006/main

• http://schemas.openxmlformats.org/officeDocument/2006/custom-properties

• http://schemas.openxmlformats.org/officeDocument/2006/extended-properties
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• http://schemas.openxmlformats.org/spreadsheetml/2006/main

• http://schemas.openxmlformats.org/drawingml/2006/chart

Schema
The NVDL schema used for these documents is located in ${frameworks}/ooxml/schemas/main.nvdl, where ${frame-
works} is a subdirectory of the <oXygen/> install directory. The schema can be easily customized to allow user defined
extension schemas for use in the OOXML files. See the Markup Compatibility and Extensibility
[http://www.ecma-international.org/news/TC45_current_work/Office%20Open%20XML%20Part%205%20-%20Markup%20Compatibility%20and%20Extensibility.pdf]
Ecma PDF document for more details.

Templates
Default templates are available for OOXML. They are stored in the ${frameworksDir}/ooxml/templates folder.

These templates are available when creating new documents from templates.

OOXML - Microsoft Excel Work-
book

Simple Microsoft Excel XLSX template file.

OOXML - Microsoft PowerPoint
Presentation

Simple Microsoft PowerPoint PPTX template file.

OOXML - Microsoft Word Docu-
ment

Simple Microsoft Word DOCX template file.

The Open Office ODF document type
The OpenDocument format (ODF) is a free and open file format for electronic office documents, such as spreadsheets,
charts, presentations and word processing documents. The standard [http://www.oasis-open.org/committees/office/]
was developed by the Open Office XML technical committee of the Organization for the Advancement of Structured
Information Standards (OASIS) consortium and based on the XML format originally created and implemented by the
OpenOffice.org office suite.

A basic OpenDocument file consists of an XML document that has <document> as its root element. OpenDocument
files can also take the format of a ZIP compressed archive containing a number of files and directories; these can
contain binary content and benefit from ZIP's lossless compression to reduce file size. OpenDocument benefits from
separation of concerns by separating the content, styles, metadata and application settings into four separate XML
files.

<oXygen/> offers support for editing, manipulating and validating documents composing the ODF package directly
through the archive support.
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Figure 6.15. Editing ODF packages in <oXygen/>

Association rules
A file is considered to be an ODF document when it has the following namespace: urn:oasis:names:tc:open-
document:xmlns:office:1.0

Schema
The RelaxNG schema used for these documents is located in ${frameworks}/odf/schemas/OpenDocument-schema-
v1.1.rng, where ${frameworks} is a subdirectory of the <oXygen/> install directory.

Templates
Default templates are available for ODF. They are stored in the ${frameworksDir}/odf/templates folder.

These templates are available when creating new documents from templates.

ODF - Presentation Simple Open Office Presentation ODP template file.

ODF - Spreadsheet Simple Open Office Spreadsheet ODS template file.

ODF - Text Document Simple Open Office Text Document ODT template file.

The OASIS XML Catalog document type
The OASIS [http://www.oasis-open.org/committees/entity/spec-2001-08-06.html] XML catalog is a document describing
a mapping between external entity references or URI's and locally-cached equivalents. You can read more about using
catalogs in <oXygen/> here.

Association rules
A file is considered to be an XML Catalog document when it has the following namespace: urn:oas-
is:names:tc:entity:xmlns:xml:catalog or when its root element name is catalog.

Schema
The OASIS 1.1 XSD schema used for these documents is located in ${frameworks}/xml/catalog1.1.xsd, where
${frameworks} is a subdirectory of the <oXygen/> install directory.
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Templates
Default templates are available for XML catalogs creation. They are stored in the ${frameworksDir}/xml/templates
folder.

These templates are available when creating new documents from templates.

OASIS XML Catalog - 1.0 Sample OASIS 1.0 XML Catalog.

OASIS XML Catalog - 1.1 Sample OASIS 1.1 XML Catalog.

The XML Schema document type
This document type is used to associated CSS stylesheets to an XML Schema so it can be visualized in the Author
page.

Association rules
A file is considered to be an XML Schema document when the root name is 'schema' and namespace is 'ht-
tp://www.w3.org/2001/XMLSchema'.

Author extensions
The following CSS alternatives are proposed for visualizing XML Schemas in the Author page.

${frameworks}/xmlschema/schema-
main.css

Documentation - representation of XML Schema optimized for editing and
viewing documentation.

${frameworks}/xmlschema/sche-
maISOSchematron.css

XMLSchema+ISOSchematron - representation of XML Schema with embedded
ISO Schematron rules.

${frameworks}/xmlschema/schemaS-
chematron.css

XMLSchema+Schematron - representation of XML Schema with embedded
Schematron rules.

${frameworks}/xmlschema/de-
fault.css

XMLSchema+Schematron - representation of XML Schema for general editing.

The RelaxNG document type
This document type is used to associated CSS stylesheets to an RelaxNG file so it can be visualized in the Author page.

Association rules
A file is considered to be an RelaxNG document when the namespace is 'http://relaxng.org/ns/structure/1.0'.

Author extensions
The following CSS alternatives are proposed for visualizing RelaxNG schemas in the Author page.

${frameworks}/relaxng/relaxng-
main.css

Relax NG - representation of Relax NG optimized for editing in the Author
mode.
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${frameworks}/relaxng/re-
laxngISOSchematron.css

RelaxNG+ISOSchematron - representation of RelaxNG with embedded ISO
Schematron rules.

${frameworks}/relaxng/relaxng-
Schematron.css

RelaxNG+Schematron - representation of RelaxNG with embedded Schematron
rules.

The NVDL document type
This document type is used to associated CSS stylesheets to a NVDL file so it can be visualized in the Author page.

Association rules
A file is considered to be a NVDL document when the namespace is 'http://purl.oclc.org/dsdl/nvdl/ns/structure/1.0'.

Author extensions
The following CSS is proposed for visualizing NVDL schemas in the Author page.

${frameworks}/nvdl/nvdl.css Representation of Relax NG optimized for editing in the Author mode.

The Schematron document type
This document type is used to associated CSS stylesheets to a Schematron file so it can be visualized in the Author
page.

Association rules
A file is considered to be a Schematron document when the namespace is 'http://purl.oclc.org/dsdl/schematron'.

Author extensions
The following CSS is proposed for visualizing Schematron schemas in the Author page.

${frameworks}/schematron/iso-
schematron.css

Representation of Schematron optimized for editing in the Author mode.

The Schematron 1.5 document type
This document type is used to associated CSS stylesheets to a Schematron 1.5 file so it can be visualized in the Author
page.

Association rules
A file is considered to be a Schematron 1.5 document when the namespace is 'http://www.ascc.net/xml/schematron'.

Author extensions
The following CSS is proposed for visualizing Schematron 1.5 schemas in the Author page.
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${frameworks}/schematron/schemat-
ron15.css

Representation of Schematron 1.5 optimized for editing in the Author mode.

The XSLT document type
This document type is used to associated CSS stylesheets to an XSLT stylesheet file so it can be visualized in the Author
page.

Association rules
A file is considered to be a XSLT document when the namespace is 'http://www.w3.org/1999/XSL/Transform'.

Author extensions
The following CSS is proposed for visualizing XSLT stylesheets in the Author page.

${frameworks}/xslt/xslt.css Representation of XSLT optimized for editing in the Author mode.

The XMLSpec document type
XMLSpec is a markup language for W3C specifications and other technical reports.

Association rules
A file is considered to be an XMLSpec document when the root name is 'spec'.

Schema
XMLSpec documents use a RelaxNG schema located in ${frameworks}/xmlspec/schema/xmlspec.rng, where
${frameworks} is a subdirectory of the <oXygen/> install directory.

Author extensions

Templates

Default templates are available for XMLSpec. They are stored in ${frameworksDir}/xmlspec/templates folder and
they can be used for easily creating an XMLSpec.

These templates are available when creating new documents from templates.

XMLSpec - New Document New XMLSpec document

Catalogs

The default catalog is stored in ${frameworks}/xmlspec/catalog.xml.

Transformation Scenarios

The following default transformation scenarios are available:
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• XMLSpec PDF - transforms an XMLSpec document into PDF document;

• XMLSpec HTML - transforms an XMLSpec document into HTML document;

• XMLSpec HTML Diff - produces "color-coded" HTML from diff markup;

• XMLSpec HTML Slices - produces "chunked" HTML specifications;

The FO document type
FO describes the formatting of XML data for output to screen, paper or other media.

Association rules
A file is considered to be an FO document when the it's namespace is http://www.w3.org/1999/XSL/Format.

Schema
FO documents use a XML Schema located in ${frameworks}/fo/xsd/fo.xsd, where ${frameworks} is a subdirectory of
the <oXygen/> install directory.

Author extensions

Transformation Scenarios

The following default transformation scenarios are available:

• FO PDF - transforms an FO document into PDF document;

The EAD document type
EAD Document Type Definition (DTD) is a standard for encoding archival finding aids using Extensible Markup
Language (XML). The standard is maintained in the Network Development and MARC Standards Office of the Library
of Congress (LC) in partnership with the Society of American Archivists.

Association rules
A file is considered to be a FO document when the it's namespace is urn:isbn:1-931666-22-9 or it's public ID
is //DTD ead.dtd (Encoded Archival Description (EAD) Version 2002)//EN.

Schema
EAD documents use a Relax NG Schema located in ${frameworks}/ead/rng/ead.rng, where ${frameworks} is a sub-
directory of the <oXygen/> install directory.
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Author extensions

Templates

Default templates are available for EAD. They are stored in ${frameworksDir}/ead/templates folder and they can
be used for easily creating an EAD document.

These templates are available when creating new documents from templates.

EAD - NWDA Template 2008-04-
08

New EAD document

Catalogs

The default catalog is stored in ${frameworks}/ead/catalog.xml.
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Chapter 7. Author Developer Guide
Introduction
Starting with version 9, <oXygen/> adds extensive support for customization.

The Author mode from <oXygen/> was designed for bridging the gap between the XML source editing and a friendly
user interface. The main achievement is the fact that the Author combines the power of the source editing and the intu-
itive interface of a text editor.

Figure 7.1. oXygen Author Editor

Although <oXygen/> comes with already configured frameworks for DocBook, DITA, TEI, XHTML, you might need
to create a customization of the editor to handle other types of documents. For instance in the case you have a collection
of XML document types used to define the structure of the documents that are used in your organisation and you want
them visually edited by people who are not experienced in using XML.

There are several ways to customize the editor:

1. Create a CSS file defining styles for the XML elements the user will work with, and create XML files that refer the
CSS through an xml-stylesheet processing instruction.

2. Fully configure a document type association. This involves putting together the CSS files, the XML schemes, actions,
menus, etc, bundling them and distributing an archive. The CSS and the GUI elements are settings of the <oXygen/>
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Author. The other settings like the templates, catalogs, transformation scenarios are general settings and are enabled
whenever the association is active, no matter the editing mode (Text, Grid or Author).

We will discuss both approaches in the following sections.

Simple Customization Tutorial

XML Schema
Let's consider the following XML Schema, test_report.xsd defining a report with results of a testing session.
The report consists of a title, few lines describing the test suite that was run and a list of test results, each with a name
and a boolean value indicating if the test passed or failed.

<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema">
    <xs:element name="report">
        <xs:complexType>
            <xs:sequence>
                <xs:element ref="title"/>
                <xs:element ref="description"/>
                <xs:element ref="results"/>
            </xs:sequence>
        </xs:complexType>
    </xs:element>
    <xs:element name="title" type="xs:string"/>
    <xs:element name="description">
        <xs:complexType>
            <xs:sequence maxOccurs="unbounded">
                <xs:element name="line">
                    <xs:complexType mixed="true">
                        <xs:sequence minOccurs="0" 
                            maxOccurs="unbounded">
                            <xs:element name="important" 
                              type="xs:string"/>
                        </xs:sequence>
                    </xs:complexType>
                </xs:element>                
            </xs:sequence>
        </xs:complexType>
    </xs:element>

    <xs:element name="results">
        <xs:complexType>
            <xs:sequence maxOccurs="unbounded">
                <xs:element name="entry">
                    <xs:complexType>
                        <xs:sequence>
                            <xs:element name="test_name" 
                              type="xs:string"/>
                            <xs:element name="passed" 
                               type="xs:boolean"/>
                        </xs:sequence>
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                    </xs:complexType>
                </xs:element>
            </xs:sequence>
        </xs:complexType>
    </xs:element>
</xs:schema>

Our use-case is that several users are testing a system and must send report results to a content management system.
The Author customization should provide a visual editor for this kind of documents.

Writing the CSS
We have to define a set of rules describing how the XML document is to be rendered into the <oXygen/> Author. This
is done using Cascading Style Sheets or CSS on short. CSS is a language used to describe how an HTML or XML
document should be formatted by a browser. CSS is widely used in the majority of websites.

Note

For more information regarding CSS, please read the specification http://www.w3.org/Style/CSS/. A tutorial is
available here : http://www.w3schools.com/css/css_intro.asp

The elements from an XML document are displayed in the layout as a series of boxes. Some of the boxes contain text
and may flow one after the other, from left to right. These are called in-line boxes. There are also other type of boxes
that flow one below the other, like paragraphs. These are called block boxes.

For example consider the way a traditional text editor arranges the text. A paragraph is a block, because it contains a
vertical list of lines. The lines are also blocks. But any block that contains inline boxes is arranging its children in a
horizontal flow. That is why the paragraph lines are also blocks, but the traditional "bold" and "italic" sections are
represented as inline boxes.

The CSS allows us to specify that some elements are displayed as tables. In CSS a table is a complex structure and
consists of rows and cells. The "table" element must have children that have "table-row" style. Similarly, the "row"
elements must contain elements with "table-cell" style.

To make it easy to understand, the following section describes the way each element from the above schema is
formatted using a CSS file. Please note that this is just one from an infinite number of possibilities of formatting the
content.

report This element is the root element of the report document. It should be rendered as a box
that contains all other elements. To achieve this we set its display type to block. Additionally
we are setting some margins for it. The CSS rule that matches this element is:

report{
    display:block;
    margin:1em;
}

title The title of the report. Usually titles have a larger font. We should use also the block display
- the next elements will be placed below it, and change its font to double the size of the
normal text.

title {
    display:block;
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    font-size:2em;    
}

description This element contains several lines of text describing the report. The lines of text are dis-
played one below the other, so the description will have the same block display. To make
it standout we are changing its background.

description {
    display:block;
    background-color:#EEEEFF;
    color:black;
}

line A line of text in the description. We do not define a specific aspect for it, just indicating
that the display should be block.

line {
    display:block;
}

important The important element defines important text from the description. Because it can be
mixed with text, its display property must be set to inline. To make it easier to spot, we
will emphasize its text.

important {
    display:inline;
    font-weight:bold;
}

results The results element shows the list of test_names and the result for each one. To make
it easier to read, we choose to display it as a table with a green border and margins.

results{
    display:table;
    margin:2em;
    border:1px solid green;
}

entry An item in the results element. Because we chose the results to be a table, the entry is the
row in the table. Thus, the display is table-row.

entry {
    display:table-row;
}

test_name, passed The name of the individual test, and its result. They are cells in the results table with display
set to table-cell. Padding and a border are added to emphasize the table grid.

test_name, passed{
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    display:table-cell;
    border:1px solid green;
    padding:20px;
}

passed{
    font-weight:bold;
}

The full content of the CSS file test_report.css is:

report {
    display:block;
    margin:1em;
}

description {
    display:block;
    background-color:#EEEEFF;
    color:black;
}

line {
    display:block;
}

important {
    display:inline;
    font-weight:bold;
}

title {
    display:block;
    font-size:2em;    
}

results{
    display:table;
    margin:2em;       
    border:1px solid green;
}

entry {
    display:table-row;
}

test_name, passed{
    display:table-cell;
    border:1px solid green;
    padding:20px;
}
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passed{
    font-weight:bold;
}                        

Figure 7.2. A report opened in the Author

The XML Instance Template
Now we have the XML Schema and the CSS file. Based on these files, the <oXygen/> Author can help the content
author in loading, editing and validating the test reports. We have to create an XML file template, a kind of skeleton,
that the users can use as a starting point for creating new test reports.

The template must be generic enough and refer the XML Schema file and the CSS stylesheet. This is an example:

<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" href="test_report.css"?>
<report xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
             xsi:noNamespaceSchemaLocation="test_report.xsd">
    <title>Test report title</title>
    <description>
        <line>This is the report 
                  <important>description</important>.</line>
    </description>
    <results>
        <entry>
            <test_name>Sample test1</test_name>
            <passed>true</passed>
        </entry>
        <entry>
            <test_name>Sample test2</test_name>
            <passed>true</passed>
        </entry>
    </results>
</report>
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The processing instruction xml-stylesheet associates the CSS stylesheet to the XML file. The href pseudo attribute
contains the URI reference to the stylesheet file. In our case the CSS is in the same directory as the XML file.

The next step is to place the XSD file and the CSS file on a web server and modify the template to use the HTTP URLs,
like this:

<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/css" 
        href="http://www.mysite.com/reports/test_report.css"?>
<report xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
        xsi:noNamespaceSchemaLocation=
        "http://www.mysite.com/reports/test_report.xsd">
    <title>Test report title</title>
    <description>
.......

The alternative is to create an archive containing the test_report.xml, test_report.css and test_re-
port.xsd and send it to the content authors.

Advanced Customization Tutorial - Document
Type Associations
<oXygen/> Author is highly customizable. Practically you can associate an entire class of documents (grouped logically
by some common features like namespace, root element name or filename) to a bundle consisting of a CSS stylesheets,
validation schemas, catalog files, templates for new files, transformation scenarios and even custom actions. This is
called a Document Type Association.

Creating the Basic Association
In this section we will create a Document Type Association for a set of documents. As an example we will create a
light documentation framework, similar to DocBook and create a complete customization of the Author editor.

You can find the complete files that were used in this tutorial in the Example Files Listings.

First step. XML Schema.

Our documentation framework will be very simple. The documents will be either articles or books, both composed
of sections. The sections may contain titles, paragraphs, figures, tables and other sections.
To complete the picture, each section will include a def element from another namespace.

The first schema file:

<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" 
    targetNamespace="http://www.oxygenxml.com/sample/documentation"
    xmlns:doc="http://www.oxygenxml.com/sample/documentation"
    xmlns:abs="http://www.oxygenxml.com/sample/documentation/abstracts"
    elementFormDefault="qualified">

    <xs:import namespace=
    "http://www.oxygenxml.com/sample/documentation/abstracts" 
     schemaLocation=
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    "abs.xsd"/>

The namespace of our documents will be http://www.oxygenxml.com/sample/documentation. The
namespace of the def element is http://www.oxygenxml.com/sample/documentation/abstracts.

Now let's define the structure of the sections. They all start with a title, then have the optional def element then either
a sequence of other sections, or a mixture of paragraphs, images and tables.

<xs:element name="book" type="doc:sectionType"/>
<xs:element name="article" type="doc:sectionType"/>
<xs:element name="section" type="doc:sectionType"/>

<xs:complexType name="sectionType">
    <xs:sequence>
        <xs:element name="title" type="xs:string"/>
        <xs:element ref="abs:def" minOccurs="0"/>
        <xs:choice>
            <xs:sequence>
                <xs:element ref="doc:section" maxOccurs="unbounded"/>
            </xs:sequence>    
            <xs:choice maxOccurs="unbounded">
                <xs:element ref="doc:para"/>
                <xs:element ref="doc:image"/>
                <xs:element ref="doc:table"/>                
            </xs:choice>
        </xs:choice>
    </xs:sequence>
</xs:complexType>

The paragraph contains text and other styling markup, such as bold (b) and italic (i) elements.

<xs:element name="para" type="doc:paragraphType"/>

<xs:complexType name="paragraphType" mixed="true">
    <xs:choice minOccurs="0" maxOccurs="unbounded">
        <xs:element name="b"/>
        <xs:element name="i"/>
    </xs:choice>
</xs:complexType>

The image element has an attribute with a reference to the file containing image data.

<xs:element name="image">
    <xs:complexType>
        <xs:attribute name="href" type="xs:anyURI" use="required"/>
    </xs:complexType>
</xs:element>

The table contains a header row and then a sequence of rows (tr elements) each of them containing the cells. Each
cell has the same content as the paragraphs.

 <xs:element name="table">
    <xs:complexType>
        <xs:sequence>
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            <xs:element name="header">
                <xs:complexType>
                    <xs:sequence>
                        <xs:element name="td" maxOccurs="unbounded" 
                            type="doc:paragraphType"/>
                    </xs:sequence>
                </xs:complexType>
            </xs:element>
            <xs:element name="tr" maxOccurs="unbounded">
                <xs:complexType>
                    <xs:sequence>
                        <xs:element name="td" type="doc:tdType" 
                             maxOccurs="unbounded"/>                                
                    </xs:sequence>
                </xs:complexType>
            </xs:element>
        </xs:sequence>
    </xs:complexType>
</xs:element>

<xs:complexType name="tdType">
    <xs:complexContent>
        <xs:extension base="doc:paragraphType">
            <xs:attribute name="row_span" type="xs:integer"/>
            <xs:attribute name="column_span" type="xs:integer"/>
        </xs:extension>            
    </xs:complexContent>
</xs:complexType>    

The def element is defined as a text only element in the imported schema abs.xsd:

<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" 
    targetNamespace=
     "http://www.oxygenxml.com/sample/documentation/abstracts">
    <xs:element name="def" type="xs:string"/>
</xs:schema>

Now that we defined our XML data structure, let's start styling it...

Second step.The CSS.

If you read the Simple Customization Tutorial then you already have some basic notions about creating simple styles.
Our document contains elements from different namespaces, so we will use CSS Level 3 extensions supported by the
<oXygen/> layout engine to associate specific properties with that element.

Note

Please note that the CSS Level 3 is a standard under development, and has not been released yet by the W3C.
However, it addresses several important issues like selectors that are namespace aware and values for the CSS
properties extracted from the attributes of the XML documents. Although not (yet) conforming with the current
CSS standard these are supported by the <oXygen/> Author.
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Defining the General Layout.

We are now creating the basic layout of the rendered documents.

Elements that are stacked one on top of the other are: book, article, section, title, figure, table, image.
These elements are marked as having block style for display. Elements that are placed one after the other in a flowing
sequence are: b, i. These will have inline display.

/* Vertical flow */
book,
section,
para,
title,
image,
ref {
    display:block;
}

/* Horizontal flow */
b,i {
    display:inline;
}

Important

Having block display children in an inline display parent, makes <oXygen/> Author change the style of
the parent to block display.

Styling the section Element.

The title of any section must be bold and smaller than the title of the parent section. To create this effect we have to
create a sequence of CSS rules. The * operator matches any element, so we can use it to match titles having progressive
depths in the document.

title{
    font-size: 2.4em;
    font-weight:bold;    
}
* * title{
    font-size: 2.0em;
}
* * * title{
    font-size: 1.6em;
}
* * * * title{
    font-size: 1.2em;
}

Note

CSS rules are combined as follows:

• All the rules that match an element are kept as a list. The more specific the rule is, the further it will be placed
to the end of the list.
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• If there is no difference in the specificity of the rules, they are placed in the list in the same order as they appear
in the CSS document.

• The list is then iterated, and all the properties from the rules are collected, overwriting the already collected
values from the previous rules. That is why the font-size is changed depending on the depth of the element,
while the font-weight property remains unchanged - no other rule is overwriting it.

It's useful to have before the title a constant text, indicating that it refers to a section. This text can include also the
current section number. To achieve we have to use the :before and :after pseudo elements, plus the CSS counters.

We declare a counter named sect for each book or article. The counter is set to zero at the beginning of each
such element:

book, 
article{
    counter-reset:sect;
}

The sect counter is incremented with each section, that is the a direct child of a book or an article element.

book > section,
article > section{
    counter-increment:sect;
}   

The "static" text that will prefix the section title is composed of the constant "Section ", followed by the decimal value
of the sect counter and a dot.

book > section > title:before,
article > section > title:before{
    content: "Section " counter(sect) ". ";
}

To make the documents easy to read, we will add a margin to the sections. In this way the higher nesting level, the
larger the left side indent. The margin is expressed relatively to the parent bounds:

section{
    margin-left:1em;
    margin-top:1em;
}
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Figure 7.3. A sample of nested sections and their titles.

In the above screenshot you can see a sample XML document rendered by our CSS. The selection "avoids" the text
that is generated by the CSS "content" property. This happens because the CSS generated text is not present in the
XML document and is just a visual aid.

Styling the table Element.

There are standard CSS properties used to indicate what elements are tables, table rows and table cells. What CSS is
missing is the possibility to indicate the cell spanning. <oXygen/> Author offers support for adding an extension to
solve this problem. This will be presented in the next chapters.

The table in this example is a simple one. The header must be formatted in a different way than the ordinary rows, so
it will have a background color.

table{
    display:table;
    border:1px solid navy;
    margin:1em;
    max-width:1000px;
    min-width:150px;
}

table[width]{
  width:attr(width, length);
}

tr, header{
    display:table-row;
}

header{
    background-color: silver;
    color:inherit
}

td{
  display:table-cell;
  border:1px solid navy;
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  padding:1em;
}

Note

Children elements with block or table-caption display placed at the beginning or the end of an element
displayed as a table, will be grouped and presented as blocks at the top or the bottom of the table.

Note

Mixing elements having table-cell, table-group, table-row, etc.. display type with others that have
block or inline display or with text content breaks the layout of the table. In such cases the table is shown
as a block.

Note

Having child elements that do not have table-cell or table display in a parent with table-row display
breaks the table layout. In this case the table display is supported for the children of the table-row element
in order to allow sub-tables in the parent table.

Note

<oXygen/> Author can automatically detect the spanning of a cell, without the need to write a Java extension
for this.

This happens if the span of the cell element is specified using the colspan and rowspan attributes, just like in
HTML, or cols and rows attributes.

For instance, the following XML code:

  <table>
        <tr>
            <td>Cell 1.1</td>
            <td>Cell 1.2</td>
            <td>Cell 1.3</td>
        </tr>
        <tr>
            <td>Cell 2.1</td>
            <td colspan="2" rowspan="2">
            Cell spanning 2 rows and 2 columns.
            </td>
        </tr>
        <tr><td>Cell 3.1</td></tr>
  </table>

using the CSS:

table{
   display: table;
}
tr{
   display: table-row;
}
td{
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   display: table-cell;
}

is rendered correctly:

Table 7.1. Built-in Cell Spanning

Cell 1.3Cell 1.2Cell 1.1

Cell spanning 2 rows and 2 columnsCell 2.1

Cell 3.1

Because in our schema the td tag has the attributes row_span and column_span that are not automatically recognized
by <oXygen/> Author, we will implement a Java extension which will provide information about the cell spanning.
See the section Configuring a Table Cell Span Provider.

Because the column widths are specified by the attributes width of the elements customcol that are not automatically
recognized by <oXygen/> Author, it is necessary to implement a Java extension which will provide information about
the column widths. See the section Configuring a Table Column Width Provider.

Styling the Inline Elements.

The "bold" style is obtained by using the font-weight CSS property with the value bold, while the "italic" style
is specified by the font-style property:

b {
    font-weight:bold;
}

i {
    font-style:italic;
}

Styling Elements from other Namespace

In the CSS Level 1, 2, and 2.1 there is no way to specify if an element X from the namespace Y should be presented
differently from the element X from the namespace Z. In the upcoming CSS Level 3, it is possible to differentiate
elements by their namespaces. <oXygen/> Author supports this CSS Level 3 functionality. For more information see
the Namespace Selectors section.

To match our def element we will declare its namespace, bind it to the abs prefix, and then write a CSS rule:

@namespace abs "http://www.oxygenxml.com/sample/documentation/abstracts";

abs|def{
    font-family:monospace;
    font-size:smaller;    
}
abs|def:before{
    content:"Definition:";
    color:gray;
}
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Styling images

The CSS 2.1 does not specify how an element can be rendered as an image. To overpass this limitation, <oXygen/>
Author supports a CSS Level 3 extension allowing to load image data from an URL. The URL of the image must be
specified by one of the element attributes.

Note

<oXygen/> Author recognizes the following image file formats: JPEG, GIF, PNG and SVG. The oXygen Author
for Eclipse does not render the SVG files.

image{
    display:block;
    content: attr(href, url);
    margin-left:2em;
}

Our image element has the required attribute href of type xs:anyURI. The href attribute contains an image
location so the rendered content is obtained by using the function:

attr(href, url)

Important

The first argument is the name of the attribute pointing to the image file. The second argument of the attr
function specifies the type of the content. If the type has the url value, then <oXygen/> identifies the content
as being an image. If the type is missing, then the content will be the text representing the attribute value.

Important

<oXygen/> Author handles both absolute and relative specified URLs. If the image has an absolute URL location
(e.g: "http://www.oasis-open.org/images/standards/oasis_standard.jpg") then it is loaded directly from this location.
If the image URL is relative specified to the XML document (e.g: "images/my_screenshot.jpg") then the location
is obtained by adding this value to the location of the edited XML document.

An image can also be referenced by the name of a DTD entity which specifies the location of the image file. For example
if the document declares an entity graphic which points to a JPEG image file:

<!ENTITY graphic SYSTEM "depo/keyboard_shortcut.jpg" NDATA JPEG>

and the image is referenced in the XML document by specifying the name of the entity as the value of an attribute:

<mediaobject>
    <imageobject>
        <imagedata entityref="graphic" scale="50"/>
    </imageobject>
</mediaobject>

The CSS should use the functions url, attr and unparsed-entity-uri for displaying the image in the Author mode:

Note

Note that the scale attribute of the imagedata element will be considered without the need of a CSS customization
and the image will be scaled accordingly.
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imagedata[entityref]{
    content: url(unparsed-entity-uri(attr(entityref))); 
}

To take into account the value of the width attribute of the imagedata and use it for resizing the image, the CSS
can define the following rule:

imagedata[width]{
  width:attr(width, length);
}

Figure 7.4. Samples of images in Author

Marking elements as foldable

You can specify what elements are collapsible. The collapsible elements are rendered having a small triangle icon in
the top left corner. Clicking on this icon hides or shows the children of the element. In our case, we will mark the
section elements as foldable. We will leave only the title child elements visible.

section{
    foldable:true;
    not-foldable-child: title;
}
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Figure 7.5. Folded Sections

Marking elements as links

You can specify what elements are links. The text content specified in the :before pseudo element will be underlined.
When hovering the mouse over that content the mouse pointer will change to indicate that it can follow the link.
Clicking on a link will result in the referred resource being opened in an editor. In our case we will mark the link
elements as links with the href attribute indicating the referred location.

link[href]:before{
    display:inline;
    link:attr(href);
    content: "Click to open: " attr(href);
}

Note

If you plan to use IDs as references for links, the value of the link property should start with a sharp sign(#). This
will ensure that the default link target reference finder implementation will work and clicking on the link will
send you to the indicated location in the document. For more details about the link target reference finder read
the section Configuring a Link target reference finder.

Example 7.1. IDs as references for links

link[linkend]:before{
    display:inline;
    link: "#" attr(linkend);
    content: "Click to open: " attr(linkend);
}

Third Step.The Association.

Now that we have the XML Schema and the CSS stylesheet for the documents we intend to edit, we can proceed to
create a distributable framework package for our content authors.
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Figure 7.6. The Document Type Dialog

Organizing the Framework Files

First create a new folder called sdf (from "Simple Documentation Framework") in {oXygen_installation_dir-
ectory}/frameworks. We will use this folder to store all files related to our documentation framework. Let's or-
ganise it a bit, by creating the following folder structure:

oxygen
  frameworks
     sdf
       schema
       css

Important

The frameworks directory is the container where all the oXygen framework customizations are located.

Each subdirectory contains files related to a specific type of XML documents: schemas, catalogs, stylesheets,
CSS files, etc.

Distributing a framework means delivering a framework directory.

Important

We assume you have the right to create files and folder inside the oXygen installation directory. If you do not
have this right, you will have to install another copy of the program in a folder you have access to, the home
directory for instance, or your desktop. You can download the "all platforms" distribution from the oXygen
website and extract it in the chosen folder.

To test your framework distribution you will need to copy it in the frameworks directory of the newly installed
application and start oXygen by running the provided start-up script files.
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We should copy the created schema files abs.xsd and sdf.xsd, sdf.xsd being the master schema, to the schema
directory and the CSS file sdf.css to the css directory.

Association Rules

We must specify when oXygen should use the files created in the previous section by creating a document type asso-
ciation. Open the Document Type dialog by following the procedure:

1. Open the Options Dialog, and select the Document Types Association option pane.

2. Select the Developer user role from the User role combo box at the top of the dialog. This is important, because
it will allow us to save the document type association in a file on disk, instead of <oXygen/> options.

3. Click on the New button.

In the displayed dialog, fill in the following data:

Name Enter SDF - This is the name of the document type.

Description Enter Simple Documentation Framework - This is a short description helping the other users
understand the purpose of the Document Type.

Storage The storage refers to the place where the Document Type settings are stored. Internal means the
Document Types are stored in the default <oXygen/> preferences file. Since we want to share the
Document Type to other users, we must select External, and choose a file.

The file must be in the {oXygen_installation_directory}/frameworks/sdf directory.
A possible location is /Users/{user_name}/Desktop/oxygen/frameworks/sdf/sdf.framework.
The framework directory structure will be:

oxygen
  frameworks
     sdf
       sdf.framework
       schema
         sdf.xsd
       css
         sdf.css

Rules If a document opened in <oXygen/> matches one of the rules defined for the Document Type, then
it is activated.

Press the Add button from the Rules section. Using the newly displayed dialog, we add a new
rule that matches documents with the root from the namespace: http://www.oxy-
genxml.com/sample/documentation. The root name, file name or PublicID are not relevant.
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Figure 7.7. Editing a rule

A document matches a rule when it fulfills the conditions imposed by each field of the rule:

Namespace the namespace of the root element declared in the XML documents of the
current document type. A value of ANY_VALUE matches any namespace
in an XML document. Value may contain wildcards(*, ?) and editor vari-
ables. Multiple values separated by comma(,) are accepted.

Root local name The local name of the root element of the XML documents of the current
document type. A value of ANY_VALUE matches any local name of the
root element. Value may contain wildcards(*, ?) and editor variables.
Multiple values separated by comma(,) are accepted.

File name The file name of the XML documents of the current document type. A
value of ANY_VALUE matches any file name. Value may contain wild-
cards(*, ?) and editor variables. Multiple values separated by comma(,)
are accepted.

Public ID The public ID of the XML documents of the current document type (for
a document validated against a DTD). A value of ANY_VALUE matches
any public ID. Value may contain wildcards(*, ?) and editor variables.
Multiple values separated by comma(,) are accepted.

Java class The full name of a Java class that has access to all root element attributes
and the above 4 values in order to decide if the document matches the rule.

Java API: Rules implemented in Java

An alternative to the rule we defined for our association is to write the entire logic in Java.

1. Create a new Java project, in your IDE.

Create the lib directory in the Java project directory and copy there the oxygen.jar file from the {oXy-
gen_installation_directory}/lib. The oxygen.jar contains the Java interfaces we have to imple-
ment and the available Author API needed to access its features.

2. Create the class simple.documentation.framework.CustomRule. This class must implement the
ro.sync.ecss.extensions.api.DocumentTypeCustomRuleMatcher interface.

The interface defines two methods: matches, and getDescription.
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1. The matches method is the one that is invoked when the edited document must be checked against the doc-
ument type association. It takes as arguments the root local name, its namespace, the document location URI,
the PublicID and the root element attributes. It must return true when the document matches the association.

2. The getDescription method returns a description of the rule.

Here is the implementation of these two methods. The implementation of matches is just a Java equivalent of
the rule we defined earlier.

 public boolean matches(
   String systemID, 
   String rootNamespace,
   String rootLocalName, 
   String doctypePublicID,
   Attributes rootAttributes) {

  return "http://www.oxygenxml.com/sample/documentation"
   .equals(rootNamespace);  
 }

 public String getDescription() {
  return "Checks if the current Document Type Association" 
  + " is matching the document.";
 }

The complete source code is found in the Example Files Listings, the Java Files section.

3. Package the compiled class into a jar file. Here is an example of an ANT script that packages the classes dir-
ectory content into a jar archive named sdf.jar:

<?xml version="1.0" encoding="UTF-8"?>
<project name="project" default="dist">    
    <target name="dist">
   <jar destfile="sdf.jar" basedir="classes">
    <fileset dir="classes">
     <include name="**/*"/>
     </fileset>
   </jar>        
    </target>
</project>

4. Copy the sdf.jar file into the frameworks/sdf directory.

5. Add the sdf.jar to the Author classpath. To do this select SDF Document Type from the Document Type
Association options page and press the Edit button.

Select the Classpath tab in the lower part of the dialog.

Press the Add button . In the displayed dialog enter the location of the jar file, relative to the <oXygen/>
frameworks directory. If you are in the process of developing the extension actions you can also specify a path
to a directory which holds compiled Java classes.

177

Author Developer Guide



Figure 7.8. Adding a classpath entry

6. Clear the rules we defined before by using the Remove button.

Press the Add button from the Rules section.

Press the Choose button that follows the Java class value. The following dialog is displayed:

Figure 7.9. Selecting a Java association rule.

To test the association, open the sdf.xml sample and validate it.

Schema Settings

In the dialog for editing the Document Type properties, in the bottom section there are a series of tabs. The first one
refers to the schema that is used for validation of the documents that match the defined association Rules.

Important

If the document refers a schema, using for instance a DOCTYPE declaration or a xsi:schemaLocation at-
tribute, the schema from the document type association will not be used when validating.

Schema Type Select from the combo box the value XML Schema.

Schema URI Enter the value ${frameworks}/sdf/schema/sdf.xsd. We should use the ${frame-
works} editor variable in the schema URI path instead of a full path in order to be valid for different
<oXygen/> installations.
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Important

The ${frameworks} variable is expanded at the validation time into the absolute location
of the directory containing the frameworks.

Figure 7.10. The Schema panel

Author CSS Settings

Select the Author tab from the Document Type edit dialog. By clicking on the CSS label in the right part of the tab the
list of associated CSS files is shown.

Here you can also specify how should the CSSs defined in the document type be treated when there are CSSs specified
in the document(with xml-stylesheet processing instructions). The CSSs from the document can either replace
the CSSs defined in the document type association or merge with them.

Add the URI of the CSS file sdf.css we already defined. We should use the ${frameworks}editor variable in
the file path.

Figure 7.11. CSS settings dialog

The Title text field refers to a symbolic name for the stylesheet. When adding several stylesheets with different titles
to a Document Type association, the content author can select what CSS will be used for editing from the Author CSS
Alternatives toolbar.

This combo-box from the toolbar is also populated in case your XML document refers CSS files directly using xml-
stylesheet processing instructions, and the processing instructions define titles for the CSS files.

Note

The CSS settings dialog allows to create a virtualxml-stylesheet processing instructions. The CSS files
defined in the Document Type Association dialog and the xml-stylesheet processing instructions from the
XML document are processed together, as being all a list of processing instructions.

<oXygen/> Author fully implements the W3C recommendation regarding "Associating Style Sheets with XML docu-
ments". For more information see: http://www.w3.org/TR/xml-stylesheet/http://www.w3.org/TR/REC-
html40/present/styles.html#h-14.3.2
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Testing the Document Type Association

To test the new Document Type create an XML instance that is conforming with our Simple Document Format. We
will not specify an XML Schema location directly in the document, using an xsi:schemaLocation attribute;
<oXygen/> will detect instead its associated document type and use the specified schema.

<book xmlns="http://www.oxygenxml.com/sample/documentation" 
      xmlns:abs="http://www.oxygenxml.com/sample/documentation/abstracts">

    <title>My Technical Book</title>
    <section>
        <title>XML</title>
        <abs:def>Extensible Markup Language</abs:def>
        <para>In this section of the book I will 
           explain different XML applications.</para>
    </section>
</book>

When trying to validate the document there should be no errors. Now modify the title to title2. Validate again.
This time there should be one error:

  cvc-complex-type.2.4.a: Invalid content was found starting with element 
  'title2'. One of '{"http://www.oxygenxml.com/sample/documentation":title}' 
  is expected.

Undo the tag name change. Press on the Author button at the bottom of the editing area. <oXygen/> should load the
CSS from the document type association and create a layout similar to this:

Packaging and Deploying

Using a file explorer, go to the <oXygen/> frameworks directory. Select the sdf directory and make an archive
from it. Move it to another <oXygen/> installation (eventually on another computer). Extract it in the frameworks
directory. Start <oXygen/> and test the association as explained above.

If you create multiple document type associations and you have a complex directory structure it might be easy from
the deployment point of view to use an <oXygen/> all platforms distribution. Add your framework files to it, repackage
it and send it to the content authors.

180

Author Developer Guide



Warning

When deploying your customized sdf directory please make sure that your sdf directory contains the sdf.framework
file (that is the file defined as External Storage in Document Type Association dialog shall always be stored inside
the sdf directory). If your external storage points somewhere else <oXygen/> will not be able to update the
Document Type Association options automatically on the deployed computers.

Author Settings
You can add a new Document Type Association or edit the properties of an existing one from the Options+Prefer-
ences+Document Type Association option pane. All the changes can be made into the Document type edit dialog.

Figure 7.12. The Document Type Dialog

Configuring Actions, Menus and Toolbars

The <oXygen/> Author toolbars and menus can be changed to provide a productive editing experience for the content
authors. You can create a set of actions that are specific to a document type.

In our example, the sdf framework, we created the stylesheet and the validation schema. Now let's add some actions
for inserting a section and a table. To add a new action, follow the procedure:

1. Open the Options Dialog, and select the Document Types Association option pane.

2. In the lower part of the Document Type Association dialog, click on the Author tab, then select the Actions label.

3. To add a new action click on the Add button.
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The Insert Section Action

This paragraph describes how you can define the action for adding a section. We assume the icon files Sec-

tion16.gif for the menu item and Section20.gif for the toolbar, are already available. Although we could
use the same icon size for both menu and toolbar, usually the icons from the toolbars are larger than the ones placed
in the menus. These files should be placed in the frameworks/sdf directory.

Figure 7.13. The Action Edit Dialog

ID An unique identifier for the action. You can use insert_section.

Name The name of the action. It is displayed as a tooltip when the action is placed in the toolbar,
or as the menu item name. Use Insert section.

Menu access key On Windows, the menu items can be accessed using (ALT + letter) combination, when
the menu is visible. The letter is visually represented by underlining the first letter from
the menu item name having the same value. Since the name is Insert section, we can
use as a menu access key the letter s.

Description You can add a short description for the action. In our case Adds a section element will
suffice.

Large icon (20x20) The path to the file that contains the toolbar image for the action. A good practice is to
store the image files inside the framework directory. This way we can use the editor
variable${frameworks} to make the image file relative to the framework location.
Insert ${frameworks}/sdf/Section20.gif
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Note

If the images are bundled in a jar archive together with some Java operations im-
plementation for instance, it might be convenient for you to refer the images not
by the file name, but by their relative path location in the class-path.

If the image file Section20.gif is located in the directory images inside the
jar archive, you can refer to it by using /images/Section20.gif. The jar file must
be added into the Classpath list.

Small icon (16x16) The path to the file that contains the menu image. Insert ${frameworks}/sdf/Section16.gif

Shortcut key A shortcut key combination for triggering the action. To define it, click in the text field
and press the desired key combination. We can choose Ctrl+Shift+s.

Note

The shortcut is enabled only by adding the action to the main menu of the Author
mode which contains all the actions that the author will have in a menu for the
current document type.

At this time the action has no functionality added to it. Next we must define how this action operates. An action can
have multiple operation modes, each of them activated by the evaluation of an XPath version 2.0 expression.

Note

The XPath expression of an operation mode is evaluated relative to the current element. The current element
is the one where the caret is positioned. In fact there is hierarchy of elements containing the caret position, but
we are considering only the closest one. A simple expression like:

title

is a relative one and checks if the current element has a "title" child element. To check that the current element
is a "section" we can use the expression:

local-name()='section'

Note

<oXygen/> Author determines the operation to be executed by iterating through the defined operation modes.
The first operation whose XPath expression "matched" the current document context gets executed, while the
others are being ignored. Make sure you order correctly your operations by placing the ones with more specific
XPath selectors before the ones having more generic selectors.

For instance the expression

person[@name='Cris' and @age='24']

is more specific than

person[@name='Cris']
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The action mode using the first expression must be placed before the one using the second expression in the action
modes list.

We decide that we can add sections only if the current element is either a book, article, or another section.

XPath expression Set the value to:

local-name()='section' or local-name()='book' or 
 local-name()='article'

Invoke operation A set of built-in operations is available. A complete list is found in the Author Default Op-
erations section. To this set you can add your own Java operation implementations. In our
case, we'll use the InsertFragmentOperation built-in operation, that inserts an XML frag-
ment at the caret position.

Configure the arguments by setting the following values:

fragment <section xmlns=
"http://www.oxygenxml.com/sample/documentation">
     <title/>
</section>

insertLocation Leave it empty. This means the location will be the element at the
caret position.

insertPosition Select "Inside".

The Insert Table Action

We will create an action that inserts into the document a table with three rows and three columns. The first row is the
table header. Similarly to the insert section action, we will use the InsertFragmentOperation.

We assume the icon files Table16.gif for the menu item and Table20.gif for the toolbar, are already
available. We place these files in the frameworks/sdf directory.

The action properties:

ID You can use insert_table.

Name Insert Insert table.

Menu access key Enter the t letter.

Description We can use Adds a section element.

Toolbar icon Use ${frameworks}/sdf/Table20.gif

Menu icon Insert ${frameworks}/sdf/Table16.gif

Shortcut key We can choose Ctrl+Shift+t.

Now let's set up the operation the action uses.

XPath expression Set it to the value
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true()

Note

true() is equivalent with leaving this field empty.

Invoke operation We'll use InsertFragmentOperation built-in operations that inserts an XML fragment at
the caret position.

Configure its arguments by setting the values:

fragment <table xmlns=
"http://www.oxygenxml.com/sample/documentation">
  <header><td/><td/><td/></header>
  <tr><td/><td/><td/></tr>
  <tr><td/><td/><td/></tr>
</table>

insertLocation In our example will always add tables at the end of the section that
contains the caret position. Use:

ancestor::section/*[last()]

insertPosition Select "After".

Configuring the Toolbar

Now that we have defined the two actions we can add them to the toolbar.

The first thing to check is that the toolbar Author custom actions should be displayed when switching to the Author
mode: Right click in the application window upper part, in the area that contains the toolbar buttons and check Author
custom actions in the displayed menu if it is unchecked.

Open the Document Type edit dialog for the SDF framework and select on the Author tab. Next click on the Toolbar
label.

Figure 7.14. Configuring the Toolbar

The panel is divided in two sections: the left side contains a list of actions, while the right one contains an action tree,
displaying the list of actions added in the toolbar. The special entry called Separator allows you to visually separate
the actions in the toolbar.
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Select the Insert section action in the left and the Toolbar label in the right, then press the Add as child button.

Now select the Insert table action in the left and the Insert section in the right. Press the Add as sibling button.

When opening a Simple Documentation Framework test document in Author mode, the toolbar below will be displayed
at the top of the editor.

Figure 7.15. Author Custom Actions Toolbar

Configuring the Main Menu

Defined actions can be grouped into customized menus in the <oXygen/> menu bar. For this open the Document Type
dialog for the SDF framework and click on the Author tab. Next click on the Menu label.

In the left side we have the list of actions and some special entries:

Submenu Creates a submenu. You can nest an unlimited number of menus.

Separator Creates a separator into a menu. In this way you can logically separate the menu entries.

In the right side we have the menu tree, having the Menu entry as root. To change its name click on this label to select

it, then press the Edit button. Enter SD Framework as name, and D as menu access key.

Figure 7.16. Changing the Name of the Menu

Select the Submenu label in the left an the SD Framework label in the right, then press the Add as child button.

Change the submenu name to Table, using the Edit button.

Select the Insert section action in the left and the Table label in the right, then press the Add as sibling button.

Now select the Insert table action in the left and the Table in the right. Press the Add as child button.
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Figure 7.17. Configuring the Menu

When opening a Simple Documentation Framework test document in Author mode, the menu we created is displayed
in the editor menu bar, between the Debugger and the Document menus. In the menu we find the Table submenu and
the two actions:

Figure 7.18. Author Menu

Note

The shortcut of an action defined for the current document type is enabled only if the action is added to the main
menu. Otherwise the author can run the action only from the toolbar.

Configuring the Contextual Menu

The contextual menu is shown when you right click (on Mac OS X it is used the combination ctrl and mouse click)
in the Author editing area. In fact we are configuring the bottom part of the menu, since the top part is reserved for a
list of generic actions like Copy, Paste, Undo, etc..

Open the Document Type dialog for the SDF framework and click on the Author tab. Next click on the Contextual
Menu label.

Follow the same steps as explained above in the Configuring the Main Menu, except changing the menu name - the
contextual menu has no name.
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Figure 7.19. Configuring the Contextual Menu

To test it, open the test file, and click to open the contextual menu. In the lower part there is shown the Table sub-menu
and the Insert section action:

Figure 7.20. Author Contextual Menu

Author Default Operations

Below are listed all the operations and their arguments.

InsertFragmentOperation Inserts an XML fragment at the current cursor position. The selection - if there
is one, remains unchanged. The fragment will be inserted in the current context
of the cursor position. That means that if the current XML document uses some
namespace declarations then the inserted fragment must use the same declara-
tions. The inserted fragment will not be copied and pasted to the cursor position,
but the namespace declarations of the fragment will be adapted if needed to the
existing namespace declarations of the XML document. Examples of namespace
adjusting when the fragment is inserted and the descriptions of the arguments
are described here.

InsertOrReplaceFragmentOperation Similar to InsertFragmentOperation, except it removes the selected content
before inserting the fragment.

InsertOrReplaceTextOperation Inserts a text. It removes the selected content before inserting the text section.

text The text section to insert.
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SurroundWithFragmentOperation Surrounds the selected content by a fragment. Since the fragment can have
multiple nodes, the surrounded content will be always placed in the first leaf
element. If there is no selection, the operation will simply insert the fragment
at the caret position. The arguments are described here.

SurroundWithTextOperation The surround with text operation takes two arguments, two text values that will
be inserted before and after the selected content. If there is no selected content,
the two sections will be inserted at the caret position. The arguments of the op-
eration are:

header The text that will be placed before the selection.

footer The test that will be placed after the selection.

The arguments of InsertFragmentOperation

fragment The value for this argument is a text. This is parsed by the <oXygen/> Author as it was already
in the document at the caret position. You can use entities references declared in the document
and it is namespace aware. The fragment may have multiple roots.

Note

You can use even namespace prefixes that are not declared in the inserted fragment, if
they are declared in the document where the insertion is done. For clarity, we recommend
always to prefix and declare namespaces in the inserted fragment!

Note

If there are namespace declarations in the fragment that are identical to the in the document
insertion context, the namespace declaration attributes are removed from the fragment
elements.
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Example 7.2. Prefixes that are not bound explicitly

For instance, the fragment:

<x:item id="dty2"/>
&ent;
<x:item id="dty3"/>

Can be correctly inserted in the document: ('|' marks the insertion point):

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE x:root [
    <!ENTITY ent "entity">
]>

<x:root xmlns:x="nsp"> 
  |
</x:root>

Result:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE x:root [
    <!ENTITY ent "entity">
]>
<x:root xmlns:x="nsp">
    <x:item id="dty2"/>
    &ent;
    <x:item id="dty3"/>
</x:root>

Example 7.3. Default namespaces

If there is a default namespace declared in the document and the document fragment does not
declare a namespace, the elements from the fragment are considered to be in no namespace.

For instance the fragment:

<item id="dty2"/>
<item id="dty3"/>

Inserted in the document:

<?xml version="1.0" encoding="UTF-8"?>
<root xmlns="nsp">
|
</root>

Gives the result document:

<?xml version="1.0" encoding="UTF-8"?>
<root xmlns="nsp">
    <item xmlns="" id="dty2"/>
    <item xmlns="" id="dty3"/>
</root>
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insertLocation An XPath expression that is relative to the current node. It selects the reference node for the
fragment insertion.

insertPosition One of the three constants: "Inside", "After", or "Before" , showing where the insertion is made
relative to the reference node selected by the insertLocation. "Inside" has the meaning of the
first child of the reference node.

The arguments of SurroundWithFragmentOperation

fragment The XML fragment that will surround the selection.

Example 7.4. Surrounding with a fragment

Let's consider the fragment:

<F>
   <A></A>
   <B>
     <C></C>
   </B>
</F>

And the document:

<doc>
  <X></X>
  <Y></Y>
  <Z></Z>
<doc>

Considering the selected content that is to be surrounded is the sequence of elements X and Y, then the
result is:

<doc>
   <F>
      <A>
         <X></X>
         <Y></Y>
      </A>
      <B>
        <C></C>
      </B>
   </F> 
  <Z></Z>
<doc>

Because the element A was the first leaf in the fragment, it received the selected content. The fragment
was then inserted in the place of the selection.

Java API - Extending Author Functionality through Java

<oXygen/> Author has a built-in set of operations covering the insertion of text and XML fragments (see the Author
Default Operations) and the execution of XPath expressions on the current document edited in Author mode. However,
there are situations in which we need to extend this set. For instance if you need to enter an element whose attributes
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should be edited by the user through a graphical user interface. Or the users must send the selected element content or
even the whole document to a server, for some kind of processing or the content authors must extract pieces of inform-
ation from a server and insert it directly into the edited XML document. Or you need to apply an XPath expression on
the current Author document and process the nodes of the result nodeset.

In the following sections we are presenting the Java programming interface (API) available to the developers. You
will need the Oxygen Author SDK [http://www.oxygenxml.com/InstData/Editor/Developer/oxygenAuthorSDK.zip]
available on the <oXygen/> website [http://www.oxygenxml.com/developer.html] which includes the source code of
the Author operations in the predefined document types and the full documentation in Javadoc format of the public
API available for the developer of Author custom actions.

The next Java examples are making use of AWT classes. If you are developing extensions for the <oXygen/> XML
Editor plugin for Eclipse you will have to use their SWT counterparts.

We assume you already read the Configuring Actions, Menus, Toolbar section and you are familiar with the <oXygen/>
Author customization. You may find the XML schema, CSS and XML sample in the Example Files Listings.

Warning

Make sure the Java classes of your custom Author operations are compiled with the same Java version that is
used by <oXygen/> XML Author . Otherwise the classes may not be loaded by the Java virtual machine. For
example if you run <oXygen/> XML Author with a Java 1.5 virtual machine but the Java classes of your custom
Author operations are compiled with a Java 1.6 virtual machine then the custom operations cannot be loaded
and used by the Java 1.5 virtual machine.

Example 1. Step by Step Example. Simple Use of a Dialog from an Author Operation.

Let's start adding functionality for inserting images, in our Simple Documentation Framework (shortly SDF). The
images are represented by the image element. The location of the image file is represented by the value of the href
attribute. In our Java implementation we will show a dialog with a text field, in which the user can enter a full URL,
or he can browse for a local file.

1. Create a new Java project, in your IDE.

Create the directory lib in the Java project directory and copy in it the oxygen.jar file from the {oXygen_in-
stallation_directory}/lib directory. The oxygen.jar contains the Java interfaces we have to im-
plement and the API needed to access the Author features.

2. Create the class simple.documentation.framework.InsertImageOperation. This class must
implement the ro.sync.ecss.extensions.api.AuthorOperation interface.

The interface defines three methods: doOperation, getArguments and getDescription.

1. The doOperation method is invoked when the action is performed either by pressing the toolbar button,
selecting the menu item or through the shortcut. It takes as arguments an object of type AuthorAccess and
a map or argument names and values.

2. The getArguments method is used by <oXygen/> when the action is configured, it returns the list of argu-
ments (name and type) that are accepted by the operation.

3. The getDescription method is also used by <oXygen/> when the operation is configured and its return
value describes what the operation does.

Here is the implementation of these three methods.
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 /**
 * Performs the operation.
 */
public void doOperation(
               AuthorAccess authorAccess, 
               ArgumentsMap arguments)
 throws IllegalArgumentException, 
                  AuthorOperationException {

 JFrame oxygenFrame = (JFrame) authorAccess.getParentFrame();
 String href = displayURLDialog(oxygenFrame);
 if (href.length() != 0) {  
     // Creates the image XML fragment.
     String imageFragment = 
        "<image xmlns='http://www.oxygenxml.com/sample/documentation' href='" 
        + href + "'/>";

     // Inserts this fragment at the caret position.
     int caretPosition = authorAccess.getCaretOffset();  
     authorAccess.insertXMLFragment(imageFragment, caretPosition);
 }
}

/**
 * Has no arguments.
 * 
 * @return null.
 */
public ArgumentDescriptor[] getArguments() {
 return null;
}

/**
 * @return A description of the operation.
 */
public String getDescription() {
 return "Inserts an image element. Asks the user for a URL reference.";
}

The complete source code of our operation is found in the Example Files Listings, the Java Files section.

Important

Make sure you always specify the namespace of the inserted fragments.

3. Package the compiled class into a jar file. An example of an ANT script that packages the classes directory
content into a jar archive named sdf.jar is listed below:

<?xml version="1.0" encoding="UTF-8"?>
<project name="project" default="dist">    
    <target name="dist">
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   <jar destfile="sdf.jar" basedir="classes">
    <fileset dir="classes">
     <include name="**/*"/>
     </fileset>
   </jar>        
    </target>
</project>

4. Copy the sdf.jar file into the frameworks/sdf directory.

5. Add the sdf.jar to the Author class path. To do this, Open the options Document Type Dialog, select SDF
and press the Edit button.

Select the Classpath tab in the lower part of the dialog.

Press the Add button . In the displayed dialog enter the location of the jar file, relative to the <oXygen/>
frameworks directory:

Figure 7.21. Adding a classpath entry

6. Let's create now the action which will use the defined operation. Click on the Actions label.

We assume the icon files Image16.gif for the menu item and Image20.gif for the toolbar are already
available. Place these files in the frameworks/sdf directory.

Define the action properties:

ID An unique identifier for the action. Use insert_image.

Name The name of the action. Use Insert image.

Menu access key Use the i letter.

Description Enter the text Inserts an image.

Toolbar icon Enter here: ${frameworks}/sdf/Image20.gif

Menu icon Enter here: ${frameworks}/sdf/Image16.gif

Shortcut key We will use: Ctrl+Shift+i.

Now let's set up the operation.

We are adding images only if the current element is a section, book or article.

XPath expression Set the value to:
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local-name()='section' or local-name='book' 
 or local-name='article'

Invoke operation In this case, we'll use our Java operation we defined earlier. Press the Choose button,
then select simple.documentation.framework.InsertImageOperation.

Figure 7.22. Selecting the Operation

This operation has no arguments.

7. Add the action to the toolbar, using the Toolbar panel.

To test the action, you can open the sdf.xml sample, then place the caret inside a section between two para
elements for instance. Press the button associated with the action from the toolbar. In the dialog select an image URL
and press Ok. The image is inserted into the document.

Figure 7.23. Dialog Displayed by the Insert Image Operation

Example 2. Operations with Arguments. Report from Database Operation.

In this example we will create an operation that connects to a relational database and executes an SQL statement. The
result should be inserted in the edited XML document as a table. To make the operation fully configurable, it will
have arguments for the database connection string, the user name, the password and the SQL expression.

1. Create a new Java project, in your IDE.

Create the directory lib in the Java project directory and copy in it the oxygen.jar file from the {oXygen_in-
stallation_directory}/lib directory.
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2. Create the class simple.documentation.framework.QueryDatabaseOperation. This class must
implements the ro.sync.ecss.extensions.api.AuthorOperation interface.

import ro.sync.ecss.extensions.api.ArgumentDescriptor;
import ro.sync.ecss.extensions.api.ArgumentsMap;
import ro.sync.ecss.extensions.api.AuthorAccess;
import ro.sync.ecss.extensions.api.AuthorOperation;
import ro.sync.ecss.extensions.api.AuthorOperationException;

public class QueryDatabaseOperation implements AuthorOperation{

Let's define the arguments of the operation. For each of them we will use a String constant representing the
argument name:

private static final String ARG_JDBC_DRIVER ="jdbc_driver";
private static final String ARG_USER ="user";
private static final String ARG_PASSWORD ="password";
private static final String ARG_SQL ="sql";
private static final String ARG_CONNECTION ="connection";

We must describe each of the argument name and type. To do this implement the getArguments method which
will return an array of argument descriptors:

public ArgumentDescriptor[] getArguments() {
  ArgumentDescriptor args[] = new ArgumentDescriptor[] {
    new ArgumentDescriptor(
      ARG_JDBC_DRIVER,
      ArgumentDescriptor.TYPE_STRING,
      "The name of the Java class that is the JDBC driver."),
    new ArgumentDescriptor(
      ARG_CONNECTION,
      ArgumentDescriptor.TYPE_STRING,
      "The database URL connection string."),
    new ArgumentDescriptor(
      ARG_USER,
      ArgumentDescriptor.TYPE_STRING,
      "The name of the database user."),
    new ArgumentDescriptor(
      ARG_PASSWORD,
      ArgumentDescriptor.TYPE_STRING,
      "The database password."),
    new ArgumentDescriptor(
      ARG_SQL,
      ArgumentDescriptor.TYPE_STRING,
      "The SQL statement to be executed.")
  };
  return args;
 }

These names, types and descriptions will be listed in the Arguments table when the operation is configured.

When the operation is invoked, the implementation of the doOperation method extracts the arguments, forwards
them to the method that connects to the database and generates the XML fragment. The XML fragment is then
inserted at the caret position.
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public void doOperation(AuthorAccess authorAccess, ArgumentsMap map)
   throws IllegalArgumentException, AuthorOperationException {

  // Collects the arguments.
  String jdbcDriver = 
   (String)map.getArgumentValue(ARG_JDBC_DRIVER);
  String connection = 
   (String)map.getArgumentValue(ARG_CONNECTION);
  String user = 
   (String)map.getArgumentValue(ARG_USER);
  String password = 
   (String)map.getArgumentValue(ARG_PASSWORD);
  String sql = 
   (String)map.getArgumentValue(ARG_SQL);

  int caretPosition = authorAccess.getCaretOffset();
  try {
   authorAccess.insertXMLFragment(
     getFragment(jdbcDriver, connection, user, password, sql), 
     caretPosition);
  } catch (SQLException e) {
   throw new AuthorOperationException(
     "The operation failed due to the following database error: " 
     + e.getMessage(), e);
  } catch (ClassNotFoundException e) {
   throw new AuthorOperationException(
     "The JDBC database driver was not found. Tried to load ' " 
     + jdbcDriver + "'", e);
  }
 }

The getFragment method loads the JDBC driver, connects to the database and extracts the data. The result is
a table element from the http://www.oxygenxml.com/sample/documentation namespace. The
header element contains the names of the SQL columns. All the text from the XML fragment is escaped. This
means that the '<' and '&' characters are replaced with the '&lt;' and '&amp;' character entities to ensure the fragment
is well-formed.

private String getFragment(
  String jdbcDriver, 
  String connectionURL, 
  String user, 
  String password, 
  String sql) throws 
   SQLException, 
   ClassNotFoundException {  

      Properties pr = new Properties();
      pr.put("characterEncoding", "UTF8");
      pr.put("useUnicode", "TRUE");
      pr.put("user", user);
      pr.put("password", password);

      // Loads the database driver.
      Class.forName(jdbcDriver);        
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      // Opens the connection
      Connection connection = 
         DriverManager.getConnection(connectionURL, pr);
      java.sql.Statement statement = 
         connection.createStatement();
      ResultSet resultSet = 
         statement.executeQuery(sql);

      StringBuffer fragmentBuffer = new StringBuffer();
      fragmentBuffer.append(
        "<table xmlns=" + 
        "'http://www.oxygenxml.com/sample/documentation'>");

      //
      // Creates the table header.
      //
      fragmentBuffer.append("<header>");
      ResultSetMetaData metaData = resultSet.getMetaData();
      int columnCount = metaData.getColumnCount();
      for (int i = 1; i <= columnCount; i++) {
          fragmentBuffer.append("<td>");
          fragmentBuffer.append(
            xmlEscape(metaData.getColumnName(i)));
          fragmentBuffer.append("</td>");
      }
      fragmentBuffer.append("</header>");

      //
      // Creates the table content.
      //
      while (resultSet.next()) {
          fragmentBuffer.append("<tr>");
          for (int i = 1; i <= columnCount; i++) {
              fragmentBuffer.append("<td>");
              fragmentBuffer.append(
                xmlEscape(resultSet.getObject(i)));
              fragmentBuffer.append("</td>");
          }
          fragmentBuffer.append("</tr>");
      }

      fragmentBuffer.append("</table>");

      // Cleanup
      resultSet.close();
      statement.close();
      connection.close();
      return fragmentBuffer.toString();        
}

The complete source code of our operation is found in the Example Files Listings, the Java Files section.

3. Package the compiled class into a jar file.
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4. Copy the jar file and the JDBC driver files into the frameworks/sdf directory.

5. Add the jars to the Author class path. For this, Open the options Document Type Dialog, select SDF and press
the Edit button.

Select the Classpath tab in the lower part of the dialog.

6. Click on the Actions label.

The action properties are:

ID An unique identifier for the action. Use clients_report.

Name The name of the action. Use Clients Report.

Menu access key Use the letter r.

Description Enter the text Connects to the database and collects the list of clients.

Toolbar icon Enter here: ${frameworks}/sdf/TableDB20.gif

We assume the image TableDB20.gif for the toolbar action is already present in
the frameworks/sdf directory.

Menu icon Leave empty.

Shortcut key We will use: Ctrl+Shift+c.

Let's set up the operation. The action will work only if the current element is a section.

XPath expression Set the value to:

local-name()='section'

Invoke operation In this case, we'll use our Java operation we defined earlier. Press the Choose button,
then select simple.documentation.framework.QueryDatabaseOpera-
tion.

Once selected, the list of arguments is displayed.

In the figure below the first argument, jdbc_driver, represents the class name of the
MySQL JDBC driver.

The connection string has the URL syntax : jdbc://<database_host>:<data-
base_port>/<database_name>.

The SQL expression used in the example is:

SELECT userID, email FROM users

but it can be any valid SELECT expression which can be applied to the database.

7. Add the action to the toolbar, using the Toolbar panel.
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Figure 7.24. Java Operation Arguments Setup

To test the action you can open the sdf.xml sample place the caret inside a section between two para elements

for instance. Press the Create Report button from the toolbar. You can see below the toolbar with the action button
and sample table inserted by the Clients Report action.

Figure 7.25. Table Content Extracted from the Database

Configuring New File Templates
We will create a set of document templates that the content authors will use as starting points for creating new Simple
Document Framework books and articles.

Each of the Document Type Associations can point to a directory usually named templates containing the file
templates. All the files that are found here are considered templates for the respective document type. The template
name is taken from the name of the file, and the template kind is detected from the file extension.

Create the templates directory into the frameworks/SDF directory. The directory tree for our documentation
framework is now:
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oxygen
  frameworks
     sdf
       schema
       css
       templates

Now let's create in this templates directory two files, one for the book template and another for the article template.

The Book.xml file:

<?xml version="1.0" encoding="UTF-8"?>
<book xmlns="http://www.oxygenxml.com/sample/documentation" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xmlns:abs="http://www.oxygenxml.com/sample/documentation/abstracts">
    <title>Book Template Title</title>
    <section>
        <title>Section Title</title>
        <abs:def/>
        <para>This content is copyrighted:</para>
        <table>
            <header>
                <td>Company</td>
                <td>Date</td>
            </header>
            <tr>
                <td/>
                <td/>
            </tr>
        </table>
    </section>
</book>

The Article.xml file:

<?xml version="1.0" encoding="UTF-8"?>
<article 
    xmlns="http://www.oxygenxml.com/sample/documentation" 
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
    <title></title>
    <section>
        <title></title>
        <para></para>
        <para></para>
    </section>        
</article>

Open the Document Type dialog for the SDF framework and click on the Templates tab. Enter in the Templates directory
text field the value ${frameworksDir}/sdf/templates. As we already seen before, it is recommended that
all the file references made from a Document Type Association to be relative to the ${frameworksDir} directory.
Binding a Document Type Association to an absolute file (e.g: "C:\some_dir\templates") makes the association difficult
to share between users.
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Figure 7.26. Setting the templates directory

To test the templates settings, press the File/New menu item to display the New dialog. The names of the two templates
are prefixed with the name of the Document Type Association, in our case SDF. Selecting one of them should create
a new XML file with the content specified in the template file.

Figure 7.27. Templates displayed in the New Dialog.

Configuring XML Catalogs
You can add catalog files to your Document Type Association using the Catalogs tab from the Document Type dialog.

Important

<oXygen/> XML Editor collects all the catalog files listed in the installed frameworks. No matter what the
Document Type Association matches the edited file, all the catalog mappings are considered when resolving
external references.

Important

The catalog files settings are available for all editing modes, not only for the Author mode.

In the XML sample file for SDF we did not used a xsi:schemaLocation attribute, but instead we let the editor
use the schema from the association. However there are cases in which we must refer for instance the location of a
schema file from a remote web location. In such cases the catalog may be used to map the web location to a local file
system entry.

In the following section we will present an use-case for the XML catalogs, by modifying our sdf.xsd XML Schema
file from the Example Files Listings.

The sdf.xml file refers the other file abs.xsd through an import element:
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<xs:import namespace=
 "http://www.oxygenxml.com/sample/documentation/abstracts" 
 schemaLocation="abs.xsd"/>

The schemaLocation attribute references the abs.xsd file located in the same directory. What if the file was on
the web, at the http://www.oxygenxml.com/SDF/abs.xsd location for instance? In this case the attribute
value will be:

<xs:import namespace=
 "http://www.oxygenxml.com/sample/documentation/abstracts" 
 schemaLocation="http://www.oxygenxml.com/SDF/abs.xsd"/>

There is a problem with this approach. What happens if an Internet connection is not available? How will we check
our document for errors if a part of the schema is not available? The answer is to create a catalog file that will help the
parser locate the missing piece containing the mapping:

http://www.oxygenxml.com/SDF/abs.xsd -> ../local_path/abs.xsd

To do this create a new XML file called catalog.xml and save it into the {oXygen_installation_direct-
ory}/frameworks/sdf directory. The content of the file should be:

<?xml version="1.0"?>
<catalog xmlns="urn:oasis:names:tc:entity:xmlns:xml:catalog">
    <system 
      systemId="http://www.oxygenxml.com/SDF/abs.xsd" 
      uri="schema/abs.xsd"/>
</catalog>

This means that all the references to http://www.oxygenxml.com/SDF/abs.xsd must be resolved to the
abs.xsd file located in the schema directory.

Note

The references in the XML catalog files are relative to the directory that contains the catalog.

Save the catalog file and modify the sdf.xsd file by changing its import element, then add the catalog to the
Document Type association. You can do this in the Catalogs tab by pressing the New button. Enter ${frame-
works}/sdf/catalog.xml in the displayed dialog.

Figure 7.28. Adding Catalogs to the Document Type Association

To test the catalog settings, restart <oXygen/> and try to validate a new sample Simple Documentation Framework
document. There should be no errors.

Configuring Transformation Scenarios
When distributing a framework to the users, it is a good idea to have the transformation scenarios already configured.
This would help the content authors publish their work in different formats. Being contained in the Document Type
Association the scenarios can be distributed along with the actions, menus, toolbars, catalogs, etc.

203

Author Developer Guide



In the following section we will create a transformation scenario for our framework.

Create the directory xsl in the directory frameworks/sdf. The directory structure for our documentation framework
should be:

oxygen
  frameworks
     sdf
       schema
       css
       templates
       xsl

Create the sdf.xsl file in the xsl directory. The complete content of the sdf.xsl file is found in the Example
Files Listings.

Open the Options/Preferences/Document Type Associations. Open the Document Type dialog for the SDF framework
then choose the Transformation tab. Click on the New. In the Edit Scenario dialog, fill the following fields:

Name The name of the transformation scenario. Enter SDF to HTML.

XSL URL ${frameworks}/sdf/xsl/sdf.xsl

Transformer Saxon 9B.

Change to the Output tab. Change the fields:

Save as ${cfd}/${cfn}.html This means the transformation output file will have the name of
the XML file and the html extension and will be placed in the same directory.

Open in browser Enable this option.

Saved file Enable this checkbox.

Figure 7.29. Configuring a transformation scenario

Now the scenario is listed in the Transformation tab:
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Figure 7.30. The transformation tab

To test the transformation scenario we created, open the SDF XML sample from the Example Files Listings. Click on

the Apply Transformation Scenario button. The Configure Transformation Dialog is displayed. Its scenario list
contains the scenario we defined earlier SDF to HTML. Click on it then choose Transform now. The HTML file should
be saved in the same directory as the XML file and opened in the browser.

Figure 7.31. Selecting the predefined scenario

Note

The key  symbol indicates that the scenario is read-only. It has this state because the scenario was loaded from
a Document Type Association. The content authors can still change parameters and other settings if they are
duplicating the scenario and edit the duplicate. In this case the copy of the scenario is created in the user local
settings.

Configuring Extensions
You can add extensions to your Document Type Association using the Extensions tab from the Document Type dialog.
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Figure 7.32. Configure extensions for a document type

Configuring an Extensions Bundle

Starting with <oXygen/> 10.3 version a single bundle was introduced acting as a provider for all other extensions. The
individual extensions can still be set but this practice is being discouraged and the single provider should be used instead.

The extensions bundle is represented by the ro.sync.ecss.extensions.api.ExtensionsBundle class.
The provided implementation of the ExtensionsBundle is instantiated when the rules of the Document Type As-
sociation defined for the custom framework match a document opened in the editor. Therefor references to objects
which need to be persistent throughout the application running session must not be kept in the bundle because the next
detection event can result in creating another ExtensionsBundle instance.

1. Create a new Java project, in your IDE.

Create the lib directory in the Java project directory and copy in it the oxygen.jar file from the {oXygen_in-
stallation_directory}/lib directory.

2. Create the class simple.documentation.framework.SDFExtensionsBundle which must extend
the abstract class ro.sync.ecss.extensions.api.ExtensionsBundle.

public class SDFExtensionsBundle extends ExtensionsBundle {

A Document Type ID and a short description should be defined first by implementing the methods getDocu-
mentTypeID and getDescription. The Document Type ID is used to uniquely identify the current framework.
Such an ID must be provided especially if options related to the framework need to be persistently stored and re-
trieved between sessions.

 public String getDocumentTypeID() {
      return "Simple.Document.Framework.document.type";
 }

 public String getDescription() {
      return "A custom extensions bundle used for the Simple Document" + 
                    "Framework document type";
 }

In order to be notified about the activation of the custom Author extension in relation with an opened document
an ro.sync.ecss.extensions.api.AuthorExtensionStateListener should be implemented.
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The activation and deactivation events received by this listener should be used to perform custom initializations
and to register/remove listeners like ro.sync.ecss.extensions.api.AuthorListener,
ro.sync.ecss.extensions.api.AuthorMouseListener or ro.sync.ecss.exten-
sions.api.AuthorCaretListener. The custom author extension state listener should be provided by
implementing the method createAuthorExtensionStateListener.

 public AuthorExtensionStateListener createAuthorExtensionStateListener() {
      return new SDFAuthorExtensionStateListener();
 }

The AuthorExtensionStateListener is instantiated and notified about the activation of the framework
when the rules of the Document Type Association match a document opened in the Author editor page. The
listener is notified about the deactivation when another framework is activated for the same document, the user
switches to another page or the editor is closed. A complete description and implementation of an
ro.sync.ecss.extensions.api.AuthorExtensionStateListener can be found in the Imple-
menting an Author Extension State Listener.

Customizations of the content completion proposals are permitted by creating a schema manager filter extension.
The interface that declares the methods used for content completion proposals filtering is ro.sync.content-
completion.xml.SchemaManagerFilter. The filter can be applied on elements, attributes or on their
values. Responsible for creating the content completion filter is the method createSchemaManagerFilter.
A new SchemaManagerFilter will be created each time a document matches the rules defined by the Document
Type Association which contains the filter declaration.

 public SchemaManagerFilter createSchemaManagerFilter() {
      return new SDFSchemaManagerFilter();
 }

A detailed presentation of the schema manager filter can be found in Configuring a Content completion handler
section.

The <oXygen/> Author supports link based navigation between documents and document sections. Therefor, if
the document contains elements defined as links to other elements, for example links based on the id attributes,
the extension should provide the means to find the referred content. To do this an implementation of the
ro.sync.ecss.extensions.api.link.ElementLocatorProvider interface should be returned
by the createElementLocatorProvider method. Each time an element pointed by a link needs to be
located the method is invoked.

 public ElementLocatorProvider createElementLocatorProvider() {
      return new DefaultElementLocatorProvider();
 }

The section that explains how to implement an element locator provider is Configuring a Link target element
finder.

The drag and drop functionality can be extended by implementing the ro.sync.exml.editor.xmledit-
or.pageauthor.AuthorDnDListener interface. Relevant methods from the listener are invoked when
the mouse is dragged, moved over, or exits the author editor page, when the drop action changes, and when the
drop occurs. Each method receives the DropTargetEvent containing information about the drag and drop
operation. The drag and drop extensions are available on Author page for both <oXygen/> Eclipse plugin and
standalone application. The Text page corresponding listener is available only for <oXygen/> Eclipse plugin. The
methods corresponding to each implementation are: createAuthorAWTDndListener, createTextSWTDnd-
Listener and createAuthorSWTDndListener.
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 public AuthorDnDListener createAuthorAWTDndListener() {
      return new SDFAuthorDndListener();
 }

For more details about the Author drag and drop listeners see the Configuring a custom Drag and Drop listener
section.

Another extension which can be included in the bundle is the reference resolver. In our case the references re
represented by the ref element and the attribute indicating the referred resource is location. To be able to obtain
the content of the referred resources we will have to implement a Java extension class which implements the
ro.sync.ecss.extensions.api.AuthorReferenceResolver. The method responsible for creating
the custom references resolver is createAuthorReferenceResolver. The method is called each time a
document opened in an Author editor page matches the Document Type Association where the extensions bundle
is defined. The instantiated references resolver object is kept and used until another extensions bundle corresponding
to another Document Type is activated as result of the detection process.

 public AuthorReferenceResolver createAuthorReferenceResolver() {
      return new ReferencesResolver();
 }

A more detailed description of the references resolver can be found in the Configuring a References Resolver
section.

To be able to dynamically customize the default CSS styles for a certain AuthorNode an implementation of
the ro.sync.ecss.extensions.api.StylesFilter can be provided. The extensions bundle method
responsible for creating the StylesFilter is createAuthorStylesFilter. The method is called each
time a document opened in an Author editor page matches the document type association where the extensions
bundle is defined. The instantiated filter object is kept and used until another extensions bundle corresponding to
another Document Type is activated as result of the detection process.

 public StylesFilter createAuthorStylesFilter() {
      return new SDFStylesFilter();
 }

See the Configuring CSS styles filter section for more details about the styles filter extension.

In order to edit data in custom tabular format implementations of the ro.sync.ecss.extensions.api.Au-
thorTableCellSpanProvider and the ro.sync.ecss.extensions.api.AuthorTableColum-
nWidthProvider interfaces should be provided. The two methods from the ExtensionsBundle specifying
these two extension points are createAuthorTableCellSpanProvider and createAuthorTable-
ColumnWidthProvider.

 public AuthorTableCellSpanProvider createAuthorTableCellSpanProvider() {
      return new TableCellSpanProvider();
 }

 public AuthorTableColumnWidthProvider 
          createAuthorTableColumnWidthProvider() {
      return new TableColumnWidthProvider();
 }

The two table information providers are not reused for different tables. The methods are called for each table in
the document so new instances should be provided every time. Read more about the cell span and column width
information providers in Configuring a Table Cell Span Provider and Configuring a Table Column Width Provider
sections.
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If the functionality related to one of the previous extension point does not need to be modified then the developed
ExtensionsBundle should not override the corresponding method and leave the default base implementation
to return null.

3. Package the compiled class into a jar file.

4. Copy the jar file into the frameworks/sdf directory.

5. Add the jar file to the Author class path.

6. Register the Java class by clicking on the Extensions tab. Press the Choose button and select from the displayed
dialog the name of the class: SDFExtensionsBundle.

The complete source code of the SDFExtensionsBundle implementation is found in the Example Files Listings,
the Java Files section.

Implementing an Author Extension State Listener

The ro.sync.ecss.extensions.api.AuthorExtensionStateListener implementation is notified
when the Author extension where the listener is defined is activated or deactivated in the Document Type detection
process.

import ro.sync.ecss.extensions.api.AuthorAccess;
import ro.sync.ecss.extensions.api.AuthorExtensionStateListener;

public class SDFAuthorExtensionStateListener implements
  AuthorExtensionStateListener {
  private AuthorListener sdfAuthorDocumentListener;
  private AuthorMouseListener sdfMouseListener;
  private AuthorCaretListener sdfCaretListener;
  private OptionListener sdfOptionListener;

The activation event received by this listener when the rules of the Document Type Association match a document
opened in the Author editor page, should be used to perform custom initializations and to register listeners like
ro.sync.ecss.extensions.api.AuthorListener, ro.sync.ecss.extensions.api.Au-
thorMouseListener or ro.sync.ecss.extensions.api.AuthorCaretListener.

 public void activated(AuthorAccess authorAccess) {
   // Get the value of the option.
   String option = authorAccess.getOptionsStorage().getOption(
               "sdf.custom.option.key", "");
   // Use the option for some initializations...

   // Add an option listener.
   authorAccess.getOptionsStorage().addOptionListener(sdfOptionListener);

   // Add author document listeners.
   sdfAuthorDocumentListener = new SDFAuthorListener();
   authorAccess.getDocumentController().addAuthorListener(
               sdfAuthorDocumentListener);

   // Add mouse listener.
   sdfMouseListener = new SDFAuthorMouseListener();
   authorAccess.getEditorAccess().addAuthorMouseListener(sdfMouseListener);
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   // Add caret listener.
   sdfCaretListener = new SDFAuthorCaretListener();
   authorAccess.getEditorAccess().addAuthorCaretListener(sdfCaretListener);

   // Other custom initializations...

 }

The authorAccess parameter received by the activated method can be used to gain access to Author specific
actions and informations related to components like the editor, document, workspace, tables, change tracking a.s.o.

If options specific to the custom developed Author extension need to be stored or retrieved, a reference to the Op-
tionsStorage can be obtained by calling the getOptionsStorage method from the author access. The same
object can be used to register OptionListener listeners. An option listener is registered in relation with an option
key and will be notified about the value changes of that option.

An AuthorListener can be used if events related to the Author document modifications are of interest. The
listener can be added to the AuthorDocumentController. A reference to the document controller is returned
by the getDocumentController method from the author access. The document controller can also be used to
perform operations involving document modifications.

To provide access to Author editor component related functionality and informations, the author access has a reference
to the AuthorEditorAccess that can be obtained when calling the getEditorAccess method. At this level
AuthorMouseListener and AuthorCaretListener can be added which will be notified about mouse and
caret events occurring in the Author editor page.

The deactivation event is received when another framework is activated for the same document, the user switches to
another editor page or the editor is closed. The deactivate method is typically used to unregister the listeners pre-
viously added on the activate method and to perform other actions. For example options related to the deactivated
author extension can be saved at this point.

 public void deactivated(AuthorAccess authorAccess) {
   // Store the option.
   authorAccess.getOptionsStorage().setOption(
               "sdf.custom.option.key", optionValue);

   // Remove the option listener.
   authorAccess.getOptionsStorage().removeOptionListener(sdfOptionListener);

   // Remove document listeners.
   authorAccess.getDocumentController().removeAuthorListener(
               sdfAuthorDocumentListener);

   // Remove mouse listener.
   authorAccess.getEditorAccess().removeAuthorMouseListener(sdfMouseListener);

   // Remove caret listener.
   authorAccess.getEditorAccess().removeAuthorCaretListener(sdfCaretListener);

   // Other actions...

 }
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Configuring a Content completion handler

You can filter or contribute to items offered for content completion by implementing the ro.sync.contentcom-
pletion.xml.SchemaManagerFilter interface.

import java.util.List;

import ro.sync.contentcompletion.xml.CIAttribute;
import ro.sync.contentcompletion.xml.CIElement;
import ro.sync.contentcompletion.xml.CIValue;
import ro.sync.contentcompletion.xml.Context;
import ro.sync.contentcompletion.xml.SchemaManagerFilter;
import ro.sync.contentcompletion.xml.WhatAttributesCanGoHereContext;
import ro.sync.contentcompletion.xml.WhatElementsCanGoHereContext;
import ro.sync.contentcompletion.xml.WhatPossibleValuesHasAttributeContext;

public class SDFSchemaManagerFilter implements SchemaManagerFilter {

You can implement the various callbacks of the interface either by returning the default values given by <oXygen/>
or by contributing to the list of proposals. The filter can be applied on elements, attributes or on their values. Attributes
filtering can be implemented using the filterAttributes method and changing the default content completion
list of ro.sync.contentcompletion.xml.CIAttribute for the element provided by the current
ro.sync.contentcompletion.xml.WhatAttributesCanGoHereContext context. For example, the
SDFSchemaManagerFilter checks if the element from the current context is the table element and add the
frame attribute to the table list of attributes.

 public List<CIAttribute> filterAttributes(List<CIAttribute> attributes,
       WhatAttributesCanGoHereContext context) {
   // If the element from the current context is the 'table' element add the 
   // attribute named 'frame' to the list of default content 
      // completion proposals
   ContextElement contextElement = context.getParentElement();
   if ("table".equals(contextElement.getQName())) {
     CIAttribute frameAttribute = new CIAttribute();
     frameAttribute.setName("frame");
     frameAttribute.setRequired(false);
     frameAttribute.setFixed(false);
     frameAttribute.setDefaultValue("void");
     attributes.add(frameAttribute);
   }
   return attributes;
 }

The elements that can be inserted in a specific context can be filtered using the filterElements method. The
SDFSchemaManagerFilter uses this method to replace the td child element with the th element when header
is the current context element.

public List<CIElement> filterElements(List<CIElement> elements,
   WhatElementsCanGoHereContext context) {
   // If the element from the current context is the 'header' element remove
   // the 'td' element from the list of content completion proposals and add 
   // the 'th' element.
   ContextElement contextElement = context.getElementStack().peek();
   if ("header".equals(contextElement.getQName())) {
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     for (Iterator<CIElement> iterator = elements.iterator(); 
               iterator.hasNext();) {
       CIElement element = iterator.next(); 
        // Remove the 'td' element
       if ("td".equals(element.getQName())) {
            elements.remove(element);
            break;
          }
        }
     // Insert the 'th' element in the list of content completion proposals
     CIElement thElement = new SDFElement();
     thElement.setName("th");
     elements.add(thElement);
   }
  return elements;
 }

The elements or attributes values can be filtered using the filterElementValues or filterAttributeValues
methods.

The complete source code of the SDFSchemaManagerFilter implementation is found in the Example Files
Listings, the Java Files section.

Configuring a Link target element finder

The link target reference finder represents the support for finding references from links which indicate specific elements
inside an XML document. This support will only be available if a schema is associated with the document type.

If you do not define a custom link target reference finder, the DefaultElementLocatorProvider implement-
ation will be used by default. The interface which should be implemented for a custom link target reference finder is
ro.sync.ecss.extensions.api.link.ElementLocatorProvider. As an alternative, the
ro.sync.ecss.extensions.commons.DefaultElementLocatorProvider implementation can also
be extended.

The used ElementLocatorProvider will be queried for an ElementLocator when a link location must be
determined (when user clicks on a link). Then, to find the corresponding (linked) element, the obtained ElementLoc-
ator will be queried for each element from the document.

The DefaultElementLocatorProvider implementation

The DefaultElementLocatorProvider implementation offers support for the most common types of links:

• links based on ID attribute values

• XPointer element() scheme

The method getElementLocator determines what ElementLocator should be used. In the default implement-
ation it checks if the link is an XPointer element() scheme otherwise it assumes it is an ID. A non-null IDTypeVeri-
fier will always be provided if a schema is associated with the document type.

The link string argument is the "anchor" part of the of the URL which is composed from the value of the link property
specified for the link element in the CSS.

public ElementLocator getElementLocator(IDTypeVerifier idVerifier, 
               String link) {
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  ElementLocator elementLocator = null;
  try {
    if(link.startsWith("element(")){
      // xpointer element() scheme
      elementLocator = new XPointerElementLocator(idVerifier, link);
    } else {
      // Locate link element by ID
      elementLocator = new IDElementLocator(idVerifier, link);
    }
  } catch (ElementLocatorException e) {
    logger.warn("Exception when create element locator for link: " 
        + link + ". Cause: " + e, e);
  }
  return elementLocator;
}

The XPointerElementLocator implementation

The XPointerElementLocator is an implementation of the abstract class ro.sync.ecss.exten-
sions.api.link.ElementLocator for links that have one of the following XPointer element() scheme patterns:

element(elementID) locate the element with the specified id

element(/1/2/3) A child sequence appearing alone identifies an element by means of stepwise nav-
igation, which is directed by a sequence of integers separated by slashes (/); each
integer n locates the nth child element of the previously located element.

element(elementID/3/4) A child sequence appearing after a NCName identifies an element by means of
stepwise navigation, starting from the element located by the given name.

The constructor separates the id/integers which are delimited by slashes(/) into a sequence of identifiers (an XPointer
path). It will also check that the link has one of the supported patterns of the XPointer element() scheme.

public XPointerElementLocator(IDTypeVerifier idVerifier, String link)
                      throws ElementLocatorException {
  super(link);
  this.idVerifier = idVerifier;

  link = link.substring("element(".length(), link.length() - 1);

  StringTokenizer stringTokenizer = new StringTokenizer(link, "/", false);
  xpointerPath = new String[stringTokenizer.countTokens()];
  int i = 0;
  while (stringTokenizer.hasMoreTokens()) {
    xpointerPath[i] = stringTokenizer.nextToken();
    boolean invalidFormat = false;

    // Empty xpointer component is not supported
    if(xpointerPath[i].length() == 0){
      invalidFormat = true;
    }

    if(i > 0){
      try {
        Integer.parseInt(xpointerPath[i]);
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      } catch (NumberFormatException e) {
        invalidFormat = true;
      }
    }

    if(invalidFormat){
      throw new ElementLocatorException(
        "Only the element() scheme is supported when locating XPointer links."
        + "Supported formats: element(elementID), element(/1/2/3), 
              element(elemID/2/3/4).");
    }
    i++;
  }

  if(Character.isDigit(xpointerPath[0].charAt(0))){
    // This is the case when xpointer have the following pattern /1/5/7
    xpointerPathDepth = xpointerPath.length;
  } else {
    // This is the case when xpointer starts with an element ID
    xpointerPathDepth = -1;
    startWithElementID  = true;
  }
}

The method startElement will be invoked at the beginning of every element in the XML document(even when
the element is empty). The arguments it takes are

uri the namespace URI, or the empty string if the element has no namespace URI
or if namespace processing is disabled

localName the local name of the element

qName the qualified name of the element

atts the attributes attached to the element. If there are no attributes, it will be empty.

The method returns true if the processed element is found to be the one indicated by the link.

The XPointerElementLocator implementation of the startElement will update the depth of the current
element and keep the index of the element in its parent. If the xpointerPath starts with an element ID then the
current element ID is verified to match the specified ID. If this is the case the depth of the XPointer is updated taking
account of the depth of the current element.

If the XPointer path depth is the same as the current element depth then the kept indices of the current element path
are compared to the indices in the XPointer path. If all of them match then the element has been found.

public boolean startElement(String uri, String localName, 
        String name, Attr[] atts) {
  boolean linkLocated = false;
  // Increase current element document depth
  startElementDepth ++;

  if (endElementDepth != startElementDepth) {
    // The current element is the first child of the parent
    currentElementIndexStack.push(new Integer(1));
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  } else {
    // Another element in the parent element
    currentElementIndexStack.push(new Integer(lastIndexInParent + 1));
  }

  if (startWithElementID) {
    // This the case when xpointer path starts with an element ID.
    String xpointerElement = xpointerPath[0];
    for (int i = 0; i < atts.length; i++) {
      if(xpointerElement.equals(atts[i].getValue())){
        if(idVerifier.hasIDType(
            localName, uri, atts[i].getQName(), atts[i].getNamespace())){
          xpointerPathDepth = startElementDepth + xpointerPath.length - 1;
          break;
        }
      }
    }
  }

  if (xpointerPathDepth == startElementDepth){
    // check if xpointer path matches with the current element path
    linkLocated = true;
    try {        
      int xpointerIdx = xpointerPath.length - 1;
      int stackIdx = currentElementIndexStack.size() - 1;
      int stopIdx = startWithElementID ? 1 : 0;
      while (xpointerIdx >= stopIdx && stackIdx >= 0) {
        int xpointerIndex = Integer.parseInt(xpointerPath[xpointerIdx]);
        int currentElementIndex = 
          ((Integer)currentElementIndexStack.get(stackIdx)).intValue();
        if(xpointerIndex != currentElementIndex) {
          linkLocated = false;
          break;
        }

        xpointerIdx--;
        stackIdx--;
      }

    } catch (NumberFormatException e) {
      logger.warn(e,e);
    }
  }
  return linkLocated;
}

The method endElement will be invoked at the end of every element in the XML document (even when the element
is empty).

The XPointerElementLocator implementation of the endElement updates the depth of the current element
path and the index of the element in its parent.

public void endElement(String uri, String localName, String name) {
  endElementDepth = startElementDepth;
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  startElementDepth --;
  lastIndexInParent = ((Integer)currentElementIndexStack.pop()).intValue();
}

The IDElementLocator implementation

The IDElementLocator is an implementation of the abstract class ro.sync.ecss.exten-
sions.api.link.ElementLocator for links that use an id.

The constructor only assigns field values and the method endElement is empty for this implementation.

The method startElement checks each of the element's attribute values and when one matches the link, it considers
the element found if one of the following conditions is satisfied:

• the qualified name of the attribute is xml:id

• the attribute is of type ID

The type of the attribute is checked with the help of the method IDTypeVerifier.hasIDType.

public boolean startElement(String uri, String localName, 
        String name, Attr[] atts) {
  boolean elementFound = false;
  for (int i = 0; i < atts.length; i++) {
    if (link.equals(atts[i].getValue())) {
      if("xml:id".equals(atts[i].getQName())) {
        // xml:id attribute
        elementFound = true;          
      } else {
        // check if attribute has ID type
        String attrLocalName = 
          ExtensionUtil.getLocalName(atts[i].getQName());
        String attrUri = atts[i].getNamespace();
        if (idVerifier.hasIDType(localName, uri, attrLocalName, attrUri)) {
          elementFound = true;
        }
      }
    }
  }

  return elementFound;
}

Creating a customized link target reference finder

If you need to create a custom link target reference finder you can do so by following these steps.

Create the class which will implement the ro.sync.ecss.extensions.api.link.ElementLocatorPro-
vider interface. As an alternative, your class could extend ro.sync.ecss.extensions.commons.De-
faultElementLocatorProvider, the default implementation.

As a start point you can use the source code of the DefaultElementLocatorProvider implementation which
is found in the Example Files Listings, the Java Files section. There you will also find the implementations for
XPointerElementLocator  and IDElementLocator .
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Configuring a custom Drag and Drop listener

You can add your own drag and drop listener implementation of ro.sync.ecss.extensions.api.DnDHandler.
You can choose from three interfaces to implement depending on whether you are using the framework with the
<oXygen/> Eclipse plugin or the standalone version or if you want to add the handler for the Text or Author pages.

Table 7.2. Interfaces for the DnD listener

DescriptionInterface

Receives callbacks from the <oXygen/> standalone application
for Drag And Drop in Author

ro.sync.exml.editor.xmleditor.pageau-
thor.AuthorCustomDnDHandler

Receives callbacks from the <oXygen/> Eclipse plugin for
Drag And Drop in Author

com.oxygenxml.editor.editors.au-
thor.AuthorDnDListener

Receives callbacks from the <oXygen/> Eclipse plugin for
Drag And Drop in Text

com.oxygenxml.editor.editors.TextDnD-
Listener

Configuring a References Resolver

We need to provide a handler for resolving references and obtain the content they refer. In our case the element which
has references is ref and the attribute indicating the referred resource is location. We will have to implement a Java
extension class for obtaining the referred resources.

Create the class simple.documentation.framework.ReferencesResolver. This class must implement
the ro.sync.ecss.extensions.api.AuthorReferenceResolver interface.

import ro.sync.ecss.extensions.api.AuthorReferenceResolver;
import ro.sync.ecss.extensions.api.AuthorAccess;
import ro.sync.ecss.extensions.api.node.AttrValue;
import ro.sync.ecss.extensions.api.node.AuthorElement;
import ro.sync.ecss.extensions.api.node.AuthorNode;

public class ReferencesResolver 
      implements AuthorReferenceResolver {

The method hasReferences verifies if the handler considers the node to have references. It takes as argument an
AuthorNode that represents the node which will be verified. The method will return true if the node is considered
to have references. In our case, to be a reference the node must be an element with the name ref and it must have an
attribute named location.

public boolean hasReferences(AuthorNode node) {
  boolean hasReferences = false;
  if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
    AuthorElement element = (AuthorElement) node;
    if ("ref".equals(element.getLocalName())) {
      AttrValue attrValue = element.getAttribute("location");
      hasReferences = attrValue != null;
    }
  }
  return hasReferences;
}

The method getDisplayName returns the display name of the node that contains the expanded referred content. It
takes as argument an AuthorNode that represents the node for which the display name is needed. The referred content
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engine will ask this AuthorReferenceResolver implementation what is the display name for each node which
is considered a reference. In our case the display name is the value of the location attribute from the ref element.

public String getDisplayName(AuthorNode node) {
  String displayName = "ref-fragment";
  if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
    AuthorElement element = (AuthorElement) node;
    if ("ref".equals(element.getLocalName())) {
      AttrValue attrValue = element.getAttribute("location");
      if (attrValue != null) {
        displayName = attrValue.getValue();
      }
    }
  }
  return displayName;
}

The method resolveReference resolves the reference of the node and returns a SAXSource with the parser and
the parser's input source. It takes as arguments an AuthorNode that represents the node for which the reference needs
resolving, the systemID of the node, the AuthorAccess with access methods to the Author data model and a SAX
EntityResolver which resolves resources that are already opened in another editor or resolve resources through
the XML catalog. In our implementation we need to resolve the reference relative to the systemID, and create a
parser and an input source over the resolved reference.

public SAXSource resolveReference(
    AuthorNode node, 
    String systemID, 
    AuthorAccess authorAccess,
    EntityResolver  entityResolver) {
  SAXSource saxSource = null;

  if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
    AuthorElement element = (AuthorElement) node;
    if ("ref".equals(element.getLocalName())) {
      AttrValue attrValue = element.getAttribute("location");
      if (attrValue != null) {
        String attrStringVal = attrValue.getValue();
        try {
          URL absoluteUrl = new URL(new URL(systemID), 
              authorAccess.correctURL(attrStringVal));

          InputSource inputSource = entityResolver.resolveEntity(null, 
              absoluteUrl.toString());
          if(inputSource == null) {
            inputSource = new InputSource(absoluteUrl.toString());
          }

          XMLReader xmlReader = authorAccess.newNonValidatingXMLReader();
          xmlReader.setEntityResolver(entityResolver);

          saxSource = new SAXSource(xmlReader, inputSource);
        } catch (MalformedURLException e) {
          logger.error(e, e);
        } catch (SAXException e) {
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          logger.error(e, e);
        } catch (IOException e) {
          logger.error(e, e);
        }
      }
    }
  }

  return saxSource;
}

The method getReferenceUniqueIDshould return an unique identifier for the node reference. The unique identi-
fier is used to avoid resolving the references recursively. It takes as argument an AuthorNode that represents the
node with the reference. In our implementation the unique identifier is the value of the location attribute from the ref
element.

public String getDisplayName(AuthorNode node) {
  String displayName = "ref-fragment";
  if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
    AuthorElement element = (AuthorElement) node;
    if ("ref".equals(element.getLocalName())) {
      AttrValue attrValue = element.getAttribute("location");
      if (attrValue != null) {
        displayName = attrValue.getValue();
      }
    }
  }
  return displayName;
}

The method getReferenceSystemIDshould return the systemID of the referred content. It takes as arguments
an AuthorNode that represents the node with the reference and the AuthorAccess with access methods to the
Author data model. In our implementation we use the value of the location attribute from the ref element and resolve
it relatively to the XML base URL of the node.

public String getReferenceSystemID(AuthorNode node, 
                                   AuthorAccess authorAccess) {
  String systemID = null;
  if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
    AuthorElement element = (AuthorElement) node;
    if ("ref".equals(element.getLocalName())) {
      AttrValue attrValue = element.getAttribute("location");
      if (attrValue != null) {
        String attrStringVal = attrValue.getValue();
        try {
          URL absoluteUrl = new URL(node.getXMLBaseURL(), 
              authorAccess.correctURL(attrStringVal));
          systemID = absoluteUrl.toString();
        } catch (MalformedURLException e) {
          logger.error(e, e);
        }
      }
    }
  }
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  return systemID;
}

The complete source code of our implementation is found in the Example Files Listings, the Java Files section.

In the listing below, the XML document contains the ref element:

<ref location="referred.xml">Reference</ref>

When no reference resolver is specified, the reference has the following layout:

Figure 7.33. Reference with no specified reference resolver

When the above implementation is configured, the reference has the expected layout:

Figure 7.34. Reference with reference resolver

Configuring CSS Styles Filter

You can modify the CSS styles for each ro.sync.ecss.extensions.api.node.AuthorNode rendered in
the Author page using an implementation of  ro.sync.ecss.extensions.api.StylesFilter You can
implement the various callbacks of the interface either by returning the default value given by <oXygen/> or by con-
tributing to the value. The received styles ro.sync.ecss.css.Styles can be processed and values can be
overwritten with your own. For example you can override the KEY_BACKGROUND_COLOR style to return your own
implementation of ro.sync.exml.view.graphics.Color or override the KEY_FONT style to return your
own implementation of ro.sync.exml.view.graphics.Font.

For instance in our simple document example the filter can change the value of the KEY_FONT property for the table
element:

package simple.documentation.framework;

import ro.sync.ecss.css.Styles;
import ro.sync.ecss.extensions.api.StylesFilter;
import ro.sync.ecss.extensions.api.node.AuthorNode;
import ro.sync.exml.view.graphics.Font;

public class SDFStylesFilter implements StylesFilter {

     public Styles filter(Styles styles, AuthorNode authorNode) {
         if (AuthorNode.NODE_TYPE_ELEMENT == authorNode.getType() 
           && "table".equals(authorNode.getName())) {
           styles.setProperty(Styles.KEY_FONT, new Font(null, Font.BOLD, 12));
         }
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         return styles;
     }
}

Configuring a Table Column Width Provider

In our documentation framework the table element and the table columns can have specified widths. In order for
these widths to be considered by <oXygen/> Author we need to provide the means to determine them. As explained
in the Styling the Table Element section which describes the CSS properties needed for defining a table, if we use the
table element attribute width <oXygen/> can determine the table width automatically. In our example the table has
col elements with width attributes that are not recognized by default. We will need to implement a Java extension
class for determining the column widths.

Create the class simple.documentation.framework.TableColumnWidthProvider. This class must
implement the ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider interface.

import ro.sync.ecss.extensions.api.AuthorAccess;
import ro.sync.ecss.extensions.api.AuthorOperationException;
import ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider;
import ro.sync.ecss.extensions.api.WidthRepresentation;
import ro.sync.ecss.extensions.api.node.AuthorElement;

public class TableColumnWidthProvider 
      implements AuthorTableColumnWidthProvider {

The method init is taking as argument the AuthorElement that represents the XML table element. In our case
the column widths are specified in col elements from the table element. In such cases you must collect the span
information by analyzing the table element.

 public void init(AuthorElement tableElement) {
  this.tableElement = tableElement;
  AuthorElement[] colChildren = tableElement.getElementsByLocalName("customcol");
  if (colChildren != null && colChildren.length > 0) {
   for (int i = 0; i < colChildren.length; i++) {
    AuthorElement colChild = colChildren[i];
    if (i == 0) {
     colsStartOffset = colChild.getStartOffset();
    } 
    if (i == colChildren.length - 1) {
     colsEndOffset = colChild.getEndOffset();
    }
    // Determine the 'width' for this col.
    AttrValue colWidthAttribute = colChild.getAttribute("width");
    String colWidth = null;
    if (colWidthAttribute != null) {
     colWidth = colWidthAttribute.getValue();
     // Add WidthRepresentation objects for the columns this 'customcol' specification
     // spans over.
     colWidthSpecs.add(new WidthRepresentation(colWidth, true));
    }
   }
  }
 }
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The method isTableAcceptingWidth should check if the table cells are td.

public boolean isTableAcceptingWidth(String tableCellsTagName) {
  return "td".equals(tableCellsTagName);
}

The method isTableAndColumnsResizable should check if the table cells are td. This method determines if
the table and columns can be resized by dragging with the mouse the edge of a column.

public boolean isTableAndColumnsResizable(String tableCellsTagName) {
  return "td".equals(tableCellsTagName);
}

The methods getTableWidth and getCellWidth are used for determining the table width and the column width.
The table layout engine will ask this AuthorTableColumnWidthProvider implementation what is the table
width for each table element and the cell width for each cell element from the table that was marked as cell in the CSS
using the property display:table-cell. The implementation is simple and just parses the value of the width
attribute. The methods must return null for the tables/cells that do not have a specified width.

 public WidthRepresentation getTableWidth(String tableCellsTagName) {
  WidthRepresentation toReturn = null;
  if (tableElement != null && "td".equals(tableCellsTagName)) {
   AttrValue widthAttr = tableElement.getAttribute("width");
   if (widthAttr != null) {
    String width = widthAttr.getValue();
    if (width != null) {
     toReturn = new WidthRepresentation(width, true);
    }
   }
  }
  return toReturn;
 }

 public List<WidthRepresentation> getCellWidth(AuthorElement cellElement, int colNumberStart,
   int colSpan) {
  List<WidthRepresentation> toReturn = null;
  int size = colWidthSpecs.size();
  if (size >= colNumberStart && size >= colNumberStart + colSpan) {
   toReturn = new ArrayList<WidthRepresentation>(colSpan);
   for (int i = colNumberStart; i < colNumberStart + colSpan; i ++) {
    // Add the column widths
    toReturn.add(colWidthSpecs.get(i));
   }
  }
  return toReturn;
 }

The methods commitTableWidthModification and commitColumnWidthModifications are used for
committing changes made to the width of the table or its columns when using the mouse drag gestures.

 public void commitTableWidthModification(AuthorDocumentController authorDocumentController,
   int newTableWidth, String tableCellsTagName) throws AuthorOperationException {
  if ("td".equals(tableCellsTagName)) {
   if (newTableWidth > 0) {
    if (tableElement != null) {
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     String newWidth = String.valueOf(newTableWidth);

     authorDocumentController.setAttribute(
       "width",
       new AttrValue(newWidth),
       tableElement);
    } else {
     throw new AuthorOperationException("Cannot find the element representing the table.");
    }
   }
  }
 }

public void commitColumnWidthModifications(AuthorDocumentController authorDocumentController,
   WidthRepresentation[] colWidths, String tableCellsTagName) throws AuthorOperationException {
  if ("td".equals(tableCellsTagName)) {
   if (colWidths != null && tableElement != null) {
    if (colsStartOffset >= 0 && colsEndOffset >= 0 && colsStartOffset < colsEndOffset) {
     authorDocumentController.delete(colsStartOffset,
       colsEndOffset);
    }
    String xmlFragment = createXMLFragment(colWidths);
    int offset = -1;
    AuthorElement[] header = tableElement.getElementsByLocalName("header");
    if (header != null && header.length > 0) {
     // Insert the cols elements before the 'header' element 
     offset = header[0].getStartOffset();
    }
    if (offset == -1) {
     throw new AuthorOperationException("No valid offset to insert the columns width specification.");
    }
    authorDocumentController.insertXMLFragment(xmlFragment, offset);
   }
  }
 }

 private String createXMLFragment(WidthRepresentation[] widthRepresentations) {
  StringBuffer fragment = new StringBuffer();
  String ns = tableElement.getNamespace();
  for (int i = 0; i < widthRepresentations.length; i++) {
   WidthRepresentation width = widthRepresentations[i];
   fragment.append("<customcol");
   String strRepresentation = width.getWidthRepresentation();
   if (strRepresentation != null) {
    fragment.append(" width=\"" + width.getWidthRepresentation() + "\"");
   }
   if (ns != null && ns.length() > 0) {
    fragment.append(" xmlns=\"" + ns + "\"");
   }
   fragment.append("/>");
  }
  return fragment.toString();
 }
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The following three methods are used to determine what type of column width specifications the table column width
provider support. In our case all types of specifications are allowed:

 public boolean isAcceptingFixedColumnWidths(String tableCellsTagName) {
  return true;
 }

 public boolean isAcceptingPercentageColumnWidths(String tableCellsTagName) {
  return true;
 }

 public boolean isAcceptingProportionalColumnWidths(String tableCellsTagName) {
  return true;
 }

The complete source code of our implementation is found in the Example Files Listings, the Java Files section.

In the listing below, the XML document contains the table element:

<table width="300">
    <customcol width="50.0px"/>
    <customcol width="1*"/>
    <customcol width="2*"/>
    <customcol width="20%"/>
    <header>
        <td>C1</td>
        <td>C2</td>
        <td>C3</td>
        <td>C4</td>
    </header>
    <tr>
        <td>cs=1, rs=1</td>
        <td>cs=1, rs=1</td>
        <td row_span="2">cs=1, rs=2</td>
        <td row_span="3">cs=1, rs=3</td>
    </tr>
    <tr>
        <td>cs=1, rs=1</td>
        <td>cs=1, rs=1</td>
    </tr>
    <tr>
        <td column_span="3">cs=3, rs=1</td>
    </tr>
</table>

When no table column width provider is specified, the table has the following layout:
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Figure 7.35. Table layout when no column width provider is specified

When the above implementation is configured, the table has the correct layout:

Figure 7.36. Columns with custom widths

Configuring a Table Cell Span Provider

In our documentation framework the table element can have cells that span over multiple columns and rows. As
explained in the Styling the Table Element section which describes the CSS properties needed for defining a table, we
need to indicate <oXygen/> Author a method to determine the cell spanning. If we use the cell element attributes
rowspan and colspan or rows and cols, <oXygen/> can determine the cell spanning automatically. In our example
the td element uses the attributes row_span and column_span that are not recognized by default. We will need to
implement a Java extension class for defining the cell spanning.

Create the class simple.documentation.framework.TableCellSpanProvider. This class must implement
the ro.sync.ecss.extensions.api.AuthorTableCellSpanProvider interface.

import ro.sync.ecss.extensions.api.AuthorTableCellSpanProvider;
import ro.sync.ecss.extensions.api.node.AttrValue;
import ro.sync.ecss.extensions.api.node.AuthorElement;

public class TableCellSpanProvider 
      implements AuthorTableCellSpanProvider {
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The method init is taking as argument the AuthorElement that represents the XML table element. In our case
the cell span is specified for each of the cells so we leave this method empty. However there are cases like the table
CALS model when the cell spanning is specified in the table element. In such cases you must collect the span in-
formation by analyzing the table element.

public void init(AuthorElement table) {
}

The method getColSpan is taking as argument the table cell. The table layout engine will ask this AuthorTa-
bleSpanSupport implementation what is the column span and the row span for each XML element from the table
that was marked as cell in the CSS using the property display:table-cell. The implementation is simple and
just parses the value of column_span attribute. The method must return null for all the cells that do not change the
span specification.

public Integer getColSpan(AuthorElement cell) {
  Integer colSpan = null;

  AttrValue attrValue = cell.getAttribute("column_span");
  if(attrValue != null) {
    // The attribute was found.
    String cs = attrValue.getValue();
    if(cs != null) {        
      try {
        colSpan = new Integer(cs);
      } catch (NumberFormatException ex) {
        // The attribute value was not a number.
      }     
    }   
  }
  return colSpan;
}

The row span is determined in a similar manner:

public Integer getRowSpan(AuthorElement cell) {
  Integer rowSpan = null;

  AttrValue attrValue = cell.getAttribute("row_span");
  if(attrValue != null) {
    // The attribute was found.
    String rs = attrValue.getValue();
    if(rs != null) {        
      try {
        rowSpan = new Integer(rs);
      } catch (NumberFormatException ex) {
        // The attribute value was not a number.
      }     
    }   
  }
  return rowSpan;
}

The method hasColumnSpecifications always returns true considering column specifications always available.
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public boolean hasColumnSpecifications(AuthorElement tableElement) {
  return true;
}

The complete source code of our implementation is found in the Example Files Listings, the Java Files section.

In the listing below, the XML document contains the table element:

<table>
    <header>
        <td>C1</td>
        <td>C2</td>
        <td>C3</td>
        <td>C4</td>
    </header>
    <tr>
        <td>cs=1, rs=1</td>
        <td column_span="2" row_span="2">cs=2, rs=2</td>
        <td row_span="3">cs=1, rs=3</td>
    </tr>
    <tr>
        <td>cs=1, rs=1</td>
    </tr>
    <tr>
        <td column_span="3">cs=3, rs=1</td>
    </tr>
</table>

When no table cell span provider is specified, the table has the following layout:

Figure 7.37. Table layout when no cell span provider is specified

When the above implementation is configured, the table has the correct layout:
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Figure 7.38. Cells spanning multiple rows and columns.

Configuring an Unique Attributes Recognizer

The ro.sync.ecss.extensions.api.UniqueAttributesRecognizer interface can be implemented
if you want to provide for your framework the following features:

Automatic ID generation You can automatically generate unique IDs for newly inserted elements. Imple-
mentations are already available for the DITA and Docbook frameworks. The
following methods can be implemented to accomplish this:

/**
 * Assign unique IDs between a start 
 * and an end offset in the document
 * @param startOffset Start offset
 * @param endOffset End offset
 */
void assignUniqueIDs(int startOffset, int endOffset);

/**
 * @return true if auto
 */
boolean isAutoIDGenerationActive();

Avoiding copying unique attributes
when "Split" is called inside an ele-
ment

You can split the current block element by pressing the "Enter" key and then
choosing "Split". This is a very useful way to create new paragraphs. All attrib-
utes are by default copied on the new element but if those attributes are IDs you
sometimes want to avoid creating validation errors in the editor. Implementing
the following method, you can decide whether an attribute should be copied or
not during the split:

  /**
   * Check if the attribute specified by QName can 
   * be considered as a valid attribute to copy 
   * when the element is split.
   * 
   * @param attrQName The attribute qualified name
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   * @param element The element
   * @return true if the attribute should be copied 
   * when Split is performed.
   */
  boolean copyAttributeOnSplit(String attrQName, 
               AuthorElement element);

Tip

The ro.sync.ecss.extensions.commons.id.DefaultU-
niqueAttributesRecognizer class is an implementation of the
interface which can be extended by your customization to provide easy
assignation of IDs in your framework. You can also check out the DITA
and Docbook implementations of ro.sync.ecss.exten-
sions.api.UniqueAttributesRecognizer to see how they
were implemented and connected to the extensions bundle.

Customizing the default CSS of a document type
The easiest way of customizing the default CSS stylesheet of a document type is to create a new CSS stylesheet in the
same folder as the customized one, import the customized CSS stylesheet and set the new stylesheet as the default CSS
of the document type. For example let us customize the default CSS for DITA documents by changing the background
color of the task and topic elements to red. First we create a new CSS stylesheet called my_dita.css in the folder
${frameworks}/dita/css_classed where the default stylesheet called dita.css is located. ${frameworks} is the subfolder
frameworks of the Oxygen XML Editor. The new stylesheet my_dita.css contains:

@import "dita.css";

task, topic{
    background-color:red;
}

To set the new stylesheet as the default CSS stylesheet for DITA documents first open the Document Type Association
preferences panel from menu Options → Preferences+Document Type Association Select the DITA document type
and start editing it by pressing the Edit button. The user role must be set to Developer otherwise a warning is displayed
and a duplicate copy of the DITA document type is created and edited. This check makes sure that regular content
authors who just edit the content of XML documents do not accidentally modify the document type. In the Author tab
of the document type edit dialog change the URI of the default CSS stylesheet from ${frame-
works}/dita/css_classed/dita.css to ${frameworks}/dita/css_classed/my_dita.css.
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Figure 7.39. Set the location of the default CSS stylesheet

Press OK in all the dialogs to validate the changes. Now you can start editing DITA documents based on the new CSS
stylesheet. You can edit the new CSS stylesheet itself at any time and see the effects on rendering DITA XML documents
in the Author mode by running the Refresh action available on the Author toolbar and on the DITA menu.

Document type sharing
A document type can be shared between authors in two ways:

• save the document type at global level in the Document Type Association panel and distribute a zip file that includes
all the files of the document type (CSS stylesheets, jar files with custom actions, etc). Each user will unzip the zip
file in a subdirectory of the ${frameworks} directory and will restart the application for adding the new document
type to the list of the Document Type Association panel

• save the document type at project level in the Document Type Association panel and distribute both the Oxygen
project file and the files of the document type (CSS stylesheets, jar files with custom actions, etc). Each user will
copy the files of the document type in the subdirectory of the ${frameworks} directory that corresponds to the doc-
ument type and will load the Oxygen project file in the Project view.

CSS support in <oXygen/> Author

CSS 2.1 features

Supported selectors

The following CSS level 2.1 selectors are supported by the <oXygen/> Author:
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Table 7.3. Supported CSS 2.1 selectors

Description/ExampleNameExpression

Matches any elementUniversal selector*

Matches any E element (i.e an element with the local name E)Type selectorE

Matches any F element that is a descendant of an E element.Descendant selectorE F

Matches any F element that is a child of an element E.Child selectorsE > F

Matches element E when E is the first child of its parent.The :first-child pseudo-classE:first-child

Matches element of type E if it is in (human) language c (the
document language specifies how language is determined).

The :lang() pseudo-classE:lang(c)

Matches any F element immediately preceded by a sibling element
E.

Adjacent selectorE + F

Matches any E element with the "foo" attribute set (whatever the
value).

Attribute selectorE[foo]

Matches any E element whose "foo" attribute value is exactly
equal to "warning".

Attribute selectorE[foo="warning"]

Matches any E element whose "foo" attribute value is a list of
space-separated values, one of which is exactly equal to "warning".

Attribute selectorE[foo~="warning"]

Matches any E element whose "lang" attribute has a hyphen-sep-
arated list of values beginning (from the left) with "en".

Attribute selectorE[lang|="en"]

The ':before' and ':after' pseudo-elements can be used to insert
generated content before or after an element's content.

Pseudo elementsE:before and E:after

Unsupported selectors

The following CSS level 2.1 selectors are not supported by the <oXygen/> Author:

Table 7.4. Unsupported CSS 2.1 selectors

Description/ExampleNameExpression

Matches any E element with ID equal to "myid".ID selectorsE#myid

Matches element E if E is the source anchor of a hyperlink of
which the target is not yet visited (:link) or already visited (:vis-
ited).

The link pseudo-classE:link, E:visited

Matches E during certain user actions.The dynamic pseudo-classesE:active, E:hover,
E:focus

The :first-line pseudo-element applies special styles to the con-
tents of the first formatted line of a paragraph.

The :first-line pseudo-classE:first-line

The :first-letter pseudo-element must select the first letter of the
first line of a block, if it is not preceded by any other content
(such as images or inline tables) on its line. The :first-letter
pseudo-element may be used for "initial caps" and "drop caps",
which are common typographical effects.

The :first-letter pseudo-classE:first-letter
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Properties Support Table

All the properties belonging to the aural and paged categories are not supported in <oXygen/> Author. The properties
from the table below belong to the visual category.
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Table 7.5. CSS Level 2.1 Properties and their support in <oXygen/> Author

Not Supported ValuesSupported ValuesName

ALL'background-attachment'

transparent<color> | inherit'background-color'

ALL'background-image'

ALL'background-position'

ALL'background-repeat'

ALL'background'

ALL'border-collapse'

transparent<color> | inherit'border-color'

ALL'border-spacing'

<border-style> | inherit'border-style'

[ <border-width> || <border-style> || 'border-top-
color' ] | inherit

'border-top' 'border-right' 'border-bot-
tom' 'border-left'

transparent<color> | inherit'border-top-color' 'border-right-color'
'border-bottom-color' 'border-left-color'

<border-style> | inherit'border-top-style' 'border-right-style'
'border-bottom-style' 'border-left-style'

<border-width> | inherit'border-top-width' 'border-right-width'
'border-bottom-width' 'border-left-width'

<border-width> | inherit'border-width'

[ <border-width> || <border-style> || 'border-top-
color' ] | inherit

'border'

ALL'bottom'

ALL'caption-side'

ALL'clear'

ALL'clip'

<color> | inherit'color'

no-open-quote | no-close-
quote

normal | none | [ <string> | <uri> | <counter> | attr(
<identifier> ) | open-quote | close-quote ]+ | inherit

'content'

[ <identifier> <integer> ? ]+ | none | inherit'counter-increment'

[ <identifier> <integer> ? ]+ | none | inherit'counter-reset'

ALL'cursor'

rtl | inheritltr'direction'

run-in | inline-block | in-
line-table - considered
block

inline | block | list-item | table | table-row-group |
table-header-group | table-footer-group | table-row
| table-column-group | table-column | table-cell |
table-caption | none | inherit

'display'

show | hide | inherit'empty-cells'

ALL'float'

[[ <family-name> | <generic-family> ] [, <family-
name> | <generic-family> ]* ] | inherit

'font-family'
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Not Supported ValuesSupported ValuesName

<absolute-size> | <relative-size> | <length> |
<percentage> | inherit

'font-size'

normal | italic | oblique | inherit'font-style'

ALL'font-variant'

normal | bold | bolder | lighter | 100 | 200 | 300 |
400 | 500 | 600 | 700 | 800 | 900 | inherit

'font-weight'

'font-variant' 'line-height'
caption | icon | menu |
message-box | small-cap-
tion | status-bar

[ [ 'font-style' || 'font-weight' ]? 'font-size' [ / 'line-
height' ]? 'font-family' ] | inherit

'font'

ALL'height'

ALL'left'

ALL'letter-spacing'

normal | <number> | <length> | <percentage> | in-
herit

'line-height'

ALL'list-style-image'

ALL'list-style-position'

lower-greek | armenian |
georgian

disc | circle | square | decimal | lower-roman | up-
per-roman | lower-latin | upper-latin | lower-alpha
| upper-alpha | none | inherit

'list-style-type'

'list-style-position' || 'list-
style-image'

[ 'list-style-type' ] | inherit'list-style'

<margin-width> | inherit'margin-right' 'margin-left'

<margin-width> | inherit'margin-top' 'margin-bottom'

<margin-width> | inherit'margin'

ALL'max-height'

<length> | <percentage> | none | inherit - supported
for block-level and replaced elements, e.g. images,
tables, table cells.

'max-width'

ALL'min-height'

<length> | <percentage> | inherit - supported for
block-level and replaced elements, e.g. images,
tables, table cells.

'min-width'

ALL'outline-color'

ALL'outline-style'

ALL'outline-width'

ALL'outline'

ALL'overflow'

<padding-width> | inherit'padding-top' 'padding-right' 'padding-
bottom' 'padding-left'

<padding-width> | inherit'padding'

ALL'position'
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Not Supported ValuesSupported ValuesName

ALL'quotes'

ALL'right'

fixed | inheritauto'table-layout'

justifyleft | right | center | inherit'text-align'

blinknone | [ underline || overline || line-through ] | inher-
it

'text-decoration'

ALL'text-indent'

ALL'text-transform'

ALL'top'

ALL'unicode-bidi'

<percentage> | <length>baseline | sub | super | top | text-top | middle | bot-
tom | text-bottom | inherit

'vertical-align'

collapsevisible | hidden | inherit'visibility'

normal | pre | nowrap | pre-wrap | pre-line'white-space'

<length> | <percentage> | auto | inherit - supported
for block-level and replaced elements, e.g. images,
tables, table cells.

'width'

ALL'word-spacing'

ALL'z-index'

<oXygen/> CSS Extensions

Media Type oxygen

The style sheets can specify how a document is to be presented on different media: on the screen, on paper, speech
synthesiser, etc. You can specify that some of the features of your CSS stylesheet should be taken into account only
in the <oXygen/> Author and ignored in the rest. This can be accomplished by using the media type oxygen.

For instance using the following CSS:

b{
 font-weight:bold;
 display:inline; 
}

@media oxygen{
 b{
  text-decoration:underline;
 }
}

would make a text bold if the document was opened in a web browser who does not recognize @media oxygen and
bold and underlined in <oXygen/> Author.

You can use this media type to group specific <oXygen/> CSS features and also to hide them when opening the docu-
ments with other viewers.
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Supported Features from CSS Level 3

Namespace Selectors

In the current CSS 2.1 standard the element selectors are ignoring the namespaces of the elements they are matching.
Only the local name of the elements are considered in the selector matching process.

<oXygen/> Author uses a different approach similar to the CSS Level 3 specification. If the element name from the
CSS selector is not preceded by a namespace prefix it is considered to match an element with the same local name as
the selector value and ANY namespace, otherwise the element must match both the local name and the namespace.

In CSS up to version 2.1 the name tokens from the selectors are matching all elements from ANY namespace that have
the same local name. Example:

<x:b xmlns:x="ns_x"/>
<y:b xmlns:y="ns_y"/>

Are both matched by the rule:

b {font-weight:bold}

Starting with CSS Level 3 you can create selectors that are namespace aware.

Example 7.5. Defining both prefixed namespaces and the default namespace

Given the namespace declarations:

@namespace sync "http://sync.example.org";
@namespace "http://example.com/foo";

In a context where the default namespace applies:

sync|A represents the name A in the http://sync.example.org namespace.

|B represents the name B that belongs to NO NAMESPACE.

*|C represents the name C in ANY namespace, including NO NAMESPACE.

D represents the name D in the http://example.com/foo namespace.

Example 7.6. Defining only prefixed namespaces

Given the namespace declaration:

@namespace sync "http://sync.example.org";

Then:

sync|A represents the name A in the http://sync.example.org namespace.

|B represents the name B that belongs to NO NAMESPACE.

*|C represents the name C in ANY namespace, including NO NAMESPACE.

D represents the name D in ANY namespace, including NO NAMESPACE.
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The attr() function: Properties Values Collected from the Edited Document.

In CSS Level 2.1 you may collect attribute values and use them as content only for the pseudo elements. For instance
the :before pseudo-element can be used to insert some content before an element. This is valid in CSS 2.1:

title:before{
  content: "Title id=(" attr(id) ")";
}

If the title element from the XML document is:

<title id="title12">My title.</title>

Then the title will be displayed as:

Title id=(title12) My title.

In <oXygen/> Author the use of attr() function is not available only for the content property but for any other
property. This is similar to the CSS Level 3 working draft: http://www.w3.org/TR/2006/WD-css3-values-
20060919/#functional. The arguments of the function are:

attr(attribute_name, attribute_type, default_value);

attribute_name ;
attribute_type ;
default_value ;

attribute_name The name of the attribute. This argument is required.

attribute_type The type of the attribute. This argument is optional. If it is missing the type of the argument is
considered string. This argument indicates what is the meaning of the attribute value and
helps to perform conversions of this value. <oXygen/> Author accepts one of the following
types:

color The value represents a color. The attribute may specify a color in different
formats. <oXygen/> Author supports colors specified either by name: red,
blue, green, etc. or as an RGB hexadecimal value #FFEEFF.

url The value is an URL pointing to a media object. <oXygen/> Author supports
only images. The attribute value can be a complete URL, or a relative one to
the XML document.

integer The value must be interpreted as an integer.

number The value must be interpreted as a float number.

length The value must be interpreted as an integer.

percentage The value must be interpreted relative to another value (length, size) expressed
in percents.

em The value must be interpreted as a size. 1 em is equal to the font-size of the
relevant font.

ex The value must be interpreted as a size. 1 ex is equal to the height of the x
character of the relevant font.
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px The value must be interpreted as a size expressed in pixels relative to the
viewing device.

mm The value must be interpreted as a size expressed in millimeters.

cm The value must be interpreted as a size expressed in centimeters.

in The value must be interpreted as a size expressed in inches. 1 inch is equal
to 2.54 centimeters.

pt The value must be interpreted as a size expressed in points. The points used
by CSS2 are equal to 1/72th of an inch.

pc The value must be interpreted as a size expressed in picas. 1 pica is equal to
12 points.

default_value This argument specifies a value that is used by default if the attribute value is missing. This
argument is optional.
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Example 7.7. Usage samples for the attr() function

Consider the following XML instance:

<sample>
    <para bg_color="#AAAAFF">Blue paragraph.</para>
    <para bg_color="red">Red paragraph.</para>
    <para bg_color="red" font_size="2">Red paragraph with large font.</para>
    <para bg_color="#00AA00" font_size="0.8" space="4">
        Green paragraph with small font and margin.</para>
</sample>

The para elements have bg_color attributes with RGB color values like #AAAAFF. We can use the attr()
function to change the elements appearance in the editor based on the value of this attribute:

background-color:attr(bg_color, color);

The attribute font_size represents the font size in em units. We can use this value to change the style of the element:

font-size:attr(font_size, em);

The complete CSS rule is:

para{
 display:block;
 background-color:attr(bg_color, color);
 font-size:attr(font_size, em);
 margin:attr(space, em);
}

The document is rendered as:

Additional Custom Selectors

Oxygen Author provides support for selecting additional types of nodes. These custom selectors apply to: document,
doctype sections, processing-instructions, comments, CDATA sections, and entities. In order for the custom selectors
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to work in your CSS files you will have to declare the Author extensions namespace at the beginning of the stylesheet
documents:

@namespace oxy url('http://www.oxygenxml.com/extensions/author');

Example rules:

• document

oxy|document {
    display:block;
}

• doctype sections

oxy|doctype {
    display:block;
    color:blue;
    background-color:transparent;
}

• processing-instructions

oxy|processing-instruction {
    display:block;
    color:purple;
    background-color:transparent;
}

• comments

oxy|comment {
    display:block;
    color:green;
    background-color:transparent;
}

• CDATA sections

oxy|cdata{
    display:block;
    color:gray;
    background-color:transparent;
} 

• entities

oxy|entity {
    display:morph;
    editable:false;
    color:orange;
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    background-color:transparent;
}

A sample document rendered using these rules:

Additional Properties

Folding elements: foldable and not-foldable-child properties

<oXygen/> Author allows you to declare some elements to be foldable (collapsible). This is especially useful when
working with large documents organized in logical blocks, editing a large DocBook article or book for instance.

To define the element whose content can be folded by the user, you must use the property: foldable:true;.

When collapsing an element, it is useful to keep some of its content visible, like a short description of the collapsed
region. The property not-foldable-child is used to identify the child elements that are kept visible. It accepts
as value an element name or a list of comma separated element names. If the element is marked as foldable (fold-
able:true;) but it doesn't have the property not-foldable-child or none of the specified non-foldable
children exists then the element will still be foldable. In this case the element that will be kept visible when folded will
be the before pseudo element.

Note

Both foldable and not-foldable-child are non standard properties and are recognized only by
<oXygen/> Author.
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Example 7.8. Folding DocBook Elements

All the elements below can have a title child element and are considered to be logical sections. We mark them as
being foldable leaving the title element visible.

set,
book,
part,
reference,
chapter,
preface,
article,
sect1,
sect2,
sect3,
sect4,
section,
appendix,
figure,
example,
table {
    foldable:true;
    not-foldable-child: title;
}

Link elements

<oXygen/> Author allows you to declare some elements to be links. This is especially useful when working with many
documents which refer to each other. The links allow for an easy way to get from one document to another. Clicking
on the link marker will open the referred resource in an editor.

To define the element which should be considered a link, you must use the property link on the before or after pseudo
element. The value of the property indicates the location of the linked resource. Since links are usually indicated by
the value of an attribute in most cases it will have the a value similar to attr(href)

Note

link is a non standard property and is recognized only by <oXygen/> Author.
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Example 7.9. Docbook Link Elements

All the elements below are defined to be links on the before pseudo element and their value is defined by the value of
an attribute.

*[href]:before{
    link:attr(href);
    content: "Click " attr(href) " for opening" ;
}

ulink[url]:before{
    link:attr(url);
    content: "Click to open: " attr(url);
}

olink[targetdoc]:before{
    link: attr(targetdoc);
    content: "Click to open: " attr(targetdoc);
}

<oXygen/> Custom CSS functions

In <oXygen/> Author there are implemented a few <oXygen/> specific custom CSS functions. Imbricated custom
functions are also supported.

Example 7.10. Imbricated functions

The result of the functions below will be the local name of the current node with the first letter capitalized.

capitalize(local-name())

The local-name() function

This function evaluates the local name of the current node. It does not have any arguments

The name() function

This function evaluates the qualified name of the current node. It does not have any arguments

The url() function

This function evaluates the URL of a location relative to the CSS file location and appends each of the relative path
components to the final location.

url(location, loc_1, loc_2);(...);

location ;
loc_1 ;
loc_2 ;

location The location as string. If not absolute, will be solved relative to the CSS file URL.

loc_1 ... loc_n Relative location path components as string. (optional)
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The base-uri() function

This function evaluates the base URL in the context of the current node. It does not have any arguments and takes into
account the xml:base context of the current node. See the XML Base specification [http://www.w3.org/TR/xmlbase/]
for more details.

The parent-url() function

This function evaluates the parent URL of an URL received as string.

parent-url(url);

url ;

url The url as string.

The capitalize() function

This function capitalizes the first letter of the text received as argument.

capitalize(text);

text ;

text The text for which the first letter will be capitalized.

The uppercase() function

This function transforms to upper case the text received as argument.

uppercase(text);

text ;

text The text to be capitalized.

The lowercase() function

This function transforms to lower case the text received as argument.

lowercase(text);

text ;

text The text to be lower cased.

The concat() function

This function concatenates the received string arguments.

concat(str_1, str_2);(...);

str_1 ;
str_2 ;

str_1 ... str_n The string arguments to be concatenated.
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The replace() function

This function has two signatures:

• replace(text, target, replacement);

text ;
target ;
replacement ;

This function replaces each substring of the text that matches the literal target string with the specified literal replace-
ment string.

text The text in which the replace will occur.

target The target string to be replaced.

replacement The string replacement.

• replace(text, target, replacement, isRegExp);

text ;
target ;
replacement ;
isRegExp ;

This function replaces each substring of the text that matches the target string with the specified replacement string.

text The text in which the replace will occur.

target The target string to be replaced.

replacement The string replacement.

isRegExp If true the target and replacement arguments are considered regular expressions
in PERL syntax, if false they are considered literal strings.

The unparsed-entity-uri() function

This function returns the uri value of an unparsed entity name.

unparsed-entity-uri(unparsedEntityName);

unparsedEntityName ;

unparsedEntityName The name of an unparsed entity defined in the DTD.

This function can be useful to display images which are referred with unparsed entity names.

Example 7.11. CSS for displaying the image in Author for an imagedata  with entityref
to an unparsed entity

imagedata[entityref]{
content: url(unparsed-entity-uri(attr(entityref))); 
}
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The attributes() function

This function concatenates the attributes for an element and returns the serialization.

attributes();

Example 7.12. attributes()

For the following XML fragment:<element att1="x" xmlns:a="2" x="&quot;"/>  the attributes()
function will return att1="x" xmlns:a="2" x=""".

Example Files Listings

The Simple Documentation Framework Files

XML Schema files

sdf.xsd

<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema"
    targetNamespace="http://www.oxygenxml.com/sample/documentation"
    xmlns:doc="http://www.oxygenxml.com/sample/documentation"
    xmlns:abs="http://www.oxygenxml.com/sample/documentation/abstracts"
    elementFormDefault="qualified">

    <xs:import
        namespace="http://www.oxygenxml.com/sample/documentation/abstracts"
        schemaLocation="abs.xsd"/>

    <xs:element name="book" type="doc:sectionType"/>
    <xs:element name="article" type="doc:sectionType"/>
    <xs:element name="section" type="doc:sectionType"/>

    <xs:complexType name="sectionType">
        <xs:sequence>
            <xs:element name="title" type="xs:string"/>
            <xs:element ref="abs:def" minOccurs="0"/>
            <xs:choice>
                <xs:sequence>
                    <xs:element ref="doc:section"
                        maxOccurs="unbounded"/>
                </xs:sequence>
                <xs:choice maxOccurs="unbounded">
                    <xs:element ref="doc:para"/>
                    <xs:element ref="doc:ref"/>
                    <xs:element ref="doc:image"/>
                    <xs:element ref="doc:table"/>
                </xs:choice>
            </xs:choice>
        </xs:sequence>
    </xs:complexType>
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    <xs:element name="para" type="doc:paragraphType"/>

    <xs:complexType name="paragraphType" mixed="true">
        <xs:choice minOccurs="0" maxOccurs="unbounded">
            <xs:element name="b"/>
            <xs:element name="i"/>
            <xs:element name="link"/>
        </xs:choice>
    </xs:complexType>

    <xs:element name="ref">
        <xs:complexType>
            <xs:attribute name="location" type="xs:anyURI"
                use="required"/>
        </xs:complexType>
    </xs:element>

    <xs:element name="image">
        <xs:complexType>
            <xs:attribute name="href" type="xs:anyURI"
                use="required"/>
        </xs:complexType>
    </xs:element>

    <xs:element name="table">
        <xs:complexType>
            <xs:sequence>
                <xs:element name="customcol" maxOccurs="unbounded">
                    <xs:complexType>
                        <xs:attribute name="width" type="xs:string"/>
                    </xs:complexType>
                </xs:element>
                <xs:element name="header">
                    <xs:complexType>
                        <xs:sequence>
                            <xs:element name="td"
                                maxOccurs="unbounded"
                                type="doc:paragraphType"/>
                        </xs:sequence>
                    </xs:complexType>
                </xs:element>
                <xs:element name="tr" maxOccurs="unbounded">
                    <xs:complexType>
                        <xs:sequence>
                            <xs:element name="td"
                                type="doc:tdType"
                                maxOccurs="unbounded"/>
                        </xs:sequence>
                    </xs:complexType>
                </xs:element>
            </xs:sequence>
            <xs:attribute name="width" type="xs:string"/>
        </xs:complexType>
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    </xs:element>

    <xs:complexType name="tdType">
        <xs:complexContent>
            <xs:extension base="doc:paragraphType">
                <xs:attribute name="row_span"
                    type="xs:integer"/>
                <xs:attribute name="column_span"
                    type="xs:integer"/>
            </xs:extension>
        </xs:complexContent>
    </xs:complexType>
</xs:schema>

abs.xsd

<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" 
    targetNamespace=
 "http://www.oxygenxml.com/sample/documentation/abstracts">
    <xs:element name="def" type="xs:string"/>
</xs:schema>

CSS Files

sdf.css

/* Element from another namespace */
@namespace abs "http://www.oxygenxml.com/sample/documentation/abstracts";

abs|def{
    font-family:monospace;
    font-size:smaller;    
}
abs|def:before{
    content:"Definition:";
    color:gray;
}

/* Vertical flow */
book,
section,
para,
title,
image,
ref {
    display:block;
}

/* Horizontal flow */
b,i {
    display:inline;
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}

section{
    margin-left:1em;
    margin-top:1em;
}

section{
    foldable:true;
    not-foldable-child: title;
}

link[href]:before{
    display:inline;
    link:attr(href);
    content: "Click to open: " attr(href);
}

/* Title rendering*/
title{
    font-size: 2.4em;
    font-weight:bold;    
}

* * title{
    font-size: 2.0em;
}
* * * title{
    font-size: 1.6em;
}
* * * * title{
    font-size: 1.2em;
}

book, 
article{
    counter-reset:sect;
}
book > section,
article > section{
    counter-increment:sect;
}
book > section > title:before,
article > section > title:before{
    content: "Section: " counter(sect) " ";
}

/* Inlines rendering*/
b {
    font-weight:bold;
}

i {
    font-style:italic;
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}

/*Table rendering */
table{
    display:table;
    border:1px solid navy;
    margin:1em;
    max-width:1000px;
    min-width:150px;
}

table[width]{
  width:attr(width, length);
}

tr, header{
    display:table-row;
}

header{
    background-color: silver;
    color:inherit
}

td{
  display:table-cell;
  border:1px solid navy;
  padding:1em;
}

image{
    display:block;
    content: attr(href, url);
    margin-left:2em;
}

XML Files

sdf_sample.xml

<?xml version="1.0" encoding="UTF-8"?>
<book xmlns="http://www.oxygenxml.com/sample/documentation"
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns:abs="http://www.oxygenxml.com/sample/documentation/abstracts">
    <title>My Technical Book</title>
    <section>
        <title>XML</title>
        <abs:def>Extensible Markup Language</abs:def>
        <para>In this section of the book I will explain
            different XML applications.</para>
    </section>
    <section>
        <title>Accessing XML data.</title>
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        <section>
            <title>XSLT</title>
            <abs:def>Extensible stylesheet language
                transformation (XSLT) is a language for
                transforming XML documents into other XML
                documents.</abs:def>
            <para>A list of XSL elements and what they do..</para>
            <table>
                <header>
                    <td>XSLT Elements</td>
                    <td>Description</td>
                </header>
                <tr>
                    <td>
                        <b>xsl:stylesheet</b>
                    </td>
                    <td>The <i>xsl:stylesheet</i> element is
                        always the top-level element of an
                        XSL stylesheet. The name
                            <i>xsl:transform</i> may be used
                        as a synonym.</td>
                </tr>
                <tr>
                    <td>
                        <b>xsl:template</b>
                    </td>
                    <td>The <i>xsl:template</i> element has
                        an optional mode attribute. If this
                        is present, the template will only
                        be matched when the same mode is
                        used in the invoking
                            <i>xsl:apply-templates</i>
                        element.</td>
                </tr>
                <tr>
                    <td>
                        <b>for-each</b>
                    </td>
                    <td>The xsl:for-each element causes
                        iteration over the nodes selected by
                        a node-set expression.</td>
                </tr>
                <tr>
                    <td column_span="2">End of the list</td>
                </tr>
            </table>
        </section>
        <section>
            <title>XPath</title>
            <abs:def>XPath (XML Path Language) is a terse
                (non-XML) syntax for addressing portions of
                an XML document. </abs:def>
            <para>Some of the XPath functions.</para>
            <table>
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                <header>
                    <td>Function</td>
                    <td>Description</td>
                </header>
                <tr>
                    <td>format-number</td>
                    <td>The <i>format-number</i> function
                        converts its first argument to a
                        string using the format pattern
                        string specified by the second
                        argument and the decimal-format
                        named by the third argument, or the
                        default decimal-format, if there is
                        no third argument</td>
                </tr>
                <tr>
                    <td>current</td>
                    <td>The <i>current</i> function returns
                        a node-set that has the current node
                        as its only member.</td>
                </tr>
                <tr>
                    <td>generate-id</td>
                    <td>The <i>generate-id</i> function
                        returns a string that uniquely
                        identifies the node in the argument
                        node-set that is first in document
                        order.</td>
                </tr>
            </table>
        </section>
    </section>
    <section>
        <title>Documentation frameworks</title>
        <para>One of the most important documentation
            frameworks is Docbook.</para>
        <image
            href="http://www.xmlhack.com/images/docbook.gif"/>
        <para>The other is the topic oriented DITA, promoted
            by OASIS.</para>
        <image
href="http://www.oasis-open.org/images/standards/oasis_standard.jpg"
        />
    </section>
</book>

XSL Files

sdf.xsl

<?xml version="1.0" encoding="UTF-8"?>
<xsl:stylesheet 
    xmlns:xsl="http://www.w3.org/1999/XSL/Transform" version="2.0"
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    xpath-default-namespace=
    "http://www.oxygenxml.com/sample/documentation">

    <xsl:template match="/">
        <html><xsl:apply-templates/></html>
    </xsl:template>

    <xsl:template match="section">
        <xsl:apply-templates/>
    </xsl:template>

    <xsl:template match="image">
        <img src="{@href}"/>
    </xsl:template>

    <xsl:template match="para">
        <p>
            <xsl:apply-templates/>
        </p>
    </xsl:template>

    <xsl:template match="abs:def"
        xmlns:abs=
        "http://www.oxygenxml.com/sample/documentation/abstracts">
        <p>
            <u><xsl:apply-templates/></u>
        </p>
    </xsl:template>

    <xsl:template match="title">
        <h1><xsl:apply-templates/></h1>
    </xsl:template>

    <xsl:template match="b">
        <b><xsl:apply-templates/></b>
    </xsl:template>

    <xsl:template match="i">
        <i><xsl:apply-templates/></i>
    </xsl:template>

    <xsl:template match="table">
        <table frame="box" border="1px">
            <xsl:apply-templates/>
        </table>
    </xsl:template>

    <xsl:template match="header">
        <tr>
            <xsl:apply-templates/>
        </tr>
    </xsl:template>

    <xsl:template match="tr">
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        <tr>
            <xsl:apply-templates/>
        </tr>
    </xsl:template>

    <xsl:template match="td">
        <td>
            <xsl:apply-templates/>
        </td>
    </xsl:template>

    <xsl:template match="header/header/td">
        <th>
            <xsl:apply-templates/>
        </th>
    </xsl:template>

</xsl:stylesheet>

Java Files

InsertImageOperation.java

package simple.documentation.framework;

import java.awt.GridBagConstraints;
import java.awt.GridBagLayout;
import java.awt.event.ActionEvent;
import java.awt.event.ActionListener;
import java.awt.event.WindowAdapter;
import java.awt.event.WindowEvent;
import java.io.File;
import java.net.MalformedURLException;

import javax.swing.BorderFactory;
import javax.swing.JButton;
import javax.swing.JDialog;
import javax.swing.JFileChooser;
import javax.swing.JFrame;
import javax.swing.JLabel;
import javax.swing.JPanel;
import javax.swing.JTextField;
import javax.swing.filechooser.FileFilter;

import ro.sync.ecss.extensions.api.ArgumentDescriptor;
import ro.sync.ecss.extensions.api.ArgumentsMap;
import ro.sync.ecss.extensions.api.AuthorAccess;
import ro.sync.ecss.extensions.api.AuthorOperation;
import ro.sync.ecss.extensions.api.AuthorOperationException;

public class InsertImageOperation implements AuthorOperation {

       //
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// Implementing the Author Operation Interface.
//

/**
 * Performs the operation.
 */
public void doOperation(AuthorAccess authorAccess, 
  ArgumentsMap arguments)
  throws IllegalArgumentException, 
      AuthorOperationException {

 JFrame oxygenFrame = (JFrame) authorAccess.getParentFrame();
 String href = displayURLDialog(oxygenFrame);
 if (href.length() != 0) {  
     // Creates the image XML fragment.
     String imageFragment = 
         "<image xmlns='http://www.oxygenxml.com/sample/documentation'" +
                " href='" + href + "'/>";

  // Inserts this fragment at the caret position.
  int caretPosition = authorAccess.getCaretOffset();  
  authorAccess.insertXMLFragment(imageFragment, caretPosition);
 }
}

/**
 * Has no arguments.
 * 
 * @return null.
 */
public ArgumentDescriptor[] getArguments() {
 return null;
}

/**
 * @return A description of the operation.
 */
public String getDescription() {
 return "Inserts an image element. Asks the" + 
" user for a URL reference.";
}

//
// End of interface implementation.
//

//
// Auxiliary methods.
//

/**
 * Displays the URL dialog. 
 * 
 * @param parentFrame The parent frame for 
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* the dialog.
 * @return The selected URL string value, 
* or the empty string if the user canceled 
* the URL selection.
 */
private String displayURLDialog(JFrame parentFrame) {

 final JDialog dlg = new JDialog(parentFrame, 
"Enter the value for the href attribute", true);
 JPanel mainContent = new JPanel(new GridBagLayout());

 // The text field.
 GridBagConstraints cstr = new GridBagConstraints();
 cstr.gridx = 0;
 cstr.gridy = 0;
 cstr.weightx = 0;
 cstr.gridwidth = 1;
 cstr.fill = GridBagConstraints.HORIZONTAL;
 mainContent.add(new JLabel("Image URI:"), cstr);

 cstr.gridx = 1;
 cstr.weightx = 1;
 final JTextField urlField = new JTextField();
 urlField.setColumns(15);
 mainContent.add(urlField, cstr);

 // Add the "Browse button."
 cstr.gridx = 2;
 cstr.weightx = 0;
 JButton browseButton = new JButton("Browse");
 browseButton.addActionListener(new ActionListener() {

  /**
   * Shows a file chooser dialog.
   */
  public void actionPerformed(ActionEvent e) {
   JFileChooser fileChooser = new JFileChooser();

   fileChooser.setMultiSelectionEnabled(false);
   // Accepts only the image files.
   fileChooser.setFileFilter(new FileFilter() {
    public String getDescription() {
     return "Image files";
    }

    public boolean accept(File f) {
     String fileName = f.getName();
     return f.isFile() && 
       ( fileName.endsWith(".jpeg")
       || fileName.endsWith(".jpg")
       || fileName.endsWith(".gif")
       || fileName.endsWith(".png")
       || fileName.endsWith(".svg"));
    }
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   });    
   if (fileChooser.showOpenDialog(dlg) 
        == JFileChooser.APPROVE_OPTION) {
    File file = fileChooser.getSelectedFile();
    try {
     // Set the file into the text field.
     urlField.setText(file.toURL().toString());
    } catch (MalformedURLException ex) {
     // This should not happen.
     ex.printStackTrace();
    }
   }
  }
 });
 mainContent.add(browseButton, cstr);

 // Add the "Ok" button to the layout.
 cstr.gridx = 0;
 cstr.gridy = 1;
 cstr.weightx = 0;
 JButton okButton = new JButton("Ok");
 okButton.addActionListener(new ActionListener() {
  public void actionPerformed(ActionEvent e) {
   dlg.setVisible(false);
  }
 });
 mainContent.add(okButton, cstr);
 mainContent.setBorder(
 BorderFactory.createEmptyBorder(10, 5, 10, 5));

 // Add the "Cancel" button to the layout.
 cstr.gridx = 2;
 JButton cancelButton = new JButton("Cancel");
 cancelButton.addActionListener(new ActionListener() {
  public void actionPerformed(ActionEvent e) {
   urlField.setText("");
   dlg.setVisible(false);
  }
 });
 mainContent.add(cancelButton, cstr);

 // When the user closes the dialog 
// from the window decoration,
 // assume "Cancel" action.
 dlg.addWindowListener(new WindowAdapter() {
  public void windowClosing(WindowEvent e) {
   urlField.setText("");
  }  
 });

 dlg.getContentPane().add(mainContent);
 dlg.pack();
 dlg.setLocationRelativeTo(parentFrame);
 dlg.setVisible(true);
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 return urlField.getText();
}

/**
 * Test method.
 *  
 * @param args The arguments are ignored.
 */
public static void main(String[] args) {
 InsertImageOperation operation = 
      new InsertImageOperation();
 System.out.println("Choosen URL: " +  
   operation.displayURLDialog(new JFrame()));
} 
}

QueryDatabaseOperation.java

package simple.documentation.framework;

import java.sql.Connection;
import java.sql.DriverManager;
import java.sql.ResultSet;
import java.sql.ResultSetMetaData;
import java.sql.SQLException;
import java.util.Properties;

import ro.sync.ecss.extensions.api.ArgumentDescriptor;
import ro.sync.ecss.extensions.api.ArgumentsMap;
import ro.sync.ecss.extensions.api.AuthorAccess;
import ro.sync.ecss.extensions.api.AuthorOperation;
import ro.sync.ecss.extensions.api.AuthorOperationException;

public class QueryDatabaseOperation implements AuthorOperation{

  private static String ARG_JDBC_DRIVER ="jdbc_driver";
  private static String ARG_USER ="user";
  private static String ARG_PASSWORD ="password";
  private static String ARG_SQL ="sql";
  private static String ARG_CONNECTION ="connection";

  /**
   * @return The array of arguments the developer must specify when
   * configuring the action.
   */
  public ArgumentDescriptor[] getArguments() {
    ArgumentDescriptor args[] = new ArgumentDescriptor[] {
        new ArgumentDescriptor(
            ARG_JDBC_DRIVER,
            ArgumentDescriptor.TYPE_STRING,
            "The name of the Java class that is the JDBC driver."),
        new ArgumentDescriptor(
            ARG_CONNECTION,
            ArgumentDescriptor.TYPE_STRING,
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            "The database URL connection string."),
        new ArgumentDescriptor(
            ARG_USER,
            ArgumentDescriptor.TYPE_STRING,
            "The name of the database user."),
        new ArgumentDescriptor(
            ARG_PASSWORD,
            ArgumentDescriptor.TYPE_STRING,
            "The database password."),
        new ArgumentDescriptor(
            ARG_SQL,
            ArgumentDescriptor.TYPE_STRING,
            "The SQL statement to be executed.")
    };
    return args;
  }

  /**
   * @return The operation description.
   */
  public String getDescription() {
    return "Executes a database query and puts the result in a table.";
  }

  public void doOperation(AuthorAccess authorAccess, ArgumentsMap map)
      throws IllegalArgumentException, AuthorOperationException {

    // Collects the arguments.
    String jdbcDriver = 
      (String)map.getArgumentValue(ARG_JDBC_DRIVER);
    String connection = 
      (String)map.getArgumentValue(ARG_CONNECTION);
    String user = 
      (String)map.getArgumentValue(ARG_USER);
    String password = 
      (String)map.getArgumentValue(ARG_PASSWORD);
    String sql = 
      (String)map.getArgumentValue(ARG_SQL);

    int caretPosition = authorAccess.getCaretOffset();
    try {
      authorAccess.insertXMLFragment(
          getFragment(jdbcDriver, connection, user, password, sql), 
          caretPosition);
    } catch (SQLException e) {
      throw new AuthorOperationException(
          "The operation failed due to the following database error: " + 
     e.getMessage(), e);
    } catch (ClassNotFoundException e) {
      throw new AuthorOperationException(
          "The JDBC database driver was not found. Tried to load ' " + 
     jdbcDriver + "'", e);
    }
  }
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  /**
   * Creates a connection to the database, executes 
   * the SQL statement and creates an XML fragment 
   * containing a table element that wraps the data 
   * from the result set.
   * 
   *  
   * @param jdbcDriver The class name of the JDBC driver.
   * @param connectionURL The connection URL.
   * @param user The database user.
   * @param password The password.
   * @param sql The SQL statement.
   * @return The string containing the XML fragment.
   * 
   * @throws SQLException thrown when there is a 
   * problem accessing the database or there are 
   * erors in the SQL expression.
   * @throws ClassNotFoundException when the JDBC 
   * driver class could not be loaded.
   */
  private String getFragment(
        String jdbcDriver, 
        String connectionURL, 
        String user, 
        String password, 
        String sql) throws 
          SQLException, 
          ClassNotFoundException {    

      Properties pr = new Properties();
      pr.put("characterEncoding", "UTF8");
      pr.put("useUnicode", "TRUE");
      pr.put("user", user);
      pr.put("password", password);

      // Loads the database driver.
      Class.forName(jdbcDriver);        

      // Opens the connection
      Connection connection = 
        DriverManager.getConnection(connectionURL, pr);
      java.sql.Statement statement = 
        connection.createStatement();
      ResultSet resultSet = 
        statement.executeQuery(sql);

      StringBuffer fragmentBuffer = new StringBuffer();
      fragmentBuffer.append(
          "<table xmlns='http://www.oxygenxml.com/sample/documentation'>");

      //
      // Creates the table header.
      //
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      fragmentBuffer.append("<header>");
      ResultSetMetaData metaData = resultSet.getMetaData();
      int columnCount = metaData.getColumnCount();
      for (int i = 1; i <= columnCount; i++) {
          fragmentBuffer.append("<td>");
          fragmentBuffer.append(
              xmlEscape(metaData.getColumnName(i)));
          fragmentBuffer.append("</td>");
        }
      fragmentBuffer.append("</header>");

      //
      // Creates the table content.
      //
      while (resultSet.next()) {
          fragmentBuffer.append("<tr>");
          for (int i = 1; i <= columnCount; i++) {
              fragmentBuffer.append("<td>");
              fragmentBuffer.append(
                  xmlEscape(resultSet.getObject(i)));
              fragmentBuffer.append("</td>");
          }
          fragmentBuffer.append("</tr>");
        }

      fragmentBuffer.append("</table>");

      // Cleanup
      resultSet.close();
      statement.close();
      connection.close();
      return fragmentBuffer.toString();        
  }

  /**
   * Some of the values from the database table 
   * may contain characters that must be escaped 
   * in XML, to ensure the fragment is well formed.
   * 
   * @param object The object from the database.
   * @return The escaped string representation.
   */
  private String xmlEscape(Object object) {
    String str = String.valueOf(object);
    return str.
      replaceAll("&", "&amp;").
      replaceAll("<", "&lt;");
  }
}

SDFExtensionsBundle.java

package simple.documentation.framework;
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import ro.sync.contentcompletion.xml.SchemaManagerFilter;
import ro.sync.ecss.extensions.api.AuthorExtensionStateListener;
import ro.sync.ecss.extensions.api.AuthorReferenceResolver;
import ro.sync.ecss.extensions.api.AuthorTableCellSpanProvider;
import ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider;
import ro.sync.ecss.extensions.api.ExtensionsBundle;
import ro.sync.ecss.extensions.api.StylesFilter;
import ro.sync.ecss.extensions.api.link.ElementLocatorProvider;
import ro.sync.ecss.extensions.commons.DefaultElementLocatorProvider;
import ro.sync.exml.editor.xmleditor.pageauthor.AuthorDnDListener;

public class SDFExtensionsBundle extends ExtensionsBundle {
 public String getDocumentTypeID() {
      return "Simple.Document.Framework.document.type";
 }

 public String getDescription() {
      return "A custom extensions bundle used for the " + 
                        "Simple Document Framework document type";
 }

 public AuthorExtensionStateListener createAuthorExtensionStateListener() {
      return new SDFAuthorExtensionStateListener();
 }

 public SchemaManagerFilter createSchemaManagerFilter() {
      return new SDFSchemaManagerFilter();
 }

 public ElementLocatorProvider createElementLocatorProvider() {
      return new DefaultElementLocatorProvider();
 }

 public AuthorDnDListener createAuthorAWTDndListener() {
      return new SDFAuthorDndListener();
 }

 public AuthorReferenceResolver createAuthorReferenceResolver() {
      return new ReferencesResolver();
 }

 public StylesFilter createAuthorStylesFilter() {
      return new SDFStylesFilter();
 }

 public AuthorTableCellSpanProvider createAuthorTableCellSpanProvider() {
      return new TableCellSpanProvider();
 }

 public AuthorTableColumnWidthProvider createAuthorTableColumnWidthProvider() {
      return new TableColumnWidthProvider();
 }
}
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SDFSchemaManagerFilter.java

package simple.documentation.framework;

import java.util.Iterator;
import java.util.List;

import ro.sync.contentcompletion.xml.CIAttribute;
import ro.sync.contentcompletion.xml.CIElement;
import ro.sync.contentcompletion.xml.CIValue;
import ro.sync.contentcompletion.xml.Context;
import ro.sync.contentcompletion.xml.ContextElement;
import ro.sync.contentcompletion.xml.SchemaManagerFilter;
import ro.sync.contentcompletion.xml.WhatAttributesCanGoHereContext;
import ro.sync.contentcompletion.xml.WhatElementsCanGoHereContext;
import ro.sync.contentcompletion.xml.WhatPossibleValuesHasAttributeContext;

public class SDFSchemaManagerFilter implements SchemaManagerFilter {

 @Override
 public List<CIValue> filterAttributeValues(List<CIValue> attributeValues,
       WhatPossibleValuesHasAttributeContext context) {
      return attributeValues;
 }

 @Override
 public List<CIAttribute> filterAttributes(List<CIAttribute> attributes,
       WhatAttributesCanGoHereContext context) {
   // If the element from the current context is the 'table' element add the 
   // attribute named 'frame' to the list of default content 
      // completion proposals
   ContextElement contextElement = context.getParentElement();
   if ("table".equals(contextElement.getQName())) {
     CIAttribute frameAttribute = new CIAttribute();
     frameAttribute.setName("frame");
     frameAttribute.setRequired(false);
     frameAttribute.setFixed(false);
     frameAttribute.setDefaultValue("void");
     attributes.add(frameAttribute);
   }
   return attributes;
 }

 @Override
 public List<CIValue> filterElementValues(List<CIValue> elementValues,
       Context context) {
      return elementValues;
 }

 @Override
 public List<CIElement> filterElements(List<CIElement> elements,
       WhatElementsCanGoHereContext context) {
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   // If the element from the current context is the 'header' 
      // element remove the 'td' element from the list of content 
      // completion proposals and add the 'th' element.
   ContextElement contextElement = context.getElementStack().peek();
   if ("header".equals(contextElement.getQName())) {
     for (Iterator<CIElement> iterator = elements.iterator(); 
                    iterator.hasNext();) {
       CIElement element = iterator.next(); 
        // Remove the 'td' element
       if ("td".equals(element.getQName())) {
          elements.remove(element);
          break;
        }
      }
     // Insert the 'th' element in the list of content completion proposals
     CIElement thElement = new SDFElement();
     thElement.setName("th");
     elements.add(thElement);
   }
    return elements;
 }

 @Override
 public String getDescription() {
  return null;
 }
}

TableCellSpanProvider.java

package simple.documentation.framework;

public class TableCellSpanProvider 
    implements AuthorTableCellSpanProvider {

  /**
   * Extracts the integer specifing what is the width 
   * (in columns)  of the cell
   * representing in the table layout the cell element.
   */
  public Integer getColSpan(AuthorElement cell) {
    Integer colSpan = null;

    AttrValue attrValue = cell.getAttribute("column_span");
    if(attrValue != null) {
      // The attribute was found.
      String cs = attrValue.getValue();
      if(cs != null) {        
        try {
          colSpan = new Integer(cs);
        } catch (NumberFormatException ex) {
          // The attribute value was not a number.
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        }     
      }   
    }
    return colSpan;
  }

  /**
   * Extracts the integer specifing what is the 
   * height (in rows) of the cell
   * representing in the table layout the cell element.
   */
  public Integer getRowSpan(AuthorElement cell) {
    Integer rowSpan = null;

    AttrValue attrValue = cell.getAttribute("row_span");
    if(attrValue != null) {
      // The attribute was found.
      String rs = attrValue.getValue();
      if(rs != null) {        
        try {
          rowSpan = new Integer(rs);
        } catch (NumberFormatException ex) {
          // The attribute value was not a number.
        }     
      }   
    }
    return rowSpan;
  }

  /**
   * @return true considering the column specifications always available.
   */
  public boolean hasColumnSpecifications(AuthorElement tableElement) {
    return true;
  }

  /**
   * Ignored. We do not extract data from the 
   * <code>table</code> element. 
   */
  public void init(AuthorElement table) {
  }

  public String getDescription() {
    return 
      "Implementation for the Simple Documentation Framework table layout.";
  }
}

TableColumnWidthProvider.java

package simple.documentation.framework.extensions;
import java.util.ArrayList;
import java.util.List;
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import ro.sync.ecss.extensions.api.AuthorDocumentController;
import ro.sync.ecss.extensions.api.AuthorOperationException;
import ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider;
import ro.sync.ecss.extensions.api.WidthRepresentation;
import ro.sync.ecss.extensions.api.node.AttrValue;
import ro.sync.ecss.extensions.api.node.AuthorElement;

/**
 * 
 * Simple Documentation Framework table column width provider.
 *
 */
public class TableColumnWidthProvider implements AuthorTableColumnWidthProvider {

 /**
  * Cols start offset
  */
 private int colsStartOffset;

 /**
  * Cols end offset
  */
 private int colsEndOffset;

 /**
  * Column widths specifications
  */
 private List<WidthRepresentation> colWidthSpecs = new ArrayList<WidthRepresentation>();

 /**
  * The table element
  */
 private AuthorElement tableElement;

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#commitColumnWidthModifications(ro.sync.ecss.extensions.api.AuthorDocumentController, ro.sync.ecss.extensions.api.WidthRepresentation[], java.lang.String)
  */
 public void commitColumnWidthModifications(AuthorDocumentController authorDocumentController,
   WidthRepresentation[] colWidths, String tableCellsTagName) throws AuthorOperationException {
  if ("td".equals(tableCellsTagName)) {
   if (colWidths != null && tableElement != null) {
    if (colsStartOffset >= 0 && colsEndOffset >= 0 && colsStartOffset < colsEndOffset) {
     authorDocumentController.delete(colsStartOffset,
       colsEndOffset);
    }
    String xmlFragment = createXMLFragment(colWidths);
    int offset = -1;
    AuthorElement[] header = tableElement.getElementsByLocalName("header");
    if (header != null && header.length > 0) {
     // Insert the cols elements before the 'header' element 
     offset = header[0].getStartOffset();
    }
    if (offset == -1) {
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     throw new AuthorOperationException("No valid offset to insert the columns width specification.");
    }
    authorDocumentController.insertXMLFragment(xmlFragment, offset);
   }
  }
 }

 /**
  * Creates the XML fragment representing the column specifications.
  *
  * @param widthRepresentations
  * @return The XML fragment as a string.
  */
 private String createXMLFragment(WidthRepresentation[] widthRepresentations) {
  StringBuffer fragment = new StringBuffer();
  String ns = tableElement.getNamespace();
  for (int i = 0; i < widthRepresentations.length; i++) {
   WidthRepresentation width = widthRepresentations[i];
   fragment.append("<customcol");
   String strRepresentation = width.getWidthRepresentation();
   if (strRepresentation != null) {
    fragment.append(" width=\"" + width.getWidthRepresentation() + "\"");
   }
   if (ns != null && ns.length() > 0) {
    fragment.append(" xmlns=\"" + ns + "\"");
   }
   fragment.append("/>");
  }
  return fragment.toString();
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#commitTableWidthModification(ro.sync.ecss.extensions.api.AuthorDocumentController, int, java.lang.String)
  */
 public void commitTableWidthModification(AuthorDocumentController authorDocumentController,
   int newTableWidth, String tableCellsTagName) throws AuthorOperationException {
  if ("td".equals(tableCellsTagName)) {
   if (newTableWidth > 0) {
    if (tableElement != null) {
     String newWidth = String.valueOf(newTableWidth);

     authorDocumentController.setAttribute(
       "width",
       new AttrValue(newWidth),
       tableElement);
    } else {
     throw new AuthorOperationException("Cannot find the element representing the table.");
    }
   }
  }
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#getCellWidth(ro.sync.ecss.extensions.api.node.AuthorElement, int, int)
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  */
 public List<WidthRepresentation> getCellWidth(AuthorElement cellElement, int colNumberStart,
   int colSpan) {
  List<WidthRepresentation> toReturn = null;
  int size = colWidthSpecs.size();
  if (size >= colNumberStart && size >= colNumberStart + colSpan) {
   toReturn = new ArrayList<WidthRepresentation>(colSpan);
   for (int i = colNumberStart; i < colNumberStart + colSpan; i ++) {
    // Add the column widths
    toReturn.add(colWidthSpecs.get(i));
   }
  }
  return toReturn;
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#getTableWidth(java.lang.String)
  */
 public WidthRepresentation getTableWidth(String tableCellsTagName) {
  WidthRepresentation toReturn = null;
  if (tableElement != null && "td".equals(tableCellsTagName)) {
   AttrValue widthAttr = tableElement.getAttribute("width");
   if (widthAttr != null) {
    String width = widthAttr.getValue();
    if (width != null) {
     toReturn = new WidthRepresentation(width, true);
    }
   }
  }
  return toReturn;
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#init(ro.sync.ecss.extensions.api.node.AuthorElement)
  */
 public void init(AuthorElement tableElement) {
  this.tableElement = tableElement;
  AuthorElement[] colChildren = tableElement.getElementsByLocalName("customcol");
  if (colChildren != null && colChildren.length > 0) {
   for (int i = 0; i < colChildren.length; i++) {
    AuthorElement colChild = colChildren[i];
    if (i == 0) {
     colsStartOffset = colChild.getStartOffset();
    } 
    if (i == colChildren.length - 1) {
     colsEndOffset = colChild.getEndOffset();
    }
    // Determine the 'width' for this col.
    AttrValue colWidthAttribute = colChild.getAttribute("width");
    String colWidth = null;
    if (colWidthAttribute != null) {
     colWidth = colWidthAttribute.getValue();
     // Add WidthRepresentation objects for the columns this 'customcol' specification
     // spans over.
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     colWidthSpecs.add(new WidthRepresentation(colWidth, true));
    }
   }
  }
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#isAcceptingFixedColumnWidths(java.lang.String)
  */
 public boolean isAcceptingFixedColumnWidths(String tableCellsTagName) {
  return true;
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#isAcceptingPercentageColumnWidths(java.lang.String)
  */
 public boolean isAcceptingPercentageColumnWidths(String tableCellsTagName) {
  return true;
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#isAcceptingProportionalColumnWidths(java.lang.String)
  */
 public boolean isAcceptingProportionalColumnWidths(String tableCellsTagName) {
  return true;
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#isTableAcceptingWidth(java.lang.String)
  */
 public boolean isTableAcceptingWidth(String tableCellsTagName) {
  return "td".equals(tableCellsTagName);
 }

 /**
  * @see ro.sync.ecss.extensions.api.AuthorTableColumnWidthProvider#isTableAndColumnsResizable(java.lang.String)
  */
 public boolean isTableAndColumnsResizable(String tableCellsTagName) {
  return "td".equals(tableCellsTagName);
 }

 /**
  * @see ro.sync.ecss.extensions.api.Extension#getDescription()
  */
 public String getDescription() {
  return "Implementation for the Simple Documentation Framework table layout.";
 } 
}

ReferencesResolver.java

package simple.documentation.framework;

import java.io.IOException;
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import java.net.MalformedURLException;
import java.net.URL;

import javax.xml.transform.sax.SAXSource;

import org.apache.log4j.Logger;
import org.xml.sax.EntityResolver;
import org.xml.sax.InputSource;
import org.xml.sax.SAXException;
import org.xml.sax.XMLReader;

import ro.sync.ecss.extensions.api.AuthorAccess;
import ro.sync.ecss.extensions.api.AuthorReferenceResolver;
import ro.sync.ecss.extensions.api.node.AttrValue;
import ro.sync.ecss.extensions.api.node.AuthorElement;
import ro.sync.ecss.extensions.api.node.AuthorNode;

/**
 * Resolver for content referred by elements named 'ref' with a 
 *    'location' attribute.
 */
public class ReferencesResolver implements AuthorReferenceResolver {

  /**
   * Logger for logging.
   */
  private static Logger logger = Logger.getLogger(
          ReferencesResolver.class.getName());

  /**
   * Verifies if the handler considers the node to have references.
   * 
   * @param node The node to be analyzed.
   * @return <code>true</code> if it is has references.
   */
  public boolean hasReferences(AuthorNode node) {
    boolean hasReferences = false;
    if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
      AuthorElement element = (AuthorElement) node;
      if ("ref".equals(element.getLocalName())) {
        AttrValue attrValue = element.getAttribute("location");
        hasReferences = attrValue != null;
      }
    }
    return hasReferences;
  }

  /**
   * Returns the name of the node that contains the expanded referred content.
   * 
   * @param node The node that contains references.
   * @return The display name of the node.
   */
  public String getDisplayName(AuthorNode node) {
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    String displayName = "ref-fragment";
    if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
      AuthorElement element = (AuthorElement) node;
      if ("ref".equals(element.getLocalName())) {
        AttrValue attrValue = element.getAttribute("location");
        if (attrValue != null) {
          displayName = attrValue.getValue();
        }
      }
    }
    return displayName;
  }

  /**
   * Resolve the references of the node. 
   * 
   * The returning SAXSource will be used for creating the referred content 
   * using the parser and source inside it.
   * 
   * @param node        The clone of the node.
   * @param systemID  The system ID of the node with references.
   * @param authorAccess The author access implementation.
   * @param entityResolver The entity resolver that can be used to resolve: 
   * 
   * <ul>
   *  <li>Resources that are already opened in editor. 
   *  For this case the InputSource will contains the editor content.</li>
   *  <li>Resources resolved through XML catalog.</li>
   * </ul>
   * 
   * @return The SAX source including the parser and the parser's input source.
   */
  public SAXSource resolveReference(
      AuthorNode node, 
      String systemID, 
      AuthorAccess authorAccess,
      EntityResolver  entityResolver) {
    SAXSource saxSource = null;

    if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
      AuthorElement element = (AuthorElement) node;
      if ("ref".equals(element.getLocalName())) {
        AttrValue attrValue = element.getAttribute("location");
        if (attrValue != null) {
          String attrStringVal = attrValue.getValue();
          try {
            URL absoluteUrl = new URL(new URL(systemID), 
                    authorAccess.correctURL(attrStringVal));

            InputSource inputSource = entityResolver.resolveEntity(null, 
                    absoluteUrl.toString());
            if(inputSource == null) {
              inputSource = new InputSource(absoluteUrl.toString());
            }
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            XMLReader xmlReader = authorAccess.newNonValidatingXMLReader();
            xmlReader.setEntityResolver(entityResolver);

            saxSource = new SAXSource(xmlReader, inputSource);
          } catch (MalformedURLException e) {
            logger.error(e, e);
          } catch (SAXException e) {
            logger.error(e, e);
          } catch (IOException e) {
            logger.error(e, e);
          }
        }
      }
    }

    return saxSource;
  }

  /**
   * Get an unique identifier for the node reference. 
   * 
   * The unique identifier is used to avoid resolving the references 
   *     recursively.
   * 
   * @param node The node that has reference.
   * @return  An unique identifier for the reference node.
   */
  public String getReferenceUniqueID(AuthorNode node) {
    String id = null;
    if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
      AuthorElement element = (AuthorElement) node;
      if ("ref".equals(element.getLocalName())) {
        AttrValue attrValue = element.getAttribute("location");
        if (attrValue != null) {
          id = attrValue.getValue();
        }
      }
    }
    return id;
  }

  /**
   * Return the systemID of the referred content.
   *
   * @param node The reference node.
   * @param authorAccess The author access.
   * 
   * @return The systemID of the referred content.
   */
  public String getReferenceSystemID(AuthorNode node, 
          AuthorAccess authorAccess) {
    String systemID = null;
    if (node.getType() == AuthorNode.NODE_TYPE_ELEMENT) {
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      AuthorElement element = (AuthorElement) node;
      if ("ref".equals(element.getLocalName())) {
        AttrValue attrValue = element.getAttribute("location");
        if (attrValue != null) {
          String attrStringVal = attrValue.getValue();
          try {
            URL absoluteUrl = new URL(node.getXMLBaseURL(), 
                authorAccess.correctURL(attrStringVal));
            systemID = absoluteUrl.toString();
          } catch (MalformedURLException e) {
            logger.error(e, e);
          }
        }
      }
    }
    return systemID;
  }

  /**
   * Verifies if the references of the given node must be refreshed
   * when the attribute with the specified name has changed.
   * 
   * @param node The node with the references.
   * @param attributeName The name of the changed attribute.
   * @return <code>true</code> if the references must be refreshed.
   */
  public boolean isReferenceChanged(AuthorNode node, String attributeName) {
    return "location".equals(attributeName);
  }

  /**
   * @return The description of the author extension.
   */
  public String getDescription() {
    return "Resolves the 'ref' references";
  }
}

CustomRule.java

package simple.documentation.framework;

import org.xml.sax.Attributes;

import ro.sync.ecss.extensions.api.DocumentTypeCustomRuleMatcher;

public class CustomRule implements 
                 DocumentTypeCustomRuleMatcher {
  /**
   * Checks if the root namespace is the one 
   * of our documentation framework.
   */
  public boolean matches(
      String systemID, 
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      String rootNamespace,
      String rootLocalName, 
      String doctypePublicID,
      Attributes rootAttributes) {

    return 
      "http://www.oxygenxml.com/sample/documentation".equals(rootNamespace);
  }

  public String getDescription() {
    return 
  "Checks if the current Document Type Association is matching the document.";
  }
}

DefaultElementLocatorProvider.java

package ro.sync.ecss.extensions.commons;

import org.apache.log4j.Logger;

import ro.sync.ecss.extensions.api.link.ElementLocator;
import ro.sync.ecss.extensions.api.link.ElementLocatorException;
import ro.sync.ecss.extensions.api.link.ElementLocatorProvider;
import ro.sync.ecss.extensions.api.link.IDTypeVerifier;

/**
 * Default implementation for locating elements based on a given link. 
 * Depending on the link structure the following cases are covered:
 * - xinclude element scheme :  element(/1/2) see 
 *        http://www.w3.org/TR/2003/REC-xptr-element-20030325/
 * - ID based links : the link represents the value of an attribute of type ID
 */
public class DefaultElementLocatorProvider implements ElementLocatorProvider {
  /** * Logger for logging. */
  private static Logger logger = Logger.getLogger(
          DefaultElementLocatorProvider.class.getName());
  /**
   * @see ro.sync.ecss.extensions.api.link.ElementLocatorProvider#
   *     getElementLocator(ro.sync.ecss.extensions.api.link.IDTypeVerifier, 
   *     java.lang.String)
   */
  public ElementLocator getElementLocator(IDTypeVerifier idVerifier, 
          String link) {
    ElementLocator elementLocator = null;
    try {
      if(link.startsWith("element(")){
        // xpointer element() scheme
        elementLocator = new XPointerElementLocator(idVerifier, link);
      } else {
        // Locate link element by ID
        elementLocator = new IDElementLocator(idVerifier, link);
      }
    } catch (ElementLocatorException e) {
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      logger.warn("Exception when create element locator for link: " 
          + link + ". Cause: " + e, e);
    }
    return elementLocator;
  }

  /**
   * @see ro.sync.ecss.extensions.api.Extension#getDescription()
   */
  public String getDescription() {
    return 
    "Default implementation for locating elements based on a given link. \n" + 
    "The following cases are covered: xinclude element scheme " 
        + "and ID based links.";
  }
}

XPointerElementLocator.java

package ro.sync.ecss.extensions.commons;

import java.util.Stack;
import java.util.StringTokenizer;

import org.apache.log4j.Logger;

import ro.sync.ecss.extensions.api.link.Attr;
import ro.sync.ecss.extensions.api.link.ElementLocator;
import ro.sync.ecss.extensions.api.link.ElementLocatorException;
import ro.sync.ecss.extensions.api.link.IDTypeVerifier;

/**
 * Element locator for links that have the one of the following pattern:
 * <ul>
 *   <li>element(elementID) - locate the element with the same id</li>
 *   <li>element(/1/2/5) - A child sequence appearing alone identifies an 
 *   element by means of stepwise navigation, which is directed by a 
 *   sequence of integers separated by slashes (/); each integer n locates 
 *   the nth child element of the previously located element. </li>
 *   <li>element(elementID/3/4) - A child sequence appearing after an 
 *   NCName identifies an element by means of stepwise navigation, 
 *   starting from the element located by the given name.</li>
 * </ul>
 *   
 */
public class XPointerElementLocator extends ElementLocator {

  /** 
   * Logger for logging. 
   */
  private static Logger logger = Logger.getLogger(
          XPointerElementLocator.class.getName());

  /**
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   * Verifies if a given attribute is of a type ID.
   */
  private IDTypeVerifier idVerifier;

  /**
   * XPointer path, the path to locate the linked element.
   */
  private String[] xpointerPath;

  /**
   * The stack with indexes in parent of the current iterated elements.
   */
  private Stack currentElementIndexStack = new Stack();

  /**
   * The number of elements in xpointer path.
   */
  private int xpointerPathDepth;

  /**
   * If true then the XPointer path starts with an element ID.
   */
  private boolean startWithElementID = false;

  /**
   * The depth of the current element in document, incremented in startElement.
   */
  private int startElementDepth = 0;

  /**
   * Depth in document in the last endElement event. 
   */
  private int endElementDepth = 0;

  /**
   * The index in parent of the previous iterated element. Set in endElement().
   */
  private int lastIndexInParent;

  /**
   * Constructor.
   * 
   * @param idVerifier Verifies if an given attribute is of type ID. 
   * @param link The link that gives the element position.    
   * @throws ElementLocatorException  When the link format is not supported.
   **/
  public XPointerElementLocator(IDTypeVerifier idVerifier, String link) 
          throws ElementLocatorException {
    super(link);
    this.idVerifier = idVerifier;

    link = link.substring("element(".length(), link.length() - 1);

    StringTokenizer stringTokenizer = new StringTokenizer(link, "/", false);
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    xpointerPath = new String[stringTokenizer.countTokens()];
    int i = 0;
    while (stringTokenizer.hasMoreTokens()) {
      xpointerPath[i] = stringTokenizer.nextToken();
      boolean invalidFormat = false;

      // Empty xpointer component is not supported
      if(xpointerPath[i].length() == 0){
        invalidFormat = true;
      }

      if(i > 0){
        try {
          Integer.parseInt(xpointerPath[i]);
        } catch (NumberFormatException e) {
          invalidFormat = true;
        }
      }

      if(invalidFormat){
        throw new ElementLocatorException(
        "Only the element() scheme is supported when locating XPointer links." 
        + "Supported formats: element(elementID), element(/1/2/3), 
            element(elemID/2/3/4).");
      }
      i++;
    }

    if(Character.isDigit(xpointerPath[0].charAt(0))){
      // This is the case when xpointer have the following pattern /1/5/7
      xpointerPathDepth = xpointerPath.length;
    } else {
      // This is the case when xpointer starts with an element ID
      xpointerPathDepth = -1;
      startWithElementID  = true;
    }
  }

  /**
   * @see ro.sync.ecss.extensions.api.link.ElementLocator#endElement(
   *     java.lang.String, java.lang.String, java.lang.String)
   */
  public void endElement(String uri, String localName, String name) {
    endElementDepth = startElementDepth;
    startElementDepth --;
    lastIndexInParent = ((Integer)currentElementIndexStack.pop()).intValue();
  }

  /**
   * @see ro.sync.ecss.extensions.api.link.ElementLocator#startElement(
   *    java.lang.String, java.lang.String, java.lang.String, 
   *    ro.sync.ecss.extensions.api.link.Attr[])
   */
  public boolean startElement(String uri, String localName, 
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          String name, Attr[] atts) {
    boolean linkLocated = false;
    // Increase current element document depth
    startElementDepth  ++;

    if (endElementDepth != startElementDepth) {
      // The current element is the first child of the parent
      currentElementIndexStack.push(new Integer(1));
    } else {
      // Another element in the parent element
      currentElementIndexStack.push(new Integer(lastIndexInParent + 1));
    }

    if (startWithElementID) {
      // This the case when xpointer path starts with an element ID.
      String xpointerElement = xpointerPath[0];
      for (int i = 0; i < atts.length; i++) {
        if(xpointerElement.equals(atts[i].getValue())){
          if(idVerifier.hasIDType(
              localName, uri, atts[i].getQName(), atts[i].getNamespace())){
            xpointerPathDepth = startElementDepth + xpointerPath.length - 1;
            break;
          }            
        }
      }
    }

    if(xpointerPathDepth == startElementDepth){
      // check if xpointer path matches with the current element path
      linkLocated = true;
      try {        
        int xpointerIdx = xpointerPath.length - 1;
        int stackIdx = currentElementIndexStack.size() - 1;
        int stopIdx = startWithElementID ? 1 : 0;
        while (xpointerIdx >= stopIdx && stackIdx >= 0) {
          int xpointerIndex = Integer.parseInt(xpointerPath[xpointerIdx]);
          int currentElementIndex = ((Integer)currentElementIndexStack.
                  get(stackIdx)).intValue();
          if(xpointerIndex != currentElementIndex) {
            linkLocated = false;
            break;
          }

          xpointerIdx--;
          stackIdx--;
        }

      } catch (NumberFormatException e) {
        logger.warn(e,e);
      }
    }
    return linkLocated;
  }
}
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IDElementLocator.java

package ro.sync.ecss.extensions.commons;

import ro.sync.ecss.extensions.api.link.Attr;
import ro.sync.ecss.extensions.api.link.ElementLocator;
import ro.sync.ecss.extensions.api.link.ExtensionUtil;
import ro.sync.ecss.extensions.api.link.IDTypeVerifier;

/**
 * Implementation of an ElementLocator that treats the link as the value of an 
 *     attribute with the type ID.
 */
public class IDElementLocator extends ElementLocator {

  /**
   * Class able to tell if a given attribute is of type ID.
   */
  private IDTypeVerifier idVerifier;

  /**
   * Constructor.
   * 
   * @param idVerifier It tells us if an attribute is of type ID.
   * @param link The link used to identify an element.
   */
  public IDElementLocator(IDTypeVerifier idVerifier, String link) {
    super(link);
    this.idVerifier = idVerifier;
  }

  /**
   * @see ro.sync.ecss.extensions.api.link.ElementLocator#endElement(
   *         java.lang.String, java.lang.String, java.lang.String)
   */
  public void endElement(String uri, String localName, String name) {
    // Nothing to do.
  }

  /**
   * @see ro.sync.ecss.extensions.api.link.ElementLocator#startElement(
   *    java.lang.String, java.lang.String, java.lang.String, 
   *    ro.sync.ecss.extensions.api.link.Attr[])
   */
  public boolean startElement(String uri, String localName, 
          String name, Attr[] atts) {
    boolean elementFound = false;
    for (int i = 0; i < atts.length; i++) {
      if (link.equals(atts[i].getValue())) {
        if("xml:id".equals(atts[i].getQName())) {
          // xml:id attribute
          elementFound = true;          
        } else {
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          // check if attribute has ID type
          String attrLocalName = 
            ExtensionUtil.getLocalName(atts[i].getQName());
          String attrUri = atts[i].getNamespace();
          if (idVerifier.hasIDType(localName, uri, attrLocalName, attrUri)) {
            elementFound = true;
          }
        }
      }
    }

    return elementFound;
  }
}
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Chapter 8. Grid Editor
Introduction
In the grid editor the XML document is displayed as a structured grid of nested tables in which the text content can be
modified by non technical users without editing directly the XML tags. The tables can be expanded and collapsed with
a mouse click to show or hide the elements of the document as needed. Also the document structure can be changed
easily with drag and drop operations on the grid components. The tables can be zoomed using Ctrl-+ , Ctrl-- , Ctrl-0
or Ctrl-mouse wheel.

Figure 8.1. The Grid Editor

You can switch between the text tab and the grid tab of the editor panel with the two buttons Text and Grid available
at the bottom of the editor panel. Also the switch can be performed with the actions Document+Edit mode → Grid and
Document+Edit mode → Text

If the edited document is associated with a schema (DTD, XML Schema, Relax NG, etc.), the editor offers content
completion for the element and attributes names and values. If you choose to insert an element that has required content,
it will be inserted automatically including the subtree of needed elements and attributes.

To display the content completion popup you have to start editing, for example by double clicking the cell. When
editing, pressing CTRL SPACE redisplays the popup.
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Figure 8.2. Content Completion in Grid Editor

Layouts: Grid and Tree
The grid editor has two modes for the layout. The default one is the "grid" layout. This smart layout of the grid editor
detects the recurring elements in the XML document and creates tables having as columns the children (including the
attributes) of these elements. In this way it is possible to have tables nested in other tables, reflecting the structure of
your document.

Figure 8.3. Grid Layout

The other layout mode is "tree"-like. This layout does not create any table, it presents the structure of the document
directly.

Figure 8.4. Tree Layout

You can switch between the two modes using the menu: Document+Grid Layout → Grid mode/Tree mode

Navigating the grid
When you open a document first in the grid tab, the document is collapsed so that it shows just the root element and
its attributes.
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Figure 8.5. Initial configuration of grid tab

The grid disposition of the node names and values are very similar to a web form or a dialog. The same set of key
shortcuts used to select dialog components are used in the grid. For instance moving to the next editable value in a
table row is done using the TAB key. Moving to the previous cell employs the SHIFT+TAB key. Changing a value
assumes pressing the ENTER key or start typing directly the new value, and, when the editing is finished, pressing
ENTER again to commit the data into the document.

The arrows and the PAGE UP/DOWN keys can be used for navigation. By pressing SHIFT while using these keys
you can create a selection zone. To add other nodes that are not close to this zone, you can use the mouse and the
CTRL (COMMAND on Mac OS X) key.

The following key combination may be used to scroll the grid:

• CTRL + UP Scrolls the grid upwards

• CTRL + DOWN Scrolls the grid downwards

• CTRL + LEFT Scrolls the grid to the left

• CTRL + RIGHT Scrolls the grid to the right

A left arrow sign displayed to the left of the node name indicates that this node has child nodes. You can click this
sign to display the children. The expand/collapse actions can be also invoked by pressing the NumPad + PLUS and
NumPad + MINUS keys.

A set of expand/collapse actions can be accessed from the submenu Expand/Collapse of the contextual menu.

The same actions can be accessed from the menu: Document+Grid Expand/Collapse

Expand All Action

Expands the selection and all its children. 

Collapse All Action

Collapses the selection and all its children. 

Expand Children Action
Expands all the children of the selection but not the selection.

Collapse Children Action
Collapses all the children of the selection but not the selection.
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Collapse Others
Collapses all the siblings of the current selection but not the selection.

Specific Grid Actions
In order to access these actions you can click the column header and choose from the contextual menu the item: Table

The same set of actions are available in the menu: Document and the first ones in the grid toolbar: Perspective+Show
Toolbar → Grid

Sorting a Table Column
You can sort the table by a specific column. The sorting can be either ascending or descending.

The icons for this pair of actions are: 

The sorting result depends on the data type of the column content and it can be different in case of number or text in-
formation. The editor analyses automatically the content and decides what type of sorting to apply. If there is present
a mixed set of values in the column, a dialog will be displayed allowing to choose the correct type.

Figure 8.6. Sort Type Dialog

Inserting a row to a table
You can add a row by either a copy/paste operation over a row, or directly, by invoking the action from the contextual
menu: Table → Insert row

The icon is: 

A shorter way of inserting a new row is to move the selection over the row header, and then to press ENTER. The row
header is the zone in the left of the row that holds the row number. The inserted row will be below the selection.

Inserting a column into a table
You can insert a column after the selected one, using the action from the contextual menu: Table → Insert column

The icon is: 

Clearing the content of a column
You can clear all the cells from a column, using the action from the contextual menu: Table → Clear content
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Adding nodes
Using the contextual menu you can add nodes before, after, or as last child of the currently selected node.

The sub-menus containing detailed actions are: Insert beforeInsert afterAppend child

Duplicating nodes
A quicker way of creating new nodes is to duplicate the existing ones.

The action is available in the contextual menu: Duplicate

The same actions may be found in the menu: Document+Grid Edit → Duplicate

Refresh layout
When using drag and drop to reorganize the document, the resulted layout may be different from the expected one.
For instance, the layout may contain a set of sibling tables that could be joined together. To force the layout to be re-

computed you can use the Refresh action  .

The action is available in the contextual menu: Refresh selected

The same action can be found in the menu: Document+Grid Edit → Refresh selected

Start editing a cell value
You can simply press ENTER after you have selected the grid cell.

The action is found in the menu: Document+Grid Edit → Start Editing 

Stop editing a cell value
You can either press ENTER when already in cell editing.

The action is found in the menu: Document+Grid Edit → End Editing 

To cancel the editing without saving in the document the current changes, you have to press the ESC key.

Drag and Drop(DnD) in the Grid Editor
The DnD features of the grid editor make easy the arrangement of the different sections in your XML document.

Using DnD you can:

• Copy or move a set of nodes.

• Change the order of columns in the tables.

• Move the rows from the tables.

These operations are available for single selection and multiple selection.
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Note that when dragging the editor paints guide-lines showing accepted locations where the nodes can be dropped.

Nodes can be dragged outside the grid editor and text from other applications can be dropped inside the grid. See Copy
and Paste in the Grid Editor for details.

Copy and Paste in the Grid Editor
The selection in the grid is a bit complex relative to the selection in a text component. It consists of a current selected
cell and additional selected cells. These additional cells are either "hand picked" by the user using the mouse, or are
implied by the current selected cell. To be more specific, let's consider you click the name of the column - this becomes
the current selected cell; the editor automatically extends the selection so it contains also all the cells from that column.
The current selected cell is painted with a color that is different from the rest of the selection.

You can select discontinuous regions of nodes and place them in the clipboard using the copy action. Pasting these
nodes may be done in two ways, relative to the current selected cell: by default as brother, just below (after) , or as last
child of the selected cell.

The paste as child action is available in the contextual menu: Paste as Child

The same action can be found in the menu: Document+Grid Edit → Paste as Child

The copied nodes from the grid can be pasted also into the text editor or other applications. When copying from grid
into the text editor or other text based applications the inserted string represents the nodes serialization. The nodes
from tables can be copied using HTML or RTF in table format. The resulting cells contain only the concatenated values
of the text nodes.

Figure 8.7. Copying from grid to other editors
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In the grid editor you can paste wellformed xml content or tab separated values from other editors. If you paste xml
content the result will be the insertion of the nodes obtained by parsing this content.

Figure 8.8. Copying XML data into grid

If the pasted text contains multiple lines of tab separated values it can be considered as a matrix of values. By pasting
this matrix of values into the grid editor the result will be a matrix of cells. If the operation is performed inside existing
cells the values from these cells will be overwritten and new ones will be created if needed. This is useful for example
when trying to transfer data from Excel like editors into grid editor.

Figure 8.9. Copying tab separated values into grid

Bidirectional Text Support in the Grid Editor
If you are editing documents employing a different text orientation you can change the way text is rendered and edited
in the grid cells.

For this, you can use the shortcut CTRL SHIFT O to toggle from the default left to right text orientation to the right
to left orientation.

Note that this change applies only to the text from the cells, not to the layout of the grid editor.
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Figure 8.10. Default left to right text orientation

Figure 8.11. Right to left text orientation
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Chapter 9.Transforming documents
XML is designed to store, carry, and exchange data, not to display data. When we want to view the data we must either
have an XML compliant user agent or transform it to a format that can be read by other user agents. This process is
known as transformation.

Status messages generated during transformation are displayed in the Information view.

Output formats
Within the current version of <oXygen/> you can transform your XML documents to the following formats without
having to exit from the application. For transformation to formats not listed simply install the tool chain required to
perform the transformation and process the xml files created with <oXygen/> in accordance with the processor instruc-
tions.

PDF Adobe Portable Document Format (PDF) is a compact binary file format that can be viewed and
printed by anyone, anywhere across a broad range of hardware and software using the free PDF
Viewer from Adobe [http://www.adobe.com/products/acrobat/readstep.html].

PS PostScr ipt  i s  the  leading pr int ing technology from Adobe
[http://www.adobe.com:80/products/postscript/main.html] for high-quality, best-in-class printing
solutions ranging from desktop devices to the most advanced digital presses, platemakers, and
large format image setters in the world. Postscript files can be viewed using viewers such as
GhostScript, but are more commonly created as a prepress format.

TXT Text files are Plain ASCII Text and can be opened in any text editor or word processor.

XML XML stands for eXtensible Markup Language and is a W3C [http://www.w3c.org/XML/] standard
markup language, much like HTML, which was designed to describe data. XML tags are not
predefined in XML. You must define your own tags. XML uses a Document Type Definition
(DTD), an XML Schema or a Relax NG schema to describe the data. XML with a DTD, XML
Schema or Relax NG schema is designed to be self-descriptive. XML is not a replacement for
HTML. XML and HTML were designed with different goals:

• XML was designed to describe data and to focus on what data is.

• HTML was designed to display data and to focus on how data looks.

• HTML is about displaying information, XML is about describing information.

XHTML XHTML stands for eXtensible HyperText Markup Language, a W3C
[http://www.w3c.org/MarkUp/] standard. XHTML is aimed to replace HTML. While almost
identical to HTML 4.01, XHTML is a stricter and cleaner version of HTML. XHTML is HTML
defined as an XML application.

All formatting during a transformation is provided under the control of an Extensible Stylesheet (XSLT). Specifying
the appropriate XSLT enables transformation to the above formats and preparation of output files for specific user
agent viewing applications, including:

HTML HTML stands for Hyper Text Markup Language and is a W3C Standard
[http://www.w3c.org/MarkUp/] for the World Wide Web. HTML is a text file containing small
markup tags. The markup tags tell the Web browser how to display the page. An HTML file must
have an htm or html file extension. An HTML file can be created using a simple text editor.
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HTML Help M i c r o s o f t  H T M L  H e l p
[http://msdn.microsoft.com/library/default.asp?url=/library/en-us/htmlhelp/html/vsconHH1Start.asp?frame=true]
is the standard help system for the Windows platform. Authors can use HTML Help to create online
help for a software application or to create content for a multimedia title or Web site. Developers
can use the HTML Help API to program a host application or hook up context-sensitive help to
an application.

JavaHelp JavaHelp software is a full-featured, platform-independent, extensible help system from Sun Mi-
crosystems  [http://java.sun.com/products/javahelp/index.html] that enables developers and authors
to incorporate online help in applets, components, applications, operating systems, and devices.
JavaHelp is a free product and the binaries for JavaHelp can be redistributed.

Eclipse Help Eclipse Help is the help system incorporated in the Eclipse platform [http://www.eclipse.org/] that
enables Eclipse plugin developers to incorporate online help in their plugins.

Many other target formats are possible, these are the most popular. The basic condition for transformation to any format
is that your source document is well-formed. Always, make sure that the XSL used for the transformation is the right
one according to the desired output format and with the input source definition. For example, if you want to transform
to HTML format using a DocBook html stylesheet, your source xml document should respect the DocBook DTD.

An XSL stylesheet specifies the presentation of a class of XML documents by describing how an instance of the class
is transformed into an output document by using special formatting vocabulary.

XSL consists of three parts:

XSL Transformations (XSLT) XSLT is a language for transforming XML documents.

XML Path (XPath) Language XPath is an expression language used by XSLT to access or refer parts of an
XML document. (XPath is also used by the XML Linking specification).

XSL Formatting Objects (XSL:FO) XSL:FO is an XML vocabulary for specifying formatting semantics.

<oXygen/> supports XSLT/XPath version 1.0 using Saxon 6.5.5, Xalan, Xsltproc, MSXML (3.0, 4.0, .NET) and
XSLT/XPath 2.0 by using Saxon 9.1.0.7 B, Saxon 9.1.0.7 SA and Saxon.NET.

Transformation scenario
Before transforming the current edited XML document in <oXygen/> you must define a transformation scenario to
apply to that document. A scenario is a set of values for various parameters defining a transformation. It is not related
to any particular document but to a document type:

Scenarios that apply to XML files Such a scenario contains the location of an XSLT stylesheet that is applied on
the edited XML document and other transform parameters.

Scenarios that apply to XSLT files Such a scenario contains the location of an XML document that the edited XSLT
stylesheet is applied on and other transform parameters.

Scenarios that apply to XQuery files Such a scenario contains the location of an XML source that the edited XQuery
file is applied on and other transform parameters. When the XML source is a
native XML database the XML source field of the scenario is empty because
the XML data is read with XQuery functions like document(). When the XML
source is a local XML file the URL of the file is specified in the XML input
field of the scenario.
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A scenario can be created at document type level or at global level. The scenarios defined at document type level are
available only for the documents that match that document type. The global scenarios are available for any document.

In order to apply a transformation scenario one has to press the Apply Transformation Scenario button from the
Transformation toolbar.

Batch transformation
Alternatively, a transform action can be applied on a batch of files from the Project view's contextual menu without
having to open the files:

• Apply Transformation Scenario - applies to each selected file the transformation scenario associated to that file.
If the currently processed file does not have an associated transformation scenario then a warning is displayed in
the Warnings view to let the user know about it.

• Transform with ... - allows the user to select one transformation scenario to be applied to each one of the currently
selected files.

Built-in transformation scenarios
If the Apply Transformation Scenario button from the Transformation toolbar is pressed, currently there is no scenario
associated with the edited document and the edited document contains a "xml-stylesheet" processing instruction referring
to a XSLT stylesheet (commonly used for display in Internet browsers), then <oXygen/> will prompt the user and offer
the option to associate the document with a default scenario containing in the XSL URL  field the URL from the href
attribute of the processing instruction. This scenario will have the "Use xml-stylesheet declaration" checkbox set by
default, will use Saxon as transformation engine, will perform no FO processing and will store the result in a file with
the same URL as the edited document except the extension which will be changed to html. The name and path will be
preserved because the output file name is specified with the help of two editor variables: ${cfd} and ${cfn}.

<oXygen/> comes with preconfigured built-in scenarios for usual transformations that enable the user to obtain quickly
the desired output: associate one of the built-in scenarios with the current edited document and then apply the scenario
with just one click.

Defining a new transformation scenario
The Configure Scenario dialog is used to associate a scenario from the list of all scenarios with the edited document
by selecting an entry from the list. The dialog is opened by pressing the Configure Transformation Scenario button on
the Transformation toolbar of the document view. Once selected the scenario will be applied with only one click on
the Apply Transformation button on the same toolbar. Pressing the Apply Transformation button before associating a
scenario with the edited document will invoke first the Configure Scenario dialog and then apply the selected scenario.

Open the Configure Transformation dialog by selecting Document+ Transformation → Configure transformation
scenario. (Ctrl+Shift+C) Complete the dialog as follows:
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Figure 9.1. The Configure Transformation Dialog - XSLT Tab

XML URL Specifies an input XML file to be used for the transformation. Please note that
this URL is resolved through the catalog resolver. If the catalog does not have
a mapping for the URL, then the editor will try to use the file directly.

Note

If the transformation engine is Saxon 9 and a custom URI resolver is
configured for Saxon 9 in Preferences then the XML input of the trans-
formation is passed to that URI resolver.

The following buttons are shown immediately after the input field:

Insert Editor Variables Opens a pop-up menu allowing to intro-
duce special <oXygen/> editor variables
in the XML URL field.

Browse for local file Opens a local file browser dialog allow-
ing to select a local file name for the text
field.

Browse for remote file Opens a URL browser dialog allowing
to select a remote file name for the text
field.

Browse for archived file Opens a zip archive browser dialog allow-
ing to select a file name from a zip
archive that will be inserted in the text
field.
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Open in editor Opens the file with the path specified in
the text field in an editor panel.

XSL URL Specifies an input XSL file to be used for the transformation. Please note that
this URL is resolved through the catalog resolver. If the catalog does not have
a mapping for the URL, then the editor will try to use the file directly.

The above set of browsing buttons are available also for this input.

Use "xml-stylesheet" declaration Use the stylesheet declared with an "xml-stylesheet" declaration instead of the
stylesheet specified in the XSL URL field. By default this checkbox is not selec-
ted and the transformation applies the XSLT stylesheet specified in the XSL
URL field. If it is checked the scenario applies the stylesheet specified explicitly
in the XML document with the xml-stylesheet processing instruction.

Transformer This combo box contains all the transformer engines available for applying the
stylesheet. These are the built-in engines and the external engines defined in the
user preferences. If you want to change the default selected engine just select
other engine from the drop down list of the combo box. For XQuery/XSLT files
only, if no validation scenario is associated, the transformer engine will be used
in validation process, if has validation support.

Parameters Opens the dialog for configuring the XSLT parameters. In this dialog you set
any global XSLT parameters of the main stylesheet set in the XSL URL field or
of the additional stylesheets set with the button Additional XSLT stylesheets.

Append header and footer Opens a dialog for specifying a URL for a header HTML file added at the begin-
ning of the result of an HTML transformation and a URL for a footer HTML
file added at the end of the HTML result of the transformation.

Additional XSLT stylesheets Opens the dialog for adding XSLT stylesheets which are applied on the result
of the main stylesheet specified in the XSL URL field. This is useful when a
chain of XSLT stylesheets must be applied to the input XML document.

Extensions Opens the dialog for configuring the XSLT/XQuery extension jars or classes
which define extension Java functions or extension XSLT elements used in the
XSLT/XQuery transformation.

Advanced options Configure advanced options specific for the Saxon B/SA engine. They are the
same options as the ones set in the user preferences but they are configured as
a specific set of transformation options for each transformation scenario. By
default if you do not set a specific value in the transformation scenario each
advanced option has the same value as the global option with the same name
set in the user preferences.

The advanced options include two options that are not available globally in the
user preferences: the initial XSLT template and the initial XSLT mode of the
transformation. They are Saxon specific options that allow imposing the name
of the first XSLT template that starts the XSLT transformation or the initial
mode of transformation.
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Figure 9.2. The advanced options of Saxon SA/Saxon B

The advanced options specific for Saxon SA/Saxon B are:

Allow calls on extension functions If checked the stylesheet is allowed to call external Java functions.

Version warnings If checked display a warning when it is applied to an XSLT 1.0 stylesheet.

DTD based validation of the source
file

If checked the source XML file is validated against the declared DTD

Line numbering Include the line number in errors for the

Handling of recoverable stylesheet
errors

Policy for handling recoverable errors in the stylesheet: Allows the user to choose
how dynamic errors will be handled. Either one of the following options can be
selected: recover silently, recover with warnings or signal the error and do not
attempt recovery.

Strip whitespaces Strip whitespaces feature can be one of the three options: All, Ignorable, None.

All strips all whitespace text nodes from source documents before
any further processing, regardless of any xsl:strip-space declar-
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ations in the stylesheet, or any xml:space attributes in the source
document.

Ignorable strips all ignorable whitespace text nodes from source documents
before any further processing, regardless of any xsl:strip-space
declarations in the stylesheet, or any xml:space attributes in the
source document. Whitespace text nodes are ignorable if they
appear in elements defined in the DTD or schema as having
element-only content.

None strips no whitespace before further processing. (However,
whitespace will still be stripped if this is specified in the
stylesheet using xsl:strip-space).

Initial mode Specifies to the transformer the initial template mode

Initial template Specifies the name of the initial template to the transformer. When specified,
the XML input URL for the transformation scenario is optional.

Validation of the source file Available only for Saxon SA.

Schema validation This mode requires an XML Schema and
determines whether source documents
should be parsed with schema-validation
enabled.

Lax schema validation This mode determines whether source
documents should be parsed with
schema-validation enabled if an XML
Schema is provided.

Disable schema validation This determines whether source docu-
ments should be parsed with schema-
validation disabled.

Validation errors in the results tree
treated as warnings

Available only for Saxon SA. If checked, all validation errors are treated as
warnings, otherwise they are treated as fatal.

When creating a scenario that applies to an XML file, <oXygen/> fills the XML URL with the default variable
"${currentFile}". This means the input for the transformation is taken from the currently edited file. You can modify
this value to other file path. This is the case of currently editing a section from a large document, and you want the
transformation to be performed on the main document, not the section. You can specify in this case either a full absolute
path: file:/c:/project/docbook/test.xml or a path relative to one of the editor variables, like the current project file:
${pdu}/docbook/test.xml .

When the scenario applies to XSL files, the field XSL URL is containing ${currentFile}. Just like in the XML case,
you can specify here the path to a master stylesheet. The path can be configured using the editor variables.

Note

If you are sharing the scenarios by saving them into the project file (see Transformation Scenario Sharing) it is
recommended that the URL fields to have path values relative to the project editor variable${pdu}.
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Figure 9.3. The Configure Transformation Dialog - FO Processor Tab

Checkbox Perform FO Processing Enable or disable applying an FO processor (either the built-in Apache FOP
engine or an external engine defined in Preferences) during the transformation.

Radio button XSLT result as input The FO processor is applied to the result of the XSLT transformation defined
on the XSLT tab of the dialog.

Radio button Edited document as in-
put

The FO processor is applied directly to the current edited document.

Combo box Method The output format of the FO processing: PDF, PostScript or plain text.

Combo box Processor The FO processor, which can be the built-in Apache FOP processor or an external
processor.
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Figure 9.4. The Configure Transformation Dialog - Output Tab

Radio button Prompt for file At the end of the transformation a file browser dialog will be displayed for
specifying the path and name of the file which will store the transformation
result.

Text field Save As The path of the file where it will be stored the transformation result. The path
can include special <oXygen/> editor variables.

Check box Open in browser If this is checked <oXygen/> will open automatically the transformation result
in a browser application specific for the type of that result (HTML/XHTML,
PDF, text).

Radio button Saved file When Open in browser is selected this button can be selected to specify that
<oXygen/> should open automatically at the end of the transformation the file
specified in the Save As text field.

Radio button Other location When Open in browser is selected this button can be used to specify that
<oXygen/> should not open the file specified in the Save As text field, it should
open the file specified in the text field of the Other location radio button. The
file path can include special <oXygen/> editor variables.

Check box Open in editor When this is checked the transformation result set in the Save As field is opened
in a new editor panel in <oXygen/> with the appropriate built-in editor type: if
the result is an XML file it is opened with the built-in XML editor, if it is an
XSL-FO file it is opened with the built-in FO editor, etc.

Check box Show As XHTML It is enabled only when Open in browser is disabled. If this is checked <oXygen/>
will display the transformation result in a built-in XHTML browser panel at the
bottom of the <oXygen/> window.
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Important

When transforming very large documents you should be aware that en-
abling this feature will result in a very long time necessary for rendering
the transformation result in the XHTML result viewer panel. This drawback
appears due to the built-in Java XHTML browser implementation. In this
situations if you wish to see the XHTML result of the transformation you
should use an external browser by checking the Open in browser checkbox.

Check box Show As XML If this is checked <oXygen/> will display the transformation result in an XML
viewer panel at the bottom of the <oXygen/> window with syntax highlight
specific for XML documents.

Check box Show As SVG If this is checked <oXygen/> will display the transformation result in a SVG
viewer panel at the bottom of the <oXygen/> window by rendering the result
as a SVG image.

Text field Image URLs are relative
to

If Show As XHTML is checked this text field specifies the path for resolving
image paths contained in the transformation result.

XSLT Stylesheet Parameters

The global parameters of the XSLT stylesheet used in the transformation scenario are configured from the dialog
available from the Parameters button:

Figure 9.5. Configure parameters dialog
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The table presents all the parameters of the XSLT stylesheet and all imported and included stylesheets with their current
values. If a parameter value was not edited then the table presents its default value. The bottom panel presents the default
value of the parameter selected in the table, a description of the parameter if it is available and the system ID of the
stylesheet that declares it.

For setting the value of a parameter declared in the stylesheet in a namespace, for example:

<xsl:param name="p:param" xmlns:p="namespace">default</xsl:param>

use the following expression in the Name column of the Parameters dialog:

{namespace}param

The buttons of the dialog have the following functions:

Add Add a new parameter to the list.

Edit Edit the value of the selected parameter.

Disable Reset the selected parameter to the default value. This button is enabled only for parameters with edited
values, that is values set in this dialog with the Edit button.

Remove Remove the selected parameter from the list. It is enabled only for parameters added to the list with the
Add button.

The editor variables displayed at the bottom of the dialog (${frameworks}, ${home}, ${cfd}, etc) can be used in the
values of the parameters to make the value independent of the location of the XSLT stylesheet or the XML document.

Additional XSLT Stylesheets

The list of additional XSLT stylesheets can be edited in the dialog opened by the button "Additional XSLT Stylesheets".

Figure 9.6. Edit additional XSL stylesheets list dialog

Add Adds a stylesheet in the "Additional XSLT stylesheets" list using a file browser dialog , also you can type
an editor variable in the file name field of the browser dialog. The name of the stylesheet will be added in
the list after the current selection.

New Opens a dialog in which you can type the name of a stylesheet. The name is considered relative to the URL
of the current edited XML document. You can use editor variables in the name of the stylesheet. The name
of the stylesheet will be added in the list after the current selection.

Remove Deletes the selected stylesheet from the "Additional XSLT stylesheets" list.
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Open Opens the selected stylesheet in a separate view .

Up Move the selected stylesheet up in the list.

Down Move the selected stylesheet down in the list.

This dialog allows the user to add additional XSLT stylesheets to the transformation.

Figure 9.7. Add a new stylesheet

The path specified in the URL text field can include special <oXygen/> editor variables.

XSLT/XQuery Extensions

The edit extensions dialog is used to specify the jars and classes containing extension functions called from the
XSLT/XQuery file of the current transformation scenario.

Figure 9.8. The XSLT/XQuery Extension Edit Dialog

An extension function called from the XSLT or XQuery file of the current transformation scenario will be searched
in the specified extensions in the order of the list displayed in the dialog. For changing the order of the items the user

must select the item that must be moved to other position in the list and press the  up and  down buttons.

Creating a Transformation Scenario

Use the following procedure to create a scenario.

1. Select Document+ Transformation → Configure transformation scenario (Ctrl+Shift+C) to open the Configure
Transformation dialog.

2. Click the Duplicate Scenario button of the dialog to create a copy of the current scenario.

3. Click in the Name field and type a new name.

4. Click OK or Transform Now to save the scenario.

300

Transforming documents



Sharing the Transformation Scenarios. Project Level
Scenarios.
In the upper part of the dialog showing the list of scenarios you will find two radio buttons controlling where the
scenarios are stored.

Figure 9.9. Transformation Scenario List Dialog

Selecting "Global Scenarios" ensures that the scenarios are saved in the user home directory.

After changing the selection to "Project Scenarios", the scenario list will be stored in the project file. If your project
is saved on a source versioning/sharing system (CVS, SVN, Source Safe, etc..) then your team can use the scenarios
you defined.

Predefined scenarios are presented according to the current document's detected type. The screenshot above shows all
default scenarios for a DocBook 4 document and one custom transformation scenario. The key symbol before the
scenario name indicates that the scenario can only be modified from the Document Type Association options page.

Other preferences can also be stored at the project level. For more information, see the Preference Sharing section.

Transformation Scenarios view
The list of transformation scenarios may be easier to manage for some users as a list presented in a dockable and
floating view called Transformation Scenarios.
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Figure 9.10. The Scenarios view

The actions available on the right click menu allow the same operations as in the dialog Configure Transformation
Scenario: creating, editing, executing, duplicating and removing a transformation scenario.

XSL-FO processors
The <oXygen/> installation package is distributed with the Apache FOP [http://xml.apache.org/fop/index.html]
(Formatting Objects Processor) for rendering your XML documents to PDF. FOP is a print and output independent
formatter driven by XSL Formatting Objects. FOP is implemented as a Java application that reads a formatting object
tree and renders the resulting pages to a specified output.

Tip

To include PNG images in the final PDF document you need the JIMI [http://java.sun.com/products/jimi/] or
JAI [http://java.sun.com/products/java-media/jai/] libraries. For TIFF images you need the JAI
[http://java.sun.com/products/java-media/jai/] library. For PDF images you need the fop-pdf-images library
[http://www.jeremias-maerki.ch/download/fop/pdf-images/]. These libraries are not bundled with <oXygen/>
(JIMI and JAI due to Sun's licensing). Using them is as easy as downloading them and creating a external FO
processor based on the built-in FOP libraries and the extension library. The external FO processor created in
Preferences will have a command line like:

java -cp "${oxygenInstallDir}/lib/xercesImpl.jar:
${oxygenInstallDir}/lib/fop.jar:${oxygenInstallDir}/lib/
avalon-framework-4.2.0.jar:
${oxygenInstallDir}/lib/batik-all-1.7.jar:${oxygenInstallDir}/lib/
commons-io-1.3.1.jar:
${oxygenInstallDir}/lib/xmlgraphics-commons-1.3.1.jar:
${oxygenInstallDir}/lib/commons-logging-1.0.4.jar:
${oxygenInstallDir}/lib/saxon9sa.jar:${oxygenInstallDir}/lib/
saxon9-dom.jar:
${oxygenInstallDir}/lib/xalan.jar:${oxygenInstallDir}/lib/
serializer.jar:
${oxygenInstallDir}/lib/resolver.jar:${oxygenInstallDir}/lib/
fop-pdf-images-1.3.jar:
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${oxygenInstallDir}/lib/PDFBox-0.7.3.jar" 
org.apache.fop.cli.Main -fo ${fo} -${method} ${out}

You need to add to the classpath JimiProClasses.zip for JIMI and jai_core.jar, jai_codec.jar and mlibwrapper_jai.jar
for JAI. For the JAI package you also need to include the directory containing the native libraries (mlib_jai.dll
and mlib_jai_mmx.dll on Windows) in the PATH system variable.

The MacOS X version of the JAI library can be downloaded from http://www.apple.com/downloads/ma-
cosx/apple/java3dandjavaadvancedimagingupdate.html. In order to use it, install the downloaded package.

Other FO processors can be configured in the Preferences -> FO Processors panel.

Add a font to the built-in FOP
If an XML document is transformed to PDF using the built-in Apache FOP processor but it contains some Unicode
characters that cannot be rendered by the default PDF fonts then a font that is capable to render these characters must
be configured and embedded in the PDF result.

Locate font

First, you have to find out the name of a font that has the glyphs for the special characters you used. One font that
covers the majority of characters, including Japanese, Cyrillic and Greek, is Arial Unicode MS. In the following is
described how to embed the true type fonts in the output PDF. Embedding the fonts is necessary to ensure your document
is portable.

On Windows the fonts are located into the C:\Windows\Fonts directory. On Mac they are placed in /Lib-
rary/Fonts. To install a new font on your system is enough to copy it in the Fonts directory.

Generate font metrics file

Generate a FOP font metrics file from the TrueType font file. This example reads the Windows Arial Unicode MS file
and generates an arialuni.xml font metrics file in the current directory. FOP includes an utility application for
this task.

I assume you have opened a terminal or command line console and changed the working directory to the oxygen install
directory. The FOP files are stored in the lib subdirectory of the Oxygen install directory.

Create the following script file in the Oxygen installation directory. The relative paths specified in the following script
file are relative to the Oxygen installation directory so if you decide to create it in other directory you have to adapt
the file paths.

For the Mac OS X: ttfConvert.sh

#!/bin/sh 
export LIB=lib
export CMD="java -cp 
"$LIB/fop.jar:$LIB/avalon-framework-4.2.0.jar:$LIB/xercesImpl.jar"
export CMD=$CMD org.apache.fop.fonts.apps.TTFReader" 
export FONT_DIR='/Library/Fonts' 
$CMD $FONT_DIR/Arialuni.ttf Arialuni.xml

For Linux: ttfConvert.sh

#!/bin/sh 
export LIB=lib
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export CMD="java -cp 
"$LIB/fop.jar:$LIB/avalon-framework-4.2.0.jar:$LIB/xercesImpl.jar"
export CMD=$CMD org.apache.fop.fonts.apps.TTFReader" 
export FONT_DIR='/Library/Fonts' 
$CMD $FONT_DIR/Arialuni.ttf Arialuni.xml

For Windows: ttfConvert.bat

set LIB=lib
set CMD="java -cp 
"%LIB%\fop.jar;%LIB%\avalon-framework-4.2.0.jar;%LIB%\xercesImpl.jar"
set CMD=%CMD% org.apache.fop.fonts.apps.TTFReader"
set FONT_DIR=C:\Windows\Fonts
%CMD% %FONT_DIR%\Arialuni.ttf Arialuni.xml

The FONT_DIR can be different on your system. Make sure it points to the correct font directory. If java executable
is not in the PATH you will have to specify the full path for java.

Execute the script. On Linux and Mac OS X you have to use sh ttfConvert.sh from the command line.

Note

If Oxygen was installed by an administrator user and now it is used by a standard user who does not have write
permission in the Oxygen installation folder (for example on Windows Vista or Linux) then the output location
of the font metrics file should be a directory where the user has write permission, for example:

%CMD% %FONT_DIR%\Arialuni.ttf C:\temp_dir\Arialuni.xml

If the font has bold and italic variants, you will have to convert those also. For this you can modify the script, by adding
two more lines:

$CMD $FONT_DIR/Arialuni-Bold.ttf Arialuni-Bold.xml
                      $CMD $FONT_DIR/Arialuni-Italic.ttf Arialuni-Italic.xml

In our case the font Arial Unicode MS is not having a Bold and Italic variant, so you will leave the script unchanged.

Register font to FOP configuration

Create a file and name it for example fopConfiguration.xml.

<fop version="1.0">
  <base>file:/C:/path/to/FOP/font/metrics/files/</base>
  <source-resolution>72</source-resolution>
  <target-resolution>72</target-resolution>
  <default-page-settings height="11in" width="8.26in"/>

  <renderers>
    <renderer mime="application/pdf">
      <filterList>
        <value>flate</value>
      </filterList>
      <fonts>
          <font metrics-url="Arialuni.xml" kerning="yes" 
                embed-url="file:/Library/Fonts/Arialuni.ttf">
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              <font-triplet name="Arialuni" style="normal" 
                    weight="normal"/>
          </font>
      </fonts>
    </renderer>
  </renderers>
</fop>

The embed-url attribute points to the TTF file to be embedded. You have to specify it using the URL convention. The
metrics-url attribute points to the font metrics file with a path relative to the base element. The triplet refers to the
unique combination of name, weight, and style (italic) for each variation of the font. In our case is just one triplet, but
if the font had variants, we would have to specify one for each variant. Here is an hypothetic example for the Arial
Unicode if it had italic and bold variants:

<fop version="1.0">
  ...
    <fonts>
        <font metrics-url="Arialuni.xml" kerning="yes" 
              embed-url="file:/Library/Fonts/Arialuni.ttf">
            <font-triplet name="Arialuni" style="normal" 
                  weight="normal"/>
        </font>
        <font metrics-url="Arialuni-Bold.xml" kerning="yes" 
              embed-url="file:/Library/Fonts/Arialuni-Bold.ttf">
            <font-triplet name="Arialuni" style="normal" 
                  weight="bold"/>
        </font>
        <font metrics-url="Arialuni-Italic.xml" kerning="yes" 
              embed-url="file:/Library/Fonts/Arialuni-Italic.ttf">
            <font-triplet name="Arialuni" style="italic" 
                  weight="normal"/>
        </font>
    </fonts>
  ...
</fop>

More details about the FOP configuration file are available on http://xmlgraphics.apache.org/fop/0.93/configura-
tion.htmlthe FOP website.

Set FOP configuration file in Oxygen

Go to menu Options → Preferences → XML → XSLT / FO / XQuery → FO Processors

Click the browse button near Configuration file for the built-in FOP text field and locate the fopConfigura-
tion.xml file.

Click on the OK button to accept the changes.

Add new font to FO output

You can do this by changing the stylesheet parameters.
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DocBook Stylesheets

Create a transformation scenario that makes use of the docbook.xsl file from the [oXygen-install-
dir]/frameworks/docbook/xsl/fo directory. You must do this in the Configure Transformation Scenario
dialog.

Figure 9.11. The Configure Transformation Scenario dialog

Also you can use the predefined Docbook PDF scenario which is based on this Docbook stylesheet. Run a test trans-
formation to make sure the PDF is generated. The Unicode characters are not yet displayed correctly. We have to
specify to the stylesheet to generate FO output that uses the font Arialuni.

Click on the Parameters button in the transformation scenario edit dialog.
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Figure 9.12. The Edit Scenario dialog

Enter the following parameters indicating the font for the body text and for the titles:

Table 9.1. XSL FO Parameters

ValueName

Arialunibody.font.family

Arialunititle.font.family

TEI Stylesheets

Create a transformation scenario that makes use of the tei.xsl file from the [oXygen-install-
dir]/frameworks/tei/xsl/fo directory. Also you can use the predefined TEI PDF scenario which is based
on this XSLT stylesheet. Run a test transformation to make sure the PDF is generated. Just like for the Docbook, we
have to specify to the stylesheet to generate FO output that uses the font Arialuni.

Click on the Parameters button of the transformation scenario edit dialog. Enter the following parameters indicating
the font for the body text and for other sections:

Table 9.2. XSL FO Parameters

ValueName

ArialunibodyFont

ArialunisansFont

Make the transformation again. The characters are now displayed correctly.
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DITA-OT Stylesheets

For setting a font to the Apache FOP processor in the transformation of a DITA map with an IDIOM FOP transformation
there are two files that must be modified :

• font-mappings.xml - available in folder ${frameworks}/dita/DITA-OT/demo/fo/cfg/fo: the
font-face element included in each element physical-font having the attribute char-set="default" must contain the
name of the font (Arialuni in our example) instead of the default value

• fop.xconf - available in folder ${frameworks}/dita/DITA-OT/demo/fo/fop/conf: an element font must
be inserted in the element fonts which is inside the element renderer having the attribute mime="application/pdf"
as in the above fopConfiguration.xml file, for example:

<renderer mime="application/pdf">
  . . .
   <fonts>
       <font metrics-url="Arialuni.xml" kerning="yes" 
           embed-url="file:/Library/Fonts/Arialuni.ttf">
           <font-triplet name="Arialuni" style="normal" 
               weight="normal"/>
       </font>
   </fonts>
  . . .
</renderer>

Common transformations
The following examples use the DocBook XSL Stylesheets to illustrate how to configure <oXygen/> for transformation
to the various target formats.

Note

<oXygen/> comes with the latest versions of the DocBook and TEI frameworks including special XSLT stylesheets
for DocBook and TEI documents. DocBook XSL extensions for the Saxon and Xalan processors are included
in the frameworks/docbook/xsl/extensions directory.

The following steps are common to all the example procedures below.

1. Set the editor focus to the document to be transformed.

2. Select Document+ Transformation → Configure transformation scenario (Ctrl+Shift+C) to open the Configure
Transformation dialog.

3. If you want to edit an existing scenario select that scenario in the list and press the Edit button. If you want to
create a new scenario press the New button. If you want to create a new scenario based on an existing scenario
select the scenario in the list and press the Duplicate button.

4. Select the XSLT tab.

5. Click the "Browse for an input XSL file button". The Open dialog is displayed.

308

Transforming documents



Note

During transformations the Editor Status Bar will show "Transformation - in progress". The transformation is
successfully complete when the message "XSL transformation successful" displays. If the transform fails the
message "XSL transformation failed" is displayed as an error message in the Messages Panel. The user can stop
the transformation process, if the transformer offers such support, by pressing the "Stop transformation" button.
In this case the message displayed in the status bar will be "Transformation stopped by user". For the specific
case of an XQuery transformation, if you chose an NXD transformer, pressing the "Stop transformation" button
will have no effect, as NXD transformers offer no such support.

PDF Output
1. Change directory to [oxygen]/frameworks/docbook/xsl/fo/.

2. Select docbook.xsl, click Open. The dialog closes.

3. Select the FOP tab.

4. Check the Perform FOP option. The remaining options are enabled.

5. Select the following options:

a. XSLT result as input.

b. PDF as method.

c. Built-in(Apache FOP) as processor.

6. Select the Output tab.

7. In the Save As field enter the output file name relative to the current directory (YourFileName.pdf ) or the
path and output file name (C:\FileDirectory\YourFileName.pdf).

8. Optionally, uncheck the XHTML and XML check boxes in the Show As group.

9. Click Transform Now. The transformation is started.

PS Output
1. Change directory to [oxygen]/frameworks/docbook/xsl/fo/.

2. Select docbook.xsl, click Open. The dialog closes.

3. Select the FOP tab.

4. Check the Perform FOP option. The remaining options are enabled.

5. Select the following options:

a. XSLT result as input.

b. PS as method.

c. Built-in(Apache FOP) as processor.
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6. Select the Output tab.

7. In the Save As field enter the output file name relative to the current directory (YourFileName.ps ) or the
path and output file name (C:\FileDirectory\YourFileName.ps).

8. Optionally, uncheck the XHTML and XML check boxes in the Show As group.

9. Click Transform Now. The transformation is started.

TXT Output
1. Change directory to [oxygen]/frameworks/docbook/xsl/fo/.

2. Select docbook.xsl, click Open. The dialog closes.

3. Select the FOP tab.

4. Check the Perform FOP option. The remaining options are enabled.

5. Select the following options:

a. XSLT result as input.

b. TXT as method.

c. Built-in(Apache FOP) as processor.

6. Select the Output tab.

7. In the Save As field enter the output file name relative to the current directory (YourFileName.txt ) or the
path and output file name (C:\FileDirectory\YourFileName.txt).

8. Optionally, uncheck the XHTML and XML check boxes in the Show As group.

9. Click Transform Now. The transformation is started.

HTML Output
1. Change directory to [oxygen]/frameworks/docbook/xsl/html/.

2. Select docbook.xsl, click Open. The dialog closes.

3. Select the FOP tab.

4. Uncheck the Perform FOP option. The FOP options are disabled.

5. Select the Output tab.

6. In the Save As field enter the output file name relative to the current directory (YourFileName.html ) or
the path and output file name (C:\FileDirectory\YourFileName.html).

a. If your pictures are not located relative to the out location, check the XHTML check box in the Show As
group.

b. Specify the path to the folder or URL where the pictures are located
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7. Click Transform Now. The transformation is started.

HTML Help Output
1. Change directory to [oxygen]/frameworks/docbook/xsl/htmlhelp/.

2. Select htmlhelp.xsl, click Open. The dialog closes.

3. Set the XSLT parameter base.dir, it identifies the output directory. (If not specified, the output directory is system
dependent.) Also set the manifest.in.base.dir to 1 in order to have the project files copied in output as well.

4. Select the FOP tab.

5. Uncheck the Perform FOP option. The FOP options are disabled.

6. Click Transform Now. The transformation is started.

7. At the end of the transformation you should find the html, hhp and hhc files in the base.dir directory.

8. Download Microsoft's HTML Help Workshop and install it.

9. Integrate HTML Help Workshop as an external tool. Go to  Options → Preferences+External Tools

10. Create a new external tool entry named HTMLHelp with Working directory being the same with the base.dir
parameter defined above and Configure command set to [path to installed HTML Help Workshop]\hhc.exe <file-
name>, where <filename> is the name of the html help project file (for example htmlhelp.hhp).

11. Run the tool from Tools → External Tools → HTMLHelp.

Java Help Output
1. Change directory to [oxygen]/frameworks/docbook/xsl/javahelp/.

2. Select javahelp.xsl, click Open. The dialog closes.

3. Set the XSLT parameter base.dir, it identifies the output directory. (If not specified, the output directory is system
dependent.)

4. Select the FOP tab.

5. Uncheck the Perform FOP option. The FOP options are disabled.

6. Click Transform Now. The transformation is started.

XHTML Output
1. Change directory to [oxygen]/frameworks/docbook/xsl/xhtml/.

2. Select docbook.xsl, click Open. The dialog closes.

3. Select the FOP tab.

4. Uncheck the Perform FOP option. The FOP options are disabled.

5. Select the Output tab.
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6. In the Save As field enter the output file name relative to the current directory (YourFileName.html ) or
the path and output file name (C:\FileDirectory\YourFileName.html).

a. If your pictures are not located relative to the out location, check the XHTML check box in the Show As
group.

b. Specify the path to the folder or URL where the pictures are located

7. Click Transform Now. The transformation is started.

Supported XSLT processors
The <oXygen/> distribution comes with the following XSLT processors:

Xalan 2.7.1 Xalan-Java http://xml.apache.org/xalan-j/ is an XSLT processor for transforming XML
documents into HTML, text, or other XML document types. It implements XSL Transform-
ations (XSLT) Version 1.0 and XML Path Language (XPath) Version 1.0.

Saxon 6.5.5 Saxon 6.5.5 [http://saxon.sourceforge.net/saxon6.5.5/] is an XSLT processor, which imple-
ments the Version 1.0 XSLT and XPath with a number of powerful extensions. This version
of Saxon also includes many of the new features that were first defined in the XSLT 1.1
working draft, but for conformance and portability reasons these are not available if the
stylesheet header specifies version="1.0".

Saxon 9.1.0.7 B Saxon-B http://saxon.sf.net/ implements the "basic" conformance level for XSLT 2.0 and
XQuery. The term basic XSLT 2.0 processor is defined in the draft XSLT 2.0 specifications:
it is a conformance level that requires support for all features of the language other than
those that involve schema processing.

Saxon 9.1.0.7 SA Saxon 9SA http://www.saxonica.com/ is the schema-aware edition of Saxon 9 and it is one
of the built-in processors of <oXygen/>. Saxon SA includes an XML Schema processor,
and schema-aware XSLT, XQuery, and XPath processors.

The validation in schema aware transformations is done according to the W3C XML Schema
1.0 specification or according to the W3C XML Schema 1.1 one. This can be configured in
Preferences.

Besides the above list <oXygen/> supports the following processors:

Xsltproc (libxslt) Libxslt http://xmlsoft.org/XSLT/ is the XSLT C library developed for the Gnome project.
Libxslt is based on libxml2 the XML C library developed for the Gnome project. It also
implements most of the EXSLT set of processor-portable extensions functions and some
of Saxon's evaluate and expressions extensions. The libxml2 version included in <oXy-
gen/> is 2.6.32 and the libxslt version is 1.1.23

<oXygen/> uses Libxslt through its command line tool (Xsltproc). The XSLT processor
is included into the distribution kit of the stand-alone version for Windows and Mac OS
X. Because there are differences between different Linux distributions, on Linux you
must install Libxslt on your machine as a separate application and set the PATH variable
to contain the Xsltproc executable.

The Xsltproc processor can be configured from the XSLTPROC options page.
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Note

Known problem: file paths containing spaces are not handled correctly in the
LIBXML processor. For example the built-in XML catalog files of the predefined
document types (DocBook, TEI, DITA, etc) are not handled by LIBXML if
<oXygen/> is installed in the default location on Windows (C:\Program Files) be-
cause the built-in XML catalog files are stored in the frameworks subdirectory of
the installation directory which in this case contains at least a space character.

MSXML 3.0/4.0 MSXML 3.0/4.0 http://msdn.microsoft.com/xml/ is available only on Windows 2000,
Windows NT and Windows XP platforms. It can be used for transformation .

<oXygen/> use the Microsoft XML parser through its command line tool  msxsl.exe
[http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnxml/html/msxsl.asp]

Because msxsl.exe is only a wrapper, Microsoft Core XML Services (MSXML) must be
installed on the computer otherwise you get an corresponding warning. You can get the
latest Microsoft XML parser from Microsoft web-site  http://www.microsoft.com/down-
loads/details.aspx?FamilyId=3144B72B-B4F2-46DA-B4B6-C5D7485F2B42&display-
lang=en  [http://www.microsoft.com/downloads/details.aspx?
FamilyId=3144B72B-B4F2-46DA-B4B6-C5D7485F2B42&displaylang=en]

MSXML .NET MSXML .NET http://msdn.microsoft.com/xml/ is available only on Windows NT4,
Windows 2000 and Windows XP platforms. It can be used for transformation .

<oXygen/> performs XSLT transformations and validations using .NET Framework's
XSLT implementation (System.Xml.Xsl.XslTransform class) through the nxslt
[http://www.tkachenko.com/dotnet/nxslt.html] command line utility. The nxslt version
included in <oXygen/> is 1.6.

You should have the .NET Framework version 1.0 already installed on your system oth-
erwise you get this warning: MSXML.NET requires .NET Framework version 1.0 to be
installed. Exit code: 128

You can get the .NET Framework version 1.0 from Microsoft web-site  http://www.mi-
crosoft.com/downloads/details.aspx?FamilyID=d7158dee-a83f-4e21-b05a-
009d06457787&displaylang=en  [http://www.microsoft.com/downloads/details.aspx?
FamilyID=d7158dee-a83f-4e21-b05a-009d06457787&displaylang=en]

.NET 1.0 A transformer based on the System.Xml 1.0 library available in the .NET 1.0 and .NET
1.1 frameworks from Microsoft (http://msdn.microsoft.com/xml/). It is available only on
Windows.

You should have the .NET Framework version 1.0 or 1.1 already installed on your system
otherwise you get this warning: MSXML.NET requires .NET Framework version 1.0 to
be installed. Exit code: 128

You can get the .NET Framework version 1.0 from Microsoft web-site  http://www.mi-
crosoft.com/downloads/details.aspx?FamilyID=d7158dee-a83f-4e21-b05a-
009d06457787&displaylang=en  [http://www.microsoft.com/downloads/details.aspx?
FamilyID=d7158dee-a83f-4e21-b05a-009d06457787&displaylang=en]

.NET 2.0 A transformer based on the System.Xml 2.0 library available in the .NET 2.0 framework
from Microsoft (http://msdn.microsoft.com/xml/). It is available only on Windows.
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You should have the .NET Framework version 2.0 already installed on your system oth-
erwise you get this warning: MSXML.NET requires .NET Framework version 2.0 to be
installed. Exit code: 128

You can get the .NET Framework version 2.0 from Microsoft web-site  http://www.mi-
crosoft.com/downloads/details.aspx?FamilyID=9655156b-356b-4a2c-857c-
e62f50ae9a55&DisplayLang=en  [http://www.microsoft.com/downloads/details.aspx?
FamilyID=9655156b-356b-4a2c-857c-e62f50ae9a55&DisplayLang=en]

Saxon.NET Saxon.NET http://weblog.saxondotnet.org/ is the port of Saxon 9B XSLT processor to
the .NET platform and it is available on a Mozilla Public License 1.0 (MPL) from the
Mozilla [http://www.mozilla.org/MPL/MPL-1.0.html] site.

In order to use it you have to unzip in the <oXygen/> install folder the Saxon.NET distri-
bution which you can download from http://saxon.sourceforge.net/
[http://www.saxondotnet.org/saxon.net/downloads/Saxon.NET-1.0-RC1.zip].

You should have the .NET Framework version 1.1 already installed on your system oth-
erwise you get this warning: Saxon.NET requires .NET Framework 1.1 to be installed.

You can get the .NET Framework version 1.1 from Microsoft web-site  http://www.mi-
crosoft.com/downloads/ThankYou.aspx?familyId=262d25e3-f589-4842-8157-
034d1e7cf3a3&displayLang=en  [http://www.microsoft.com/downloads/ThankYou.aspx?
familyId=262d25e3-f589-4842-8157-034d1e7cf3a3&displayLang=en]

Note

There is no integrated XML Catalog support for MSXML 3.0/4.0 and .NET processors.

The button Transformation options available on the Transformation toolbar allows quick access to the XSLT options
in the <oXygen/> user preferences.

Configuring custom XSLT processors
One can configure other XSLT transformation engines than the ones which come with the <oXygen/> distribution.
Such an external engine can be used for XSLT transformations within <oXygen/>, in the Editor perspective, and is
available in the list of engines in the dialog for editing transformation scenarios.

The output messages of a custom processor are displayed in an output view at the bottom of the <oXygen/> window.
If an output message follows the format of an <oXygen/> linked message then a click on the message in the output
view highlights the location of the message in an editor panel containing the file referred in the message.

Configuring the XSLT processor extensions
paths
The Xalan and Saxon processors support the use of extension elements and extension functions. Unlike a literal result
element, which the stylesheet simply transfers to the result tree, an extension element performs an action. The extension
is usually used because the xslt stylesheet fails in providing adequate functions to the user for accomplishing a more
complex task.

Extensions for Xalan and Saxon are included in [<oXygen/> install directory] \frameworks\docbook\xsl\extensions.
If you want to use the extensions group for Xalan, you have to rename the file "xalan27.jar.ext" to "xalan27.jar". Same
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specifications for Saxon: rename "saxon65.jar.ext" to "saxon65.jar". You can only use one group of extensions at a
time.

Samples on how to use extensions can be found at:

• for Xalan - http://xml.apache.org/xalan-j/extensions.html

• for Saxon 6.5.5 - http://saxon.sourceforge.net/saxon6.5.5/extensions.html

• for Saxon 9.1.0.7 - http://www.saxonica.com/documentation/extensions/intro.html

In order to set an XSLT processor extension (a directory or a jar file), you have to use the Extensions button of the
scenario edit dialog. The old way of setting an extension (using the parameter -Dcom.oxygenxml.additional.classpath)
was deprecated and you should use the extension mechanism of the XSLT transformation scenario.
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Chapter 10. Querying documents
Running XPath expressions

What is XPath
XPath is a language for addressing specific parts of an XML document. XPath, like the Document Object Model
(DOM), models an XML document as a tree of nodes. An XPath expression is a mechanism for navigating through
and selecting nodes from the XML document. An XPath expression is in a way analogous to a Structured Query Language
(SQL) query used to select records from a database.

XPath models an XML document as a tree of nodes. There are different types of nodes, including element nodes, at-
tribute nodes and text nodes. XPath defines a way to compute a string-value for each type of node.

XPath defines a library of standard functions for working with strings, numbers and Boolean expressions.

Examples:

child: : * Select all children of the root node.

.//name Select all elements having the name "name", descendants of the current node.

/catalog/cd[price>10.80]Selects all the cd elements that have a price element with a value larger than 10.80

To find out more about XPath, the following URL is recommended: http://www.w3.org/TR/xpath

<oXygen/>'s XPath console
To use XPath effectively requires at least an understanding of the XPath Core Function Library
[http://www.w3.org/TR/xpath#corelib]. If you have this knowledge the <oXygen/> XPath expression field part of the
current editor toolbar can be used to aid you in XML document development.

In <oXygen/> a XPath 1.0 or XPath 2.0 expression is typed and executed on the current document from the XPath
console available on the XPath toolbar for every open XML document. . Both XPath 2.0 basic and XPath 2.0 schema
aware expressions can be executed in the XPath console.

The content completion assistant that helps in entering XPath expressions in attributes of XSLT stylesheets elements
is also available in the XPath console and offers always proposals dependent of the current context of the cursor inside
the edited document. The set of XPath functions proposed by the assistant depends on the XPath version selected from
the drop-down menu of the XPath button (1.0 or 2.0).

In the following example the cursor is on a person element and the content completion assistant offers all the child
elements of the person element and all XPath 2.0 functions:
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Figure 10.1. Content Completion in the XPath console

The evaluation of the XPath expression tries to resolve the locations of documents referred in the expression through
the XML catalogs which are configured in Preferences and the current XInclude preferences, for example when eval-
uating the collection(URIofCollection) function (XPath 2.0). If you need to resolve the references from the files
returned by the collection() function with an XML catalog set up in the <oXygen/> preferences you have to specify
in the query which is the parameter of the collection() function the name of the class of the XML catalog enabled
parser for parsing these collection files. The class name is ro.sync.xml.parser.CatalogEnabledXMLReader
and you specify it like this:

let $docs := collection(iri-to-uri(
    "file:///D:/temp/test/XQuery-catalog/mydocsdir?recurse=yes;select=*.xml;
    parser=ro.sync.xml.parser.CatalogEnabledXMLReader"))

If you want to see in the XPath console the XPath expression at the current cursor position when navigating in the

document you can check the button  XPath update on caret move.

The results of an XPath query are returned in the Message Panel. Clicking a record in the result list highlights the nodes
within the text editor panel with a character level precision. Results are returned in a format that is a valid XPath ex-
pression:

- [FileName.xml] /node[value]/node[value]/node[value] -
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Figure 10.2. XPath results highlighted in editor panel with character precision

When using the grid editor, clicking a result record will highlight the entire node.

Figure 10.3. XPath results highlighted in the Grid Editor
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Note

XPath 2.0 basic queries are executed using Saxon 9 B engine. XPath 2.0 schema aware queries are executed
using Saxon 9 SA engine.

When the limit of long expressions is reached (60 characters) a dialog pops up and offers to switch the focus to the
XPath builder view. This is a view specially designed to assist you with typing and testing complex XPath 1.0 / 2.0
expressions.

Figure 10.4. Popup dialog to switch to the XPath Builder view

Example 10.1. XPath Utilization with DocBook DTD

Our example is taken from a DocBook book based on the DocBook XML DTD. The book contains a number of
chapters. DocBook defines that chapters as have a <chapter> start tag and matching </chapter> end tag to close the
element. To return all the chapter nodes of the book enter //chapter into the XPath expression field, then Enter. This
will return all the chapter nodes of the DocBook book, in the Message Panel. If your book has six chapters, their will
be six records in the result list. Each record when clicked will locate and highlight the chapter and all sibling nodes
contained between the start and end tags of the chapter.

If we used XPath to query for all example nodes contained in the section 2 node of a DocBook XML document we
would use the following XPath expression //chapter/sect1/sect2/example. If an example node is found in any section
2 node, a result will be returned to the message panel. For each occurrence of the element node a record will be created
in the result list.

In our example an XPath query on the file oxygen.xml  determined that:

- [oxygen.xml] /chapter[1]/sect1[3]/sect2[7]/example[1]

Which means:

In the file oxygen.xml, first chapter, third section level 1, seventh section level 2, the example node found is the
first in the section.

Note

If your project is comprised of a main file with ENTITY references to other files, you can use XPath to return
all the name elements of a certain type by querying the main file. The result list will query all referenced files.

Note

When the edited document is of type XSL the XPath expression typed in the XPath console is applied over the
XML document specified in the transformation scenario associated with the XSL document. <oXygen/> provides
a user preference to be set if you want to apply the XPath expression over the XSL document itself.
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Important

If the document defines a default namespace then <oXygen/> will bind this namespace to the first free prefix
from the list: default, default1, default2, etc. For example if the document defines the default namespace xm-
lns="something" and the prefix default is not associated with a namespace then you can match tags without
prefix in a XPath expression typed in the XPath console by using the prefix default. For example to find all the
level elements when the root element defines a default namespace you should execute in the XPath console the
expression:

//default:level

To define default mappings between prefixes that can be used in the XPath console and namespace URIs go to the 
XPath Options user preferences panel and enter the mappings in the Default prefix-namespace mappings table. The
same preferences panel allows also the configuration of the default namespace used in XPath 2.0 expressions entered
into the XPath toolbar and the creation of different results panels for XPath queries executed on different XML docu-
ments.

To apply a XPath expression relative to the element on which the caret is positioned use the action Document → XML
Document → Copy XPath (Ctrl+Alt+.) (also available on the context menu of the main editor panel) to copy the XPath
expression of the element to the clipboard and the Paste action of the contextual menu of the XPath console to paste
this expression in the console. Then add your relative expression and execute the resulting complete expression.

On Windows the context menu can be displayed with the mouse on a right click or with the keyboard by pressing the
special context menu key available on Windows keyboards.

The XPath Builder View
Complex XPath expressions can be composed with the help of the content completion assistant available for XPath
expressions in a special view called XPath Builder. Also the expressions can be tested in the view by execution on the
edited document. The view is opened from menu Perspective -> Show View.

Figure 10.5. The XPath Builder View
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The Execute button runs the expression on the edited document and takes into account the value selected in the combo
box with the XPath version number: 1.0 or 2.0. Both XPath 2.0 basic and XPath 2.0 schema aware expressions can be

evaluated in this view on the current XML document. The XPath preferences panel is accessible from the  XPath
Options shortcut button near the Execute button. A history list with the XPath expressions evaluated in the past on all
documents opened in the current <oXygen/> session is also available in the bottom area of the view so that new expres-
sions can be composed based on old ones without re-entering the whole expression.

The  XPath update on caret move button enables the XPath Builder view to display the XPath expression at the
current cursor position when navigating in the document.

The evaluation of the XPath expression tries to resolve the locations of documents referred in the expression through
the XML catalogs which are configured in Preferences and the current XInclude preferences, for example when eval-
uating the collection(URIofCollection) function (XPath 2.0).

The results of the XPath query are displayed in the same Message Panel as for the XPath console and are computed
with the same character level precision.

The usual edit actions (Cut, Copy, Paste, Select All, Undo, Redo) are available in the popup menu of the top part of
the view, where XPath expressions are entered. For the history list area of the view the popup menu contains two actions:

• Execute - to execute again the expression selected in the list.

• Remove - to remove the selected expression from the list.
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Chapter 11. Comparing and merging
documents
In large teams composed either of developers or technical writers, the usage of a shared repository for the source or
document files is a must. Often many authors are changing the same file at the same time.

Finding what has been modified in your files and folders can be hard. If your data is changing, you can benefit from
accurate identification and processing of changes in your files and folders with <oXygen/>'s new features: Compare
files and Compare directories. These are powerful and easy to use tools that will do the job fast and thoroughly. With
the new possibilities of differencing and merging, it is now easy to manage multiple changes.

<oXygen/> provides a simple means of performing file and folder comparisons. You can see the differences in your
files and folders and also you can merge the changes.

There are two levels on which the comparison can be done, namely comparing directories or comparing individual
files. These two operations are available from the Tools menu.

Also the comparison tool can be started using command line arguments. In the Oxygen installation folder there are 2
executable shells (diffFiles.bat and diffDirs.bat if running on Windows). You can give one or two command
line arguments to each of these shells.

For example, to start the comparison between 2 directories on Windows use:

diffDirs.bat "c:\Program Files" "c:\ant"

Note that if there are spaces in the path names, the paths need to be surrounded by quotes. Also one argument can be
missing in which case the second directory will be chosen manually by the user.

The same goes for the files diff utility as well.

If you run the diff tool from the command line (diffFiles.exe or diffFiles.bat on Windows, diffFiles.sh
on Linux, diffFilesMac.sh on Mac OS X), you must specify one or two parameters, because Diff Files perform
only two-way comparing.

Directories Comparison
The directories comparison result is presented as a tree of files and directories.The directories that contain different
files are expanded automatically, so you can focus directly on the differences. You can merge the directories' contents
using the copy actions or you can compare and merge the different files by double-clicking on them.
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Figure 11.1. The Compare directories window

The directories comparison user interface
The directory comparison user interface is comprised of the following components:

The Operations Menu

This menu contains the functions available for directories comparison:

Figure 11.2. The Operations Menu

Operations → Perform directories differencing : Performs the comparison of the directories.

Operations → Perform files differencing : Performs the comparison of the files.

Operations → Copy change from left to right : Copies the selected file or folder to the corresponding directory from
the right (if there is no file/folder in the left part the right file/folder will be deleted)

Operations → Copy change from right to left : Copies the selected file or folder to the corresponding directory from
the left (if there is no file/folder in the right part the left file/folder will be deleted)

Operations → Close (Ctrl+W) : Closes the Compare directories window.

323

Comparing and merging documents



Compare Toolbar

Figure 11.3. The Compare toolbar

The available functions are presented in the Operations menu.

For the Algorithm and Diff Options buttons look below at File Comparison / Compare Toolbar

File filters are available; you can choose to see the differences only for XML files, or XSL files for instance.

Directories Selector

Figure 11.4. The Directories Selector

To open the directories you want to compare, select a folder from each "Browse for local file" button. <oXygen/>
keeps track of the folders you are currently working with and those you opened in this window. You can see and select
them from the two combo-boxes.

If you want to compare two archives' content you can select the archives from the "Browse for archive file" button.

Tip

By default <oXygen/> treats supported archives as directories and the comparison is also done with the files inside
them. You can disable this behaviour by unchecking the "Look in archives" checkbox from the Diff preferences
page.

The comparison result
The directory comparison result is presented using a tree of files and directories.
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Figure 11.5. Comparison result

For the files and folders from the compared directories you can see their name, size and their modification date.

If a file or a folder exists only in one of the compared directories, the name of the file or folder will be blue and marked
with

If a file exists in both directories but the content is different, the name of the file will be red and marked with a "not-
equal" sign. <oXygen/> offers an useful option here: you can double-click the line marked with the "not-equal" sign
and a new "File Content Comparison" Window will be opened, showing the differences between the two files.

Files Comparison
The comparison of a pair of files is done by opening them in two editors arranged in a side-by-side layout. You can
edit either the source or the target file. The differences are refreshed when you save the modified document.

325

Comparing and merging documents



Figure 11.6. The Compare Files Window

The window is comprised of the following components:

The Main Menu
The Main Menu provides access to all the functions and features available in this window:

The Source Menu

Here you can select the source file to be compared.

Source → Open : Browses for a file (the source file).

Source → Open URL : Opens URL to be used as a source file. See Open URL for details.

Source → Save : Saves the changes made in the source file.

The Target Menu

Here you can select the target file to be compared.

Target → Open : Browses for a file (the target file).

Target → Open URL : Opens URL to be used as a target file. See Open URL for details.
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Target → Save : Saves the changes made in the target file.

Operations Menu

Operations → Perform files differencing : Performs the comparison of the source and the target files.

Operations → Go to first modification : Selects the first difference in the files. (The button becomes available if the
selection is not on the first modification)

Operations → Go to previous modification : Selects the previous difference in the files. (The button becomes available
if the selection is not on the first modification)

Operations → Go to next modification : Selects the next difference in the files. (The button becomes available if the
selection is not on the last modification)

Operations → Go to last modification : Selects the last difference in the files. (The button becomes available if the
selection is not on the last modification)

Operations → Copy all non-conflicting changes from left to right : Copies the non-conflicting changes from the source
to the target.

Operations → Copy all non-conflicting changes from right to left : Copies the non-conflicting changes from the target
to the source.

Operations → Copy change from left to right : Copies the selected difference from the source to the target.

Operations → Copy changes from right to left : Copies the selected difference from the target to the source.

Operations → Show modification details at word level : Provides Word Level Comparison

Operations → Show modification details at char level : Provides Character Level Comparison

Compare Toolbar
This is where you'll find the operations that can be performed on the source and target files.

Figure 11.7. The Compare Toolbar

The available functions are presented at the Operations menu.

 Perform files differencing Run the diff algorithm selected in the Algorithm combo box on the two selected
files.

 Diff Options Opens the Diff Options page [preferences-diff].

 Go to first modification Scroll the two-way comparison panel to the first difference marked in the two-
way comparison panel.

 Go to previous modification Scroll the two-way comparison panel to the previous difference marked in the
two-way comparison panel.

 Go to next modification Scroll the two-way comparison panel and select the next difference marked in
the two-way comparison panel.
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 Go to last modification Scroll the two-way comparison panel and select the last difference marked in
the two-way comparison panel.

 Copy all non-conflicting changes
from left to right

All the nodes present in the left side file and not present in the right side file are
copied to the right side file.

 Copy change from left to right Copy the current difference marked in the two-way comparison panel from the
left side file to the right side file.

 Copy change from right to left Copy the current difference marked in the two-way comparison panel from the
right side file to the left side file.

 Copy all non-conflicting changes
from right to left

All the nodes present in the right side file and not present in the left side file are
copied to the left side file.

 Show modification details at word
level

The Word algorithm is applied to the current difference marked in the two-way
comparison panel and the result is displayed in a separate dialog.

 Show modification details at char
level

The Characters algorithm is applied to the current difference marked in the two-
way comparison panel and the result is displayed in a separate dialog.

 Enable scrolling synchronization
When one of the two panels is scrolled up or down the other panel is scrolled
in the same direction so that corresponding match of the current difference from
the other panel is displayed at the same time as in the scrolled panel.

 Disable scrolling synchroniza-
tion

When one of the two panels is scrolled up or down the other panel is not scrolled.
The effect is that the corresponding match of the current difference from the
other panel is not displayed at the same time as in the scrolled panel.

Also, <oXygen/> offers you the complete diff solution:

• two XML diff algorithms

• XML Accurate works on small files and it is very precise.

• XML Fast works on larger files but it is less precise than XML Accurate.

• Syntax Aware for the file types known by <oXygen/>, it computes the differences taking into consideration the
syntax of the documents.

• three all-purpose algorithms:

• Lines algorithm computes the differences at line level

• Words algorithm computes the differences at word level

• Characters algorithm computes the differences at character level

• an automatic selection of the algorithm:

• Auto selects the most appropriate algorithm, based on the files' content and size.

Diff Options button It provides quick access to the Diff preferences pane where you set Diff parameters that
will be saved for the next time when you open the Compare Files dialog.
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Files Selector
To open the source and target files where you want to see the differences, select a file from the "Open" or "Open URL"
button. <oXygen/> keeps track of the files you are currently working with and those you opened in this window. You
can see and select them from the two combo-boxes.

You can also save the changes in the source file or the target file by clicking the corresponding "Save" button.

File contents panel
The files are opened in two side-by-side editors. The text view is used, offering a better view of the changes.

The two editors are kept in sync, if you scroll the text in one of them, the other will also scroll to show the difference.
The differences are indicated using highlights connected through colored areas. You can use the "Go to modification"
buttons to navigate between differences or simply select a change by clicking on it in the overview ruler located in the
right-most part of the window. Also the overview ruler contains a success indicator in its upper part that will turn green
in case the are no differences and red if differences are found. You can also do this by clicking on a colored area
between the text editors.

You can edit either the source or the target file. The differences are refreshed when you save the modified document.

You can right-click the text editors for the "Cut", "Copy", "Paste" and "Select all" actions. The Find/Replace dialog is
displayed by pressing Ctrl+F (Cmd+F on Mac). Also there are available the Find/Replace options: F3 used to perform
another search using the last search configuration, and Shift+F3 to perform another search in backward direction using
the last search configuration.

If the compared blocks of text are too large and you want to see the differences at a finer level, you can use the com-
parison at "Word" or "Character" level.

Word Level Comparison
This option is only available if modifications exist between the source and the target file. You can go to Word Level
Comparison by clicking the "Show modification details at word level" button from the Compare Panel or from the
Operations menu.

Figure 11.8. Word Level Comparison
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Character Level Comparison
This option is only available if modifications exist between the source and the target file. You can go to Character
Level Comparison by clicking the "Show modification details at char level" button from the Compare Panel or from
the Operations menu.

Figure 11.9. Character Level Comparison
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Chapter 12. Working with Archives
<oXygen/> offers the means to manipulate files directly from ZIP type archives. By manipulation one should understand
opening and saving files directly in archives, browsing and modifying archive structures. The archive support is
available for all ZIP-type archives, for JAR and ODF formats and for IDML files which are also based on the ZIP
archive format. This means that you can modify, transform, validate files directly from OOXML or ODF packages.

Using files directly from archives
Now you can transform, validate and perform many other operations on files directly from an archive. When selecting

an URL for a specific operation like transformation or validation you can click the Browse for archived file  button
to navigate and choose the file from a certain archive.

Figure 12.1. Browsing for a file in an archive

Browsing and modifying archives' structure
You can navigate archives directly in the Archives Browser view either by opening them from the Project view or by
choosing them in the <oXygen/> file chooser or by dropping them in the Archives browser view from the file explorer.
When the Archive browser view is closed the archived currently opened in it will be unmounted.

Important

If a file extension is not known by <oXygen/> as a supported archive type you can add it from the Archive
preferences page .
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Figure 12.2. Browsing an archive

The following operations are available on the Archive Browser's toolbar:

Open Archive... Open a new archive in the browser. If the extension is not known as an archive extension
you will be directed to the Archive preferences page to add a new extension.

Close Unmount the browsed archive.

New folder... Create a new folder as child of the selected folder in the browsed archive.

New file... Create a new file as child of the selected folder in the browsed archive.

Add files... Add some already existing files as children of the selected folder in the browsed archive.

Delete Delete the selected resource in the browsed archive.

Archive Options... Open the Archive preferences page.

The following additional operations are available from the Archive Browser's contextual menu:

Figure 12.3. Contextual menu
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Open Open a resource from the archive in the editor.

Extract... Extract a resource from the archive in a specified folder.

Rename... Rename a resource in the archive.

Preview Preview an image contained in the archive See the Image Preview section for more details.

Copy location Copy the URL location of the selected resource.

Refresh Refresh the selected resource.

Properties... View properties for the selected resource.

Figure 12.4. Archive resource properties

Editing files from archives
You can open in <oXygen/> and edit files directly from an archive.

When saving the archived file you will be prompted with some backup operations which can be performed to ensure
that your archive data will not be corrupted.

Figure 12.5. Archive Backup options
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You have the following backup before save options :

No backup Perform no backup of the archive before save. This means that the file will be saved
directly in the archive without any additional precautions.

Single file backup Before any operation which modifies the archive is performed, the archive contents will
be duplicated. The duplicate file name will be originalArchiveFileName.bak
and will be saved in the same directory.

Incremental backup Before each operation which modifies the archive is performed, the archive contents will
be duplicated. The duplicate file names will be originalArchiveFile-
Name.bak#dupNo and the files will be saved in the same directory.

Never ask me again Check this if you do not want to be notified again to backup. The last backup option you
chose will always be used as the default one.

You can re-enable the dialog pop-up from the Messages preferences page.
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Chapter 13. Working with Databases
XML is a storage and interchange format for structured data and it is supported by all major database systems. <oXygen/>
offers the means of managing the interaction with some of the widely used databases, both relational ones and Native
XML Databases. By interaction, one should understand browsing, querying, SQL execution support, content editing,
importing from databases, generating XML Schema from database structure.

Relational Database Support
Relational databases use a relational model and are based on tables linked by a common key. <oXygen/> offers support
for the following relational databases: IBM DB2, JDBC-ODBC Bridge, MySQL, Microsoft SQL Server, Oracle 11g
like browsing the tables of these types of database in the Database Explorer view, executing SQL queries against them,
calling stored procedures with input and output parameters.

In the following sections one can find the tools that <oXygen/> offers for working with relational databases and a de-
scription on how to configure a relational data source, a connection to a data source and also the views where connections
can be browsed and results are displayed.

Configuring Database Data Sources

How to configure an IBM DB2 Data Source

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select DB2 from the driver type combo box.

Figure 13.1. Data Source Drivers Configuration Dialog

335



Press the Add button to add the following IBM DB2 specific files:

• db2jcc.jar

• db2jcc_license_cisuz.jar

• db2jcc_license_cu.jar

In the Download links for database drivers section there are listed the URLs from where to download the drivers
necessary for accessing IBM DB2 databases in <oXygen/>.

You can manually manage the Driver Files using Add, Remove, Detect and Stop(detection) buttons.

3. Select the most suited Driver class.

4. Click OK to finish the data source configuration.

How to configure a Generic JDBC Data Source

<oXygen/>'s default configuration already contains a generic JDBC data source called JDBC-ODBC Bridge.

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select Generic JDBC from the driver type combo box.

Click the Add button and find the driver file on your file system.

You can manage the Driver Files using Add, Remove, Detect and Stop(detection) buttons.

3. Select the most suited Driver class.

4. Click OK to finish the data source configuration.

How to configure a Microsoft SQL Server Data Source

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select SQLServer from the driver type combo box.

3. Press the Add button to add the following Microsoft SQL Server specific files:

• sqljdbc.jar

In the Download links for database drivers section there are listed the URLs from where to download the drivers
necessary for accessing Microsoft SQL Server databases in <oXygen/>.

You can manage the Driver Files using Add, Remove, Detect and Stop(detection) buttons.

4. Select the most suited Driver class.

5. Click OK to finish the data source configuration.

How to configure a MySQL Data Source

<oXygen/>'s default configuration already contains a generic JDBC data source called  MySQL.

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.
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2. Enter a unique name for this data source and select Generic JDBC from the driver type combo box.

Press the Add button to add the following MySQL specific files:

• mysql-com.jar

You can manage the Driver Files using Add, Remove, Detect and Stop(detection) buttons.

3. Select the most suited Driver class.

4. Click OK to finish the data source configuration.

How to configure an Oracle 11g Data Source

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select Oracle from the driver type combo box.

Press the Add button to add the following Oracle 10.2 specific files:

• ojdbc5.jar

In the Download links for database drivers section there are listed the URLs from where to download the drivers
necessary for accessing Oracle 11g databases in <oXygen/>.

You can manage the Driver Files using Add, Remove, Detect and Stop(detection) buttons.

3. Select the most suited Driver class.

4. Click OK to finish the data source configuration.

How to configure a PostgreSQL 8.3 Data Source

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select Postgres from the driver type combo box.

Press the Add button to add the following Postgres 8.3 specific files:

• postgresql-8.3-603.jdbc3.jar

In the Download links for database drivers section there are listed the URLs from where to download the drivers
necessary for accessing PostgreSQL databases in <oXygen/>.

You can manage the Driver Files using Add, Remove, Detect and Stop(detection) buttons.

3. Select the org.postgresql.Driver class in the Driver class combo box.

4. Click OK to finish the data source configuration.

Configuring Database Connections
This section presents a set of procedures describing how to configure connections that use relational data sources.
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How to Configure an IBM DB2 Connection

Figure 13.2. The Connection Configuration Dialog

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured DB2 data sources from the
Data Source combo box.

3. Fill-in the Connection Details:

URL URL to the installed IBM DB2 engine.

User User name to access the IBM DB2 database engine.

Password Password to access the IBM DB2 engine.

4. Click OK.

How to Configure a JDBC-ODBC Connection

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured Generic JDBC data sources
from the Data Source combo box.

3. Fill-in the Connection Details:

URL URL to the configured ODBC source.

User User name to access the configured ODBC source.

Password Password to access the configured ODBC source.

4. Click OK.

How to Configure a Microsoft SQL Server Connection

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.
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2. Enter a unique name for this connection and select one of the previously configured SQLServer data sources from
the Data Source combo box.

3. Fill-in the Connection Details:

URL URL to the installed SQLServer engine.

User User name to access the SQLServer database engine.

Password Password to access the SQLServer engine.

4. Click OK.

How to Configure a MySQL Connection

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured MySQL data sources from
the Data Source combo box.

3. Fill-in the Connection Details:

URL URL to the installed MySQL engine.

User User name to access the MySQL database engine.

Password Password to access the MySQL engine.

4. Click OK.

How to Configure an Oracle 11g Connection

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured Oracle data sources from the
Data Source combo box.

3. Fill-in the Connection Details:

URL URL to the installed Oracle engine.

User User name to access the Oracle database engine.

Password Password to access the Oracle engine.

4. Click OK.

Note

Registering,unregistering or updating a schema might involve dropping/creating types. For schema-based XML-
Type tables or columns in schemas, you need privileges like

• CREATE ANY TABLE
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• CREATE ANY INDEX

• SELECT ANY TABLE

• UPDATE ANY TABLE

• INSERT ANY TABLE

• DELETE ANY TABLE

• DROP ANY TABLE

• ALTER ANY TABLE

• DROP ANY INDEX

To avoid granting these privileges to the schema owner, Oracle recommends that the operations requiring these
privileges be performed by a DBA if there are XML schema-based XMLType table or columns in other users'
database schemas.

How to Configure a PostgreSQL 8.3 Connection

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured PostgreSQL data sources
from the Data Source combo box.

3. Fill-in the Connection Details:

URL URL to the installed PostgreSQL engine.

User User name to access the PostgreSQL database engine.

Password Password to access the PostgreSQL engine.

4. Click OK.

Resource Management

Database Explorer View

This view presents in a tree-like fashion the database connections configured in Preferences -> Data Sources. You
can connect to a database simply by expanding the connection node. The database structure can be expanded up to
column level. <oXygen/> supports multiple simultaneous database connections and the connections tree provides an
easy way to browse them.
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Figure 13.3. Database Explorer View

The following objects are displayed by the Database Explorer view:

•  Connection

•  Catalog

•  XML Schema Repository

•  XML Schema Component

•  Schema

• Table

•  System Table

• Table Column

The following actions are available in the view's toolbar:

• The  Filters button opens the Data Sources / Table FiltersPreferences page, allowing you to decide which table
types will be displayed in the Database Explorer view.

• The  Configure Database Sources button opens the Data Sources preferences page where you can configure both
data sources and connections.

Below you can find a description of the contextual menu actions available on the Database Explorer levels. Please note
that you can also open an XML schema component in the editor by double-clicking it. To view the content of a table
in the Table Explorer view double-click one of its fields.

341

Working with Databases



Actions available at connection level

•  Refresh - performs a refresh of the selected node's subtree.

•  Configure Database Sources - opens the Data Sourcespreferences page where you can configure both data sources
and connections.

Actions available at catalog level

•  Refresh - performs a refresh of the selected node's subtree.

Actions available at schema level

•  Refresh - performs a refresh of the selected node's subtree.

Actions available at table level

•  Refresh - performs a refresh of the selected node's subtree.

• Edit - opens the selected table in the Table Explorer View.

• Export to XML - opens the Export Criteria dialog .

XML Schema Repository level

For relational databases that support XML schema repository (XSR) in their database catalogs, the actions available
at this level are presented in the following sections.

Oracle's XML Schema Repository Level

•  Refresh - performs a refresh of the selected node's subtree.

• Register - Opens a dialog for adding a new schema file in the DB XML repository.

Figure 13.4. Register Dialog

To add an XML Schema, enter the schema URI and location on your file system. Local scope means that the schema
will be visible only to the user who registers it. Global scope means that the schema is public.

IBM DB2's XML Schema Repository Level

•  Refresh - performs a refresh of the selected node's subtree.

• Register - opens a dialog for adding a new schema file in the XML Schema repository.
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Figure 13.5. Register Dialog

The XSR Information section of the above figure contains the following fields:

• XML schema file - location on your file system.

• XSR name - schema name.

• Comment - short comment (optional).

• Schema location - primary schema name (optional).

Decomposition means that parts of the XML documents are stored into relational tables. Which parts map to which
tables and columns is specified into the schema annotations.

Schema dependencies management is done by using the Add and Remove buttons.

Actions available at schema level:

•  Refresh - performs a refresh of the selected node (and it's subtree).

• Unregister - removes the selected schema from the XML Schema Repository.

• View - opens the selected schema in <oXygen/>.

Microsoft SQL Server's XML Schema Repository Level

•  Refresh - performs a refresh of the selected node's subtree.

• Register - Opens a dialog for adding a new schema file in the DB XML repository.
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Figure 13.6. Register Dialog

To register a new schema, enter a collection name and the necessary schema files in the above dialog. XML Schema
files management is done by using the Add and Remove buttons.

Actions available at schema level:

•  Refresh - performs a refresh of the selected node (and it's subtree).

• Add - adds a new schema to the XML Schema files.

• Unregister - removes the selected schema from the XML Schema Repository.

• View - opens the selected schema in <oXygen/>.

Table Explorer View

Every table from the Database Explorer can be displayed and edited by pressing the Edit button from the contextual
menu or by double-clicking one of its fields. To modify a cell's content, double click it and start typing. When editing
is finished, <oXygen/> will try to update the database with the new cell content.

Figure 13.7. The Table Explorer View
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You can sort the content of a table by one of its columns by clicking on its (column) header.

Note the following:

• The first column is an index (does not belong to the table structure).

• Every column header contains the field name and its data type.

• The primary key columns are marked with this symbol:  .

• Multiple tables are presented in a tabbed manner

For performance issues, you can set the maximum number of cells that will be displayed in the Table Explorer view (
the "Limit the number of cells" field from the Data Sources Preferences page ). If a table having more cells than the
value set in <oXygen/>'s options is displayed in the Table Explorer view, a warning dialog will inform you that the
table is only partially shown.

Note

A custom validator cannot be applied on files loaded through an <oXygen/> custom protocol plugin developed
independently and added to <oXygen/> after installation. This applies also on columns of type XML.

You will be notified if the value you have entered in a cell is not valid ( and thus it cannot be updated).

• If the content of the edited cell does not belong to the data type of the column, the cell will be marked by a red square
and it will remain in editing state until a correct value is inserted.

For example, in the above figure DEPARTMENT_ID contains NUMBER values. If a character or string was inserted,
the cell will look like this:

Figure 13.8. Cell containing an invalid value.

• If the constraints of the database are not met (like primary key constraints for example), an Information dialog will
appear, notifying you of the reason the database has not been updated.

For example, if you'd try to set the primary key DEPARTMENT_ID for the second record in the table to 10 also,
you would get the following message:
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Figure 13.9. Duplicate entry for primary key

The usual edit actions (Cut, Copy, Paste, Select All, Undo, Redo) are available in the popup menu of the edited cell

The contextual menu available on every cell has the following actions:

• Set NULL - sets the content of the cell to (null). This action is disabled for columns that cannot be null.

• Insert row - inserts an empty row in the table.

• Duplicate row - makes a copy of the selected row and adds it in the Table Explorer view. You should note that
the new row will not be inserted in the database table until all conflicts are solved.

• Commit row - commits the selected row.

• Delete row - deletes the selected row.

• Copy - copies the content of the cell.

• Paste - performs paste in the selected cell

Some of the above actions are also available on the Table Explorer toolbar:

• Export to XML - opens the Export Criteria dialog .

•  Refresh - performs a refresh of the selected node's subtree.

• Insert row - inserts an empty row in the table.

• Duplicate row - makes a copy of the selected row and adds it in the Table Explorer view. You should note that
the new row will not be inserted in the database table until all conflicts are solved.

• Commit row - commits the selected row.

• Delete row - deletes the selected row.
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Native XML Database (NXD) Support
Native XML databases have an XML-based internal model and their fundamental unit of storage is XML. <oXygen/>
offers support for: Berkeley DB XML, eXist, MarkLogic, Software AG Tamino, Raining Data TigerLogic, Documentum
xDb (X-Hive/DB) and Oracle XML DB.

Configuring Database Data Sources
This section presents a set of procedures describing how to configure NXD data sources.

How to configure a Berkeley DB XML datasource

The latest instructions on how to configure Berkeley DB XML support in <oXygen/> can be found on our website
[http://www.oxygenxml.com/doc/ug-oxygen/native-xml-database-support.html#configure-berkeley-datasource].

<oXygen/> supports Berkeley DB XML versions 2.3.10, 2.4.13 & 2.4.16. The following directory definitions shall
apply:

• OXY_DIR - <oXygen/> installation root directory. (for example on Windows C:\Program Files\Oxygen 10.3)

• DBXML_DIR - Berkeley DB XML database root directory. (for example on Windows C:\Program Files\Sleepycat
Software\Berkeley DB XML <version>)

• DBXML_LIBRARY_DIR (usually on Mac and Unix is DBXML_DIR/lib and on Windows is DBXML_DIR/bin)

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select Berkeley DBXML from the driver type combo box.

Figure 13.10. Data Source Drivers Configuration Dialog

3. Press the Add button to add the following Berkeley DB specific files:

• db.jar (check for it into DBXML_DIR/lib or DBXML_DIR/jar)
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• dbxml.jar (check for it into DBXML_DIR/lib or DBXML_DIR/jar)

4. Click OK to finish the data source configuration.

How to configure an eXist datasource

The latest instructions on how to configure eXist support in <oXygen/> can be found on our website
[http://www.oxygenxml.com/doc/ug-oxygen/native-xml-database-support.html#configure-exist-datasource].

The eXist database server versions supported by <oXygen/> are 1.0, 1.1, 1.2.2, 1.2.4, 1.2.5 and 1.3.

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select eXist from the driver type combo box.

3. Press the Add button to add the following eXist specific files which are located in the eXist installation root dir-
ectory:

• exist.jar

• lib/core/xmldb.jar

• lib/core/xmlrpc-client-3.1.1.jar

• lib/core/xmlrpc-common-3.1.1.jar

• lib/core/ws-commons-util-1.0.2.jar

4. Click OK to finish the data source configuration.

How to configure a MarkLogic datasource

The latest instructions on how to configure MarkLogic support in <oXygen/> can be found on our website
[http://www.oxygenxml.com/doc/ug-oxygen/native-xml-database-support.html#configure-marklogic-datasource].

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select MarkLogic from the driver type combo box.

3. Add the following MarkLogic specific file:

• xcc.jar

In the Download links for database drivers section there are listed the URLs from where to download the drivers
necessary for accessing MarkLogic databases in <oXygen/>.

4. Click OK to finish the data source configuration.

How to configure a Software AG Tamino datasource

The latest instructions on how to configure Software AG Tamino support in <oXygen/> can be found on our website
[http://www.oxygenxml.com/doc/ug-oxygen/native-xml-database-support.html#configure-tamino-datasource].

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.
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2. Enter a unique name for this data source and select Tamino from the driver type combo box.

3. Using the Add button add the following jar files available in the SDK\TaminoAPI4J\lib subdirectory of the
Tamino 4.4.1 database install directory:

• TaminoAPI4J.jar

• TaminoAPI4J-l10n.jar

• TaminoJCA.jar

Note

You must use the jar files from the version 4.4.1 of the Tamino database.

4. Click OK to finish the data source configuration.

How to configure a Raining Data TigerLogic datasource

The latest instructions on how to configure TigerLogic support in <oXygen/> can be found on our website
[http://www.oxygenxml.com/doc/ug-oxygen/native-xml-database-support.html#configure-tigerlogic-datasource].

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select TigerLogic from the driver type combo box.

3. Add the following TigerLogic specific files (found in the TigerLogic JDK lib directory from the server side):

• connector.jar

• jca-connector.jar

• tlapi.jar

• tlerror.jar

• utility.jar

• xmlparser.jar

• xmltypes.jar

4. Click OK to finish the data source configuration.

How to configure a Documentum xDb (X-Hive/DB) datasource

The latest instructions on how to configure Documentum xDb (X-Hive/DB) support in <oXygen/> can be found on
our website  [http://www.oxygenxml.com/doc/ug-oxygen/native-xml-database-support.html#configure-xhive-datasource].

1. Go to Preferences -> Data Sources. In the Data Sources panel click the New button.

2. Enter a unique name for this data source and select Documentum xDb (X-Hive/DB) from the driver type combo
box.
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3. Add the following Documentum xDb (X-Hive/DB) specific files (found in the Documentum xDb (X-Hive/DB)
lib directory from the server side):

• antlr-runtime-3.0.1.jar

• icu4j.jar

• xhive.jar

If you like to use a bootstrap file when connecting to the database you need to additionally add the following JAR
files found in the same place:

• fop.jar

• jsr173_api.jar

• lucene.jar

• mx4j.jar

• serializer.jar

• w3c.jar

• xalan.jar

• xbean.jar

• xercesImpl.jar

• xml-apis.jar

4. Click OK to finish the data source configuration.

Configuring Database Connections
This section presents a set of procedures describing how to configure connections that use Native XML Database data
sources.

How to configure a Berkeley DB XML Connection

<oXygen/> supports Berkeley DB XML versions 2.3.10, 2.4.13 & 2.4.16.
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Figure 13.11. The Connection Configuration Dialog

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured Berkeley data sources from
the Data Source combo box.

3. Fill-in the Connection Details:

Environment home directory Path to the Berkeley DB XML's home directory.

Verbosity The user can choose between four levels of verbosity: DEBUG, INFO,
WARNING, ERROR.

Join existing environment If checked, an attempt will be made to join an existing environment in the
specified home directory and all the original environment settings will be
preserved. If that fails, you should consider reconfiguring the connection
with this option unchecked.

4. Click OK.
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How to configure an eXist Connection

Figure 13.12. The Connection Configuration Dialog

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured eXist data sources from the
Data Source combo box.

3. Fill-in the Connection Details

XML DB URI URI to the installed eXist engine.

User User name to access the eXist database engine.

Password Password to access the eXist database engine.

Collection eXist organizes all documents in hierarchical collections. Collections are like directories. They
are used to group related documents together. This text field allows the user to set the default
collection name.

4. Click OK.
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How to configure a MarkLogic Connection

Figure 13.13. The Connection Configuration Dialog

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured MarkLogic data sources from
the Data Source combo box.

3. Fill-in the Connection Details:

XDBC Host The host name or ip address of the installed MarkLogic engine.

Port The port number of the MarkLogic engine.

User User name to access the MarkLogic engine.

Password Password to access the MarkLogic engine.

WebDAV
URL

The url used for browsing the MarkLogic database in the Database Explorer view. (optional)

4. Click OK.

353

Working with Databases



How to configure a Software AG Tamino Connection

Figure 13.14. The Connection Configuration Dialog

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured Tamino data sources from
the Data Source combo box.

3. Fill-in the Connection Details:

XML DB URI URI to the installed Tamino engine

User User name to access the Tamino database engine

Password Password to access the Tamino database engine

Database The name of the database to access from the Tamino database engine. Choose
the Select button to display all databases on the specified server in an addi-
tional dialog box. You can then choose the desired database. This feature
works only with databases that have been created starting with version 4.2.1.
In all other cases, a message appears saying that a list of databases is not
available.

Show system collections Check this if you want to see the Tamino system collections in the Database
Explorer.

4. Click OK.
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How to configure a Raining Data TigerLogic Connection

Figure 13.15. The Connection Configuration Dialog

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured TigerLogic data sources from
the Data Source combo box.

3. Fill-in the Connection Details:

Host The host name or ip address of the installed TigerLogic engine.

Port The port number of the TigerLogic engine.

User User name to access the TigerLogic engine.

Password Password to access the TigerLogic engine.

Database The name of the database to access from the TigerLogic engine.

4. Click OK.
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How to configure an Documentum xDb (X-Hive/DB) Connection

Figure 13.16. The Configure Connection Dialog

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the previously configured Documentum xDb (X-Hive/DB)
data sources from the Data Source combo box.

3. Fill-in the Connection Details:

URL The URL property for Documentum xDb (X-Hive/DB) connection. It is
also called xhive.bootstrap and specifies the location of the Documentum
xDb (X-Hive/DB) federation.

This property can be used in two different ways:

If the property is a URL of the form xhive://host:port, the Documentum
xDb (X-Hive/DB) connection will attempt to connect to an Documentum
xDb (X-Hive/DB) server running behind the specified TCP/IP port.

If the property is the complete (or relative) path to an  XhiveData-
base.bootstrap file, an Documentum xDb (X-Hive/DB) server will
be started in the current JVM. Depending on the application, this can be
much faster than using a remote server because the communication
overhead is avoided. However, only one JVM can run an Documentum
xDb (X-Hive/DB) server for a specific federation at the same time.

For the second case (using a bootstrap file to connect) you need to add
additional JAR files when you configure the data source.

User User name to access the Documentum xDb (X-Hive/DB) database engine.

Password Password to access the Documentum xDb (X-Hive/DB) database engine.

Database The name of the database to access from the Documentum xDb (X-
Hive/DB) database engine.
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Run XQuery in read/write session
(with committing)

If checked the Documentum xDb (X-Hive/DB) session ends with a commit,
otherwise it ends with a rollback.

4. Click OK.

Resource Management

Database Explorer View

This view presents in a tree-like fashion the database connections configured in Preferences -> Data Sources. You
can connect to a database simply by expanding the connection node. The database structure can be expanded up to
column level. <oXygen/> supports multiple simultaneous database connections and the connections tree provides an
easy way to browse them.

Some of the basic components employed by the XML:DB API are collections and resources, and they appear in the
tree sorted in alphabetical order.

A  collection is a hierarchical container for  resources and further sub-collections.

There are two types of resources:  XML resource and  non XML resource . An XML resource represents an xml
document or a document fragment, selected by a previously executed XPath query.

Figure 13.17. The Database Explorer View

Below you can find a description of the contextual menu actions available on the Database Explorer levels (explained
for each connection). Please note that you can open in the editor a resource or a schema component by double-clicking
it.

Berkeley DB XML Connection

Actions available at connection level

•  Refresh - performs a refresh of the selected node's subtree.
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•  Configure Database Sources - opens the Data Sources preferences page where you can configure both data
sources and connections.

• Add container - allows adding a new container.

Figure 13.18. Add Container Dialog

Name The name of the new container.

Container type At creation time, every container must have a type defined for it. This container type
identifies how XML documents are stored in the container. As such, the container type
can only be determined at container creation time; you cannot change it on subsequent
container opens.

Containers can have one of the following types specified for them:

Node container Xml documents are stored as individual nodes in
the container. That is, each record in the underlying
database contains a single leaf node, its attributes
and attribute values if any, and its text nodes, if
any. BDB XML also keeps the information it needs
to reassemble the document from the individual
nodes stored in the underlying databases. This is
the default, and preferred, container type.

Whole document container The container contains entire documents; the doc-
uments are stored without any manipulation of line
breaks or whitespace.

Allow validation If checked it causes documents to be validated when they are loaded into the container.
The default behavior is to not validate documents.

Index nodes If checked it causes indices for the container to return nodes rather than documents. The
default is to index at the document level. This property has no meaning if the container
type is whole document container.

Actions available at container level

•  Refresh - performs a refresh of the selected node's subtree.

• Add Resource - adds a new XML resource to the selected container.
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• Rename - allows you to specify a new name for the selected container.

•  Delete - removes the selected container from the database tree.

• Edit indices - allows you to edit the indices for the selected container.

Figure 13.19. Container indices

• Specifying the granularity:

• Document granularity is good for retrieving large documents

• Node granularity is good for retrieving nodes from within documents

• Adding/editing indices:
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Figure 13.20. Adding/editing indices

• Node - the node name

• Namespace - the index namespace

• Index strategy:

• Index type:

• Uniqueness - indicates whether the indexed value must be unique within the container

• Path type:

• node - indicates that you want to index a single node in the path

• edge - indicates that you want to index the portion of the path where two nodes meet

• Node type:

• element - an element node in the document content

• attribute - an attribute node in the document content

• metadata - a node found only in a document's metadata content.

• Key type:

• equality - improves the performances of tests that look for nodes with a specific value

• presence - improves the performances of tests that look for the existence of a node regardless of its
value

• substring - improves the performance of tests that look for a node whose value contains a given substring

• Syntax types - the syntax describes what sort of data the index will contain and is mostly used to determine
how indexed values are compared
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Actions available at resource level

•  Refresh - performs a refresh of the selected resource.

•  Open - opens the selected resource in the editor.

• Rename - allows you to change the name of the selected resource.

• Move - allows you to move the selected resource in a different container in the database tree.

•  Delete - removes the selected resource from the container.

• Copy location - allows you to copy to clipboard an application specific URL for the resource which can then be used
for various actions like opening or transforming the resources.

eXist Connection

Actions available at connection level

•  Refresh - performs a refresh of the selected node's subtree.

•  Configure Database Sources - opens the Data Sources preferences page where you can configure both data
sources and connections.

Actions available at container level

•  Refresh - performs a refresh of the selected node's subtree.

• Add Resource - adds a new XML resource to the selected container.

• Add Container - creates a new collection in the selected one.

•  Delete - removes the selected collection.

• Rename - allows you to change the name of the selected collection.

• Move - allows you to move the selected collection in a different location in the database tree.

Actions available at resource level

•  Refresh - performs a refresh of the selected resource.

•  Open - opens the selected resource in the editor.

• Rename - allows you to change the name of the selected resource.

• Move - allows you to move the selected resource in a different collection in the database tree.

•  Delete - removes the selected resource from the collection.

• Copy location - allows you to copy to clipboard an application specific URL for the resource which can then be used
for various actions like opening or transforming the resources.

• Properties - allows the user to view various useful properties associated with the resource.
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• Save As - allows you to save the name of the selected binary resource as a file on disk.

WebDAV Connection
This section presents the procedure used to configure a WebDAV connection in the Database Explorer.

<oXygen/>'s default configuration already contains a WebDAV data source called WebDAV.

How to Configure a WebDAV Connection

Figure 13.21. The WebDAV Connection Configuration Dialog

1. Go to Preferences -> Data Sources. In the Connections panel click the New button.

2. Enter a unique name for this connection and select one of the WebDAV data source from the Data Source combo
box.

3. Fill-in the Connection Details:

WebDAV
URL

URL to the WebDAV repository.

User User name to access the WebDAV repository.

Password Password to access the WebDAV repository.

4. Click OK.

WebDAV connection actions

Actions available at connection level

•  Refresh - performs a refresh of the connection.

•  Configure Database Sources - opens the Data Sources preferences page where you can configure both data
sources and connections.

• Add container - allows you to create a new folder.
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• Add Resource - allows you to add a new file on the server.

Actions available at folder level

•  Refresh - performs a refresh of the selected node's subtree.

• Add container - allows you to create a new folder.

• Add Resource - allows you to add a new file on the server in the current folder.

• Rename - allows you to change the name of the selected folder.

• Move - allows you to move the selected folder in a different location in the tree.

•  Delete - removes the selected folder.

Actions available at file level

•  Refresh - performs a refresh of the selected node.

•  Open - allows you to open the selected file in the editor.

• Rename - allows you to change the name of the selected file.

• Move - allows you to move the selected file in a different location in the tree.

•  Delete - removes the selected file.

• Copy location - allows you to copy to clipboard an application specific URL for the resource which can then be used
for various actions like opening or transforming the resources.
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Chapter 14. Digital signature
Overview
Digital signatures are widely used as security tokens, not just in XML.

A digital signature provides a mechanism for assuring integrity of data, the authentication of its signer, and the nonre-
pudiation of the entire signature to an external party.

• a digital signature must provide a way to verify that the data has not been modified or replaced to ensure integrity.

• the signature must provide a way to establish the identity of the data's signer for authentication.

• the signature must provide the ability for the data's integrity and authentication to be provable to a third party for
nonrepudiation.

A public key system is used to create the digital signature and it's also used for verification. The signature binds the
signer to the document because digitally signing a document requires the originator to create a hash of the message
and then encrypt that hash value with his own private key. Only the originator has that private key and he is the only
one can encrypt the hash so that it can be unencrypted using his public key. The recipient, upon receiving both the
message and the encrypted hash value, can decrypt the hash value, knowing the originator's public key. The recipient
must also try to generate the hash value of the message and compare the newly generated hash value with the unencrypted
hash value received from the originator. If the hash values are identical, it proves that the originator created the message,
because only the actual originator could encrypt the hash value correctly.

XML Signatures can be applied to any digital content (data object), including XML (see W3C Recommendation, XML-
Signature Syntax and Processing [http://www.w3.org/TR/xmldsig-core/ ] ). An XML Signature may be applied to the
content of one or more resources.

• Enveloped or enveloping signatures are over data within the same XML document as the signature.

• Detached signatures are over data external to the signature element; the signature is "detached" from the content it
signs. This definition typically applies to separate data objects, but it also includes the instance where the Signature
and data object reside within the same XML document but are sibling elements.

The XML Signature is a method of associating a key with referenced data; it does not normatively specify how keys
are associated with persons or institutions, nor the meaning of the data being referenced and signed.

The original data is not actually signed; instead, the signature is applied to the output of a chain of canonicalization
and transformation algorithms, which are applied to the data in a designated sequence. This system provides the flex-
ibility to accommodate whatever "normalization" or desired preprocessing of the data that might be required or desired
before subjecting it to being signed.

To canonicalize something means to put it in a standard format that everyone generally uses. Because the signature is
dependent on the content it is signing, a signature produced from a not canonicalized document could possibly be dif-
ferent from one produced from a canonicalized document. The canonical form of an XML document is physical rep-
resentation of the document produced by the method described in this specification. The term canonical XML refers
to XML that is in canonical form. The XML canonicalization method is the algorithm defined by this specification
that generates the canonical form of a given XML document or document subset. The term XML canonicalization
refers to the process of applying the XML canonicalization method to an XML document or document subset. XML
canonicalization is designed to be useful to applications that require the ability to test whether the information content
of a document or document subset has been changed. This is done by comparing the canonical form of the original
document before application processing with the canonical form of the document result of the application processing.
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A digital signature over the canonical form of an XML document or document subset would allows the signature digest
calculations to be oblivious to changes in the original document's physical representation. During signature generation,
the digest is computed over the canonical form of the document. The document is then transferred to the relying party,
which validates the signature by reading the document and computing a digest of the canonical form of the received
document. The equivalence of the digests computed by the signing and relying parties (and hence the equivalence of
the canonical forms over which they were computed) ensures that the information content of the document has not
been altered since it was signed.

The following canonicalization algorithms are used in <oXygen/>: Canonical XML (or Inclusive XML Canonicaliza-
tion)(XMLC14N [http://www.w3.org/TR/2001/REC-xml-c14n-20010315]) and Exclusive XML Canonicalization(EX-
CC14N [http://www.w3.org/TR/2002/REC-xml-exc-c14n-20020718/]). The first is used for XML where the context
doesn't change while the second was designed for canonicalization where the context might change.

Inclusive Canonicalization copies all the declarations, even if they are defined outside of the scope of the signature.
In this way all the declarations you might use will be unambiguously specified. A problem appears when the signed
XML is moved into another XML document which has other declarations because the Inclusive Canonicalization will
copy then and the signature will be invalid.

Exclusive Canonicalization finds out what namespaces you are actually using (the ones that are a part of the XML
syntax) and just copies those. It does not look into attribute values or element content, so the namespace declarations
required to process these are not copied.

This type of canonicalization is useful when you have a signed XML document that you wish to insert into other XML
documents and it will insure the signature verifies correctly every time, so it is required when you need self-signed
structures that support placement within different XML contexts.

Inclusive Canonicalization is useful when it is less likely that the signed data will be inserted in other XML document
and it's the safer method from the security perspective because it requires no knowledge of the data that are to be secured
in order to safely sign them.

The canonicalization method can specify whether or not comments should be included in the canonical form output
by the XML canonicalization method. If a canonical form contains comments corresponding to the comment nodes in
the input node-set, the result is called canonical XML with comments. In an uncommented canonical form comments
are removed, including delimiter for comments outside document element.

These three operations: Digital Signing, Canonicalization and Verification of the signature are available from the Tools
menu or from the Editor contextual menu->Source.

Canonicalizing files
The user can select the canonicalization algorithm to be used for his document from the following dialog displayed by
the action Canonicalize available from editor panel context menu+Sourceand also from menuToolsand from menuDoc-
ument+Tools
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Figure 14.1. Canonicalization settings dialog

URL Specifies the location of the input URL

Exclusive If selected, the exclusive (uncommented) canonicalization method is used.

Exclusive with comments If selected, the exclusive with comments canonicalization method is used.

Inclusive If selected, the inclusive (uncommented) canonicalization method is used.

Inclusive with comments If selected, the inclusive with comments canonicalization method is used.

XPath The XPath expression provides the fragments of the XML document to be signed.

Output Specifies the output file path where the signed XML document will be saved.

Open in editor If checked, the output file will be opened in the editor.

Certificates
A certificate is a digitally signed statement from the issuer (an individual, an organization, a website or a firm), saying
that the public key (and some other information) of some other entity has a particular value. When data is digitally
signed, the signature can be verified to check the data integrity and authenticity. Integrity means that the data has not
been modified. Authenticity means the data comes indeed from the entity that claims to have created and signed it.
Certificates are kept in special repositories called Keystores.

A Keystore is an encrypted file that contains private keys and certificates. All keystore entries (key and trusted certi-
ficate entries) are accessed via unique aliases. An alias must be assigned for every new entry of either a key or certificate
as a reference for that entity. No Keystore can store an entity if it's "alias" already exists in that Keystore and no KeyStore
can store trusted certificates generated with keys in it's KeyStore.

In <oXygen/> there are provided two types of keystores: Java Key Store (JKS) and Public-Key Cryptography Standards
version 12 (PKCS-12). A keystore file is protected by a password. In a PKCS 12 keystore you should not store a certi-
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ficate without alias together with other certificates, with or without alias, as in such a case the certificate without alias
cannot be extracted from the keystore.

To set the options for a certificate or to validate it, go to  Options → Preferences → Certificates .

Note

A certificate without alias stored in a PKCS 12 keystore together with other certificates, with or without alias,
cannot be always extracted correctly from the keystore due to the missing alias. Such a certificate should be the
only certificate of a PKCS 12 keystore.

Signing files
The user can select the type of signature to be used for his document from the following dialog displayed by the action
Sign available from editor panel context menu+Sourceand also from menuToolsand from menuDocument+Tools

Figure 14.2. Signature settings dialog

URL Specifies the location of the input URL

None If selected, no canonicalization algorithm is used.

Exclusive If selected, the exclusive (uncommented) canonicalization method is used.

Exclusive with comments If selected, the exclusive with comments canonicalization method is used.

Inclusive If selected, the inclusive (uncommented) canonicalization method is used.
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Inclusive with comments If selected, the inclusive with comments canonicalization method is used.

XPath The XPath expression provides the fragments of the XML document to be signed.

ID Provides ID of the XML element to be signed.

Envelope If selected, the enveloping signature is used.

Detached If selected, the detached signature is used.

Output Specifies the output file path where the signed XML document will be saved.

Open in editor If checked, the output file will be opened in the editor.

Verifying the signature
The user can select a file to verify its signature in the following dialog displayed by the action Verify Signature available
from editor panel context menu+Sourceand also from menuToolsand from menuDocument+Tools

Figure 14.3. Verifying signature dialog

URL Specifies the location of the document for which to verify the signature.

If the signature is valid, a dialog displaying the name of the signer will be opened. If not, an error message will show
details about the problem.
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Chapter 15.The Syncro SVN Client
Introduction

What is Syncro SVN Client
Syncro SVN is a client for the Subversion version control system compatible with Subversion 1.6 servers. It manages
files and directories that change over time and are stored in a central repository. The version control repository is much
like an ordinary file server, except that it remembers every change ever made to your files and directories. This allows
you to access older versions of your files and examine the history of how and when your data changed.

Quick start guide and reference
The Main window  section will provide a short description of the application main window layout, general functions,
views and menus.

A Getting started  chapter will take you through the basic operations, such as:

• Define a repository location

• Define a working copy

• Manage working copy resources

• Synchronize with a repository

• Obtain information for a resource

• Using the log history of a resource

• Adding and changing the properties of a resource

• Creating and maintaining branches and tags

• Some more advanced repository operations

The next few chapters refer to the views of the application:

• Repository view

• Working copy view

• Synchronize view

• Compare resources view

• Editor

• Image preview

• History view

• Properties view
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• Console view

• Help view

• Preferences dialog

Main window
Figure 15.1. The Syncro SVN Client main window

Starting Syncro SVN Client
The Syncro SVN Client can be used as a standalone application. To start the client follow the instructions for the installed
package:

Procedure 15.1. Windows

• From the Windows Explorer double-click svnClient.exe .
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Procedure 15.2. Linux

• At the prompt type: sh svnClient.sh .

Procedure 15.3. Mac OS X

• Double-click svnClient .

Procedure 15.4. All Platforms

• On Windows run svnClient.bat. On Mac OS X run svnClientMac.sh. On Linux/Unix run svnCli-
ent.sh.

The client can be started from inside <oXygen/> by using Tools → SVN Client action or the Project view contextual
menu → Team → Open in SVN Client action. When the action from the Project view is performed, if the selected re-
source is under version control, its working copy root will be determined and opened in the SVN client Working copy
view.

Views
The main window consists of the following views:

• Repository view allows you to define and manage Subversion repository locations.

• Working copy view allows you to manage with ease the content of the working copy.

• Synchronize view displays the modified resources from your working copy (outgoing) and from the repository (in-
coming).

• Compare view displays the differences between two revisions of a text file.

• Compare images view displays the compared images side by side.

• Editor view allows you to modify and save a file from the working copy.

• Image preview allows you to view the image files from the Synchronize view, Working copy view, Synchronize view
or from the History view.

• History view displays the log messages for a given resource.

• Properties view displays the SVN properties for the currently selected resource from the Synchronize view or from
the Working copy view.

• Console view shows the start and progress of an operation as if a Subversion command was run from the shell.

• Help view dynamically shows the help for the currently selected view.

The main window's Status bar presents in the left side the operation in progress or the final result of the last performed
action. In the right side there is a progress bar for the running operation and a stop button to cancel the operation.

Main menu
The main menu of the Syncro SVN Client is composed of the following sub menus:

• File
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 Save - Saves the local file currently opened in the Editor view or the Compare view.•

• Exit - Exits the Subversion client.

• Edit

•
 Undo - undo edit changes in the local file currently opened in the Editor view or the Compare view.

•
 Redo - redo edit changes in the local file currently opened in the Editor view or the Compare view.

•
 Cut - cut selection to clipboard from the local file currently opened in the Editor view or the Compare view.

•
 Copy - copy selection to clipboard from the local file currently opened in the Editor view or the Compare

view.

•
 Paste - paste selection from clipboard in the local file currently opened in the Editor view or the Compare

view.

•
 Find/Replace - perform find/replace operations in the local file currently opened in the Editor view or the

Compare view.

•  Find Next - go to the next find match using the same find options of the last find operation. The action runs in
the editor panel and in any non editable text area, for example the Console view.

•  Find Previous - go to the previous find match using the same find options of the last find operation. The action
runs in the editor panel and in any non editable text area, for example the Console view.

• Repository - operations from the Repository view:

•  New Repository Location - allows you to enter a new repository location by means of the Add SVN Repository
dialog.

•  Edit Repository Location - context dependent, allows you to edit the selected repository location by means of
the Edit SVN Repository dialog. It is active only when a repository location root is selected.

•  Remove Repository Location - allows you to remove the selected repository location from the view. It shows
you a confirmation dialog before removal. It is active only when a repository location root is selected.

•  Move Up - move the selected repository up with one position in the list of repositories in the Repository view.

•  Move Down - move the selected repository down with one position in the list of repositories in the Repository
view.

• Working copy - operations from the Working copy view:

• Add/Remove Working Copy - opens the Working copies list dialog which displays the working copies the
Subversion client is aware of. In this dialog you can add existing or remove no longer needed working copies.

•  Synchronize - contacts the repository and determines the changes made by you to the working copy and by
others to the repository. The synchronize result will be displayed in the Synchronize view. The action performs
a synchronize operation on the root of the working copy.

372

The Syncro SVN Client



•  Refresh - refreshes (re scans) the content of the working copy. The action performs a refresh operation on the
root of the working copy.

•  Cleanup - performs a maintenance cleanup operation on the working copy.

•  Show History ... - brings up the History view and displays the log history for the selected resource from the
working copy.

• Edit conflict - opens a Compare view for editing the selected conflict.

•  Show SVN Properties - brings up the Properties view and displays the SVN properties for the selected file.

• Synchronize - operations from the Synchronize view:

•  Update all - updates all resources with incoming changes. It is disabled when Outgoing mode is selected or
the synchronization result does not contain resources with incoming changes. It will perform a recursive update
on the synchronized resources.

•  Commit all - commits all resources with outgoing changes. It is disabled when Incoming mode is selected or
the synchronization result does not contain resources with outgoing changes. It will perform a recursive commit
on the synchronized resources.

• Add - it is enabled for unversioned resources and performs a svn add command which adds the resources to version
control.

• Commit ... - it is enabled for outgoing changes and commits all selected resources, recursively in the case of dir-
ectories, to the repository. This action collects the outgoing changes from the selected resources and presents
them in a dialog.

• Update - it is enabled for resources with incoming changes. Updates all selected resources to the HEAD revision.
If one of the selected resources is a directory then the update for that resource will be recursive.

• Override and Commit ... - it is enabled on conflicting resources. The action will drop any incoming changes and
will send your local version of the resource to the repository. See also Drop incoming modifications.

• Override and Update ... - it is enabled on resources with outgoing changes including the conflicting ones. It is
used for dropping any outgoing change and replacing the local resource with the HEAD revision. See Revert your
changes section.

• Mark Resolved - it is enabled on resources with real content conflicts. Its function is to tell the Subversion system
that you resolved the conflict and the resource can be committed. See also Merge conflicts part.

•  Expand All - expands the selected directories to leaf level.

•  Collapse All - collapses all child nodes of the selected tree node.

• Compare - operations from the Compare view:

•  Perform Files Differencing - used to perform file differencing on request.

•  Go to First Modification - used to navigate to the first difference.

•  Go to Previous Modification - used to navigate to the previous difference.
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•  Go to Next Modification - used to navigate to the next difference.

•  Go to Last Modification - used to navigate to the last difference.

•  Copy All Non-Conflicting Changes from Right to Left - this action copies all non-conflicting changes from
the right editor to the left editor. A non-conflicting change from the right editor is a change that does not overlap
with a left editor change.

•  Copy Change from Right to Left - this action copies the selected change from the right editor to the left editor.

•  Show Modification Details at Word Level - because the differences are computed using a line differencing
algorithm sometimes is useful to see exactly what words are different in a changed section.

•  Show Modification Details at Character Level - useful when you want to find out exactly what characters are
different between the two analyzed sections.

•  Ignore Whitespaces - Enables or disables the whitespace ignoring feature. Ignoring whitespace means that
before the strings are compared they are first normalized and then the whitespace at the beginning and the end of
the strings is trimmed.

• Layout - layout control actions:

• Reset Layout - resets all the views to their default position.

• Show View - Brings to front the specified view.

• Options

• Preferences - opens the preferences dialog.

• Reset Options - resets all your options to the default ones.

• Import Options - allows you to import options you have previously exported.

• Export Options - allows you to export the current options to a file.

• Reset Authentication - resets the Subversion authentication information.

• Help

• Dynamic Help - shows the Dynamic Help dialog.

• Help - opens the Help dialog.

• Check for New Versions - checks the availability of new Syncro SVN Client versions.

Note

In order to avoid unusual situations you can currently execute only one action that involves operations with the
working copy or with the repository at a time.
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Getting started

Define a repository location
Usually team members do all of their work separately, in their own working copies and need to share their work. This
is done via a Subversion repository. Syncro SVN Client supports the versions 1.3, 1.4 and 1.5 of the SVN repository
format.

Figure 15.2. Repository View

Add / Edit / Remove repository locations

Before you can begin working with a Subversion repository, you must define a repository location in the Repository
View.

To create a new repository location, click the New Repository Location toolbar button or right click inside the view
and select New Repository Location... from the popup menu. On Windows the context menu can be displayed with the
mouse on a right click or with the keyboard by pressing the special context menu key available on Windows keyboards.

The Add SVN Repository dialog will prompt you for the URL of the repository you want to connect to. No authentication
information is requested at the time the location is defined; it is left to the Subversion client to request the user and
password information when it is needed. The main benefit of allowing Subversion to manage your password in this
way is that it will prompt you for a new password only when your password changes.

Figure 15.3. The Add SVN Repository dialog

To edit a repository location, click the Edit Repository Location toolbar button or right click inside the view on a re-
pository entry and select Edit Repository Location... from the popup menu.

The Edit SVN Repository dialog works in the same way as the Add SVN Repository dialog. It will show the previously
defined repositories URL and it will allow you to change them.
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To remove a repository location, click the Remove Repository Location toolbar button or right click inside the view
on a repository entry and select Remove Repository Location... from the popup menu. A confirmation dialog will appear
in order to make sure you don't accidentally remove locations.

The order of the repositories can be changed in the Repository view at any time with the two buttons on the toolbar of
the view, the up arrow and the down arrow. For example pressing the up arrow once moves the selected repository up
in the list with one position.

To set the reference revision number of a SVN repository right-click on the repository in the list displayed in the Re-
pository View and select the action Change Browse Revision.

Figure 15.4. The Change Browse Revision dialog

The revision number of the repository set with this dialog will be used for displaying the contents of the repository
when it is viewed in the Repository View: only the files and folders that were present in the repository at the moment
when this revision number was generated on the repository are displayed as contents of the repository tree. Also this
revision number is used and for all the file open operations executed directly from the Repository View.

Authentication

Five protocols are supported: HTTP, SVN, HTTPS, SVN + SSH and FILE. If the repository that you are trying to access
is password protected, the Enter authentication data dialog will request a username and a password. If the Store au-
thentication data checkbox is checked the credentials will be stored in Subversion's default directory:

• Windows - %HOME%\Application Data\Subversion\auth. Example: C:\Documents and Set-
tings\John\Application Data\Subversion\auth

• Linux & Mac OS X - $HOME/.subversion/auth. Example: /home/John/.subversion/auth

There will be one file for each server that you access. If you want to make Subversion forget your credentials, you can
use the Reset authentication command from the Options menu. This will cause Subversion to forget all your credentials.

Note

When you reset the authentication data, you will have to restart the application in order for the change to take
effect.

Tip

The FILE protocol is recommended if the SVN server and Syncro SVN Client are located on the same computer
as it ensures faster access to the SVN server than the other protocols.
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Figure 15.5. User & Password authentication dialog

For https connections where client authentication is required by your SSL server, you have to choose the Certificate
File and enter the corresponding Certificate Password which is used to protect your certificate.

Figure 15.6. SSL authentication dialog

When using a secure http (https) protocol for accessing a repository, a Certificate information dialog will pop up and
ask you whether you accept the certificate permanently, temporarily or simply deny it.

If the repository used has svn+ssh protocol the SSH authentication can also be made with a private key and a pass
phrase.

Figure 15.7. User & Private key authentication dialog
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After the SSH authentication dialog another dialog will pop up for entering the SVN user name that will access the
SVN repository and will be recorded as the committer in SVN operations.

Figure 15.8. SVN user authentication dialog

Defining a working copy
A Subversion working copy is an ordinary directory tree on your local system, containing a collection of files. You
can edit these files however you wish, your working copy being your private work area. In order to make your own
changes available to others or incorporate other people's changes, you must explicitly tell Subversion to do so. You
can even have multiple working copies of the same project.

Figure 15.9. Working Copy View

A Subversion working copy also contains some extra files, created and maintained by Subversion, to help it keep track
of your files. In particular, each directory in your working copy contains a subdirectory named .svn, also known as the
working copy administrative directory. This administrative directory contains an unaltered copy of the last updated
files from the repository. This copy is usually referred to as the pristine copy or the BASE revision of the working copy.
These files help Subversion recognize which files contain unpublished changes, and which files are out-of-date with
respect to others' work.

A typical Subversion repository often holds the files (or source code) for several projects; usually, each project is a
subdirectory in the repository's file system tree. In this arrangement, a user's working copy will usually correspond to
a particular subtree of the repository.

Check out a working copy

Check out is the term used to describe the process of making a copy of a project from a repository into your local file
system. This checked out copy is called a working copy. A Subversion working copy is a specially formatted folder
structure which contains additional .svn folders that store Subversion information, as well as a pristine copy of each
item that is checked out.
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You check out a working copy from the Repository View. If you have not yet defined a connection to your repository,
you will need to add a new repository location.

To check out a new working copy, navigate inside the repository to the desired directory, right click on it and select
Check Out... from the popup menu.

In the Check out dialog click on the Browse button and choose the location where the working copy will be checked
out.

Figure 15.10. Check out dialog

After a check out, the new working copy will be added to the list in the Working Copy view and its content will be
displayed in that view.

Depth

You can choose the depth for the checkout folder. This allows you to specify the recursion level into children. This is
used if you want to check out only a portion of an working copy and then bring in a future update operation previously
ignored files and subdirectories. You can find out more about checkout depth in the sparse checkouts section.

Revision

By default the last (HEAD) revision will be checked out. If you need another revision you can select the Revision radio
button and then click on the History button and choose a desired revision from the new dialog. Or you can simply type
the revision number in the corresponding text field.
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Figure 15.11. History dialog

The History dialog presents a list of revisions for a resource. There are presented information about revision, commit
date, author and commit comment. The initial number of entries in the list is 50. Additional revisions can be added to

the list using the  Get next 50 and  Get all buttons. The list of revisions can be refreshed at any time with the 
Refresh button.

The Affected Paths area displays all paths affected by the commit of the revision selected in history. On a revision se-
lected in the Affected Paths area the contextual menu contains the actions:

Open Opens the revision in the editor panel.

Save revision to ... Save the revision to a new file.

Compare with previous version Make a diff between the selected revision and the previous one. If there is no
external application specified for executing diff operations the built-in diff tool
is applied. This is the action also executed on double clicking on a file in the
Affected Paths area.

Update to revision Make the selected revision the current revision in the working copy.

Revert changes from this revision The changes committed by the selected revision are reverted in the current ver-
sion of the file in the working copy. If the committed changes were in fact a
SVN delete operation the result is restoring the deleted file in the working copy.

Show History Display the history of the SVN resource of the selected revision.

Show Annotation Open the Annotations View for the selected revision.
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Use an existing working copy

This is the process of taking an working copy that exists on your file system and connecting it to Subversion. If you
have a brand new project that you want to import into your repository, then see the section Import resources into the
repository

This assumes that you have an existing valid working copy on your file system. In the Working Copy View click on
the Add/Remove Working Copy toolbar button.

Figure 15.12. Add/Remove Working Copy dialog

In the Working copies list dialog press the Add button and choose the working folder copy from the file system.

Select the new working copy from the list and press the OK button. The selected working copy will be loaded and
presented in the Working Copy View.

The Edit button allows changing the name of the working copy. The name is useful to differentiate between working
copies located in folders with the same name. The default name is the name of the root folder of the working copy.

The order of the working copies can be changed in the list using the two arrow buttons which move the selected
working copy with one position up or down.

Manage working copy resources

Edit files

You can edit files from the Working Copy View by double clicking them or by right clicking them and choosing Open
from the popup menu, or from the Synchronize View by using Open from the popup menu. Please note that only one
file can be edited at a time; if you try to open another file it will be opened in the same editor window. The editor has
syntax highlighting for known file types, meaning that a different color will be used for each type of recognized token
in the file. If the selected file is an image, then it will be previewed in the editor, with no access to modifying it.
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Figure 15.13. Editor View

When you edit a file from your working copy, you will notice that after modifying and saving it, a modified marker -
an asterisk(*) - will appear on the file's icon in the Working Copy View.

Add resources to version control

The new file(s) or folder(s) you create during your development process must be added to Version Control, using the
Add command from the context menu in Working Copy View or Synchronize View. If you do not do this, the resource
will be marked with a question mark (?), meaning that it is unversioned (unknown). After you have added it to version
control, the resource will be marked as added(+) which means you first have to commit your working copy to make
those resources available to other developers. Adding a resource to version control does not affect the repository.

If you try to add to version control an unversioned directory the entire subtree starting with that directory will be added.

When you commit your changes, if you forgot to add a resource, it will still be presented in the commit dialog, but
will be de-selected by default. When you commit the unversioned resource, it will be automatically added to version
control before being committed and the marking will also be removed.

Figure 15.14. Unversioned / Added

Ignore resources not under version control

Sometimes you will have files and folders inside your working copy that should not be subject to version control.
These might include files created by the compiler, *.obj, *.class, *.lst, maybe an output directory used to
store the executable. Whenever you commit changes, Subversion shows your modified files but also the unversioned
files, which fills up the file list in the commit dialog. Though the unversioned files will not be committed unless otherwise
specified, it is difficult to see exactly what you are committing.

The best way to avoid these problems is to add the derived files to the Subversion's ignore list. That way they will
never show up in the commit dialog and only genuine unversioned files which must be committed will be shown.

You can choose to ignore a resource by using the Add to svn:ignore action in the context menu from Working Copy
View or Synchronize View.

In the Add to svn:ignore dialog you can specify the resource to be ignored by name or by a custom pattern. The custom
pattern can contain wildcard characters such as:

• * - Matches any string of characters of any size, including the empty string.
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• ? - Matches any single character.

For example you may choose to ignore all text documents by using the pattern: *.txt

The action adds a predefined Subversion property called svn:ignore to the parent directory of the specified resource.
In this property there are specified all the child resources of that directory that must be ignored. The result will be
visible in the Working Copy view. The ignored resources will be represented with grayed icons.

Delete resources

The delete command can be found in the Edit submenu of the context menu from the Working Copy View.

When you delete a resource from the Subversion working copy it will be removed from the file system and it will be
also marked as deleted. If unversioned, added or modified resources will be encountered, a dialog will prompt you to
confirm their deletion.

The delete command will not delete from the file system the directories under version control, it will only mark them
as deleted. This is because the directories also contain the pristine copy of that directory content. In the Working Copy
View this is transparent as all resources will have the deleted mark(-). The directories will be removed from the file
system when you commit them to the repository. You can also change your mind completely and revert the deleted
files to their initial, pristine state.

If a resource is deleted from the file system without Subversion's knowledge, your working copy will be in an incon-
sistent state. The resource will be considered and marked as missing (!). If a file was deleted, it will be treated in the
same way as if it was deleted by Subversion. However if a directory is missing you will be unable to commit. If you
update your working copy, Subversion will replace the missing directory with the latest version from the repository
and you can then delete it the correct way using the Delete command. The Delete action is not enabled when the selection
contains missing resources.

Copy / Move / Rename resources

Copy resources

You can copy several resources from different locations of the working copy. You select them in the Working Copy
View and then you initiate the copy command from the context menu. This is not a simple file system copy but a
Subversion command. It will copy the resource and the copy will also have the original resource's history. This is one
of Subversion's very important features, as you can keep track of where the copied resources originated.

Please note that you can only copy resources that are under version control and are committed to the repository or un-
versioned resources. You cannot copy resources that are added but not yet committed.
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Figure 15.15. Copy files dialog

In the Copy File(s) dialog you can navigate through the working copy directories in order to choose a target directory.
If you try to copy a single resource you are also able to change that resource's name in the corresponding text field.

If an entire directory is copied the Override and update action will be enabled only for it and not for its descendants.
In the Synchronize view and the Commit dialog will appear only the directory in question without its children.

Move resources

As in the case of the copy command you can perform the operation on several resources at once. Just select the resources
in the Working Copy View and choose the Move command from the context menu. The move command actually behaves
as if a copy followed by a delete command were issued. You will find the moved resources at the desired destination
and also at their original location but marked as deleted.

Rename a resource

The rename action can be found in the context menu in the Working Copy View. This action can only be performed
on a single resource. The rename command acts as a move command with the destination being the same as the original
location of the resource. A copy of the original resource will be made with the new name and the original will be
marked as deleted.

Note

Because the rename and move commands act as a copy followed by delete, when you want to commit a renamed
or moved resource you must also commit the deleted original. It is also recommended that you commit the renamed
or moved resources before changing their contents in order to avoid difficulties in resolving conflicts.

Lock / Unlock resources

The idea of version control is based on the copy-modify-merge model of file sharing. This model states that each user
contacts the repository and creates a local working copy(check out). Users can then work independently and make
modifications to their working copies as they please. When their goal has been accomplished it is time for the users to
share their work with the others, to send them to the repository(commit). When a user has modified a file that has been
also modified on the repository the two files will have to be merged. The version control system assists the user with
the merging as much as it can, but in the end the user is the one that must make sure it is done correctly.
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The copy-modify-merge model only works when files are contextually mergeable: this is usually the case of line-based
text files (such as source code). However this is not always possible with binary formats, such as images or sounds.
In these situations, the users must each have exclusive access to the file, ending up with a lock-modify-unlock model.
Without this, one or more users could end up wasting time on changes that cannot be merged.

A Subversion lock is a piece of metadata which grants exclusive access to a user. This user is called the lock owner.
A lock is uniquely identified by a lock token (a string of characters). If someone else attempts to commit the file (or
delete a parent of the file), the repository will demand two pieces of information:

• User authentication. The user performing the commit must be the lock owner.

• Software authorization. The user's working copy must have the same lock token as the one from the repository,
proving that it is the same working copy where the lock originated from.

Scanning for locks

When starting to work on a file that is not contextually mergeable (usually a binary file), it is better to verify if someone
else isn't already working on that file. You can do this in the Working Copy View by selecting one or more resources,
then right clicking on them and choosing the Scan for locks action from the context menu.

Locked items

Figure 15.16. The locked items dialog

The Locked items dialog contains a table with all the resources that were found locked on the repository. For each resource
there are specified: resource path, state of the lock, owner of the lock, lock comment, creation and expiration date for
the lock (if any).

The state of the lock can be one of:

• Other - if someone else locked the file.

• Locked - if you locked the file.

• Broken - if you locked the file but it was forcefully unlocked by someone else afterwards.

• Stolen - if you locked the file but it was forcefully locked by someone else afterwards.

You can unlock a resource by selecting it and pressing the Unlock button.

Locking a file

A locked file allows you exclusive write access to a file from the repository, meaning that you are the only one who
can modify and commit the file to the repository.
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You can lock a file from the context menu in Working Copy View. Note that you can only lock several files at once
but no directories. This is a restriction of Subversion which is used to discourage the use of the lock-modify-unlock
model at large scale or when unnecessary.

Figure 15.17. The lock dialog

In the Lock dialog you can write a comment for the lock and if necessary steal (force) the lock. Note that you should
only steal a lock after you made sure that the previous owner no longer needs it, otherwise you may cause an unsolvable
conflict which is exactly why the lock was put there in the first place. The Subversion server can have a policy concerning
lock stealing, it may not allow you to steal a lock if a certain condition is not satisfied.

The lock will stay in place until you commit the locked file or until someone unlocks it. There is also the possibility
that the lock will expire after a period of time specified in the Subversion server policy.

Unlocking a file

A file can be unlocked from the context menu in the Working Copy View. A dialog will prompt you to confirm the
unlocking and it will also allow you to break the lock (unlock it by force).

Synchronize with the repository
In the work cycle you will need to incorporate other people's changes(update) and to make your own work available
to others(commit). This is what the Synchronize View was designed for, to help you send and receive modifications
from the repository.

Figure 15.18. Synchronize View
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In the Synchronize view you can see the overall status of your working copy resources when compared to the repository
resources. The view focuses on incoming and outgoing changes, where incoming changes are the changes that other
users have committed since you last updated your working copy. The outgoing changes are the modifications you made
to your working copy as a result of editing, removing or adding resources.

The view presents the status of the working copy resources against the BASE revision after a Refresh operation. You
can view the state of the resources versus a repository HEAD revision by using the Synchronize actions from the
Working Copy view.

Presentation modes

The Synchronize view has three presentation modes:

Tree mode The resources are presented in a tree layout as in the above image which mirrors the tree
structure of the SVN repository and of the Working Copy view. This mode is more appropriate
when you want a quick overview of the locations which need synchronization with the SVN
repository or when you want to apply a synchronization operation (Commit, Update, Revert,
Add) recursively on a folder.

Figure 15.19. Synchronize View - Tree mode

Compressed mode The resources are presented in a layout with two levels, that is a compressed path for each
folder in the list as in the following image. This mode is useful when you need the full list of
resources which need synchronization without having to expand a tree to get to the unsyn-
chronized resources of that folder. Also it is useful when you do not want to apply a synchron-
ization operation recursively, that is the operation applied to a folder resource must not have
any effect on other unsynchronized resources located in the folder but displayed in other list
entries in the view.
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Figure 15.20. Synchronize View - Compressed mode

Flat mode The full list of the resources that must be synchronized with the repository are presented in
a flat list. As in the Compressed mode it is useful when you do not want to apply a synchron-
ization operation recursively on a folder.

Figure 15.21. Synchronize View - Flat mode
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Switching between the three presentation modes is done with the switch button on the right side of the toolbar of the
Synchronize view.

View differences

One of the most common requirements in project development is to see what changes have been made to the files from
your Working Copy or to the files from the repository. You can examine these changes after a synchronize operation
with the repository, by using the Open in compare editor action from the contextual menu.

The text files are compared using a built-in Compare View which uses a line differencing algorithm or a specified ex-
ternal diff application if such an application is set in the SVN preferences. When a file with outgoing status is involved,
the compare is performed between the file from the working copy and the BASE revision of the file. When a file with
incoming or conflict status is involved, the differences are computed using a three-way algorithm which means that
the local file and the repository file are each compared with the BASE revision of the file. The results are displayed
in the same view. The differences obtained from the local file comparison are considered outgoing changes and the
ones obtained from the repository file comparison are considered incoming changes. If any of the incoming changes
overlap outgoing changes then they are in conflict.

A special case of difference is a diff pseudo-conflict. This is the case when the left and the right sections are identical
but the BASE revision does not contain the changes in that section. By default this type of changes are ignored. If you
want to change this you can go to SVN Preferences and change the corresponding option.

The right editor of the internal compare view presents either the BASE revision or a revision from the repository of
the file so its content cannot be modified. By default when opening a synchronized file in the Compare View, a compare
is automatically performed. After modifying and saving the content of the local file presented in the left editor, another
compare is performed. You will also see the new refreshed status in the Working copy view.

Figure 15.22. Compare View

There are three types of differences:

• incoming changes - changes committed by other users and not present yet in your working copy file. They are marked
with a blue highlight and on the middle divider the arrows point from right to left.

• outgoing changes - changes you have done in the content of the working copy file. They are marked with a gray
highlight and the arrows on the divider are pointing from left to right.
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• conflicting changes - this is the case when the same section of text which you already modified in the local file has
been modified and committed by some other person. They are marked with a red highlight and red diamonds on the
divider.

There are numerous actions and options available in the Compare View toolbar or in the Compare menu from the main
menu. You can decide that some changes need adjusting or that new ones must be made. After you perform the adjust-
ments, you may want to perform a new compare between the files. For this case there is an action called Perform files
differencing. After each files differencing operation the first found change will be selected. You can navigate from one
change to another by using the actions Go to first / Go to previous / Go to next / Go to last modification. If you decide
that some incoming change needs to be present in your working file you can use the action Copy change from right to
left. This is useful also when you want to override the outgoing modifications contained in a conflicting section. The
Copy all non-conflicting changes from right to left copies all incoming changes which are not contained inside a con-
flicting section in your local file.

Let us assume that only a few words or letters are changed, considering that the differences are performed taking into
account whole lines of text, the change will contain all the lines involved. For finding exactly what words or letters
have changed there are available two dialogs which present a more detailed compare result: Word Details and Character
Details.

Figure 15.23. Word details dialog

When you want to examine only the changes in the real text content of the files disregarding the changes in the number
of white spaces between words or lines there is available an option which allows you to enable or disable the white
space ignoring feature of the compare algorithm.

Resolve conflicts

Once in a while, you will get file conflicts when you update your files from the repository. A file conflict occurs when
two or more developers have changed the same few lines of a file or the properties of the same file. As Subversion
knows nothing of your project, it leaves resolving the conflicts to the developers. Whenever a conflict is reported, you
should open the file in question, and try to analyse and resolve the conflicting situation.

Real conflicts vs mergeable conflicts

There are two types of conflicts. The real conflict (conflicted state) is obtained when a file in the working copy has
incoming and outgoing changes in the same section. When updated the differences cannot be merged automatically
so the file is marked as conflicted. A file can be in real conflict state when its content or its properties are in conflict.
A folder can be in real conflict only when its properties are in conflict.

A file is in a mergeable conflict state when it contains both incoming and outgoing changes not necessarily in the same
sections. A file is in mergeable conflict when its content has both incoming and outgoing changes but the changes can
be merged by the update operation. A folder can be in mergeable conflict when it contains files in mergeable conflict
and / or real conflict themselves. After an update it is possible that the state of conflict can be resolved automatically
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by merging the incoming changes into the working copy resource. A conflicting resource cannot be committed. In the
conflict case the resource will be marked with a conflict icon and will appear in all the Synchronization trees.

Content conflicts vs Property conflicts

On the other hand depending on the situation the conflicts are separated in two categories: Content conflicts and
Properties conflicts. Content conflicts - this type refers to the fact that the conflict appears in the content of a file. A
merge occurs for every inbound change to a file which is also modified in the working copy. In some cases, if the
local change and the incoming change intersect each other, Subversion cannot merge these changes without intervention.
So if the conflict is real when updating the file in question the conflicting area is marked like this:

                        <<<<<<< filename
                        your changes
                        =======
                        code merged from repository
                        >>>>>>> revision

Also, for every conflicted file Subversion places three additional temporary files in your directory:

• filename.ext.mine - This is your file as it existed in your working copy before you updated your working
copy - that is, without conflict markers. This file has your latest changes in it and nothing else.

• filename.ext.rOLDREV - This is the file that was the BASE revision before you updated your working copy.
That is, the file revision that you updated before you made your latest edits.

• filename.ext.rNEWREV - This is the file that Subversion client just received from the server when you updated
your working copy. This file corresponds to the HEAD revision of the repository.

OLDREV and NEWREV are revision numbers. If you have conflicts with binary files, Subversion does not attempt
to merge the files by itself. The local file remains unchanged (exactly as you last changed it) and you will get file-
name.ext.r* files also. Properties conflicts - refer to the conflicts that are obtained when two people modify the same
property of the same file or folder. When updating such a resource a file named filename.ext.prej is created
in your working copy containing the nature of the conflict. Your local file property that is in conflict will not be changed.
After resolving the conflict one should use the Mark resolved action in order to be able to commit the file. Note that
the Mark resolved action does not really resolve the conflict. It just removes the conflicted flag of the file and deletes
the temporary files.

Edit real content conflicts

The conflicts of a file in the conflicted state (a file with the red double arrow icon) can be edited visually with the
Compare view (the built-in file diff tool) or with an external diff application to decide for each conflict if the local
version of the change will remain or the remote one instead of the special conflict markers inserted in the file by the
SVN server.
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Figure 15.24. Compare view for editing a conflict

The Compare view (or the external diff application set in Preferences) is opened with the action Edit Conflict which
is available on the context menus of the Synchronize view and the Working Copy view and is enabled only for files
in the conflicted state (an update operation was executed but the differences could not be merged without conflicts).
The external diff application is called with 3 parameters because it is a 3-way diff operation between the local version
of the file from the working copy and the HEAD version from the SVN repository with the BASE version from the
working copy as common ancestor.

If the option Show warning dialog when edit conflicts is enabled you will be warned at the beginning of the operation
that the operation will overwrite the conflict version of the file received from the SVN server (the version which contains
the conflict markers <<<<<<<, =======, >>>>>>>) with the original local version of the file that preceded the update
operation. If you press the OK button the visual conflict editing will proceed and a backup file of the conflict version
received from the SVN server is created in the same working copy folder as the file with the edited conflicts. The name
of the backup file is obtained by appending the extension .sync.bak to the file as stored on the SVN server. If you press
the Cancel button the visual editing will be aborted.

The usual operations on the differences between two versions of a file are available on the toolbar of this view:

Save Save the modifications of the local version of the file displayed in the left side
of the view.

Perform Files Differencing Apply the diff operation on the two versions of the file displayed in the view.
It is useful after modifying the local version displayed in the left side of the
view.

Go to First Modification Scroll the view to the topmost difference.

Go to Previous Modification Scroll the view to the previous difference. The current difference is painted with
a darker color than the other ones.

Go to Next Modification Scroll the view to the next difference. The current difference is painted with a
darker color than the other ones.

Go to Last Modification Scroll the view to the last difference.

Copy All Non Conflicting Changes
from Left to Right

Not applicable for editing conflicts so it is disabled.

Copy Change from Left to Right Not applicable for editing conflicts so it is disabled.
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Copy Change from Right to Left Copy the current difference from the left side to the right side by replacing the
highlighted text of the current difference from the left side with the one from
the right side.

Copy All Non Conflicting Changes
from Right to Left

Apply the previous operation for all the differences.

Show Modification Details at Word
Level

Display a more detailed version of the current difference computed at word
level.

Show Modification Details at Char
Level

Display a more detailed version of the current difference computed at character
level.

Ignore Whitespaces The text nodes are normalized before computing the difference so that if two
text nodes differ only in whitespace characters they are reported as equal.

The operation begins by overwriting the conflict version of the file received from the SVN server (the version which
contains the conflict markers <<<<<<<, =======, >>>>>>>) with the original local version of the file before running
the update action which created the conflict. After that the differences between this original local version and the re-
pository version are displayed in the Compare view.

If you want to edit the conflict version of the file directly in a text editor instead of the visual editing offered by the
Compare view you should work on the local working copy file after the update operation without running the action
Edit Conflict. If you decide that you want to edit the conflict version directly after running the action Edit Conflict you
have to work on the .sync.bak file.

If you did not finish editing the conflicts in a file at the first run of the action Edit Conflict you can run the action again
and you will be prompted to choose between resuming the editing where the previous run left it and starting again from
the conflict file received from the SVN server.

After the conflicts are edited and saved in the local version of the file you usually run the action Mark Resolved on the
file so that the result of the conflict editing process can be committed to the SVN repository or the action Revert so
that the repository version overwrites all the local modifications. Both actions remove the backup file and other tem-
porary files created with the conflict version of the local file.

Revert your changes

If you want to undo all changes you made in a file since the last update you need to select the file, right click to pop
up the context menu and then select Revert. A dialog will pop up showing you the files that you have changed and can
be reverted. Select those you want to revert and click the OK button. Revert will only undo your local changes. It does
not undo any changes which have already been committed. If you choose to revert the file to the pristine copy which
resides in the administration folders then the eventual conflict is solved by losing your outgoing modifications. If you
try to revert a resource not under version control, the resource will be deleted from the file system.

If you want some of your outgoing changes to be overridden you must first open the file in Compare view and choose
the sections to be replaced with ones from repository file. This can be achieved either by editing directly the file or by
using the action Copy change from right to left from Compare view toolbar. After editing the conflicting file you have
to use Mark as merged before committing it.

If you want to drop all local changes and in the same time bring all incoming changes into your working copy resource
you can use the Override and update action which discards the changes in the local file and updates it from the repos-
itory. A dialog will show you the files that will be affected.
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Figure 15.25. Override and update dialog

In the first table in the dialog you will be able to see the resources that will be overridden. You can also select or
deselect them as you wish. In the second table you will find the list of resources that will be updated. Only resources
that have an incoming status in the Synchronize view will be updated.

Merge conflicted resources

Before you can safely commit your changes to the repository you must first resolve all conflicts. In the case of pseudo-
conflicts they can be resolved in most cases with an Update operation which will merge the incoming modifications
into your working copy resource. In the case of real conflicts, conflicts that persist after an update operation, it is ne-
cessary to resolve the conflict using the built-in compare view and editor or, in the case of properties conflict, the
Properties view. Before you can commit you must mark as resolved the affected files. Both pseudo and real conflicts
can be resolved without an update. You can:

• open the file in the compare editor

• analyze the changes

• edit the changes

• decide which incoming changes need to be copied locally

• decide which outgoing changes must be overridden or modified

After saving your local file you have to use the Mark as merged action from the contextual menu before committing.

Drop incoming modifications

In the situation when your file is in conflict but you decide that your working copy file and its content is the correct
one, you can decide to drop some or all of the incoming changes and commit afterwards. The action Mark as merged
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proves to be useful in this case too. After opening the conflicting files with Compare view, Editor or editing their
properties in the Properties view and deciding that your file can be committed in the repository replacing the existing
one, you should first use Mark as merged action. When you want to override completely the remote file with the local
file you can use Override and commit which drops any remote changes and commits your file.

Figure 15.26. Override and commit dialog

In general it is much safer to analyze all incoming and outgoing changes using Compare view and only after to update
and commit.

Tree conflicts

A tree conflict is a conflict at the folder level and occurs when the user runs an update action on a file but the file does
not exist in the repository anymore because other user renamed the file, moved the file to other folder or deleted the
file from repository. The same conflict situation can occur at folder level in a merge action or switch action. The action
ends with an error and the folder containing the file that exists now only in the working copy is marked with a conflict
icon ().

Such a conflict can be resolved in one of the following ways which are available when the user double clicks on the
conflict in the Synchronize view or when he runs the action Edit conflict:
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Figure 15.27. Resolve a tree conflict

• keep the the local modified file; if there is a renamed version of the file committed by other user that will be added
to the working copy too

• delete the local modified file, which means keep the incoming change that comes from the repository.

Update the working copy

While you are working on a project, other members of your team may be committing changes to the project repository.
To get these changes, you have to update your working copy. Updating may be done on single files, a set of selected
files, or recursively on entire directory hierarchies The update operation can be performed either from Working Copy
view or Synchronize view. The Update action in the Working Copy view is different from the Update action in the
Synchronize view. The Update action from the Working Copy view updates the selected resources to the HEAD revision
on the repository. The Synchronize view action updates the selected resources to the revision against which the Syn-
chronize operation was performed.

There are three different kinds of incoming changes:

• Non-conflicting - A non-conflicting change occurs when a file has been changed remotely but has not been modified
locally.

• Conflicting, but auto-mergeable - An auto-mergeable conflicting change occurs when a text file has been changed
both remotely and locally (i.e. has non-committed local changes) but the changes are on different lines.

• Conflicting - A conflicting change occurs when one or more of the same lines of a text file have been changed both
remotely and locally. Binary files are never auto-mergeable and are conflicting by default.

If the resource contains only incoming changes or the outgoing changes do not intersect with incoming ones then the
update will end normally, the Subversion system merging incoming changes into the local file. In the case of conflicting
situation the update will have as result a file with conflict status.

The Syncro SVN Client allows you to update your working copy files to a specific revision, not only the most recent
one. This can be done by using Update to revision action from the History view contextual menu.
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If you select multiple files and folders and then you perform an Update, all of those files/folders are updated one by
one. The Subversion client makes sure that all files/folders belonging to the same repository are updated to the exact
same revision, even if between those updates another commit occurred.

When the update fails with a message saying that there is already a local file with the same name Subversion tried to
checkout a newly versioned file, and found that an unversioned file with the same name already existed in your
working folder. Subversion will never overwrite an unversioned file unless you specifically do this with Override and
update. If you get this error message, the solution is simply to rename the local unversioned file. After completing the
update, you can check whether the renamed file is still needed.

Send your changes to the repository

Sending the changes you made to your working copy is known as committing the changes. If your working copy is up
to date and there are no conflicts, you are ready to commit your changes.

The Commit action sends the changes in your local working copy to the repository. After selecting the action from the
contextual menu you will see a dialog displaying the resources that can be committed.

Figure 15.28. Commit dialog

Enter a comment to associate with the commit or choose a previously entered comment from the list (the last 10 commit
messages will be remembered even after restarting the SVN client application). The dialog will list modified, added,
deleted and unversioned resources. All modified, added and deleted resources will be selected by default. If you don't
want a changed file to be committed, just uncheck that file. The unversioned items are not selected by default unless
you have selected them specifically before issuing the commit command.

To select all resources, click Select All. To deselect all resources, click Deselect All. Checking the Keep locks option
will preserve any locks you have on repository resources. Your working copy must be up-to-date with respect to the
resources you are committing. This is ensured by using the Update action prior to committing, resolving conflicts and
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re-testing as needed. If your working copy resources you are trying to commit are out of date you will get an appropriate
error message.

The table presented in the dialog is sortable. For example if you want to see all the resources that are in the modified
state click on the State column header to sort the table by that column.

The modifications that will be committed for each file can be reviewed in the compare editor window by double
clicking on the file in the Commit dialog or by right clicking and selecting the action Show Modifications.

If you have modified files which have been included from a different repository using svn:externals, those changes
cannot be included in the same commit operation.

Integration with Bug Tracking Tools

Users of bug tracking systems can associate the changes they make in the repository resources with a specific ID in
their bug tracking system. When the user enters a commit message, the bug ID is added to this message. The format
and the location of the ID in the commit message are configured with SVN properties.

To make the integration possible Syncro SVN Client needs some data about the bug tracking tool used in the project.
You can configure this using the following SVN properties which must be set on the folder containing resources asso-
ciated with the bug tracking system. Usually they are set recursively on the root folder of the working copy.

bugtraq:message A string property. If it is set the Commit dialog will display a text field for entering
the bug ID. It must contain the string %BUGID%, which is replaced with the bug
number on commit.

bugtraq:label A string property that sets the label for the text field configured with the
bugtraq:message property.

bugtraq:url A string property that is the URL pointing to the bug tracking tool. The URL string
should contain the substring "%BUGID%" which Syncro SVN Client replaces with
the issue number. That way the resulting URL will point directly to the correct issue.

bugtraq:warnifnoissue A boolean property with the values "true"/"yes" or "false"/"no". If set to "true", then
Syncro SVN Client will warn you if the bug ID text field is left empty. The warning
will not block the commit, only give you a chance to enter an issue number.

bugtraq:number A boolean property with the value "true" or "false". If this property is set to "false",
then any character can be entered in the bug ID text field. Any other value or if the
property is missing then only numbers are allowed as the bug ID.

bugtraq:append A boolean property. If set to "false", then the bug ID is inserted at the beginning of
the commit message. If "yes" or not set, then it's appended to the commit message.

bugtraq:logregex This property contains one or two regular expressions, separated by a newline. If
only one expression is set, then the bug ID's must be matched in the groups of the
regexp string. Example:

[Ii]ssue #?(\d+)

If two expressions are set, then the first expression is used to find a string which
relates to a bug ID but may contain more than just the bug ID (e.g. "Issue #123" or
"resolves issue 123"). The second expression is then used to extract the bug ID from
the string extracted with the first expression. An example: if you want to catch every
pattern "issue #XXX" and "issue #890, #789" inside a log message you could use
the following regexp strings:
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[Ii]ssue #?(\d+)(,? ?#?(\d+))+

(\d+)

The data configured with these SVN properties is stored on the repository when a revision is committed. A bug tracking
system or a statistics tools can retrieve from the SVN server the revisions that affected a bug and present the commits
related to that bug to the user of the bug tracking system.

If the bugtraq:url property was filled in with the URL of the bug tracking system and this URL includes the %BUGID%
substring as specified above in the description of the bugtraq:url property then the History view presents the bug ID
as a hyperlink in the commit message. A click on such a hyperlink in the commit message of a revision opens a Web
browser at the page corresponding to the bug affected by that commit.

Obtain information for a resource

Request status information for a resource

While you are working you often need to know which files you have changed, added, removed or renamed, or even
which files got changed and committed by others. That's where the Synchronize action from Working Copy view comes
in handy. The Working Copy View will show you every file that has changed in any way in your working copy, as well
as any unversioned files you may have. If you use Synchronize view then you can also look for changes in the repository.
That way you can check before an update if there's a possible conflict.

If you want more detailed information about a given resource you can use Information action from the Working copy
viewcontextual menu or the Synchronize viewcontextual menu. A dialog called SVN Information will pop up showing
remote and local information regarding the resource, such as:

• local path and repository location

• revision number

• last change author, revision and date

• commit comment

• information about locks

• local file status

• local properties status

• remote file status

• remote properties status

• file size, etc.
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Figure 15.29. Information about a SVN resource

The value of a property of the resource displayed in the dialog can be copied by right clicking on the property and se-
lecting the Copy action.

A less detailed list of information is also presented when you hover with the mouse pointer over a resource and the
tooltip window is displayed.

Figure 15.30. Tooltip for a resource

Request history for a resource

In Subversion, both files and directories are versioned and have a history. If you want to examine the history for a se-
lected resource and find out what happened at a certain revision, what has been changed regarding that resource and
who did the changes, drop the modifications made in a certain revision, check out / update the resource to a selected
revision, compare two revisions of the same file and other actions, you have to use the Show history action. This is
available from any of the three views: Repository view menu, Working copy view menu or Synchronize view menu.
From the Repository view you can display the log history regarding any remote resource residing in repository. From
the Working copy view you can display the history of local versioned resources. From the Synchronize view you can
show the history of any incoming or outgoing resources.

The view itself consists of three distinct areas:

400

The Syncro SVN Client



• The revision table showing revision numbers, date/time of revision, name of the author, as well as the first line of
the commit message. You can click on any revision to show its full details.

• The list of resources affected by this revision (modified, added, deleted or changed properties).

• The commit message for the selected revision.

Figure 15.31. History View

The Resource history view does not always show all the changes ever made to a resource because for a large repository
there may be thousands of changes and retrieving the entire list can take a long time. Normally you are interested in
the more recent ones and that is why the number of revisions is limited by default from the options to 50. This can be
changed by accessing the Preferences->SVN page.

Note

When using Subversion servers older than version 1.2, a history request may take a very long time because the
server will reply with the entire history even if you limited the number of entries to a smaller number.

Using the resource history view
The History view provides a set of actions you can use to get even more information about the project history and make
changes to your working copy related with older revisions.

History actions available in the popup menu displayed by a right click
in the view when a single resource is selected:

• Open - opens the selected revision of the file into the Editor. This is enabled only for files.

• Save revision as - saves the selected revision to a file so you have an older version of that file. This option is only
available when you access the history of a file, and it saves a version of that one file only.
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• Compare with working copy - compares the selected revision with your working copy file. It is enabled only when
you select a file.

• Update to revision - updates your working copy resource to the selected revision. Useful if you want to have your
working copy reflect a time in the past. It is best to update a whole directory in your working copy, not just one file,
otherwise your working copy will be inconsistent and you will be unable to commit your changes.

• Check out from revision - gets the content of the selected revision for the resource into local file system.

• Revert changes from this revision - reverts changes which were made in the selected revision. The changes are re-
verted in your working copy so this operation does not affect the repository file! The action will undo the changes
made only in selected revision. It does not replace your working copy file with the entire file at the earlier revision.
This is useful for undoing an earlier change when other unrelated changes have been made since the date of the re-
vision. This option is enabled when the resource history was launched for a local working copy resource.

• Get Contents - replace the current content of the local version of the selected file with the content of the selected
revision.

History actions available on the popup menu for double selection:

• Compare revisions - When the resource is a file the action compares the two selected revisions using the Compare
view. When the resource is a folder the action displays the set of all resources from that folder that were changed
between the two revision numbers.

• Revert changes from these revisions - Similar to the svn-merge command, it merges two selected revisions into the
working copy resource. This action is only enabled when the resource history was requested for a working copy
item.

Directory Change Set View

The result of comparing two reference revisions from the history of a folder resource is a set with all the resources
changed between the two revision numbers and contained in the folder or in a subfolder of the folder. These resources
are presented in a tree format and for each changed resource of the set all the revisions committed between the two
reference revision numbers are presented.
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Figure 15.32. Directory Change Set View

The set of changed resources displayed in the tree is obtained by running the action Compare revisions available on
the context menu of the History view when two revisions of a folder resource are selected in the History view.

The left side panel of the view contains the tree hierarchy with the names of all the changed resources between the two
reference revision numbers. The right side panel presents the list with all the revisions of the resource selected in the
tree that were committed between the two reference revision numbers. Selecting one revision in the list displays the
commit message of that revision in the bottom area of the right side panel.

A double click on a file listed in the left side tree performs a diff operation between the two revisions of the file corres-
ponding to the two reference revisions of the folder for which the change set was computed. A double click on one of
the revisions displayed in the right side list of the view performs a diff operation between that revision and the previous
one of the same file.

The context menu of the right side list contains the following actions:

Show Modifications Performs a diff operation between the selected revision in the list and the previous
one.

Open Open the selected revision in the associated editor type.

Open with Displays a dialog with the available editor types and allow the user to select the editor
type for opening the selected revision.

Save revision to ... Save the selected revision in a file on disk.

Show Annotation Request the annotations of the file and display them in the Annotations view.

Management of SVN properties
In the Properties view you can read and set the Subversion properties of a file or folder. There is a set of predefined
properties with special meaning to Subversion. For more information about properties in Subversion see the SVN
Subversion specification. Subversion properties are revision dependent. After you change, add or delete a property for
a resource, you have to commit your changes to the repository.
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Add / Edit / Remove SVN properties

If you want to change the properties of a given resource you need to select that resource from the Working copy view
or the Synchronize view and access the Show properties action from the contextual menu. The properties view will
show the local properties for the resource in the working copy. Once the Properties View is visible, it will always
present the properties of the currently selected resource.

In the Properties view toolbar there are available actions which allow you to add, change and delete the properties.

If you choose the Add a new property action, a new dialog will pop-up. The sections in the dialog are:

• Name - it is a combo box which allows you to enter the name of the property. The drop down list of the combo box
presents the predefined Subversion properties such as svn:ignore, svn:externals, svn:needs-lock, etc.

• Current value - it is a text area which allows you to enter the value of the new property.

If the selected item is a directory, you can also set the property recursively on its children by checking the Set property
recursively checkbox.

Figure 15.33. Edit property dialog

If you want to change the value for a previously set property you can use Edit property action which will display a
dialog where you can set:

• Name - the property name. It cannot be changed; only its value can.

• Current value - presents the current value and allows you to change it.

• Base value - the value of the property, if any, from the resource in the pristine copy. It cannot be modified.

If you want to completely remove a property previously set you can choose Remove property action. It will display a
confirmation dialog in which you can choose also if the property will be removed recursively.

In the Properties view there is a Refresh action which can be used when the properties have been changed from outside
the view. This can happen, for example, when the view was already presenting the properties of a resource and they
have been changed after an Update operation.
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Creation and management of Branches/Tags
One of the fundamental features of version control systems is the ability to create a new line of development from the
main one. This new line of development will always share a common history with the main line if you look far enough
back in time. This line is known as a branch. Branches are mostly used to try out features or fixes. When the feature
or fix is finished, the branch can be merged back into the main branch (trunk).

Another feature of version control systems is the ability to take a snapshot of a particular revision, so you can at any
time recreate a certain build or environment. This is known as tagging. Tagging is especially useful when making release
versions.

In Subversion there is no difference between a tag and a branch. On the repository both are ordinary directories that
are created by copying. The trick is that they are cheap copies instead of physical copies. Cheap copies are similar to
hard links in Unix, which means that they merely link to a specific tree and revision without making a physical copy.
As a result branches and tags occupy little space on the repository and are created very quickly.

As long as nobody ever commits to the directory in question, it remains a tag. If people start committing to it, it becomes
a branch.

Create a Branch/Tag

In the Working Copy view, select the resource which you want to copy to a branch or tag, then select the command
Branch/Tag....

Figure 15.34. The Branch/Tag dialog

The default target URL for the new branch/tag will be the repository URL of the selected resource from your working
copy. You will need to change that URL to the new path for your branch/tag. To do this, click on the Browse button
and choose a repository target directory for your resource.
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Figure 15.35. Repository Browser dialog

You can also specify the source of the copy. There are three options:

• HEAD revision in the repository - The new branch/tag will be copied in the repository from the HEAD revision.
The branch will be created very quickly as the repository will make a cheap copy.

• Specific revision in the repository - The new branch will be copied in the repository but you can specify exactly the
desired revision. This is useful for example if you forgot to make a branch/tag when you released your application.
If you click on the History button on the right you can select the revision number from the History dialog. This type
of branch will also be created very quickly.

• Working copy - The new branch will be a copy of your local working copy. If you have updated some files to an
older revision in your working copy, or if you have made local changes, that is exactly what goes into the copy. This
involves transferring some data from your working copy back to the repository, more exactly the locally modified
files.

When you are ready to create the new branch/tag, write a commit comment in the corresponding field and press the
OK button.

Merging

At some stage during the development you will want to merge the changes made on one branch back into the trunk,
or vice versa.

Merge is closely related to Diff. The merge is accomplished by comparing two points (branches or revisions) in the
repository and applying the obtained differences to your working copy.

It is a good idea to perform a merge into an unmodified working copy. If you have made changes to your working
copy, commit them first. If the merge does not go as you expect, you may want to revert the changes and Revert cannot
recover your uncommitted modifications.

The Merge command can be found in the Modify submenu of the context menu of the Working Copy view. The directory
selected when you issued the command will be the result directory of the merge operation.
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There are three common types of merging which are handled in different ways, as described below. The first page of
the merge operation wizard allows you to select the merging method.

Figure 15.36. The Merge type dialog

Merge revisions

This is the case when you have made one or more revisions to a branch (or to the trunk) and you want to port those
changes across to a different branch or trunk. An example of such operation can be the following: Calculate the changes
necessary to get (from) revision 17 of branch B1 (to) revision 25 of branch B1, and apply those changes to my working
copy, of the trunk or another branch.
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Figure 15.37. Merge revisions range dialog

Enter the folder URL of the branch or tag containing the changes you want to port into your working copy In the From:
field. You may also click the Browse button to browse the repository and find the desired branch. If you have merged
from this branch before, then just use the drop down list which shows a history of previously used URLs.

In the Revision range to merge section you can choose to merge all revisions or enter the list of revisions you want
to merge in the Revision range field. This can be a single revision, a list of comma separated specific revisions, or a
range of revisions separated by a dash, or any combination of these.

You can click on History button to select in the easiest way the list of revisions to be merged. One or several revisions
can be selected then by clicking on OK the list of revision numbers to merge will be filled in the Revision range text
field.

If you want to merge changes back out of your working copy, to revert a change which has already been committed,
select the revisions to revert and check the Reverse merge box.

If you have already merged some changes from this branch and you remember the last merged revision, you can use
History for the Working Copy to trace that revision. For example, if you have merged revisions 27 to 33 last time, then
the start point for this merge operation should be revision 33.

Subversion has merge tracking features and automatically records the last merged revision so you do not need to re-
member when you performed the last merge.

Be careful about using the HEAD revision. It may not refer to the revision you think it does if someone else made a
commit after your last update.

The target panel of the dialog reminds you the location of the target resource from the working copy where the merge
result will be saved and its corresponding repository URL.

Click Next and go to Merge Options.
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Reintegrate a branch

This method covers the case when you have made a feature branch. All trunk changes have been ported to the feature
branch, and now you want to merge it back into the trunk. Because you have kept the feature branch synchronized
with the trunk, the latest versions of branch and trunk will be absolutely identical except for your branch changes.
These changes can be reintegrated into the trunk by this method

It uses the merge-tracking features of Subversion to calculate the correct revision ranges to use, and perform additional
checks which ensure that the branch has been fully updated with trunk changes. This ensures that you don't accidentally
undo work that others have committed to trunk since you last synchronized changes. After the merge, all branch devel-
opment has been completely merged back into the main development line. The branch is now redundant and can be
deleted.

Figure 15.38. Reintegrate a branch dialog

Enter the full folder URL of the branch that you want to merge back. There are some conditions which apply to a rein-
tegrate merge. Firstly, the server must support merge tracking. The working copy must be of depth infinite (no sparse
checkouts), and it must not have any local modifications, switched items or items that have been updated to revisions
other than HEAD. All changes to trunk made during branch development must have been merged across to the branch
(or marked as having been merged). The range of revisions to merge will be calculated automatically.

The target panel of the dialog reminds you the location of the target resource from the working copy where the merge
result will be saved and its corresponding repository URL.

Merge two different trees

This is a general case of the reintegrate method. You can consider the following example: calculate the changes necessary
to get (from) the HEAD revision of the trunk (to) the HEAD revision of the branch, and apply those changes to my
working copy (of the trunk). The result is that trunk will be identical with the branch.

If the server does not support merge-tracking then this is the only way to merge a branch back to trunk.
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Figure 15.39. Merge trees dialog

By default the start URL will be the URL of the selected file in the working copy. You can browse the repository and
select a start URL and then choose a revision.

If you are using this method to merge a feature branch back to trunk, you need to start the merge wizard from within
a working copy of trunk. In the "From" field enter the full folder URL of the trunk. This may sound wrong, but remember
that the trunk is the start point to which you want to add the branch changes. In the "To" field enter the full folder URL
of the feature branch.

In both the From Revision field and the To Revision field, enter the last revision number at which the two trees were
synchronized. If you are sure no-one else is making commits you can use the HEAD revision in both cases. If there is
a chance that someone else may have made a commit since that synchronization, use the specific revision number to
avoid losing more recent commits.

The target panel of the dialog reminds you the location of the target resource from the working copy where the merge
result will be saved and its corresponding repository URL.

Merge Options

This page lets you specify advanced options, before starting the merge process.
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Figure 15.40. Merge options dialog

You can specify how far down into your working copy the merge should go by setting the merge depth. The depth
term is described in the Sparse checkouts section. The default depth is Working copy, which uses the existing depth
setting.

The Ignore ancestry checkbox allows a merge to be applied between a branch and the trunk or between two branches
even if they do not share a common ancestry. Normally the branch and the trunk or the two branches that are merged
must have a common ancestor revision in the same repository. In case the two merged trees were imported in the re-
pository they are not related in the sense of a common ancestor tree and the merge operation is possible by ignoring
the missing common ancestry of the two merged trees.

The Ignore line endings and Ignore whitespaces checkboxes allow you to specify how the line endings and whitespace
changes should be handled. If they are checked the changes due only to the line endings and whitespaces are ignored.
The default behavior is to treat all whitespace and line-end differences as real changes to be merged. Ignore whitespace
changes excludes changes which are caused by a change in the amount or type of whitespace, for example changing
the indentation or changing tabs to spaces. Adding whitespace where there was none before, or removing a whitespace
completely is still shown as a change. If Ignore all whitespaces is checked all whitespace-only changes are excluded.

If you are using merge tracking support and you want to mark a revision as having been merged, without actually doing
the merge here, check the Only record the merge checkbox. You might want to do this for two possible reasons. You
make the changes by hand, then mark the change as merged so that the merge tracking algorithm is aware of it. Or you
might want to prevent a particular revision from being merged by marking it as already merged. This will prevent future
merging.

By pressing the Test merge button you can choose to do a Dry run of the Merge operation in order to see what files
are affected and how, without modifying the working copy at all. This is very helpful in detecting where conflicts may
occur.
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Press the Merge button in order for the operation to take place. You will obtain the result in the selected resource from
the working copy.

When the merge is completed it's a good idea to look at the result of the merge and see if it meets your expectations.
Because merging is sometimes complicated, when there are major changes, conflicts may appear.

Resolve merge conflicts

After the merge operation is finished it is possible to have some resources in conflict. This means that some incoming
modifications for a resource could not be merged with the current modifications from the working copy. If there are
such conflicts, a dialog will appear presenting you the resources that are in conflict and from where you can choose a
way in which every conflict should be resolved.

Figure 15.41. Merge conflicts dialog

The options to resolve a conflict are:

• Resolve later - used to leave the conflict as it is for manual resolving it later;

• Keep incoming - this option keeps all the incoming modifications, discarding all current ones from your working
copy;

• Keep outgoing - this option keeps all current modifications from your working copy, discarding all incoming ones;

• Mark resolved - you should chose this option after you have manually edited the conflict. To do that, use the Edit
conflict button, which will bring to you a dialog presenting the conflicting resource's content for current working
copy version and the one with the incoming modifications. After manually resolving the conflict, the resource will
be marked as resolved.

412

The Syncro SVN Client



Switch the Repository Location

The Switch action is useful when the repository location of a working copy or only of a versioned item of the working
copy must be changed within the same repository. It is available on the contextual menu of the working copy tree when
the selected item is a versioned resource except an external folder.

Figure 15.42. The Switch Dialog

Relocate a Working Copy

When the base URL of the repository changed, for example the repository itself was relocated to a different server,
you do not have to check out again a working copy from the new repository location. It is easier to change the base
URL of the root folder of the working copy to the new URL of the repository. This action is available on the contextual
menu of the Working Copy view only if the selected item of the working copy tree is a versioned folder.

Figure 15.43. The Relocate Dialog

If the selected item is not the root folder of the working copy then the effect is the same as for the Switch action applied
on the same selected item.

Create Patches

Let's suppose you are working to a set of XML files, that you distribute to other people. From time to time you are
tagging the project and distribute the releases. If you continue working for a period correcting problems, you may find
yourself in the situations to notify your users that you have corrected a problem. In this case you may prefer to distribute
them a patch, a collection of differences that applied over the last distribution would correct the problem. The SVN
client creates the patch in the Unified Diff format [http://en.wikipedia.org/wiki/Diff#Unified_format].

Creating patches in Subversion implies the access to two states (revisions) of a project. If you have not committed yet
your current working copy and prefer not to do it, it is possible to create a patch between the current working copy and
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a revision from the repository. If you want to create a patch between two revisions that are already committed to the
repository that is also possible.

In order to create the patch, you will use the action from the submenu Modify of the contextual menu of the Working
Copy view: Create Patch. This opens the Create patch wizard.

Figure 15.44. The Create patch wizard - step 1

In the first step of the wizard you select the type of the patch: a patch between working copy and repository revision
or a patch between two repository revisions. The Next button moves the wizard to the second step.

Create a patch from working copy

In case of the first type of patch in this step you specify the revision of the repository for finding the patch between
the working copy and the repository. The revision can be HEAD or a revision number selected from the list of all revi-
sions committed to the repository.
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Figure 15.45. Patch between working copy and repository - step 2

In the next step the following options can be specified:

Figure 15.46. Patch between working copy and repository - step 3
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Patch depth The depth of recursive folders included in the patch. If the patch is created only for a
file then the depth is always zero. The depth can have one of the values:

Current depth The depth of going into the folder for creating
the patch is the same as the depth of that folder
in the working copy.

Recursive (infinity) The patch is created on all the files and folders
contained in the selected folder.

Immediate children (immediates) The patch is created only on the child files and
folders without going in subfolders.

File children only (files) The patch is created only on the child files.

This folder only (empty) The patch is created only on the selected folder
(that is no child file or folder is included in the
patch).

Ignore ancestry The SVN ancestry that may exist when the two URLs specified for creating the patch
have a common SVN history is ignored when the patch is created.

Ignore line endings The differences in line endings are ignored when the patch is created.

Ignore whitespaces The differences in whitespaces are ignored when the patch is created.

Save in clipboard The patch will be created and saved in clipboard.

Save in file The patch will be created and saved in the specified file.

Include unversioned files in the patch

In the next step you can specify the unversioned files that will be included in the generated patch. If the patch is applied
on a folder of the working copy and that folder contains unversioned files this step of the wizard offers the option of
selecting the ones that will be included in the patch.
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Figure 15.47. Patch between working copy and repository - step 4

Create patch from repository revision

In case of the second type of patch in the second step of the wizard you select the two repository revisions. The two
revisions can be on the same repository or on two different repositories. For each revision you can select the HEAD
revision or a revision number available on the repository.
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Figure 15.48. Patch between two repository revisions - step 2

The next step of the wizard is the same as for the first type of patch. It allows to specify the options patch depth, ignore
ancestry, ignore line endings, ignore whitespaces, save in clipboard, save in file. The description of the options is the
same as for the first type of patch.

Figure 15.49. Patch between two repository revisions - step 3

418

The Syncro SVN Client



Working with repositories

Import / Export resources

Import resources into the repository

This is the process of taking a project and importing it into a repository so that it can be managed by Subversion. If
you have already been using Subversion and you have an existing working copy you want to use, then you will likely
want to follow the procedure for Use an existing working copy.

A dialog will ask you to select a directory that will be imported into the selected repository location. The complete
directory tree will be imported into the repository including all files. The name of the imported folder will not appear
in the repository, but only the contents of the folder will.

Export resources from the repository

This is the process of taking a resource from the repository and saving it locally in a clean form, with no version control
information. This is very useful when you need a clean build for an installation kit.

Figure 15.50. The export dialog

The export dialog is very similar to the check out dialog. You can choose the target directory from the file system by
pressing the Browse button. If you need to export a specific revision, you can select the Revision radio button and then
click on the History button and choose a revision from the new dialog. Or you could simply type the revision number
in the corresponding text field.

Please note that the content of the selected directory from the repository and not the directory itself will be exported
to the file system.

Copy / Move / Delete resources from the repository

Once you have a location defined in the Repository view you can execute commands like copy, move and delete directly
on the repository. The commands correspond to the following actions in the contextual menu.

The Copy action allows you to copy individual or multiple resources. After invoking the action the Copy file dialog
will pop up.
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Figure 15.51. Copy files dialog

The dialog displays the path of the resource that is copied and the tree structure of the repository allowing you to choose
the destination directory. The path of this target directory will be presented in the text field Destination Directory. If
you choose to copy a single resource then an additional checkbox and a text field allow you to choose the new name
of the copied resource.

The Move action will display a similar dialog allowing you to move the selected resources to a different folder. If you
choose to move a single resource you can also change its name. This will allow you to rename a resource by moving
it into the same parent directory but choosing a different name. The move operation is basically a copy operation followed
by a delete operation. If you select a directory, any other selected descendants will be ignored when you have issued
the move command.

Another useful action is Delete. This action allows you to delete resources directly from the repository. After choosing
the action from the Repository view contextual menu a confirmation dialog will be displayed.

All three actions are commit operations and you will be prompted with the Commit message dialog.

Sparse checkouts
Sometimes you need to check out only certain parts of a directory tree. For this you can checkout the top folder and
then update recursively only the needed directories. Each directory now understands the notion of depth which has
four possible values:

• Recursive (infinity) - Updates all descendant folders and files recursively.

• Immediate children  - Updates the directory including direct child folders and files but does not populate the child
folders.

• File children only (files) - Updates the directory including only child files without the child folders.

• This folder only (empty) - Updates only the selected directory without updating any children.

Current depth - for some operations you can use as depth the current depth of the resource from working copy. This
is the depth of directories from the working copy, it can have one of the values defined above. This is the depth value
defined in a previous checkout or update operation.
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The sparse checked out directories are marked in the Working Copy view with a marker corresponding to the depth
value as follows:

• Recursive (infinity) - This is the default value and it is has no mark.

• Immediate children (immediates) - The directory is marked with a purple bubble in the top left corner .

• File children only (files) - The directory is marked with a blue bubble in the top left corner .

• This folder only (empty) - The directory is marked with a gray bubble in the top left corner .

The depth information is also presented in the Information view and the tool tip displayed when hovering over the
directory in the Working copy view.

This feature requires the svn client to be 1.5 or above and will work most efficiently if the server is 1.5 or above. The
client will work also with a 1.4 server or lower but will be less efficient.

Repository View

General description
The repository view allows you to define and manage Subversion repository locations. Repository files and folders
are presented in a tree view with the repository locations at the first level, where each location represents a connection
to a specific Subversion Repository. When hovering with the mouse over a repository resource a tooltip window will
display more detailed information regarding: URL, last change revision, last change author, last change date.

Toolbar
The toolbar for the repository view contains the following buttons:

•  New Repository Location - allows you to enter a new repository location by means of the Add SVN Repository
dialog.

•  Check Out - checks out a working copy from the selected directory in the repository. Displays the new working
copy in the Working Copy view.

•  Edit Repository Location - context dependent, allows you to edit the selected repository location by means of
the Edit SVN Repository dialog. It is active only when a repository location root is selected.

•  Remove Repository Location - allows you to remove the selected repository location from the view. It shows
you a confirmation dialog before removal. It is active only when a repository location root is selected.

•  Move Up - move the selected repository up with one position in the list of repositories in the Repository view.

•  Move Down - move the selected repository down with one position in the list of repositories in the Repository
view.

Contextual menu actions
The repository view has one contextual menu for the repository locations (roots) and another contextual menu for the
repository resources. Besides the actions described above, the locations context menu from the repository view contains
the following actions:
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• Import Folder Content ... - imports the content of a specified folder from the file system into the selected folder from
the repository.

• Export ... - exports a directory from the repository to the local file system.

•  Show History ... - brings up the History view and displays the log history for the selected resource from the re-
pository.

•  Show Annotation ... - brings up a dialog for selecting the start revision and the end revision of the interval of re-
visions for which the SVN annotations will be computed and marked in the selected resource in the editor panel.

Figure 15.52. The Show Annotation dialog

After selecting the start revision and the end revision and pressing OK the Annotations view and the History view
are displayed and the annotations are marked on the SVN resource in the editor panel.

• New Folder ... - allows you to create a new folder in the selected repository path.

•  Show SVN Properties - brings up the Properties view and displays the SVN properties for the selected repository
resource. This view does not allow adding, editing or removing SVN properties of a repository item. These operations
are allowed only for working copy resources.

•  File Information ... - provides additional information for the selected repository. For more details please see the
section Information view.

•  Refresh - refreshes the currently selected repository.

The repository resources context menu from the view contains the following actions:

•  Check Out ... - checks out a working copy from the selected directory in the repository.

• Import ... - imports a directory from the file system into the selected directory from the repository.

• Export ... - exports a directory from the repository to the local file system.

•  Show History ... - brings up the History view and displays the log history for the selected resource from the re-
pository.

•  Show Annotation ... - brings up the Annotations view .

• New Folder ... - allows you to create a new folder in the selected repository path.
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• Open - opens the selected file in the Editor view in read only mode.

• Open with ... - Displays the 'Open with ...' dialog for specifying the editor in which the selected file will be opened.
In case multiple files are selected only external applications can be used to open the files.

• Copy ... - displays the Copy Files dialog which allows you to select the location where the selected resources will
be copied.

• Copy URL Location - copies the encoded URL for the selected resource from the repository to the clipboard.

• Rename ... - renames the current folder on the repository.

• Move ... - displays the Move Files dialog which allows you to select the location where the selected resources will
be moved.

• Delete - deletes the selected resources. It will ask for confirmation.

•  Show SVN Properties - brings up the Properties view and displays the SVN properties for the selected resource
from the repository.

•  File Information ... - provides additional information for the selected resource from the repository. For more details
please see the section Information view.

•  Refresh - refreshes the currently selected resources from the repository.

Working Copy View

General description
The working copy view allows you to manage with ease the content of the working copy. Resources (files and folders)
are presented in a tree view with the root of the tree representing the location of the working copy on the file system.
Each resource has an icon representation which describes the type of resource and also depicts the state of that resource
with a small overlay icon.

Figure 15.53. The Working Copy View

When a SVN working copy is loaded in the view by selecting it in the combo on the toolbar of the view Syncro SVN
Client first checks the format of the working copy. If it is a SVN 1.6 format the admin data of that working copy is
loaded and displayed in a tree like form in the view using the icons specific for the status of each resource: normal,
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unversioned, modified, etc. If it is the old format, that is the SVN 1.5, SVN 1.4 or SVN 1.3 one, a confirmation dialog
is displayed allowing the automatic conversion to the working copy to the new format, that is the SVN 1.6 one.

Figure 15.54. The Working Copy format warning dialog

If you select the Never ask me again checkbox and press the Yes button then the option Automatically upgrade working
copies to the client's version is automatically checked.

For each file and folder a tooltip is displayed with details like SVN status, full path, current revision number, last
changed date, etc. If the tooltips seem annoying by covering useful information they can be disabled from the option
Show tooltip on Working Copy and Synchronize trees.

Toolbar
The toolbar from the working copy view contains the following buttons:

•  Synchronize - contacts the repository and determines the changes made by you to the working copy and by others
to the repository. The synchronize result will be displayed in the Synchronize view. The actions performs a synchronize
operation on the root of the working copy.

•  Refresh - refreshes the content of the working copy. The content of the working copy is always scanned(refreshed)
when starting the Subversion client or when changing the working copy from the combo box in the toolbar. However,
if you make modifications from other applications outside the Subversion client, while the client is started, you will
have to manually refresh the working copy. The action performs a refresh operation on the root of the working copy.

•  Cleanup - performs a maintenance cleanup operation on the working copy. Sometimes, when an operation fails,
the working copy will enter an inconsistent state in which some resources will remain locked by SVN. Cleanup re-
moves those maintenance locks and allows you to continue your work. When the SVN client determines that an
operation failed because the working copy is locked by SVN you will be asked if a Cleanup operation should be
performed first.

• Combo box - The combo box list contains all the working copies the Subversion client is aware of. When you select
another working copy from the combo, the newly selected working copy content will be scanned and displayed in
the view.

• Add/Remove Working Copy - opens the Working copies list dialog which displays the working copies the Sub-
version client is aware of. In this dialog you can add existing or remove no longer needed working copies. If you
try to add a directory which is not a valid Subversion working copy, a warning dialog will inform you that the selected
directory is not under version control. Please note that removing a working copy from this dialog will NOT remove
it from your file system; you will have to do that manually.

•  Show ignored files - shows in the working copy tree the resources that were listed in the svn:ignore property of
their parents. This option is off by default.
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•  Show deleted files - shows in the working copy tree the resources that were marked to be deleted but are not yet
committed. This option is off by default.

Contextual menu actions
The contextual menu in the Working Copy view contains the following actions:

•  Open - This action will open the selected file in an editor where you can make modifications to it. The action is
active only when a single item is selected. In case of a file the action opens the file with the internal editor or the
external application associated with that file type. In case of a folder the action opens the selected folder with the
system application for folders (for example Windows Explorer on Windows, Finder on Mac OS X, etc).

• Open with ... - Displays the 'Open with ...' dialog for specifying the editor in which the selected file will be opened.
In case multiple files are selected only external applications can be used to open the files

•  Synchronize - it contacts the repository and determines the working copy and the repository changes made to the
selected resources. It displays the result of the operation in the Synchronize view. This is useful when you have a
large working copy and you only want to verify the changes to a specific part you are currently working on.

• Update - This command updates your selected resources from the working copy to the HEAD revision from the re-
pository (latest modifications). It the same as the update action from the Synchronize view in that also brings you
the HEAD revision from the repository. If a directory is involved it will be updated depending on its depth. The
action is active only on resources that are under version control.

• Update to revision/depth - This action allows you to update the selected resources from the working copy to an
earlier revision from the repository. You can also select the update depth for the current folder. You can find out
more about the depth term in the sparse checkouts section. The action is active only on resources under version
control.

Figure 15.55. Update to revision/depth dialog

• Commit - This action collects the outgoing changes from the selected resources in the working copy and presents
them in a dialog. Then you can choose exactly what to commit by selecting or unselecting resources accordingly.
A directory will always be committed recursively. The unversioned resources will be deselected by default. In the
commit dialog you will also have to enter a commit comment before sending your changes to the repository.

• Compare with:
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Latest from Head - This action will perform a 3-way diff operation between the selected file and the HEAD revision
from the repository and will display the result in the Compare view. The common ancestor of the 3-way diff op-
eration is the BASE version of the file from the local working copy.

•

• Base revision - This will compare the working copy file with the file from the pristine copy (BASE revision).

• Revision - This command will bring to front the History view with the log history for that resource.

• Branch/Tag - This will compare the working copy file with a revision of the file from a branch or tag. The revision
is specified by URL (selected with a repository browser dialog) and revision number (selected with a revision
browser dialog).

Figure 15.56. Compare with Branch/Tag dialog

• Each other - This action only works when two files are selected. It will compare the two selected files with each
other.

These actions are enabled only if the selected resource is a file.

•  Show History ... - It will display the History view where the log history for the selected resource will be presented.
For more details about resource history see the sections Using the resource history view and Request history for a
resource.

•  Show Annotation - It will display the Annotations view where all the users that modified the selected resource
will be presented together with the specific lines and revision numbers modified by each user. For more details about
resource annotations see the section Annotations View.

• New:

• New Folder ... - This operation creates a new folder and adds it to version control. If the selected path is not under
version control, the newly created directory will not be added to version control.

• New File ... - This operation creates a new file and adds it to version control. If the selected path is not under
version control, the newly created file will not be added to version control.

• New External Folder ... - This operation sets a folder name in the property svn:externals of the selected folder.
The repository URL to the folder to which the new external folder will point and the revision number of that re-
pository URL can be selected easily with the Browse and History buttons of the dialog.

Subversion clients 1.5 and higher support relative external URLs. You can specify the repository URLs to which
the external folders point using the following relative formats:
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• ../ - Relative to the URL of the directory on which the svn:externals property is set.

• ^/ - Relative to the root of the repository in which the svn:externals property is versioned.

• // - Relative to the scheme of the URL of the directory on which the svn:externals property is set.

• / - Relative to the root URL of the server on which the svn:externals property is versioned.

Figure 15.57. New External Folder dialog

• Edit:

• Delete - This action allows you to delete resources from the Subversion working copy. If unversioned, added or
modified resources will be encountered, a dialog will prompt you to confirm their deletion. This is because their
content cannot be recovered. The action it is not enabled when the selection contains missing resources.

• Copy ... - This action copies resources from the working copy. Each copy will also have the original resource's
history. For more details please read the section Copy / Move / Rename resources.

• Move ... - This command actually performs as if a copy and then a delete command were issued. You will find
the moved resources at the desired destination and also at their original location but marked as deleted.

• Rename ... - You can only rename a resource at a time. As for the move command, a copy of the original resource
will be made with the new name and the original will be marked as deleted.

• Revert - Undoes all local changes for the selected resources. It does not contact the repository, the files will be obtained
from Subversion's pristine copy. It is enabled only for modified resources. Read the Revert your changes section
for more information.

• Mark resolved - This action is only enabled on conflicted resources and its function is to tell the Subversion system
that you resolved the conflict. See the section Merge conflicts.

•  Cleanup - performs a maintenance cleanup operation to the selected resources from the working copy. This oper-
ation removes the Subversion maintenance locks that were left behind. Useful when you already know where the
problem originated and want to fix it as quickly as possible. Only active for resources under version control.

• Add - This operation adds the selected resources to version control. A directory will be added recursively to version
control. It is not mandatory to explicitly add resources to version control but it is recommended. At commit time
unversioned resources will have to be manually selected in the commit dialog. It is only active on unversioned re-
sources.
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• Add to svn:ignore ... - This action can only be performed on resources not under version control. It allows you to
keep inside your working copy, files that should not participate to the version control operations. The action actually
modifies the value of the svn:ignore property of the resource's parent directory.

•  Show SVN Properties - brings up the Properties view and displays the SVN properties for the selected resource.

• Lock:

• Scan for locks ... - This action contacts the repository and recursively obtains the list of locks for the selected re-
sources. A dialog containing the locked files and the lock description will be displayed. Only active for resources
under version control. For more details see the section Scanning for locks.

•  Lock ... - It allows you to lock certain files for which you need exclusive access. You can write a comment
describing the reason for the lock and you can also force(steal) the lock. The action is active only on files under
version control. For more details on the use of this action please read the section  Locking a file.

•  Unlock ... - This action releases(unlocks) the exclusive access to a file from the repository. You can also choose
to unlock it by force(break the lock).

• Modify:

• Branch/Tag ... - This action displays the Branch/Tag dialog where you can select the revision of the resource and
the destination URL in the repository. For more details about creating branches and tags see the section Create a
branch/tag.

• Merge ... - The selected resource will be considered the destination for the merge operation. From the displayed
Merge dialog you will be able to specify the merge operation you want to perform. See section Merging section
for more details.

• Switch ... - The repository location of the working copy or only of a resource of the working copy is changed
within the same repository. It is available when the selected item is a versioned resource except an external folder.

• Relocate ... - Change the repository path of the selected item. This action is available on the contextual menu only
if the selected item is a versioned folder. It is useful when the base URL of the repository changed, for example
the repository itself was relocated to a different server. If the selected item is not the root folder of the working
copy then the effect is the same as for the Switch action applied on the same selected item.

• Create patch ... - The selected resource will be used to create a patch. From the displayed Create patch dialog you
will be able to specify the two sources of the patch, the first one being either the working copy files or a revision/tag
and the second a repository URL or a revision/tag. See section Create patches for more details.

•  File Information ... - provides additional information for the selected resource from the working copy. For more
details please see the section Obtain information for a resource.

•  Refresh - This action will rescan the selected resources recursively and refresh their status in the working copy
view.

Drag and drop operations
New files and folders can be added to the file tree of the Working Copy view as unversioned resources by drag and
drop operations from other applications, for example Windows Explorer on Windows or Finder on Mac OS X. Also
the structure of the files tree can be changed with drag and drop operations inside the view.
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Icons
The icons in the working copy view have a small overlaid icon which describes the current state of the resource in the
working copy. These state icons are:

•  Unversioned - The resource marked with this symbol is not under version control. This is how new files are
represented when they are created or copied from the file system. Unversioned resources can be filtered from the
Working Copy view by setting ignore filters in the Preferences.

• Added - This resource has been added to version control but has not been committed. This state is obtained after
issuing an Add command on an unversioned resource.

• Added with history - This resource has been copied with history. This state is obtained by copying, moving or
renaming a resource from the working copy.

•  Modified - The resource has been locally modified since the last update. This is obtained after editing a file and
making changes.

•  Deleted - This resource has been deleted from the working copy. This state appears after deleting, moving or
renaming files with Subversion.

•  Missing/Incomplete - This resource is in an inconsistent state. If it's missing, it means it has been deleted from
the file system without Subversion's knowledge. If it's incomplete, a check out or update action has probably failed
or has been interrupted before finishing. A directory in such a state must be restored with an update action before
any other action can be performed.

•  Conflict - This resource has conflicting changes. A resource can be in this state after an update, if it was modified
both locally and on the repository and the modifications were overlapping.

• Tree Conflict - This resource has a tree conflict. A resource can be in this state after an update or merge: the
local file is modified but the remote file was removed so the local modifications cannot be committed (the file does
not exist on the repository any longer) and a remote version cannot override the local modifications.

•  External - This indicates a mapping of a local directory to the URL of a versioned resource. It is declared with
a svn:externals property in the parent folder.

•  Normal - A resource with no overlaid icon is an unmodified resource under version control.

•  Grayed - A resource with a grayed icon but no overlaid icon is an ignored resource. It is obtained with the action
Add to svn:ignore.

•  Switched - This indicates a resource that has been switched from the initial repository location to a new location
within the same repository. The resource goes to this state as a result of the Switch action executed from the contex-
tual menu of the Working Copy view.
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Synchronize View

General description
The synchronize view is visible in the default layout configuration. It displays the result of a Refresh or Synchronize
operation in a hierarchical form. The nodes represent synchronized or refreshed resources and their status.

Figure 15.58. Synchronize View

Synchronize trees
The results are presented using four tree structures:

• Incoming changes tree - presents items which contain incoming changes. This includes resources modified and
committed by others or resources newly added or newly deleted from the repository.

• Outgoing changes tree - presents resources with outgoing changes meaning that they have been modified locally or
have been added or deleted from your working copy.

• Incoming - Outgoing tree - includes all the resources with incoming and outgoing changes

• Conflict tree - includes resources with conflicting state meaning they contain both incoming and outgoing changes
(pseudo-conflicting state) or they are in a state of real conflict.

A resource which is in a real conflict state will not appear in the Incoming tree.

For each file and folder a tooltip is displayed with details like SVN status, full path, current revision number, last
changed date, etc. If the tooltips seem annoying by covering useful information they can be disabled from the option
Show tooltip on Working Copy and Synchronize trees.

Toolbar
The Synchronize view toolbar consists of the following buttons:

•  Incoming Mode - filters synchronized resources displaying only the ones with incoming changes.

•  Outgoing Mode - filters synchronized resources displaying the ones with outgoing changes.
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•  In-Out Mode - displays resources with incoming or outgoing changes, basically all resources with any type of
change.

•  Conflicts Mode - filters synchronized resources displaying the ones in pseudo or real conflict state.

•  Update All - updates all resources with incoming changes. It is disabled when Outgoing mode is selected or the
synchronization result does not contain resources with incoming changes. It will perform a recursive update on the
synchronized resources.

•  Commit All - commits all resources with outgoing changes. It is disabled when Incoming mode is selected or the
synchronization result does not contain resources with outgoing changes. It will perform a recursive commit on the
synchronized resources.

•  Expand All - expands all the descendant nodes of the node currently selected in the view.

•  Collapse All - collapses all the descendant nodes of the node currently selected in the view.

Contextual menu actions
The contextual menu contains the following actions:

• Open in compare editor - if the selected file has a text content type it will be opened in the Compare view and a file
differencing will be performed. If the file has a binary content type then the position of the first different byte will
be displayed. It is disabled for directories. See also View differences section.

•
 Open - it is enabled existing local files and folders. In case of a file the action opens the selected file into the

Editor. See also Edit files section. In case of a folder the action opens the selected folder with the system application
for folders (for example Windows Explorer on Windows, Finder on Mac OS X, etc).

• Open with ... - Displays the 'Open with ...' dialog for specifying the editor in which the selected file will be opened.
In case multiple files are selected only external applications can be used to open the files

• Update - it is enabled for resources with incoming changes. Updates all selected resources to the HEAD revision.
If one of the selected resources is a directory then the update for that resource will be recursive.

• Commit ... - it is enabled for resources with outgoing changes. Commits all selected resources, recursively in the
case of directories, to the repository. This action collects the outgoing changes from the selected resources and
presents them in a dialog. You can choose exactly what items will be committed by checking or unchecking them
in the table. Also you will have to enter a commit comment. See also Sending your changes to the repository section.

•  Show History ... - It will display the History view where the log history for the selected resource will be presented.
For more details about resource history see the sections Using the resource history view and Request history for a
resource.

• Revert ... - it is useful when you want to undo all local changes made to a resource. It is enabled on resources which
contain outgoing changes. Read the Revert your changes section for more information.

• Mark Resolved - it is enabled on real conflicting resources. Its function is to tell the Subversion system that you re-
solved the conflict and the resource can be committed. See also Merge conflicts part.

• Mark as Merged - the action is enabled on pseudo-conflicting resources. It is used after you resolved the pseudo-
conflict by merging the changes and you want to commit the resource. Read the Merge conflicts section for more
information on methods to solve the pseudo-conflicts.
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• Override and Update ... - it is enabled on resources with outgoing changes including the conflicting ones. It is used
for dropping any outgoing change and replacing the local resource with the HEAD revision. See Revert your changes
section.

• Override and Commit ... - it is enabled on conflicting resources. The action will drop any incoming changes and
will send your local version of the resource to the repository. See also Drop incoming modifications.

• Add - it is enabled for unversioned resources. It performs a svn add command by adding the resources to version
control. You can directly commit unversioned items because in this case the Commit action will perform first a svn
add command.

• Add to svn:ignore ... - it is also enabled for unversioned resources. It is useful when you decide that some resources,
for example some compiler generated Java classes, should be ignored by the Subversion system. The action modifies
the value of the svn:ignore property of the parent directory. For more information read the section Ignore resources
not under version control.

•  Show SVN Properties - brings up the Properties view and displays the SVN properties for the selected resource.

•  File Information ... - provides additional information for the selected resource from the working copy. For more
details please see the section Obtain information for a resource.

•  Expand All - expands the selected directories to leaf level.

•  Collapse All - collapses all child nodes of the selected tree node.

•  Refresh - This action will rescan the selected resources recursively and refresh their status in the working copy
view.

Icons
The icons for the items displayed into the synchronized trees are the same icons used in the <oXygen/> XML Editor
decorated with overlay images. The overlay icons correspond to the status of the resource as follows:

•  Incoming resource - resource with incoming changes.

•  Remote added resource - resource that was added on the repository and is not present in your working copy.

•  Remote deleted resource - resource that no longer exists in the repository.

•  Outgoing resource - resource with outgoing changes.

•  Locally added or unversioned resource - resource added locally to version control or a resource not yet under
version control.

•  Locally deleted or missing resource - a resource that you deleted with Delete action or that was deleted from
the file system in some other way.

•  Conflicting resource - resource in a pseudo or real conflicting state.
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Compare View

Description
In the Syncro SVN Client there are three types of files that can be checked for differences: text files, image files, and
binary files. For the text files and image files you can use the built-in Compare view.

Figure 15.59. Compare View

When comparing text, the differences are computed using a line differencing algorithm. The view can be used to show
the differences between two files in the following cases:

• After obtaining the outgoing status of a file with a Refresh operation, the view can be used to show the differences
between your working file and the pristine copy. In this way you can find out what changes you will be committing.

• After obtaining the incoming and outgoing status of the file with the Synchronize operation, you can examine the
exact differences between your local file and the HEAD revision file.

• You can use the Compare view from the History view to compare the local file and a selected revision or compare
two revisions of the same file.

If in any of the cases one of the involved files cannot be loaded then you will be prompted with a dialog informing
you about the file that cannot be opened. The Compare view contains two editors. Edits are allowed only in the left
editor and only when it contains the working copy file. To learn more about how the view can be used in the day by
day work you can read the section View differences.

Toolbar
The list of actions available in the toolbar consists of:

•  Save action - it allows you to save the content of the left editor when it can be edited.

•  Perform files differencing - used to perform files differencing on request.

•  Go to first modification - used to navigate to the first difference.
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•  Go to previous modification - used to navigate to the previous difference.

•  Go to next modification - used to navigate to the next difference.

•  Go to last modification - used to navigate to the last difference.

•  Copy change from right to left - this action copies the selected change from the right editor to the left editor.

•  Copy all non-conflicting changes from right to left - this action copies all non-conflicting changes from the right
editor to the left editor. A non-conflicting change from the right editor is a change that does not overlap with a left
editor change.

•  Show modification details at word level - because the differences are computed using a line differencing algorithm
sometimes is useful to see exactly what words are different in a changed section.

•  Show modification details at character level - useful when you want to find out exactly what characters are dif-
ferent between the two analyzed sections.

•  Ignore whitespaces - Enables or disables the whitespace ignoring feature. Ignoring whitespace means that before
the strings are compared they are first normalized and then the whitespace at the beginning and the end of the strings
is trimmed.

These actions are available also from the Compare menu.

Compare images view
The images are compared using the Compare images view. The images are presented in the left and right part scaled
to fit the view's available area. You can use the contextual menu actions to scale the images at its original size or scale
it down to fit in the view's available area.

The supported image types are: GIF, JPG / JPEG, PNG, BMP.

Figure 15.60. Compare images view
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Editor

Description
You can open a file for editing in an internal built-in editor. There are default associations between frequently used
file types and the internal editors in the File Types preferences panel.

The internal editor can be accessed either from the Working copy view or from the Synchronize view. The editor can
also be used from the History view to view a selected revision of a file. In this case there are no edits allowed.

Figure 15.61. Editor View

Only one file can be edited in an internal editor at a time. If you try to open another file it will be opened in the same
editor window. The editor has syntax highlighting for known file types. This means that a different color will be used
for each type of recognized token in the file. If the content type of the file is unknown you will be prompted to choose
the proper way the file should be opened.

After editing the content of the file in an internal editor you can save it to disk by using the Save action from the File
menu or the Ctrl + S key shortcut. After saving your file you can see the file changed status into Working copy view
and Synchronize view.

If the internal editor associated with a file type is not the XML Editor then the encoding set in the preference Encoding
for non XML files is used for opening and saving a file of that type. This is necessary because in case of XML files the
encoding is usually declared at the beginning of the XML file in a special declaration or it assumes the default value
UTF-8 but in case of non XML files there is no standard mechanism for declaring the encoding of the file.

Image preview

Description
You can view your local files by using the built-in Image preview component. The view can be accessed either from
the Working copy view, Synchronize view or from the Repository view. It can also be used from the History view to
view a selected revision of a image file.
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Figure 15.62. Image preview

Only one image file can be opened at a time. If an image file is opened in the Image preview and you try to open an-
other one it will be opened in the same window. Supported image types are GIF, JPEG/JPG, PNG, BMP. Once the
image is displayed in the Image preview panel using the actions from the contextual menu one can scale the image at
its original size (1:1 action) or scale it down to fit in the view's available area (Scale to fit action).

History View

Description
In Subversion, both files and directories are versioned and have a history. If you want to examine the history for a se-
lected resource and find out what happened at a certain revision you can use the History view that can be accessed
from any of the three views: Repository view menu, Working copy view menu or Synchronize view menu. From the
Repository view you can display the log history regarding any repository resource. From the Working copy view you
can display the history of local versioned resources. From the Synchronize view you can show the history of any incoming
or outgoing resources.

The view consists of three distinct areas:

• The revision table showing revision numbers, date/time of revision, the name of the author, as well as the first line
of the commit message.

• The list of resources affected by this revision (modified, added, deleted or changed properties).

• The commit message for the selected revision.
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Figure 15.63. History View

History Filters

The History filter dialog

The History view does not always show all the changes ever made to a resource because there may be thousands of
changes and retrieving the entire list can take a long time. Normally you are interested in the more recent ones. That
is why you can specify the criteria for the revisions displayed in the History view by selecting one of several options
presented in the History dialog which is displayed when you invoke the Show History action.

Figure 15.64. History filters dialog

The options for the set of revisions presented in the History view are:

• all the revisions of the selected resource
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• only the revisions between a start revision number and an end revision number

• only the revisions added in a period of time like today, last week, last month, etc.

• only the revisions between a start calendar date and an end calendar date

• only the revisions committed by a specified SVN user

The toolbar of the History view has two buttons for extending the set of revisions presented in the view: Get next 50
and Get all.

Note

When using Subversion servers older than version 1.2, a history request may take a very long time because the
server will reply with the entire history even if you limited the number of entries to a smaller number.

The History filter field

When only the history entries which contain a specified substring need to be displayed in the History view the filter
field displayed at the top of this view is the perfect fit. Just enter the search string in the field next to the label Find.
Only the items with an author name, commit message, revision number or date which match the search string is kept

in the History view. The filter action is executed and the content of the table is updated when the button  Search is
pressed.

Features
Single selection actions:

• Open - opens the selected revision of the file into the Editor. This is enabled only for files.

• Open with ... - Displays the 'Open with ...' dialog for specifying the editor in which the selected file will be opened.

• Save revision to - saves the selected revision to a file so you have an older version of that file. This option is only
available when you access the history of a file, and it saves a version of that one file only.

• Compare with working copy - compares the selected revision with your working copy file. It is enabled only when
you select a file.

• Update to revision - updates your working copy resource to the selected revision.

• Check out from revision - gets the content of the selected revision for the resource into local file system.

• Revert changes from this revision - reverts changes made in the selected revision.

• Get Contents - replaces the current version from the working copy with the contents of the selected revision from
the history of the file. The BASE version of the file is not changed in the working copy so that after this action the
file will appear as modified in a synchronization operation, that is newer than the BASE version, even if the contents
is from an older version from history.

• Show Annotation - computes the latest revision number and author name that modified each line of the file up to
the selected revision, that is no modification later than the selected revision is taken into account.

• Change Author - changes the name of the SVN user that committed the selected revision.

• Change Message - changes the commit message of the selected revision.
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Double selection actions:

• Compare revisions - When the resource is a file the action compares the two selected revisions using the Compare
view. When the resource is a folder the action displays the set of all resources from that folder that were changed
between the two revision numbers.

• Revert changes from these revisions - Similar to the svn-merge command, it merges two selected revisions into the
working copy resource. This action is only enabled when the resource history was requested for a working copy
item.

• Change Message - changes the commit message of the revisions that are selected.

For more information about the History view and its features please read the sections Request history for a resource
and Using the resource history view

Annotations View

Description
Sometimes you need to know not only what lines have changed, but also who changed specific lines in a file. This
view displays the author and the revision that changed every line in a file. Just click on a line in the editor panel where
the file is opened to see the revision that edited that line last time highlighted in the History view and to see all the
lines changed by that revision highlighted in the editor panel. Also the entries of the Annotations view corresponding
to that revision are highlighted. So the Annotations view, the History view and the editor panel are synchronized.
Clicking on a line in one of them highlights the corresponding lines in the other two.
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Figure 15.65. The Annotations View

The annotations of a file are computed with the action Show Annotation available on the right click menu of the History
view and the Repository view.

If the file has a very long history the computation of the annotation data can take long. If you want only the annotations
of a range of revisions you can specify the start revision and the end revision of the range in a dialog similar with the
History filter dialog that will be displayed in the History view. The action is called Show Annotation and is available
on the right click menu of the Working Copy view.

Properties View

Description
The properties view presents the Subversion properties for the currently selected resource from either the Working
copy view or the Synchronize view.
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Figure 15.66. The properties View

Above the table it is specified the currently active resource for which the properties are presented. Here you will also
find a warning when an unversioned resource is selected.

The table in which the properties are presented has four columns:

• State - can be one of

• (empty) - normal unmodified property, same current and base values.

• *(asterisk) - modified property, current and base values are different.

• +(plus) - new property.

• -(minus) - removed property.

• Name - the property name.

• Current value - the current value of the property.

• Base value - the base(original) value of the property.

The svn:externals property

The svn:externals property can be set on a folder or a file. In the first case it stores the URL of a folder from other re-
pository.

In the second case it stores the URL of a file from other repository. The external file will be added into the working
copy as a versioned item. There are a few differences between directory and file externals:

• The path to the file external must be in a working copy that is already checked out. While directory externals can
place the external directory at any depth and it will create any intermediate directories, file externals must be placed
into a working copy that is already checked out.

• The file external's URL must be in the same repository as the URL that the file external will be inserted into; inter-
repository file externals are not supported.

• While commits do not descend into a directory external, a commit in a directory containing a file external will
commit any modifications to the file external.

The differences between a normal versioned file and a file external:
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• File externals cannot be moved or deleted; the svn:externals property must be modified instead; however, file externals
can be copied.

A file external shows up as a X in the switched status column.

Warning

Incomplete support - In subversion 1.6 it is not possible to remove a file external from your working copy once
you have added it, even if you delete the svn:externals property altogether. You have to checkout a fresh working
copy to remove the file.

Toolbar / Contextual menu
The properties view toolbar and contextual menu contain the following actions:

• Add a new property - This button invokes the Add property dialog in which you can specify the property name
and value.

•  Edit property - This button invokes the Edit property dialog in which you can change the property value and also
see its original(base) value.

•  Remove property - This button will prompt a dialog to confirm the property deletion. You can also specify if you
want to remove the property recursively.

•  Refresh - This action will refresh the properties for the current resource.

Console View

Description
The Console View shows the communication between your client and the Subversion repository. The output is expressed
as subcommands to the Subversion server and simulates the Subversion command line notation. For a detailed description
of the Subversion console output read the SVN User Manual. In the right toolbar there are available a Clear  action

which clears the content of the view and a Lock/Unlock scroll  action which disables the automatic console scrolling.

The maximum number of lines displayed in the console (the length of the buffer) can be modified from Preferences.
By default this is set to 100.

Help View

Description
The Help view is a dynamic help window. It changes its content displaying the help section referring to the currently
selected view. As you change the focused view you will be able to read a short description of it and its functionality.

The Revision Graph of a SVN Resource
The history of a SVN resource can be watched on a graphical representation of all the revisions of that resource together
with the tags in which the resource was included. The graphical representation is identical to a tree structure and is
easy to view.
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The graphical representation of a resource history is invoked with the action  Revision graph available on the right
click menu of a SVN resource in the Working Copy view and the Repository view.

Figure 15.67. The Revision Graph of a File Resource

In every node of the revision graph an icon and the background color represent the type of operation that created the
revision represented in that node. Also the commit message associated with that revision, the repository path and the
revision number are contained in the node. The tooltip displayed when the mouse pointer hovers over a node specifies
the URL of the resource, the SVN user who created the revision of that node, the revision number, the date of creation,
the commit message, the modification type and the affected paths.

The types of nodes used in the graph are:

added resource the icon for a new resource added to the repository (  ) and green background

copied resource the icon for a resource copied to other location, for example when a SVN tag is created (

 ) and green background

modified resource the icon for a modified resource (  ) and blue background

deleted resource the icon for a resource deleted from the repository (  ) and red background

replaced resource the icon for a resource removed and replaced with another one on the repository (  ) and
orange background

indirect resource the icon for a revision from where the resource was copied or an indirectly modified re-

source, that is a directory in which a resource was modified (  ) and grey background;
the Modification type field of the tooltip specifies how that revision was obtained in the
history of the resource

443

The Syncro SVN Client



A directory resource is represented with two types of graphs:

simplified graph lists only the changes applied directly to the directory

complete graph lists also the indirect changes of the directory resource, that is the changes applied to the
resources contained in the directory

Figure 15.68. The Revision Graph of a Directory (Direct Changes)
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Figure 15.69. The Revision Graph of a Directory (Also Indirect Changes)

You can switch between the two graphs with the  Show/Hide indirect modifications button of the toolbar of the Re-
vision graph dialog.

The toolbar also contains buttons for zooming in and zooming out the graph and also for resetting the scale of the
graphical representation. When the font has the minimum size (zoom out to last level) the text content is not displayed
in nodes anymore, only the icon is displayed and the distances between graph nodes are smaller so that the graph has
a more compact representation.

The right click menu of a node of the graph contains the following actions:

 Open available only for files, opens the selected revision in the editor panel.

 Show History available for both files and directories, displays the history of the resource in
the History view.

 Compare with HEAD available only for files, compares the selected revision with the HEAD revision
and displays the result in the diff panel.

 Check Out available only for directories, checks out the selected revision of the directory.

When two nodes are selected in the revision graph of a file the right click menu of this selection contains only one
item: Compare for comparing the two revisions corresponding to the selected nodes. If the resource for which the re-
vision graph was built is a folder then the right click menu displayed for a two nodes selection also contains the item
Compare but it computes the differences between the two selected revisions as a set of directory changes. The result
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is displayed in the Directory Change Set view in the same way as for the compare action invoked from the History
view on two revisions of a folder.

Warning

Generating the revision graph of a resource with many revisions may be a slow operation. You should enable
caching for revision graph actions so that future actions on the same repository will not request the same data
again from the SVN server which will finish faster.

Syncro SVN Client Preferences
The options used in the SVN client are saved and loaded independently from the <oXygen/> XML Editor options.
However if at the Syncro SVN Client's first startup it cannot be determined a set of SVN options to be loaded, some
of the preferences are imported from the XML Editor options (e.g. License and HTTP Proxy settings).

The preferences dialog can be accessed from the Options -> Preferences. The preferences panels are called Global ,
SVN , Diff colors and HTTP/Proxy Configuration.

There is a second set of preferences applied to the SVN client: the preferences set in the global SVN files called 'config'
and 'servers', that is the files with parameters that act as defaults applied to all the SVN client tools that are used by
the same user on his login account on the computer. These files can be opened for editing with the two edit actions
available in the SVN client tool on the Global Runtime Configuration submenu of the Options menu.

Command line interface cross reference
This section specifies the equivalent Subversion commands for each action in the Syncro SVN Client action.

Actions commands reference

Checkout

svn checkout [--revision rev] URL
PATH

--revision rev specifies the desired revision(if necessary).

URL is the repository URL you want to check out from.

PATH is the location on the file system.

Update

svn update [--revision rev] PATH --revision rev specifies the desired revision(if necessary).

PATH is the location on the file system of the resource to update.

There are two behaviours for the update action in Syncro SVN client. If invoked from the Synchronize View, it updates
the resources to the HEAD revision. If invoked from the Working Copy view it always updates to the HEAD revision.

Commit

svn commit -m "log message" [--no-
unlock] PATH...

-m "log message" specifies the commit comment.

--no unlock specifies that the resource should keep locks after commit if this is
the case.
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PATH is the location on the file system of the resource to commit. Can be more
than one.

Diff

svn diff --revision rev1:rev2 PATH --revision rev1:rev2 specifies the desired revisions to be compared.

PATH is the location on the file system of the resource to be compared.

If you use the Compare with latest from HEAD from the Working copy view you will be comparing the local file with
the HEAD revision file. If you use Compare with BASE revision the local file will be compared with the pristine copy.
From the Synchronize view you can compare the working copy file with the HEAD revision file. You can choose to
compare the local file with an older revision or two revisions of the same file from the History view.

Show History

svn log [--revision rev1:rev2] [--
limit N] --verbose PATH

--revision rev1:rev2 - specifies the range of revisions for which to obtain the
log.

--limit N - limits the number of log messages to N.

--verbose - gives detailed information about the operation.

Syncro SVN Client uses by default the --limit option in order to obtain only 50 log messages.

Refresh

svn status --verbose PATH --verbose - specifies that the status of all files should be reported.

PATH - The location on the file system to get status for.

Synchronize

svn status --show-updates PATH --show-updates - get the resource status by contacting the repository.

PATH - The location on the file system to get status for.

Import

svn import -m "log message" PATH
URL

-m "log message" - specifies the commit log message

PATH - the local path to the resource on the file system.

URL - the URL on the repository where the resource will be imported.

Export

svn export [--revision rev] URL
PATH

--revision rev specifies the desired revision(if necessary).

URL is the repository URL you want to export from.

PATH is the location on the file system where to export.
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Information

svn info [--revision HEAD] PATH |
URL

--revision HEAD - specifies that the information will be for the HEAD revision
of the resource.

PATH - the local file system path to the resource.

URL - the repository URL for the resource.

This command can obtain information for a resource from a working copy or from a Subversion repository.

Add

svn add PATH... PATH- the local file system path for the unversioned resources to be added to
version control. More than one can be specified.

Add to svn:ignore

svn propset svn:ignore PATH
PARENTPATH

svn:ignore - the predefined property name for ignoring resources.

PATH - the relative path from the working copy root for the resource to be ig-
nored.

PARENTPATH - the path to the parent of the resource to be ignored.

Delete

svn delete --recursive PATH | URL --recursive - specifies that he operation should be performed recursively.

PATH- the local file system path for the resource to delete.

URL- the repository URL for the resource to delete.

This command can delete resources from a working copy or from a Subversion
repository.

Copy

svn copy (SRCPATH DSTPATH)
| (SRCURL DSTURL)

SRCPATH - the working copy path of the resource to be copied.

DSTPATH - the working copy path to be copied to.

SRCURL - the repository path of the resource to be copied.

DSTURL - the repository path to be copied to.

Move / Rename

svn move (SRCPATH DSTPATH)
| (SRCURL DSTURL)

SRCPATH - the working copy path of the resource to be moved.

DSTPATH - the working copy path to be moved to.

SRCURL - the repository path of the resource to be moved.

DSTURL - the repository path to be moved to.
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Mark resolved

svn resolved --recursive PATH --recursive - specifies that he operation should be performed recursively.

PATH - the path to the resource in the local working copy.

Revert

svn revert [--recursive] PATH --recursive - specifies that he operation should be performed recursively.

PATH - the local working copy path to revert.

Cleanup

svn cleanup PATH PATH - the working copy path to cleanup.

Show / Refresh Properties

svn proplist PATH & svn propget
PROPNAME PATH

PATH - the local path for the resource

PROPNAME - the property name.

First you can discover the property names with svn proplist, then you can obtain their values with svn propget.

Branch / Tag

svn copy -m "log message" URL1
URL2 or svn copy -m "log message"

-m "log message" - the commit comment

URL1 - the source repository URL.URL1@rev1 URL2 or svn copy -m
"log message" PATH URL

rev1 - the revision of the source.

URL2 - the destination repository URL.

PATH - the source working copy path.

URL - the destination repository URL.

Merge

Merge - svn merge [--dry-run]
rev1:rev2 URL PATH or svn merge

--dry-run - specifies that the operation will be simulated without making any
modifications.

[--dry-run] URL1@rev1
URL2@rev2 PATH URL - the repository URL for the resource to merge.

URL1 - the repository URL for the start branch to merge.

rev1 - the start revision for the resource to merge.

URL2 - the repository URL for the end branch to merge.

rev2 - the end revision for the resource to merge.

PATH - the destination path in the working copy for the result of the merge
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Scan for locks

svn status --show-updates --verbose
PATH

--show-updates - get the resource status by contacting the repository.

--verbose - specifies that the status of all files should be reported.

PATH - The location on the file system to get status for.

The command will obtain the repository status for all the resources in the path.

Lock

svn lock [--force] [-m "log message"]
PATH

--force - forces(steals) the lock

-m "log message" - the lock comment.

PATH - the path to the file from the working copy..

Unlock

svn unlock [--force] PATH --force - forces(breaks) the lock

PATH - the path to the file from the working copy..

Mark as merged

Mark as merged - rename FILE
FILE.TMP, svn update FILE and
rename FILE.TMP FILE

FILE - the file to be marked as merged.

FILE.TMP - a temporary filename.

Override and update

svn revert PATH, svn update PATH PATH  - the path of the resource to be overridden.

Override and commit

If the resource is in conflict it per-
forms first mark resolved and if the

-m "log message" specifies the commit comment.

--no unlock specifies that the resource should keep locks after commit if this is
the case.

resource has incoming changes mark
as merged and then svn commit -m
"log message" [--no-unlock] PATH

PATH is the location on the file system of the resource to be committed.

Add / Edit property

svn propset [--recursive] PROP-
NAME PROPVALUE PATH

--recursive - specifies that the property should be set recursively.

PROPNAME - the property name.

PROPVALUE - the property value.

PATH - the resource path.

450

The Syncro SVN Client



Remove property

svn propdel [--recursive] PROP-
NAME PATH

--recursive - specifies that the property should be deleted recursively.

PROPNAME - the property name.

PATH - the resource path.

Revert changes from this revision

svn merge rev:rev-1 URL rev - revision whose changes must be reverted.

URL - The SVN URL corresponding to the resource.

Revert changes from these revisions

svn merge rev1:rev2 URL rev1 - first revision number.

rev2 - second revision number.

URL - The SVN URL corresponding to the resource.
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Chapter 16. How to develop an
<oXygen/> plugin
This chapter explains how to write and install a plugin for the Text mode of the <oXygen/> XML Author10.3 or
higher. It treats only the standalone version, as the Eclipse plugin version can be extended with other plugins following
the rules of the Eclipse platform.

Introduction
<oXygen/> defines a couple of extension points to allow providing custom functionality via plugins. The plugin support
includes four types of plugins:

• General plugins

• Selection plugins

• Document plugins

• Custom protocol plugins

• Resource locking custom protocol plugins

A selection plugin can be applied to both an XML document and a non XML document but the other types of plugins
can be applied only to XML documents.

Requirements
In order to develop a plugin a Java development environment must be installed. Apart from any library that the specific
plugin will require the file oxygen.jar is necessary for plugin compilation. Also an <oXygen/> installation will be
helpful for testing the deployment and plugin the functionality.

Implementing plugins
O n  t h e  < o X y g e n / >  w e b s i t e  t h e r e  i s  a  p l u g i n  d e v e l o p m e n t  k i t
[http://www.oxygenxml.com/InstData/Plugins/OxygenPluginsDevelopmentKit.zip] with some sample plugins (source
code and compiled code) and the Javadoc API necessary for developing custom plugins. On the Plugins page
[ht tp: / /www.oxygenxml.com/plugins .html]  there  is  a  developer  manual
[http://www.oxygenxml.com/doc/HowToDevelopOxygenPlugins.pdf] with instructions for developing custom plugins.

The minimal implementation of a plugin must provide two classes: one that extends the Plugin class and another that
implements the plugin extension and a plugin descriptor file. There are five available extensions SelectionPlu-
ginExtension, DocumentPluginExtension, GeneralPluginExtension, URLStreamHandlerPlu-
ginExtension and StartupPluginExtension.

A PluginDescriptor object is passed to the plugin class on constructor containing information about the plugin

• basedir - File - the base directory of the plugin.

• description - String - the description of the plugin.
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• name - String - the name of the plugin.

• vendor - String - the vendor name of the plugin.

• version - String - the plugin version.

The PluginDescriptor fields are filled with information from the plugin descriptor file.

The plugin descriptor defines how the plugin will be integrated in <oXygen/> and what libraries should be loaded.
The structure of the plugin descriptor file is fully described in a DTD grammar located in OXYGEN_INSTALLA-
TION_FOLDER/plugins/plugin.dtd.

Here is a sample plugin descriptor used by the Capitalize Lines sample plugin:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plugin SYSTEM "../plugin.dtd">
<plugin
    name="Capitalize Lines"
    description="Capitalize the first character on each line"
    version="1.0.0"
    vendor="SyncRO"
    class="ro.sync.sample.plugin.caplines.CapLinesPlugin">
    <runtime>
        <library name="lib/caplines.jar"/>
    </runtime>
    <extension type="selectionProcessor" 
    class="ro.sync.sample.plugin.caplines.CapLinesPluginExtension" keyboardShortcut="ctrl shift EQUALS"/>
</plugin>

If your plugin is of type selectionProcessor, documentProcessor or generalExtension and thus
contributes an action either to the contextual menu or to the main menu then you can assign a keyboard shortcut for
it. You can use the keyboardShortcut attribute for each extension to specify the desired shortcut.

Tip

To compose string representations of the desired shortcut keys you can go to the <oXygen/> Menu Shortcut
Keys preferences page, press Edit on any action, press the desired key sequence and use the representation which
appears in the edit dialog.

General plugins
GeneralPluginExtension - this interface is intended for general purpose plugins - kind of external tools but
triggered from the Plugins main menu. The implementing classes must contain the method process(GeneralPlu-
ginContext) which should provide the plugin processing. This method takes as a parameter an GeneralPlugin-
Context object.

GeneralPluginContext - represents the context in which the general plugin extension does its processing. The
only method available is getFrame() which returns the currently editing frame (java.awt.Frame). It is useful
if the plugin wants to display graphical components as they in general need a parent in order to appear properly on
screen.
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Selection plugins
SelectionPluginExtension - This interface is intended for selection processing plugins. A selection plugin
can be applied to both an XML document and a non XML document. It works as follows: the user makes a selection
in the editor and then goes to the contextual menu and selects from the Plugins section the corresponding entry. The
context containing the selection is passed to the extension and the processed result is going to replace the initial selection.

The context is represented by an SelectionPluginContext object, this provides two methods:

• getSelection() - String - returns the current selection of text.

• getFrame() - Frame - returns the currently editing frame.

The process method must return a SelectionPluginResult object which contains the result of the processing.

Document plugins
DocumentPluginExtension - This interface is intended for document processing plugins. This type of plugins
can be started from the contextual menu, Plugins section, by selecting the corresponding entry. The context containing
the current document is passed to the extension in order to be processed.

The context is represented by an DocumentPluginContext object, this provides two methods:

• getDocument() - Document - returns the current document.

• getFrame() - Frame - returns the currently editing frame.

The process method can return a DocumentPluginResult object containing a new document.

Custom protocol plugins
URLStreamHandlerPluginExtension allows the developer to work with a protocol that he designed for re-
trieving and storing files. There is one method that has to be implemented:

• getURLStreamHandler(String protocol) - URLStreamHandler- It takes as an argument the name of
the protocol and returns the handler for it, or null if it was not able to find it.

With the help of the URLChooserPluginExtension interface, it is possible to write your own dialog that will
work with the custom protocol. This interface provides two methods:

• chooseURLs() - URL[] - returns the URLs the user decided to open with the custom protocol. You can invoke
your own URL chooser dialog here and then return the chosen URLs having your own custom protocol.

• getMenuName() - String - returns the name of the entry that will be added in the File submenu of the editor

With the help of the URLChooserToolbarExtension interface, it is possible to provide a toolbar entry which
will be used to launch the custom URLs chooser from in the URLChooserPluginExtension. This interface
provides two methods:

• getToolbarIcon() - Icon - returns the javax.swing.Icon image which will be used on the toolbar.

• getToolbarTooltip() - String - returns the tooltip which will be used on the toolbar button.
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Resource locking custom protocol plugins
URLStreamHandlerWithLockPluginExtension allows the developer to work with a protocol that he designed
for retrieving and storing files and lock a resource on opening it in <oXygen/>. This type of plugin extends the custom
protocol plugin type URLStreamHandlerPluginExtension with resource locking support. The plugin receives
callbacks following the simple protocol for resource locking and unlocking imposed by <oXygen/> as you can read
in the developer manual [http://www.oxygenxml.com/doc/HowToDevelopOxygenPlugins.pdf]. There are two addi-
tional methods that must be implemented:

• getLockHandler() - returns a LockHandler implementation class with the implementation of the lock specific
methods from your plugin.

• isSupported(String protocol) - boolean - you can accept to manage locking for a certain URL protocol
like scheme like ftp, http, https or customName.

Components Validation plugins
ComponentsValidatorPluginExtension allow developers to make customization of the Editor's menus,
toolbars and some other components. There is one method that has to be implemented:

• getComponentsValidator() - returns a ro.sync.exml.ComponentsValidator implementation class use for
validate the menus, toolbars and their actions.

The ComponentsValidator provides methods to filter various features from being added to the application GUI:

• validateMenuOrTaggedAction(String[] menuOrActionPath) - boolean - check if an menu or a
tag action from an menu is allowed. A tag is used to uniquely identifying an action. The String[] argument is the
tag of the menu/action and the tags of its parent menus if any.

• validateToolbarTaggedAction(String[] toolbarOrAction) - boolean - check if an action from
a toolbar is allowed. The String[] argument is the tag of the action from a toolbar and the tag of its parent toolbar if
any.

• validateComponent(String key) - boolean - check if the given component is allowed. The String argument
is the tag identifying the component. You can remove toolbars entirely using this callback.

• validateAccelAction(String category, String tag) - boolean - check if the given accelerator
action is allowed to appear in the GUI. An accelerator action can be uniquely identified so it will be removed both
from toolbars or menus. The first argument represent the action category, the second is the tag of the action.

• validateContentType(String contentType) - boolean - check if the given content type is allowed.
The String argument represent the content type. You can instruct the application to ignore content types like or
"text/xsl" or "text/xquery" and the application will no longer be able to recognize them.

• validateOptionPane(String optionPaneKey) - boolean - check if the given options page can be add
in the application Preferences option tree. The String argument is the option pane key.

• validateOption(String optionKey) - boolean - check if the given option can be add in the option page.
The String argument is the option key. This method is mostly used for internal used and will not get called for each
option in a preferences page.

• validateLibrary(String library) - boolean - check if the given library is allowed to appear listed in
the About dialog. The String argument is the library. This method is mostly for internal use.
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• validateNewEditorTemplate(EditorTemplate editorTemplate) - boolean - check if the given
template for a new editor is allowed. The EditorTemplate argument is the editor template. An EditorTemplate is
used to create a new editor for a given extension. You can thus filter what appears in the "New"->From Templates
dialog list.

• isDebuggerperspectiveAllowed() - boolean - check if the debugger perspective is allowed.

• validateSHMarker(String marker) - boolean - check if the given marker is allowed. The String argument
represent the syntax highlight marker to be checked. If you decide to filter certain content types you can also filter
the syntax highlight options so that that content type is no longer present in the Preferences options tree.

Tip

The best way to decide what to filter is to first see the values the application passes when these callbacks are
called. You can first create an implementation for this interface which lists in a file in in the console all values
received by each function. Then you can decide on the values to filter and act accordingly.

Example - UppercasePlugin
The following plugin is an example. It is used in <oXygen/> for capitalizing the characters in the current selection.
This example consist of two classes and the plugin descriptor:

package ro.sync.sample.plugin.uppercase;

import ro.sync.exml.plugin.Plugin;
import ro.sync.exml.plugin.PluginDescriptor;

public class UppercasePlugin extends Plugin {
    /**
    * Plugin instance.
    */
    private static UppercasePlugin instance = null;  

    /**
    * UppercasePlugin constructor.
    * 
    * @param descriptor Plugin descriptor object.
    */
    public UppercasePlugin(PluginDescriptor descriptor) {
        super(descriptor);

        if (instance != null) {
            throw new IllegalStateException("Already instantiated !");
        }    
        instance = this;
    }

    /**
    * Get the plugin instance.
    * 
    * @return the shared plugin instance.
    */
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    public static UppercasePlugin getInstance() {
        return instance;
    }
}

package ro.sync.sample.plugin.uppercase;

import ro.sync.exml.plugin.selection.SelectionPluginContext;
import ro.sync.exml.plugin.selection.SelectionPluginExtension;
import ro.sync.exml.plugin.selection.SelectionPluginResult;
import ro.sync.exml.plugin.selection.SelectionPluginResultImpl;

public class UppercasePluginExtension implements SelectionPluginExtension {
    /**
    * Convert the text to uppercase.
    *
    *@param  context  Selection context.
    *@return          Uppercase plugin result.
    */
    public SelectionPluginResult process(SelectionPluginContext context) {
        return new SelectionPluginResultImpl(
            context.getSelection().toUpperCase());
    }
}

<!DOCTYPE plugin SYSTEM "../plugin.dtd">
<plugin
    name="UpperCase"
    description="Convert the selection to uppercase"
    version="1.0.0"
    vendor="SyncRO"
    class="ro.sync.sample.plugin.uppercase.UppercasePlugin">
    <runtime>
        <library name="lib/uppercase.jar"/>
    </runtime>
    <extension type="selectionProcessor" 
     class="ro.sync.sample.plugin.uppercase.UppercasePluginExtension"/>
</plugin>

Example - a custom protocol plugin
1. Write the handler class for your protocol (implement the java.net.URLStreamHandler interface)

Note

You must be careful to provide ways to correct and un correct the URLs of your files.
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2. Write the plugin class (the ro.sync.exml.plugin.Plugin  class must be extended in order to create the
new plugin)

3. Write the plugin extension class. It is necessary that the plugin extension for the custom protocol implements the
URLStreamHandlerPluginExtension interface. Without it, you can’t use your plugin,because <oXygen/>
will not be able to find the protocol handler.

You can choose to implement also the URLChooserPluginExtension interface. It will allow you to write
and use your own customized dialog for this protocol.

4. Write the plugin.xml file (remember to change the name of the plugin class to the one from the second step and
the plugin extension class name with the one you have chosen at step 3)

5. Create a .jar archive and install your new plugin.

Installing the plugin
In the directory where <oXygen/> is installed there exists a directory called plugins. This contains all the available
plugins. In order for <oXygen/> to use the new functionality you provided follow the next steps:

1. In the directory plugins create a new directory, generally named after your plugin. For instance in the uppercase
plugin example this can be Uppercase.

2. Put in this new folder the plugin descriptor file, "plugin.xml" and the plugin files.

3. Restart <oXygen/> and try your plugin.
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Chapter 17.Text editor specific actions
<oXygen/> XML Author provides user actions common in any text editor:

Undoing and redoing user actions
•

Edit → Undo (Ctrl+Z)or the toolbar button  Undo to reverse a maximum of 100 editing actions to return to the
preceding state. Complex operations like "Replace All", "Indent selection", etc are treated as a single undo event.

•
Edit → Redo (Ctrl+Y for Windows, Ctrl+Shift+Z for Mac OSX and Linux)or the toolbar button  Redo to
recreate a maximum of 100 editing actions that were undone by the Undo function.

Copying and pasting text
•

Edit → Cut (Ctrl+X)or the toolbar button  Cut to remove the current selected node from the document and places
it in the clipboard.

•
Edit → Copy (Ctrl+C)or the toolbar button  Copy to place a copy of the current selection in the clipboard as
RTF. All text attributes such as color, font or syntax highlight are preserved when pasting into another application.

•
Edit → Paste (Ctrl+V)or the toolbar button  Paste to place the current clipboard content into the document at
the cursor position.

• Edit → Select All (Ctrl+A) selects the entire body of the current document, including whitespace preceding the first
and following the last character.

Finding and replacing text in the current file

The Find/Replace dialog

The Find/Replace dialog opened with the menu entry Find → Find/Replace... (Ctrl+F)or the toolbar button 
Find/Replace enables you to define "search for" or "search for and replace" operations on the current document. The
find works on multiple lines, which means a find match can cover characters on more than one line. To insert a new
line in the find or replace text area press CTRL + Enter instead of Enter. The replace operation can bind Perl 5 regular
expression group variables ($1, $2, etc.) from the find match. For example to replace the tag with attributes called tag-
name with the tag tag-name1 use as text to find <tag-name(\s+)(.*)> and as replace text <tag-name1$1$2>.

• Find occurrences of a word or string of characters including white spaces represented on a line or on multiple lines
and highlight the position in the editor.

• Replace occurrences of target defined in the Text to find area with a word or string of characters, including white
spaces, that can be on a line or on multiple lines, defined in the Replace with area.

• Find all occurrences of a word or string of characters including white spaces that can be on a line or on multiple
lines and return a result list to the Message Panel.
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• Replace all occurrences of a word or string of characters including white spaces that can be on a line or on multiple
lines.

Figure 17.1. Find/Replace Dialog

Complete the dialog as follows:

Text to find The target character string to search for. The string can be on a line or on multiple
lines. Special characters like newline and tab can be inserted using the contex-
tual menu.

You can search for Unicode characters specified in the \uNNNN format. Also,
hexadecimal notation (\xNNNN) and octal notation (\0NNNN) can be used.
Note that in this case you have to check the Regular expression checkbox. For
example to search a space character you can use \u0020 code.

Replace with The character string with which to replace the target. The string for replace can
be on a line or on multiple lines. Special characters like newline and tab can be
inserted using the contextual menu.

Unicode characters can also be used in the Replace with area.

The Find and Replace history buttons The last find and replace operations history is available using the  History
buttons from the top of the find or replace text area.

The character string with which to replace the target. It may contain regexp
group markers if the search expression is a regular expression and the regular
expression checkbox is checked.

XPath The XPath 2.0 expression entered in this combo is used to restrict the search
scope. It is applied only at the first search command (Find, Replace, Find all,
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Replace to end) after the user changes the content of this combo so that he is
able to replace tag names covered by the current XPath expression.

The content completion assistant that helps in entering XPath expressions in
attributes of XSLT stylesheets elements is also available in the XPath console
and offers always proposals dependent of the current context of the cursor inside
the edited document.

Direction Specify if the search direction is from current position to end of file (forward
direction) or to start of file (backward direction).

Scope Specify if the search is executed on all file or only on the lines that were selected
when the dialog was invoked. If the selection was on a single line the search is
executed on all the file.

Find Execute a find operation for the next occurrence of the target and stop.

Replace Execute a replace operation for the target followed by a find operation for the
next occurrence.

Find all Executes a find operation and returns all results to the Message Panel.

Replace all Execute a replace operation in the entire scope of the document.

Replace to end Execute a replace operation starting from current target until the end of the
document, in the direction specified by the current selection of the Direction
switch (forward or backward).

Case sensitive When checked, operations are case sensitive.

Whole words only When checked only whole occurrences of a word will be included in the opera-
tion.

Search also in tags When checked, operation will include content of the start and end tags of the
XML elements.

Incremental When checked, search operation is started for every letter typed in or deleted.
The first match that obeys the checked conditions will be highlighted.

Regular expression When checked allows using any regular expression in PERL syntax.

Wrap around Continues the find from the start (end) of the document after reaching the end
(start) if the search is in forward (backward) direction.

The Find All Elements dialog
The Find All Elements dialog opened with the menu entry Find → Find All Elements... (Ctrl+Shift+E) assists you in
defining "search for XML elements" operations on the current document. As a result, the dialog can perform the fol-
lowing:

• Find all the elements with a specified name

• Find all the elements which contain a specified string in their text

• Find all the elements which have a specified attribute
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• Find all the elements which have an attribute with a specified value

All these search criteria can be combined to fine filter your results.

The results of all the operations in the Find All Elements dialog will be presented as a list in the Message Panel.

Figure 17.2. Find All Elements Dialog

The dialog fields are described as follows:

Element name The target element name to search for. Only the elements with this exact name are returned.
For any element name just leave the field empty.

Element text The target element text to search for. The combo box beside this field allows you to specify
that you are looking for an exact or partial match of the element text. For any element text,
select contains in the combo box and leave the field empty.

If you leave the field empty but select equals in the combo box, only elements with no text
will be found.

Attribute name The name of the attribute which needs to be present in the elements. Only the elements which
have an attribute with this name will be returned. For any/no attribute name just leave the
field empty.

Attribute value The attribute value The combo box beside this field allows you to specify that you are looking
for an exact or partial match of the attribute value. For any/no attribute value select contains
in the combo box and leave the field empty.

If you leave the field empty but select equals in the combo box, only elements that have at
least an attribute with an empty value will be found.

Case sensitive When this option is checked, operations are case sensitive.

The Quick Find toolbar
A reduced version of the Find/Replace dialog is available as a toolbar, activated by the shortcut specified in the Find
menu and displayed by default at the bottom of the <oXygen/> window, above the status bar.
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Figure 17.3. The Quick Find toolbar

The Find, Find next, Find previous, Incremental and Case sensitive controls work in the same way as in the Find/Replace
dialog. Also the search process works as if the Search also in tags option of the Find/Replace dialog is true, the Whole
words only one is false, the Regular expression one is false and the Wrap around one is true. The toolbar becomes in-
visible again when the ESC key is pressed.

The enabling shortcut can be changed in Options → Preferences+Menu Shortcut Keys+Quick FindAs with any dockable
toolbar, the screen location of the Quick Find toolbar can be changed at any time by dragging (and docking) it to the
desired location. However the buttons of this toolbar can be used only if it has a horizontal layout so docking it to the
West side or the East side of the window is not allowed.

Keyboard shortcuts for finding the next and previous
match
Navigation from a find match to the next one or the previous one is very easy with two keyboard shortcuts: F3 and
Shift F3. They are useful to quickly repeat the last find action performed with the Find/Replace dialog, taking into account
the same find options set there through check boxes.

Find → Find next (F3) performs another search in forward direction using the last search configuration.

Find → Find previous (Shift+F3) performs another search in backward direction using the last search configuration.

Finding and replacing text in multiple files

The Find and Replace in Files option ( Find → Find/Replace in Files... or the toolbar button  Find/Replace in Files
) enables you to define "search for" or "search for and replace" operations across a number of files. The find works at
line level, which means a find match cannot cover characters on more than one line. The replace operation can bind
Perl 5 regular expression group variables ($1, $2, etc.) from the find match. For example to replace the tag with attributes
called tag-name with the tag tag-name1 use as text to find <tag-name(\s+)(.*)> and as replace text <tag-name1$1$2>.

The encoding used to read and write the files is detected from the XML header or from the BOM. If a file does not
have an XML header or BOM <oXygen/> uses the UTF-8 encoding for files of type XML, that is one of the extensions:
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xml, xsl, fo, xsd, rng, nvdl, nrl, sch, wsdl or an extension associated with the XML editor type, or the encoding configured
for non XML files.

You can cancel a long operation at any time by pressing the Cancel button of the progress dialog displayed when the
operation is executed.

Figure 17.4. Find/Replace in Files

Complete the dialog as follows:

Text to Find The target character string to search for.

Case Sensitive When checked, operations are case sensitive.

Whole words only When checked only whole occurrences of a word will be included in the opera-
tion.

Search also in tags When checked, operation will include content of the start and end tags of the
XML elements.

Regular Expression When checked allows using any regular expression in PERL syntax.

Replace with The character string with which to replace the target. It may contain regexp
group markers if the search expression is a regular expression and the regular
expression checkbox is checked.
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Make Backups with extension In the replace process <oXygen/> makes backup files of the modified files. The
default extension is *bak, but you can change extension as you prefer.

All opened files Search in all files opened in <oXygen/> (regular files or DITA Maps). You will
be prompted to save all modified files before any operation is performed.

Directory of the current edited file The search is done in the directory of the file opened in the current editor panel.
If there is no opened file this option is disabled in the dialog.

Scope of the current DITA Map The search is done in all maps and topics referenced by the current edited DITA
Map. If "Recurse referenced maps" is checked the references from the maps
referenced in the main DITA map will also be searched in. If there is no opened
DITA Map this option is disabled in the dialog. You will be prompted to save
all modified files before any operation is performed.

Project Files Search in all files from the current project.

Selected project files Search only in the selected files of the current opened project

Note

The search is performed only on local files. If you have added to the project
remote files from an FTP or WebDAV server these will be skipped from
the search.

Specified Path Choose the search path

Recurse subdirectories The search is performed recursively in the sub-directories found in the specified
directory path only when this option is checked.

Recurse subdirectories When checked, the search is performed recursively in the sub-directories found
in the specified directory path.

Include hidden files When checked, the search is performed also in the hidden files.

Find All Executes a find operation and returns the result list to the Message Pane

Replace All Replaces all occurrences of the target contained in the specified files.

Use this option with caution.

Global search and replace across all project files does not open the files containing the targets, nor does it prompt
on a per occurrence basis, to confirm that a replace operation must be performed. As the operation simply matches
the string defined in the find field, this may result in replacement of matching strings that were not originally
intended to be replaced.

Using Check Spelling

The Check Spelling option ( Edit → Check Spelling (F4) or the toolbar button  Check spelling ) enables you to
perform the check spelling on the current document:
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Figure 17.5. Check Spelling Dialog

Complete the dialog as follows:

Unrecognized Word Contains the word that cannot be found in the selected dictionary. The word is
also highlighted in the XML document.

Replace with The character string which is suggested to replace the unrecognized word.

Guess Displays a list of words suggested to replace the unknown word. Double clicking
a word in this list automatically inserts it in the document and continues the
spell checking process.

Dictionary Displays a list with the available dictionaries.

Replace Replaces the currently highlighted word in the XML document, with the selected
word in the "Replace with" field.

Replace All Replaces all occurrences of the currently highlighted word in the XML document,
with the selected word in the "Replace with" field.

Ignore Allows you to continue checking the document while ignoring the first occurrence
of the unknown word. The same word will be flagged again if it appears in the
document.

Ignore all Ignores all instances of the unknown word in the whole document.

Learn Includes the unrecognized word in the list of valid words so that the spell
checker will not consider it for correction.

Options Sets the configuration options of the Spell Checker.

Begin at caret position When checked, the spell checker begins checking from the current cursor posi-
tion.

OK Closes the Spell Checker dialog.
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<oXygen/> provides dictionaries only for the languages English (EN, GB, CA, US), French (FR, BE, CA, CH) and
German in the form of .dar files located in the directory [oXygen-install-dir]/dicts. A pre-built dictionary
can be added by copying the corresponding .dar archive to the same directory and restarting <oXygen/>. A dictionary
can be built with the tool available at http://www.xmlmind.com/spellchecker/dictbuilder.shtml.

Learned words are stored into an persistent learned-words dictionary with the .tdi extensions located in [user-home-
dir]/Application Data/com.oxygenxml.author/spell directory on Windows and [user-home-dir]/Library/Prefer-
ences/com.oxygenxml.author/.spell directory on Mac OS X. There is one dictionary for each language-country variant
combination. If the Learn button is pressed by mistake the only possibility to delete the learned word from the learned-
words dictionary is to edit this dictionary manually and restart <oXygen/> because the spell-check component does
not allow its editing by the user interface.

Note

The Czech check spelling dictionary may be downloaded from http://www.kosek.cz/sw/xxe/cs.dar

Spell checking feature can be also used as you type by enabling it from the Preferences panel. Also for words with
wrong spelling the suggestions of the Spelling dialog are available on the context menu of the editor panel in the Spell
check suggestions submenu:

Figure 17.6. Spell check suggestions in the editor context menu

Note

Words with lengths in excess of 100 characters are ignored by the spell checker.

Note

The check spelling is available when editing documents in the text editor as well as in the Author editor.
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Changing the font size
The font size of the editor panel can be changed with the following actions:

Document → Font size → Increase
editor font (Ctrl + NumPad + +)

Increase the font size with one point for each execution of the action.

Document → Font size → Decrease
editor font (Ctrl + NumPad + -)

Decrease the font size with one point for each execution of the action.

Document → Font size → Normal
editor font (Ctrl + 0)

Reset the font size to the value of the editor font set in Preferences.

VI editor actions
The Text mode editor implements many actions known from the VI text editor:

Ctrl+Delete (Meta+Delete on Mac) Delete next word

Ctrl+Backspace (Meta+Backspace
on Mac)

Delete previous word

Ctrl+W (Meta+W on Mac) Cut previous word

Ctrl+K (Meta+K on Mac) Cut to end of line

Dragging and dropping the selected text
To move a whole region of text to other location in the same edited document just select the text, drag the selection
by holding down the left mouse button and drop it to the target location.

Inserting a file at caret position
Document+File → Insert file... inserts in a file under the current position of the caret in the current document.

Opening the file at caret in system application
Document+File → Open File at Caret in system Application opens the filename under the current position of the caret
from the current document with the default associated application.

Opening the file at caret position
Document+File → Open File at Caret : Opens in a new panel the file with the name under the current position of the
caret in the current document. If the file does not exist at the specified location the error dialog that is displayed contains
a Create new file action which displays the New file dialog. This allows you to choose the type or the template for the
file. If the action succeeds, the file is created with the referred location and name and is opened in a new editor panel.
This is useful when you decide first on the file name and after that you want to create it in the exact location specified
at the current cursor position.
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Switching between opened tabs
Ctrl + Tab Switch between the tabs with opened files in the order from the recent ones to the not

recent ones.

Ctrl + Shift + Tab Switch between the tabs with opened files in the reverse order.

Printing a file
File → Print (Ctrl+P) displays the Page Setup dialog used to define the page size and orientation properties for printing.

Printing is supported for Text, Grid and Author page of the editor.

A Print Preview action is available in the File menu. This allows you to manage the format of the printed document:

Figure 17.7. Print Preview Dialog

The main window is split in three sections:

Preview area Displays the printed document page formatted.
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Left stripe The left-hand side stripe which displays a list of thumbnail pages. Clicking any of them will display
the page in the main preview area.

Toolbar The toolbar top area which contains controls for printing, page settings, page navigation. print
scaling and zoom.

Exiting the application
File → Exit (Ctrl+Q) : Terminates <oXygen/> XML Author . Session information such as the current Project, open
Documents and Option settings is made persistent. When <oXygen/> XML Author is re-opened, the persistence in-
formation returns to the last saved state.
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Chapter 18. Configuring the application
Importing/Exporting Global Options
In the Options menu you can find the Import/Export preferences operations which allow you to move your global
preferences in XML format from one computer to another.

Preferences
Once the application is installed you can use the Preferences dialog accessed from Options → Preferences to customize
the application for your requirements and network environment.

There is a search field available in the dialog for selecting only the preferences panels containing required words in
the panel title or in the text of a label or a button contained in the panel. If you want to go to first match press Enter,
Up Arrow or Down Arrow.

Figure 18.1. The Search field from the Preferences dialog

You can always revert modifications to their default values by using the Restore Defaults button, available in each
preference page.

Global
The Global preferences panel is opened from menu Options → Preferences+Global
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Figure 18.2. The Global preferences panel

Automatic Version Checking When enabled, checks the availability of new <oXygen/> XML Author versions
at http://www.oxygenxml.com .

Language The application supports a number of languages for localization of the GUI.
Select Options → Preferences → Global+Language drop-list to display the
language choices.

Note

After restarting the application, if some GUI labels are not rendered cor-
rectly you will need to install the corresponding language pack from your
OS installation kit.

Other language To change the user interface language of <oXygen/> you must set here the
properties file with all the user interface messages and labels translated to your
preferred language. For details about creating this file see the section describing
the creation process. After setting the file you have to restart <oXygen/> in order
to change the user interface language to your preferred language.

Look and Feel Use this option to change graphic style (look and feel) of the GUI.

Styles On Windows there are available the following styles:

• Office 2003
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• Vsnet

• Eclipse

• Xerto

• Default

Note

After changing the style one has to restart the application in order for the
modification to take effect.

On Linux there are available the following styles:

• Eclipse

• Default

• GTK+ (not recommended due to stability and paint issues)

Note

After changing the style one has to restart the application in order for the
modification to take effect.

On Mac OS X this option is not available.

Themes On Windows this option is enabled only if the Office 2003 or Default styles. In
these cases, the following themes are available:

• Normal Color

• Home Stead

• Metallic

• Default

• Gray

On Linux this option is not available.

On Mac OS X this option is not available.

Line separator This option defines line separator to be used. The System Default choice sets
the line separator from the platform.

Detect the line separator on file open When this option is checked the editor will detect the line separator when the
edited file is loaded and it will use it when the file is saved. The new files are
saved using the line separator defined by the "Line separator" option.

Default Internet browser The path to a web browser executable. The browser is used to open XSLT or
PDF transformation results, to open the <oXygen/> home page or to point to
specific paragraphs in the W3C recommendation of XML Schema on the W3C
website in case of validation errors.
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Open last edited files from project When enabled, <oXygen/> will open the last edited files from project at start-
up. Filer larger than 50 KB are not opened.

Beep on operation finished If checked, it notifies the user through a beep that an action has ended. It will
notify the user only at the end of validate, wellformed and transform actions.

Show Java vendor at startup Sun Microsystems Java VM or Apple Computer Java VM (on Mac OS X) is
required to run <oXygen/>. If a different VM is used, then a warning is generated.
This option allows the user to choose whether the warning dialog is shown in
this case or not.

Auto update unmodified editors on
file system changes

Checked by default. If checked, the synchronization of the unmodified editors
with the system changes is done automatically, without the user's interaction.

Last visited directory The dialog used for opening files remembers the last visited directory and the
next time it starts directly in this directory.

Directory of the edited file The dialog used for opening files starts in the directory where the currently edited
file is stored.

Show hidden files and directories Show system hidden files and folders in the file and directory browsers. This
setting is not available on Mac OS X.

Fonts
The Fonts preferences panel is opened from menu Options → Preferences+Fonts

Figure 18.3. The Fonts preferences panel

Editor Use this option to select the font family and size used to display text in the editor. This
option affects both the text and grid page of the editor.

Author default font Use this option to select the font family and size used to display text in the author editor.
This value will be used in the case another one is not specified in the CSS associated
with the opened document.

Schema default font Use this option to select the font family and size used to display text in the XML Schema
diagram and in the images included in the HTML documentation generated from an
XML Schema.

Text antialiasing Enable text antialiasing at the specified level. On JVM versions prior to 1.6 this combo
box contains only the values Default, On and Off. Default means that <oXygen/> will
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not set anything special for text antialiasing but the JVM will use the setting of the op-
erating system if it is available. The On option sets the text antialiasing to pixel level
and the Off option disables it. Starting with version 1.6 the combo contains also values
specific for sub pixel antialiasing, like GASP, LCD_HRGB, LCD_VRGB which sets
the respective antialiasing mode for the text displayed in the <oXygen/> editors and
views.

Text components Use this option to select the font family and size used to display text in text components.
After changing the font one has to restart the application.

GUI Use this option to select the font family and size used to display GUI labels. After
changing the font one has to restart the application.

Document Type Association
The Document Type Association preferences panel is opened from menu Options → Preferences+Document Type
Association

Figure 18.4. Document Type Association preferences panel

User roles You can select between two user roles Content author and Developer. When
the selected role is Content author you can modify only the properties of the
Document Type Associations stored in the user preferences. The externally
stored associations cannot be modified and you will have to duplicate them in
order to further customize these associations. The Developer user can change
any document type association.

Document types table The table presents the currently defined document type associations. The columns
are:

Document type Contains the name of the document type.
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Enabled When checked the corresponding document type associ-
ation is enabled, it is analyzed when trying to determine
the type of a document opened in <oXygen/>.

Storage Presents the location where the document type association
is stored.

When expanding a Document Type Association its defined rules are presented.
A rule is described by:

Namespace Specifies the namespace of the root element from the
association rules set (any by default). If you want to
apply the rule only when the root element is in no
namespace you must leave this field empty (remove
the ANY_VALUE string).

Root local name Specifies the local name of the root element (any by
default).

File name Specifies the name of the file (any by default).

Public ID Represents the Public ID of the matched document.

Java class Presents the name of the class which will be used to
determine if a document matches the rule.

New Opens a new dialog allowing you to add a new association.

Edit Opens a new dialog allowing you to edit an existing association.

Delete Deletes one of the existing association.

Up Moves the selected association one level up (the order is important because the
first document type association in the list that can be associated with the docu-
ment will be used).

Down Moves the selected association one level down.

Enable DTD/XML Schema pro-
cessing in document type detection

When this is enabled the matching process will also examine the DTD/XML
Schema associated with the document. For example the fixed attributes declared
in the DTD for the root element will be analyzed also if this is specified in the
association rules.

Example 18.1. Enabling DTD Processing for DITA
customizations

If you are writing DITA customizations you should enable this checkbox. DITA
Topics and Maps are also matched by looking for the DITAArchVersion attribute
in the root element. If the DTD is not processed on detection then this attribute
specified as default in the DTD will not be detected on the root element and the
DITA customization will not be correctly matched.

Only for local DTDs/XML Schemas When the previous feature is enabled you can choose to process only the local
DTDs/XML Schemas.
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Note

The Reset Defaults button that is available in all Preferences panels has no effect for document types with external
storage.

Perspectives Layout
The Perspectives Layout preferences panel is opened from menu Options → Preferences+Perspectives Layout

<oXygen/> has a large number of helper views that can be arranged in different layouts. Use this options to select a
different layout for the editor.

Figure 18.5. The Perspectives Layout preferences panel

Use default layout This option is checked by default. It indicates that the editor must use the default layout
for all the perspectives. Any modification of this layout (for instance closing/showing
views or a new view arrangement) is saved when the program exits and is reloaded at
the next start up.

Used fixed layout Check this when you want the editor to always start with a certain view layout. Modific-
ations of the selected layout are lost when the program exists.

There are two kinds of fixed layout:

Predefined <oXygen/> has several predefined layouts to choose from, depending
on the type of work you intend to do:

Advanced All the views are visible.

Basic Just the project view and the outline view
are visible. This is recommended when
you edit XML content and you need
screen space.

Intermediate The project, outline, attributes and model
view are visible.

Schema development The project, outline, attributes, model
view and schema components are visible.

Schema development The project, outline, attributes, model
view and schema components are visible.

XQuery development Only the project and the editing area are
visible.
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XSLT development The project, outline, attributes, model
view and XSLT input are visible.

Specified You can choose an existing layout file from disk. In order to create such
a file, you can arrange the views in the desired order and then use the
action: Perspective → Save layout..

Encoding
The Encoding preferences panel is opened from menu Options → Preferences+Encoding

Figure 18.6. The Encoding preferences panel

Encoding for non XML files This option defines the default encoding to be used when opening non XML
documents. This is necessary because non XML files have a large variety of
formats and there is no standard mechanism for declaring the encoding that
should be used for opening and saving the file. In case of XML files the encoding
is usually declared at the beginning of the file in a special declaration or it as-
sumes the default value UTF-8.

BOM handling This option defines how to handle the BOM (Byte Order Mark) on document
save.

The available options are:

• Don't Write - Don't write the BOM bytes, the loaded BOM bytes are ignored;

• Write - Write the BOM bytes accordingly with chosen encoding;

• Keep - If the loaded document has BOM then write them accordingly with
chosen encoding. This is the default option.

Encoding errors handling This option defines how to handle characters that cannot be represented in the
specified encoding of the document when the document is opened. The available
options are:

• REPORT - Show an error dialog with the character that cannot be represented
in the specified encoding and allow the user to decide how to continue (ignore
that character, replace it with a standard replacement character). This is the
default option.

• IGNORE - The character is ignored and it will not be included in the document
displayed in the editor panel.

• REPLACE - Replace the character with a standard replacement character.
For example if the encoding is UTF-8 the replacement character has the
Unicode code FFFD, and if the encoding is ASCII the character code is 63.
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Editor
The Editor preferences panel is opened from menu Options → Preferences+Editor

Use these options to configure the visual aspect of the text editor.

Figure 18.7. The Editor preferences panel

Selection background color Use this option to set the background color of selected text.

Selection foreground color Use this option to set the text color of selected text.

Completion proposal background Use this option to set the background color for the content completion window.

Completion proposal foreground Use this option to set the foreground color for the content completion window.

Documentation window background Use this option to set the background color for the window containing document-
ation for the content completion elements.

Documentation window foreground Use this option to set the foreground color for the window containing document-
ation for the content completion elements.

Can edit read only files If checked, you have the possibility to edit the read only files.

Undo history size Use this option to control the maximum amount of undo edits which will be re-
membered by the editor in each of the pages.

Pages

The Pages preferences panel is opened from menu Options → Preferences → Editor → Pages and allows you to select
the initial page for an editor. The mode in which a file was edited in the previous session is saved and will be used
when the application is restarted and the file reopened.
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Figure 18.8. The <oXygen/> Pages preferences panel

Text

The Author preferences panel is opened from menu Options → Preferences+Editor+Text

Figure 18.9. The <oXygen/> Text preferences panel

Editor background color Use this option to set the background color of the editor and also of the Diff
Files' editors.

Editor caret color Use this option to set the background color of the editor.

Line number foreground Use this option to set the foreground color for the line numbers displayed at the
right of editor panel.
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Line Wrap (disables folding) This option will do a soft wrap of long lines, that is automatically wrap lines in
edited documents. When this option is checked line folding will be disabled.

Show fold bar This options enables the display of the document folding bar.

Highlight current line Enables highlight for the current line. Use the button to set the highlight color.

Highlight matching tag This option enables highlight for the tag matching the one on which the caret is
situated. Use the button to set the color of the highlight.

Show print margin Enables displaying a vertical line in the editor panel representing the paper
margin if the current content of the editor panel is printed with the action File
→ Print. Use the button to set the color of the print margin line.

Print margin column The number of characters included on a line which the print format allows.

Show line numbers in editor This option enables the line numbers column located in the left part of the editing
space. When unchecked, line numbers option is disabled.

Show line numbers in results This option enables the line numbers column located in the left part of the Results
panel in the Debugger perspective.

Show TAB/NBSP/EOL/EOF marks Marks the TAB/NBSP/EOL/EOF using small icons, for a better visualisation
of the document. Also set the marks color.

Cut/Copy whole line when nothing
is selected

Enables the Cut/Copy shortcut keys when nothing is selected in the editor. The
Cut/Copy actions will operate on the entire current line.

Author

The Author preferences panel is opened from menu Options → Preferences+Editor+Author

Figure 18.10. The <oXygen/> Author preferences panel
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Show caret position info If checked, the position information tooltip will be displayed. More information
about the position information tooltip can be found in the section Position in-
formation tooltip. The documentation tooltip can be disabled from the Content
Completion Annotations preferences panel.

Show placeholders for empty ele-
ments

When checked, placeholders will be displayed for empty elements to make them
clearly visible.

Show Author layout messages If checked, all errors reported during layout creation will be presented in the
Errors view.

Show block range If checked, a block range indicator will be shown in a stripe located in the left
side of the editor.

Hide comments When checked, comments from the documents edited in Author mode will be
hidden.

Hide processing instructions When checked, processing instructions from the documents edited in Author
mode will be hidden.

Hide doctype When checked, doctype sections from the documents edited in Author mode
will be hidden.

Show very large images If unchecked, images larger than 6 megapixels(24MB uncompressed) will not
be loaded and displayed in Author mode. Please be aware that this option is
unchecked by default because of the large amounts of application memory that
images of high resolution can occupy. As a result, an OutOfMemory error could
occur which would practically make <oXygen/> unusable without a restart of
the entire application.

Display referred content (e.g.: entit-
ies, XInclude, DITA conref, etc.)

When checked, the references(entities, XInclude, DITA conref, etc) will also
display the content of the resources they refer.

Format and indent when passing
from author to text or on save

The content of the document is formatted by applying the Format and Indent
action on every switch from the author editor to the text editor of the same
document.

Tags display mode Default display mode for element tags presented in Author mode. You can
choose between Full Tags with Attributes, Full Tags, Block Tags, Inline Tags,
Partial Tags and No Tags.

Tags background color Allows you to configure the author tags background color.

Tags foreground color Allows you to configure the author tags foreground color.

Track Changes

The Author Track Changes preferences panel is opened from menu Options → Preferences+Editor+Author+Track
Changes
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Figure 18.11. The <oXygen/> Track Changes preferences panel

Author The name of the user who performs the changes when Change Tracking is active
for a given editor. This information will be associated with each performed change.

Inserted content color Automatically assign colors for the insert
changes based on the Author name.

Auto

Custom Use a custom color for all insert changes,
regardless of the Author name.

Use same color for background Use the same color for the insert text back-
ground with a certain transparency.

Deleted content color Automatically assign colors for the delete
changes based on the Author name.

Auto

Custom Use a custom color for all delete changes,
regardless of the Author name.

Use same color for background Use the same color for the delete text back-
ground with a certain transparency.
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Messages

Figure 18.12. The Author's Messages preferences panel

Delete tag action Specifies the default behavior when you delete the start or end marker of an
element. You can choose between:

• Always ask

• Always join

• Always unwrap

You can read more about this in Editing the XML markup section.

When opening a map Specified the default behavior when try to open a map. You can choose between:

• Always open in the DITA Map Manager

• Always open as XML

• Always ask

When opening a reference from the
DITA Map Manager

Specifies the default behavior when try to open a reference from the DITA Map
Manager. You can choose between:

• Always open in Author mode

• Always open in text mode

• Always ask

Show author page warning When checked, a warning dialog will be displayed when switching to Author
mode. The warning reminds you that the whitespaces from the text content are
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evaluated according to the value of the CSS white-space property associated to
the enclosing elements.

Grid

The Grid preferences panel is opened from menu Options → Preferences+Editor+Grid

Figure 18.13. The Grid editor preferences panel

Compact representation If checked a child element is displayed at the same height level with the parent
element. If unchecked a child elements is presented nested with one level in the
parent container, that is lower than the parent with one row.

Format and indent when passing
from grid to text or on save

The content of the document is formatted by applying the Format and Indent
action on every switch from the grid editor to the text editor of the same docu-
ment.

Default column width (characters) The default width in characters of a table column of the grid. A column can hold
an element name and its text content, an attribute name and its value. If the total
width of the grid structure is too large you can resize any column with the mouse
but the change is not persistent. To make it persistent set the new column width
in this user option. the

Current selection color The background color used in the focused selected cell of the grid to make it
different in the set of selected cells. For example when an entire row is selected
only one cell of the row is the focused selected one.

Selection color The background color used in the selected cells of the grid except the focused
selected cell which uses a different background color.
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Border color The color used for the lines that separate the grid cells.

Background color The background color of grid cells that are not selected.

Foreground color The color of the text used for the element names, text content of elements, attrib-
ute names and attribute values.

Row header colors - Background
color

The background color of row headers that are not selected.

Row header colors - Current selec-
tion color

The background color of the row header that is currently selected and has the
focus.

Row header colors - Selection color The background color of the row header that is currently selected and does not
have the focus.

Column header colors - Background
color

The background color of column headers that are not selected.

Column header colors - Current selec-
tion color

The background color of the column header that is currently selected and has
the focus.

Column header colors - Selection
color

The background color of the column header that is currently selected and does
not have the focus.

The column headers are painted with two color gradients, one for the upper 1/3 part of the header and the other for the
lower 2/3 part. The start and end colors of the first gradient are set with the first two color buttons. The start and end
colors of the second gradient are set with the last two color buttons.

Format

The Format preferences panel is opened from menu Options → Preferences+Editor+Format

Figure 18.14. The Format preferences panel
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Detect indent on open The editor tries to detect the indent settings of the opened XML document. In
this way you can correctly format (pretty-print) files that were created with dif-
ferent settings, without changing your options. More than that you can activate
the advanced option for detecting the maximum line width to be used for
formatting and hard wrap. These features were designed to minimize the differ-
ences created by the pretty print operation when working with a versioning
system, like CVS for example.

Indent with tabs When checked enables 'Indent with tabs' to set the indent to a tab unit. When
unchecked, 'Indent with tabs' is disabled and the indent will measure as many
spaces as needed in order to go to the next tab stop position. The maximum
number of space characters is defined by the 'Indent size' option.

Indent size Sets the number of spaces or the tab size that will equal a single indent. The
Indent can be spaces or a tab, select the preference using the Indent With Tabs
option. If set to 4 one tab will equal 4 white spaces or 1 tab with size of 4 char-
acters depending on which option was set in the Indent With Tabs option.

Hard line wrap This feature saves time when writing a reach text XML document. You can set
a limit for the length of the lines in your document. When this limit is exceeded
the editor will insert a new line before the word that breaks the limit, and indent
the next line. This will minimize the need of reformatting the document.

Indent on Enter If checked, it indents the new line introduced when pressing Enter.

Enable Smart Enter If checked, it inserts a new indented line between start and end tag.

Detect line width on open If checked, it detects the line width automatically when the document is opened.

Format and indent the document on
open

When checked, the Format and indent the document on open operation will
format and indent the document before opening it in the editor panel.

Line width - Format and Indent Defines the point at which the "Format and Indent" (Pretty-Print) function will
perform hard line wrapping. So if set to 100 Pretty-Print will wrap lines at the
100th space inclusive of white spaces, tags and elements.

Clear undo buffer before Format and
Indent

If checked, the undo buffer is cleared. The undo action can now only undo the
Format and Indent action

XML

The XML Format preferences panel is opened from menu Options → Preferences+Editor+Format+XML
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Figure 18.15. The XML format preferences panel

Preserve empty lines When checked the Format and Indent  operation will preserve all empty lines
found in the document on which the pretty-print operation os applied.

Preserve text as it is If checked, the "Format and Indent" (Pretty-Print) function will preserve text
nodes as they are without removing or adding any whitespace.

Preserve line breaks in attributes If checked, the "Format and Indent" (Pretty-Print) function will preserve the
line breaks found in attributes. When this option is checked, Break long lines
option will be disabled.

Break long attributes If checked, the "Format and Indent" (Pretty-Print) function will break long at-
tributes.

Expand empty elements When checked the Format and Indent  operation will output empty elements
with a separate closing tag, ex. <a atr1="v1"></a>. When not checked the same
operation will represent an empty element in a more compact form: <a
atr1="v1"/>

Sort attributes When checked the Format and Indent  operation will sort the attributes of an
element alphabetically. When not checked the same operation will leave them
in the same order as before applying the operation.

Add space before slash in empty
elements

When checked the Format and Indent  operation will add a space before the
closing slash of an empty element, for instance an empty br will appear as <br
/>.
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Break line before attribute's name If checked, the "Format and Indent" (Pretty-Print) function will break the line
before the attribute's name.

Preserve space elements (XPath) This list contains simplified XPath expressions for the names of the elements
for which the contained white spaces like blanks, tabs and newlines are preserved
by the Format and Indent operation exactly as before applying the operation.
The allowed XPath expressions are of one of the form:

• author

• //listing

• /chapter/abstract/title

• //xs:documentation
The namespace prefixes like xs in the previous example are treated as part of
the element name without taking into account its binding to a namespace.

Strip space elements (XPath) This list contains the names of the elements for which contiguous white spaces
like blanks, tabs and newlines are merged by the Format and Indent operation
into one blank.

Indent (when typing) in preserve
space elements

If checked, automatic tags indentation while editing will take place for all ele-
ments including the ones that are excluded from Pretty Print (default behaviour).
When unchecked, indentation while editing will not take place in elements that
have the 'xml:space' attribute set on 'preserve' or are in the list of Preserve Space
Elements.

Indent on paste Indent paste text corresponding to the indent settings set by the user. This is
useful for keeping the indent style of text copied from other document.

Locks/Unlocks the XML tags The default state of the opened editors. For more information see the Locking
and unlocking XML markup section.

Whitespaces

This panel displays the special whitespace characters of Unicode. Any character that is checked in this panel is considered
whitespace that can be normalized in an XML document. The whitespaces are normalized when the action Format
and Indent is applied or when you switch from Text mode to Author mode or from Author mode to Text mode.

The characters with the codes 9, 10, 13 and 32 are always in the group of whitespace characters that must be normalized
so they are always enabled in this panel.

The list of whitespace characters can be improved with additional characters. Any character added to the list is considered
whitespace.
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Figure 18.16. The Whitespaces preferences panel

The Whitespaces dialog is used to add a new character as whitespace by specifying the hexa value, the name and the
character block.

Figure 18.17. The add whitespace dialog

CSS

The CSS Format preferences panel is opened from menu Options → Preferences+Editor+Format+CSS
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Figure 18.18. The CSS format preferences panel

Indent class content If checked, the class content is indented during a "Format and Indent" (Pretty-
Print) operation.

Class body on new line If checked, the class body (including the curly brackets) are placed on a new
line after a Pretty-Print operation.

Add new line between classes If checked, an empty line is added between two classes after a Pretty-Print oper-
ation is performed.

Allow formatting embedded CSS If checked, the CSS content embedded in XML will be formated when the XML
content is formated.

JavaScript

The JavaScript Format preferences panel is opened from menu Options → Preferences+Editor+Format+JavaScript

Figure 18.19. The JavaScript Format preferences panel

Start curly brace on new line If true, opening curly braces will start on a new line.

Preserve empty lines If true, empty lines in the JavaScript code will be preserved.

Allow formatting embedded JavaS-
cript

If checked, the JavaScript content embedded in XML will be formated when
the XML content is formated.

Content Completion

The Content Completion feature enables inline syntax lookup and Auto Completion of mark-up elements and attributes
to streamline mark-up and reduce errors while editing.

These settings define the operating mode of the content assistant.

The Content Completion preferences panel is opened from menu Options → Preferences+Editor+Content Completion
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Figure 18.20. The Content Completion preferences panel

Auto close the last opened tag If the Use Content Completion option is not checked and if this option is checked,
<oXygen/> will close the last opened tag when </ is typed.

Automatically rename matching tag If checked, <oXygen/> will automatically rename the matching end tag when
the start tag is modified in the editor.

Use Content Completion When unchecked, all Content Completion features are disabled.

Close the inserted element When inserting elements from the Content Completion assistant, both start and
end tags are inserted.

If it has no matching tag When checked, the end tag of the inserted element will be automatically added
only if it is not already present in the document.

Add element content When checked, <oXygen/> will insert automatically the required elements from
the DTD or XML Schema. This option is applied also in the Author mode of
the XML editor.

Add optional content When checked, <oXygen/> will insert automatically the optional elements from
the DTD or XML Schema. This option is applied also in the Author mode of
the XML editor.

Add first Choice particle When checked, <oXygen/> will insert automatically the first Choice particle
from the DTD or XML Schema. This option is applied also in the Author mode
of the XML editor.

Case sensitive search When it is checked the search in the content completion window when you type
a character is case sensitive ('a' and 'A' are different characters). This option is
applied also in the Author mode of the XML editor.
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Cursor position between tags When checked, <oXygen/> will set the cursor automatically between tags. Even
if the auto-inserted elements have attributes that are not required, the position
of cursor can be forced between tags.

Show all entities When checked, <oXygen/> will display a list with all the internal and external
entities declared in the current document when the user types the start character
of an entity reference (i.e. &).

Insert the required attributes When checked, <oXygen/> will insert automatically the required attributes from
the DTD or XML Schema for an element inserted with the help of the Content
Completion assistant. This option is applied also in the Author mode of the XML
editor.

Insert the fixed attributes When checked, <oXygen/> will insert automatically any FIXED attributes from
the DTD or XML Schema for an element inserted with the help of the Content
Completion assistant. This option is applied also in the Author mode of the XML
editor.

Show recently used items When checked, <oXygen/> will remember the last inserted items from the
Content Completion window. The number of items to be remembered is limited
by Maximum number of recent items shown combo box. These most frequently
used items are displayed on the top of Content Completion window and are
separated from the rest of the suggestions by a thin grey line. This option is ap-
plied also in the Author mode of the XML editor.

Maximum number of recent items
shown

Limits the number of recently used items presented at the top of the content
completion window. This option is applied also in the Author mode of the XML
editor.

Learn attributes values When checked, <oXygen/> will display a list with all attributes values learned
from the current document. This option is applied also in the Author mode of
the XML editor.

Learn on open document When checked, <oXygen/> will automatically learn the document structure
when the document is opened. This option is applied also in the Author mode
of the XML editor.

Learn words (Dynamic Abbrevi-
ations, available on CTRL+SPACE)

When checked, <oXygen/> will automatically learn the typed words and will
make them available in a Content Completion fashion by pressing
CTRL+SPACE.

Note

In order to be learned, the words need to be separated by space characters.

Annotations

The Annotations preferences panel is opened from menu Options → Preferences+Editor+Content Completion+Annota-
tions
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Figure 18.21. The Content Completion Annotations preferences panel

Show annotations When checked, <oXygen/> will display the annotations that are present in the
used schema for the current element, attribute or attribute value. This option is
applied also in the Author mode of the XML editor.

Show annotations as tooltip If checked, it shows the annotations of elements and attributes as tooltips. This
option is applied also in the Author mode of the XML editor.

Use DTD comments as annotation When checked, <oXygen/> will use all DTD comments as annotation.

Use all Relax NG annotations as
documentation

When checked any element that is not from the Relax NG namespace, that is
"http://relaxng.org/ns/structure/1.0" will be considered annotation and will be
displayed in the annotation window next to the content completion window and
in the Model View. When unchecked only elements from the Relax NG annota-
tions namespace, that is "http://relaxng.org/ns/compatibility/annotations/1.0"
will be considered annotation.

XPath

The XPath preferences panel is opened from menu Options → Preferences+Editor+Content Completion+XPath

Figure 18.22. The Content Completion XPath preferences panel

Enable content completion for XPath
expressions

Disables and enables content completion in XPath expressions entered in the
XSL attributes match, select and test and also in the XPath toolbar.

Options are available to allow the user to include XPath functions, XSLT func-
tions or axes in the content completion suggestion list.

The XPath section controls if the functions, axes are presented in the content completion list when editing XPath ex-
pressions.
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Show signatures of XSLT/XPath
functions

If checked, the editor will indicate in a tooltip helper the signature of the XPath
function located at the caret position.

Function signature window back-
ground

The background color of the tooltip window.

Function signature window fore-
ground

The foreground color of the tooltip window.

Colors

<oXygen/> supports Syntax Highlight for XML, JavaScript, PHP,CSS documents. While <oXygen/> provides a default
color configuration for highlighting the tokens, you may choose to customize, as required, using the Colors dialog.

The Colors preferences panel is opened from menu Options → Preferences+Editor+Colors

Figure 18.23. The Colors preferences panel

Open the Colors dialog by selecting Options->Preferences->Colors and choose one of the supported Document Types.
Each document type contains a set of Tokens. When a Document Type node is expanded, the associated tokens are
listed. Selecting a token displays the current color properties and enables you to modify them. You can also select a
token by clicking directly in the preview area on that type of token.

Use Swatches, HSB or RGB models from the Color dialog to define the color properties.

Modifications are saved when the OK button is clicked. Cancel discards changes. Reset button changes the color to
the default value.
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Swatches Displays a color palette containing a variety of colors from across the color spectrum and shades thereof.
Select a color.

HSB Hue, Saturation and Brightness (HSB) enables you to specify a color by describing it using hue, saturation
and brightness.

RGB Red, Green and Blue (RGB) enables you to specify a color using triplets of red, green and blue numbers.

Preview Displays the color properties of the current token and results of customization.

Syntax Highlight / Elements by Prefix

The Colors preferences panel is opened from menu Options → Preferences+Editor+Colors+Elements by Prefix

Figure 18.24. The Elements by Prefix preferences panel

One row of the table contains the association between a namespace prefix and the color used to mark start tags and
end tags in that prefix. Note that the marking mechanism does not look at the namespace bound to that prefix. If the
prefix is bound to different namespaces in different XML elements of the same file all the tags with the prefix will be
marked with the same color.

One can choose that only the prefix to be displayed in the chosen color by checking the Draw only the prefix with a
separate color option.

Open/Save

The Open/Save preferences panel is opened from menu Options → Preferences+Editor+Open/Save
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Figure 18.25. The Open/Save preferences panel

Format document when long lines
exceeds

Specifies the default behavior when the longest line of a document exceeds the
specified limit. You can choose between:

• Always format

• Never format

• Always ask

Characters limit for bidirectional text
documents

Specify the characters limit for bidirectional text documents.

Make backup copy on save If checked, a backup copy is made when saving the edited document. The default
extension is *bak, but you can change extension as you prefer.

Enable automatic save Automatic save is a useful feature that ensures your work is being saved in the
background. You can specify the time intervals between automatic saves. If
checked it enables Automatic Save. When unchecked, Automatic Save is dis-
abled.

Automatic save interval (minutes) Selects the period in minutes for Auto Save intervals.

Save all files before transformation
or validation

Save all opened files before validating or transforming an XML document. In
this way the dependencies are resolved, for example when modifying both the
XML document and its XML Schema.

Check errors on save If checked, a checking for errors is done when saving the edited document.
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Save all files before calling external
tools

If checked, all files will be saved before executing an external tool.

Clear undo buffer on save If checked, the undo action has no effect after you've saved your document. You
can only undo the modifications made after you've saved it.

Consider application bundles to be
directories when browsing

This option is available only on the Mac OS X platform. When checked the file
browser dialog allows browsing inside an application bundle as in a regular
folder. When unchecked the file browser dialog does not allow browsing inside
an application bundle, as the Finder application does on Mac OS X. The same
effect can be obtained by setting the property apple.awt.use-file-dialog-packages
to true or false in the Info.plist descriptor file of the <oXygen/> application
by adding two lines in this descriptor file:

<key>apple.awt.use-file-dialog-packages</key>
<string>false</string>

Code Templates

Code templates are small document fragments that can be reused in other editing sessions. <oXygen/> comes with a
large set of ready-to use templates for XSL and XML Schema. You can even share your code templates with your
colleagues using the Export and Import functions. To obtain the template list you have use the Content Completion
on request shortcut key (usually CTRL-SPACE).

The Code Templates preferences panel is opened from menu Options → Preferences+Editor+Templates+Code Templates

Figure 18.26. The Code Templates preferences panel

New Define a new code template.

You can define a code template for a specific type of editor or for all editor types.

498

Configuring the application



Edit Edit the selected code template.

Duplicate Duplicate the selected code template.

Delete Delete the selected code template.

Import Import a file with code templates.

Export Export a file with code templates.

Document Templates

The user can add template files in the templates folder of the <oXygen/> install directory. Directories to be scanned
for additional templates can also be specified in the Document Templates option page.

The Document Templates preferences panel is opened from menu Options → Preferences+Editor+Templates+Document
Templates

Figure 18.27. Document Templates preferences panel

Figure 18.28. Document Templates input dialog

Spell Check

The Spell Check preferences panel is opened from menu Options → Preferences+Editor+Spell Check
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Figure 18.29. Spell check preferences panel

Automatic Spell Check When checked, the spell checker is activated. Spell errors will be highlighted
as you type.

Spell check highlight color Use this option to set the color of the spell check errors.

Apply spell checking on whole docu-
ment

When checked, a spell check action will be performed on entire document,
highlighting all encountered errors.

Note

On large documents, spell checking the entire content may take a lot of
time.

Default language The default language combo allows you to choose the language used by default.

XML language attributes Options in this subsection control the way the attributes lang and xml:lang
change the language used for check spelling.

• Obey "lang" and "xml:lang" attributes - when checked the value of these
attributes is used as check spelling language inside the content of the element
where they are present.

• When these attributes are missing the language used is controlled by the
two radio buttons. The two options are to Use the default language or Do not
check the spelling.
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XML spell checking in These options allow the user to specify if the spell checker will be enabled inside
Comments, Attribute values, Text and CDATA sections.

Case sensitive When checked, operations ignore capitalization errors.

Ignore mixed case words When checked, operations do not check words containing case mixing (e.g.
"SpellChecker").

Ignore words with digits When checked, the Spell Checker does not check words containing digits (e.g.
"b2b").

Ignore Duplicates When checked, the Spell Checker does not signal two successive identical words
as an error.

Ignore URL When checked, ignores words looking like URL or file names (e.g.
"www.oxygenxml.com" or "c:\boot.ini") .

Check punctuation When checked, punctuation checking is enabled: misplaced white space and
wrong sequences, like a dot following a comma, are detected.

Enable auto replace Enables the "Replace Always" feature.

Allow compounds words When checked, all words formed by concatenating two legal words with an
hyphen are accepted. If the language allows it, two words concatenated without
hyphen are also accepted.

Allow general prefixes When checked, a word formed by concatenating a registered prefix and a legal
word is accepted. For example if "mini-" is a registered prefix, accepts "mini-
computer".

Allow file extensions When checked, accepts any word ending with registered file extensions (e.g.
"myfile.txt", "index.html" etc.).

Suggestion This option indicates the type of spell checker accuracy, which may be: "Favour
speed over quality", "Normal" and "Favour quality over speed".

Document Checking

The Document Checking preferences panel is opened from menu Options → Preferences+Editor+Document Checking

Figure 18.30. Document Checking preferences panel
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Validate as you type Validation of edited document is executed as the document is modified by
editing in <oXygen/>.

Delay after the last key event (s) The period of keyboard inactivity which starts a new validation (in seconds).

Maximum number of errors reported
per document

If there are many validation errors the process of marking them in the document
is long. You should limit the maximum number of reported errors with this setting
to keep the time for error marking short

Validation error highlight color The color used to mark validation errors in the document.

Validation warning highlight color The color used to mark validation warnings in the document.

Validation success color The color used to mark the success of the validation in the vertical ruler bar.

Always show validation status If this option is checked the line at the bottom of the editor panel which presents
the message of the current validation error is always visible. This is useful to
avoid scrolling problems when Validate as you type is enabled and the vertical
scroll bar may change position when the document is edited and the line with
the validation error message is made visible.

Custom Validation

The Custom Validation preferences panel is opened from menu Options → Preferences+Editor+Custom Validation

Figure 18.31. Custom Validation preferences panel

If you want to add a new custom validation tool or edit the properties of an exiting one you can use the Custom Valid-
ator dialog displayed by pressing New or Edit buttons.
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Figure 18.32. Custom validator dialog

Name The name of the custom validation tool displayed in the External Validation
toolbar

Executable path The path to the executable file of the external validation tool. You can insert
here editor variables like ${homeDir}, ${pd}, etc.

Working directory The working directory of the external validation tool. The following editor
variables can be used:

${homeDir} The path to user home directory

${pd} Project directory

${oxygenInstallDir} <oXygen/> installation directory

Associated editors The editors which can perform validation with the external tool.

Command line arguments for detec-
ted schemas

Command line arguments used to validate the current edited file against different
types of schema (W3C XML Schema, Relax NG full syntax, Relax NG compact
syntax, Namespace Routing Language, Schematron, DTD, other schema type).
The arguments can include any custom switch (like -rng) and the editor variables:

${cf} The path of the currently edited file

${cfu} Path of current file (URL)

${ds} The path of detected schema file
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${dsu} The path of detected schema file (URL)

CSS Validator
The CSS Validator preferences panel is opened from menu Options → Preferences+CSS Validator

Figure 18.33. CSS Validator preferences panel

Profile Choose one of the available validation profiles: CSS 1, CSS 2, CSS 2.1, CSS 3, SVG, SVG Basic,
SVG Tiny, Mobile, TV Profile, ATSC TV Profile

Media Type Choose one of the available mediums: all, aural, braille, embossed, handheld, print, projection,
screen

Warning Level Set the minimum severity level for reported validation warnings. It is one of: all, normal, most
important, no warnings.

XML

XML Catalog

The XML Catalog preferences panel is opened from menu Options → Preferences+XML+XML Catalog

Figure 18.34. The XML Catalog preferences panel

The Prefer option is used to specify if <oXygen/> will try to resolve first the PUBLIC or SYSTEM reference using
the specified XML catalogs. If a PUBLIC reference is not mapped in any of the catalogs then a SYSTEM reference is
looked up.
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When using catalogs it is sometimes useful to see what catalog files are parsed, if they are valid or not, and what
identifiers are resolved by the catalogs. The Verbosity option selects the detail level of such messages of the catalog
resolver that will be displayed in the Catalogs view at the bottom of the window:

None No message is displayed by the catalog resolver when it tries to resolve a URI reference
with the XML catalogs set in the application.

Unresolved entities Only the messages that track the failed attempts to resolve URI references are displayed.

All messages The messages of both failed attempts and successful ones are displayed.

If the Use default catalog option is checked the first XML catalog which <oXygen/> will use to resolve system IDs at
document validation and URI references at document transformation will be a default built-in catalog which maps such
references to the built-in local copies of the local DocBook and TEI frameworks and the schemas for XHTML, SVG
and JSP documents.

You can also add or configure catalogs for each of the defined document types from Document Type Association
preferences page.

When you add/delete or edit an XML catalog to/from the list you must sometimes reopen the current edited files which
use the modified catalog so that the changes take full effect.

XML Parser

The XML Parser preferences panel is opened from menu Options → Preferences+XML+XML Parser

Figure 18.35. The XML Parser preferences panel
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http://apache.org/xml/features/valid-
ation/schema-full-checking

This option sets the 'schema-full-checking' feature to true.

http://apache.org/xml/features/hon-
our-all-schema-location

This option sets the 'honour-all-schema-location' feature to true. This means all
the schemas that are imported for a specific namespace are used to compose the
validation model. If this is false, only the first schema import is taken into ac-
count.

Ignore the DTD for validation if a
schema is specified

This option forces validation against a referred schema (XML Schema, Relax
NG schema, Schematron schema) even if the document includes also a DTD
declaration. It is useful when the DTD declaration is used to declare entities and
the schema reference is used for validation.

Enable XInclude processing Enable XInclude processing - if checked the XInclude support in <oXygen/> is
turned on.

Base URI fix-up [Xerces XML Parser documentation:] According to the specification for XIn-
clude, processors must add an xml:base attribute to elements included from
locations with a different base URI. Without these attributes, the resulting infoset
information would be incorrect.

Unfortunately, these attributes make XInclude processing not transparent to
Schema validation.

One solution to this is to modify your schema to allow xml:base attributes to
appear on elements that might be included from different base URIs.

If the addition of xml:base and/or xml:lang is undesired by your application,
you can disable base URI fix-up.

Language fix-up [Xerces XML Parser documentation:]The processor will preserve language in-
formation on a top-level included element by adding an xml:lang attribute if its
include parent has a different [language] property.

If the addition of xml:lang is undesired by your application, you can disable the
Language fix-up.

Check ID/IDREF Checks the ID/IDREF matches when the Relax NG document is validated.

Check feasibly valid Checks the Relax NG to be feasibly valid when this document is validated.

Schematron XPath Version 1.0 - Allows XSLT 1.0 expressions for Schematron 1.5 assertion tests.

2.0 - Allows XSLT 2.0 expressions for Schematron 1.5 assertion tests.

Optimize (visit-no-attributes) If your ISO Schematron assertion tests do not contain the attributes axis you
should check this option for faster ISO Schematron validation.

Allow foreign elements (allow-for-
eign)

Enable support for allow-foreign on ISO Schematron. Used to pass non-
Schematron elements to the generated stylesheet.

Use Saxon SA (schema aware) for
xslt2 query binding

If checked, Saxon SA will be used for xslt2 query binding.
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Saxon SA Validation

The Saxon SA Validation preferences panel is opened from menu Options → Preferences+XML+XML Parser+Saxon
SA Validation

Figure 18.36. The Saxon SA preferences panel

XML Schema version 1.0 The validation of XML Schema schemas is done according to the W3C XML
Schema 1.0 specification.

XML Schema version 1.1 The validation of XML Schema schemas is done according to the W3C XML
Schema 1.1 specification.

XSLT/FO/XQuery

The XSLT/FO/XQuery preferences panel is opened from menu Options → Preferences+XML+XSLT/FO/XQuery

Figure 18.37. The XSLT/FO/XQuery preferences panel

Check the option Create transformation temporary files in system temporary directory when creating transformation
temporary files in the same folder as the source of the transformation breaks the transformation, for example the
transformation processes all the files located in the same folder as the source of the transformation, which will include
the temporary files, which you probably do not want.

XSLT

The XSLT preferences panel is opened from menu Options → Preferences+XML+XSLT/FO/XQuery+XSLT

Figure 18.38. The XSLT preferences panel

507

Configuring the application



If you want to use an XSLT transformer different than the ones that ship with <oXygen/> namely Apache Xalan and
Saxon all you have to do is to specify the name of the transformer's factory class which <oXygen/> will set as the value
of the Java property "javax.xml.transform.TransformerFactory". To perform an XSLT transformation with Saxon 7
for instance you have to place the Saxon 7 jar file in the <oXygen/> libraries directory (the lib subdirectory of the in-
stallation directory), set "net.sf.saxon.TransformerFactoryImpl" as the property value and select JAXP as the XSLT
processor in the transformation scenario associated to the transformed XML document.

Value Allows the user to enter the name of the transformer factory Java class.

XSLT 1.0 Validate with Allows the user to set the XSLT Engine used for validation of XSL 1.0 documents.

XSLT 2.0 Validate with Allows the user to set the XSLT Engine used for validation of XSL 2.0 documents.

Saxon6

The Saxon 6 preferences panel is opened from menu Options → Preferences+XML+XSLT/FO/XQuery+XSLT+Sax-
on+Saxon 6

Figure 18.39. The Saxon 6 XSLT preferences panel

• Line numbering: If checked line numbers are maintained for the source document.

• Allow calls on extension functions: If checked external functions called is allowed. Not checking this is recommended
in an environment where untrusted stylesheets may be executed. Also disables user-defined extension elements, to-
gether with the writing of multiple output files, all of which carry similar security risks.

• Policy for handling recoverable errors in the stylesheet: Allows the user to choose how dynamic errors will be
handled. Either one of the following options can be selected: recover silently, recover with warnings or signal the
error and do not attempt recovery.

Saxon-B/SA

The Saxon-B/SA preferences panel is opened from menu Options → Preferences+XML+XSLT/FO/XQuery+XSLT+Sax-
on+Saxon-B/SA

The XSLT options which can be configured for the Saxon 9 transformer (both the Basic and the Schema Aware versions)
are:

508

Configuring the application



Figure 18.40. The Saxon-B/SA XSLT preferences panel

• Version warnings: If checked a warning will be output when running an XSLT 2.0 processor against an XSLT 1.0
stylesheet. The XSLT specification requires this to be done by default.

• Allow calls on extension functions: If checked external functions called is allowed. Not checking this is recommended
in an environment where untrusted stylesheets may be executed. Also disables user-defined extension elements, to-
gether with the writing of multiple output files, all of which carry similar security risks.

• DTD based validation of the source file: If checked XML source documents are validated against their DTD.

• Line numbering: If checked line numbers are maintained for the source document.

• Policy for handling recoverable errors in the stylesheet: Allows the user to choose how dynamic errors will be
handled. Either one of the following options can be selected: recover silently, recover with warnings or signal the
error and do not attempt recovery.

• Strip whitespaces feature can be one of the three options: All, Ignorable, None.

All strips all whitespace text nodes from source documents before any further processing, regardless of
any xsl:strip-space declarations in the stylesheet, or any xml:space attributes in the source document.

Ignorable strips all ignorable whitespace text nodes from source documents before any further processing, re-
gardless of any xsl:strip-space declarations in the stylesheet, or any xml:space attributes in the source
document. Whitespace text nodes are ignorable if they appear in elements defined in the DTD or
schema as having element-only content.
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None strips no whitespace before further processing. (However, whitespace will still be stripped if this is
specified in the stylesheet using xsl:strip-space).

Saxon9SA specific options

• Schema based validation of the source file: This determines whether source documents should be parsed with schema-
validation enabled.

• Lax schema based validation of the source file: This determines whether source documents should be parsed with
schema-validation enabled.

• Validation errors in the result tree treated as warnings: If checked, all validation errors are treated as warnings, oth-
erwise they are treated as fatal.

Saxon-B/SA Advanced options

The Saxon-B/SA Advanced preferences panel is opened from menu Options → Prefer-
ences+XML+XSLT/FO/XQuery+XSLT+Saxon+Saxon-B/SA+Advanced

The advanced XSLT options which can be configured for the Saxon 9 transformer (both the Basic and the Schema
Aware versions) are:

Figure 18.41. The Saxon-B/SA XSLT Advanced preferences panel

• URI Resolver class name: Allows the user to specify a custom implementation for the URI resolver used by the
XSLT Saxon 9 transformer ("-r" option when run from the command line). The class name must be fully specified
and the corresponding jar or class extension must be configured from the dialog for configuring the XSLT extension
for the particular scenario

• Collection URI Resolver class name: Allows the user to specify a custom implementation for the Collection URI
resolver used by the XSLT Saxon 9 transformer ("-cr" option when run from the command line). The class name
must be fully specified and the corresponding jar or class extension must be configured from the dialog for config-
uring the XSLT extension for the particular scenario

XSLTProc

The XSLTProc preferences panel is opened from menu Options → Preferences+XML+XSLT/FO/XQuery+XSLT+XSLT-
Proc
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Figure 18.42. The XSLTProc preferences panel

The options of the XSLTProc processor are the same as the ones available in the command line for the XSLTProc
processor:

Enable XInclude processing If checked XInclude references will be resolved when XSLTProc is used as
transformer in the transformation scenario.

Skip loading the document's DTD If checked the DTD specified in the DOCTYPE declaration will not be loaded.

Do not apply default attributes from
document's DTD

If checked the default attributes declared in the DTD and not specified in the
document are not included in the transformed document.

Do not use Internet to fetch DTD's,
entities or docs

If checked the remote references to DTD's and entities are not followed.

Maximum depth in templates stack If the limit of maximum templates is reached the transformation ends with an
error.

Verbosity If checked the transformation will output detailed status messages about the
transformation process in the Warnings view.

Show version of libxml and libxslt
used

If checked <oXygen/> will display in the Warnings view the version of the
libxml and libxslt libraries invoked by XSLTProc.

Show time information If checked the Warnings view will display the time necessary for running the
transformation.

Show debug information If checked the Warnings view will display debug information about what tem-
plates are matched, parameter values, etc.
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Show all documents loaded during
processing

If checked <oXygen/> will display in the Warnings view the URL of all the
files loaded during transformation.

Show profile information If checked <oXygen/> will display in the Warnings view a table with all the
matched templates, and for each template: the match XPath expression, template
name, number of template modes, number of calls, execution time.

Show the list of registered extensions If checked <oXygen/> will display in the Warnings view a list with all the re-
gistered extension functions, extension elements and extension modules.

Refuses to write to any file or re-
source

If checked the XSLTProc processor will not write any part of the transformation
result to an external file on disk. If such an operation is requested by the pro-
cessed XSLT stylesheet the transformation ends with a runtime error.

Refuses to create directories If checked the XSLTProc processor will not create any directory during the
transformation process. If such an operation is requested by the processed XSLT
stylesheet the transformation ends with a runtime error.

MSXML

The MSXML preferences panel  is  opened from menu Options →  Prefer-
ences+XML+XSLT/FO/XQuery+XSLT+MSXML

Figure 18.43. The MSXML preferences panel

The options of the MSXML 3.0 and 4.0 processors are the same as  the ones available in the command line for the
MSXML processors: [http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnxml/html/msxsl.asp]

Validate documents during parse
phase

If checked and either the source or style sheet document has a DTD or schema
against which its content should be checked, validation is performed.

Do not resolve external definitions
during parse phase

By default, MSXSL instructs the parser to resolve external definitions such as
document type definition (DTD), external subsets or external entity references
when parsing the source and style sheet documents. If this option is checked the
resolution is disabled.

Strip non-significant whitespaces If checked strip non-significant white space from the input XML document
during the load phase. Enabling this option can lower memory usage and improve
transformation performance while, in most cases, creating equivalent output.

Show time information If checked the relative speed of various transformation steps can be measured:
time to load, parse, and build the input document; time to load, parse, and build
the style sheet document; time to compile the style sheet in preparation for the
transformation; time to execute the style sheet.
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Start transformation in this mode Although style sheet execution usually begins in the empty mode, this default
may be changed by specifying another mode. Changing the start mode allows
execution to jump directly to an alternate group of templates.

MSXML.NET

The MSXML.NET preferences panel is opened from menu Options → Prefer-
ences+XML+XSLT/FO/XQuery+XSLT+MSXML.NET

Figure 18.44. The MSXML.NET preferences panel

The options of the MSXML.NET processor are the same as  the ones available in the command line for the MSXML.NET
processor: [http://www.xmllab.net/Products/nxslt/tabid/62/Default.aspx]

Enable XInclude processing If checked XInclude references will be resolved when MSXML.NET is used as
transformer in the transformation scenario.

Validate documents during parse
phase

If checked and either the source or style sheet document has a DTD or schema
against which its content should be checked, validation is performed.

Do not resolve external definitions
during parse phase

By default MSXML.NET resolves external definitions such as DTD external
subsets or external entity references when parsing source XML document and
stylesheet document. Using this option you can disable this behaviour. (Note,
that it may affect also the validation process.)

Strip non-significant whitespaces If checked strip non-significant white space from the input XML document
during the load phase. Enabling this option can lower memory usage and improve
transformation performance while, in most cases, creating equivalent output.

Show time information If checked the relative speed of various transformation steps can be measured:
time to load, parse, and build the input document; time to load, parse, and build
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the style sheet document; time to compile the style sheet in preparation for the
transformation; time to execute the style sheet.

Forces ASCII output encoding There is a known problem with .NET 1.X XSLT processor (Sys-
tem.Xml.Xsl.XslTransform class) - it doesn't support escaping of characters as
XML character references when they cannot be represented in the output encod-
ing. That means that when you output a character that cannot be represented in
output encoding, it will be outputted as '?'. Usually this happens when output
encoding is set to ASCII. With this option checked the output is forced to be
ASCII encoded and all non-ASCII characters get escaped as XML character
references (&#nnnn; form).

Allow multiple output documents This option allows to create multiple result documents using  the exsl:docu-
m e n t  e x t e n s i o n  e l e m e n t .
[http://www.exslt.org/exsl/elements/document/index.html]

Use named URI resolver class This option allows to specify a custom URI resolver class to resolve URI refer-
ences in xsl:import/xsl:include instructions (during XSLT stylesheet loading
phase) and in document() function (during XSL transformation phase).

Assembly file name for URI resolver
class

The previous option specifies partially or fully qualified URI resolver class
name, e.g. Acme.Resolvers.CacheResolver. Such name requires addi-
tional assembly specification using this option or the next option, but fully
qualified class name (which always includes an assembly specifier) is all-suffi-
cient. See MSDN for more info about  fully qualified class names.
[http://msdn.microsoft.com/library/default.asp?url=/library/en-us/cpguide/html/
cpconspecifyingfullyqualifiedtypenames.asp] This option specifies a file name
of the assembly, where the specified resolver class can be found.

Assembly GAC name for URI resolv-
er class

This option specifies partially or fully qualified name of the assembly in the
g l o b a l  a s s e m b l y  c a c h e
[http://msdn.microsoft.com/library/default.asp?url=/library/en-us/cpguide/html/
cpconglobalassemblycache.asp] (GAC), where the specified resolver class can
be found. See MSDN for more info about  partial assembly names.
[http://msdn.microsoft.com/library/default.asp?url=/library/en-us/cpguide/html/
cpconpartialassemblyreferences.asp] Also see the previous option.

List of extension object class names This  opt ion a l lows to  speci fy   extens ion object
[http://msdn.microsoft.com/library/default.asp?url=/library/en-us/cpguide/html/
cpconxsltargumentlistforstylesheetparametersextensionobjects.asp] classes,
whose public methods then can be used as extension functions in an XSLT
stylesheet. It is a comma-separated list of namespace-qualified extension object
class names. Each class name must be bound to a namespace URI using prefixes
a s   w h e n  p r o v i d i n g  X S L T  p a r a m e t e r s .
[http://www.xmllab.net/Products/nxslt/tabid/62/Default.aspx#parameters]

Use specified EXSLT assembly MSXML.NET supports rich library of the EXSLT [http://www.exslt.org/] and
EXSLT.NET [http://www.xmllab.net/exslt] extension functions via embedded
or plugged in EXSLT.NET [http://workspaces.gotdotnet.com/exslt] library.
EXSLT support is enabled by default and cannot be disabled in this version. If
you want to use an external EXSLT.NET implementation instead of a built-in
one use this option.
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Credential loading source xml This option allows to specify user credentials to be used when loading XML
source documents. The credentials should be provided in the "username:pass-
word@domain" format (all parts are optional).

Credential loading stylesheet This option allows to specify user credentials to be used when loading XSLT
stylesheet documents. The credentials should be provided in the "username:pass-
word@domain" format (all parts are optional).

FO Processors

Besides the built-in formatting objects processor (Apache FOP) the user can use other external processors. <oXygen/>
has implemented an easy way to add RenderX XEP as external FO processor if the user has the XEP installed.

The FO Processors preferences panel is opened from menu Options → Preferences+XML+XSLT/FO/XQuery+FO
Processors

Figure 18.45. The FO Processors preferences panel

Enable the output of the built-in FOP When checked all FOP output will be displayed in a results pane at the bottom
of the editor window including warning messages about FO instructions not
supported by FOP.

Memory available to the built-in FOP If your FOP transformations fail with an "Out of Memory" error select from this
combo box a larger value for the amount of memory reserved for FOP transform-
ations.

Configuration file for the built-in
FOP

You should specify here the path to a FOP configuration file, necessary for ex-
ample to render to PDF using a special true type font a document containing
Unicode content.

The built-in FOP generates PDF/A-
1b output

When selected PDF/A-1b output is generated.
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Note

All fonts have to be embedded, even the implicit ones. More information
about configuring metrics files for the embedded fonts can be found in
Add a font to the built-in FOP.

Note

You cannot use the <filterList> key in the configuration file. FOP
will generate the following error: The Filter key is prohibited when PDF/A-
1 is active.

The users can configure the external processors for use with <oXygen/> in the following dialog.

Figure 18.46. The external FO processor configuration dialog

Name The name that will be displayed in the list of available FOP processors on the FOP tab of
the Transforming Configuration dialog.

Description The description of the FO processor displayed in the Preferences->FO Processors option.

Output Encoding The encoding used for the output stream of the FO processor which will be displayed in
a results panel at the bottom of the <oXygen/> window.

Error Encoding The encoding used for the error stream of the FO processor which will be displayed in a
results panel at the bottom of the <oXygen/> window.

Working directory The directory in which the intermediate and final results of the processing will be stored.
Here you can use one of the following editor variables:
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${homeDir} The path to user home directory.

${cfd} The path of current file directory. If the current file
is not a local file the directory will be the user's
Desktop directory.

${pd} The project directory.

${oxygenInstallDir} The <oXygen/> installation directory.

Command line The command line that will start the FO processor, specific to each processor. Here you
can use one of the following editor variables:

${method} The FOP transformation method (pdf, ps, txt).

${fo} The input FO file.

${out} The output file.

${pd} The project directory.

${frameworksDir} The path of the frameworks subdirectory of the
<oXygen/> install directory.

${oxygenInstallDir} The <oXygen/> installation directory.

${ps} The separator which can be used on different oper-
ating systems between libraries specified in the class
path.

XPath

The XPath preferences panel is opened from menu Options → Preferences+XML+XSLT/FO/XQuery+XPath
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Figure 18.47. The XPath preferences panel

Unescape XPath expression When checked, unescapes the entities found in the XPath expression. For example
the expression

//varlistentry[starts-with(@os,'&#x73;')]

is equivalent with

//varlistentry[starts-with(@os,'s')]

.

Multiple XPath results When checked, results of different XPath expressions executed on the same file
are written in separate result set tabs.

No namespace If checked <oXygen/> will consider unprefixed element names in XPath expres-
sions evaluated in the XPath console as belonging to no namespace.

Use the default namespace from the
root element

If checked <oXygen/> will consider unprefixed element names in XPath expres-
sions evaluated in the XPath console as belonging to the default namespace de-
clared on the root element of the document.

Use the namespace of the root If checked <oXygen/> will consider unprefixed element names in XPath expres-
sions evaluated in the XPath console as belonging to the same namespace as
the root element of the document.

This namespace The user has the possibility to enter here the namespace of the unprefixed ele-
ments used in the XPath console
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Default prefix-namespace mappings Associates prefixes to namespaces. These mappings are useful when applying
an XPath in XPath console and you don't have to define these mappings for each
document separately.

The New button creates an editable prefix-namespace mapping.

The Delete button deletes the selected mapping.

Custom Engines

One can configure transformation engines other than the ones which come with the <oXygen/> distribution. Such an
external engine can be used for XSLT / XQuery transformations within <oXygen/>, in the Editor perspective, and is
available in the list of engines in the dialog for editing transformation scenarios.

The Custom Engines preferences panel is opened from menu Options → Preferences+XML+XSLT/FO/XQuery+Custom
Engines

Figure 18.48. Configuration of custom transformation engines

The following parameters can be configured for a custom engine:
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Figure 18.49. Parameters of a custom transformation engine

Engine type Combo box allowing you to choose the transformer type. There are two options: XSLT
engines and XQuery engines.

Name The name of the transformer displayed in the dialog for editing transformation scenarios

Description Text description of the transformer

Output Encoding The encoding of the characters sent to the output stream of the transformer

Error Encoding The encoding of the characters sent to the error stream of the transformer

Working directory The start directory of the transformer executable program. The following editor variables
are available for making the path to the working directory independent of the input XML
file:

• ${homeDir} - the user home directory in the operating system

• ${cfd} - the path to the directory of the current file

• ${pd} - the path to the directory of the current project

• ${oxygenInstallDir} - the <oXygen/> install directory

Command line The command line that must be executed by <oXygen/> to perform a transformation with
the engine. The following editor variables are available for making the items of the com-
mand line (the transformer executable, the input files) independent of the input XML file:

• ${xml} - the XML input document as a file path
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• ${xmlu} - the XML input document as a URL

• ${xsl} - the XSL / XQuery input document as a file path

• ${xslu} - the XSL / XQuery input document as a URL

• ${out} - the output document as a file path

• ${outu} - the output document as a URL

• ${ps} - the separator which can be used on different operating systems between libraries
specified in the class path.

Data Sources
The Data Sources preferences panel is opened from menu Options → Preferences+Data Sources

Configuration of Data Sources

Here you can configure data sources and connections to relational databases as well as native XML databases. You
can check the list of drivers (http://www.oxygenxml.com/database_drivers.html) available for the major database
servers.

Figure 18.50. The Data Sources preferences panel

New Opens the Data Sources Drivers dialog, allowing you to configure a new driver.
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Figure 18.51. The Data Sources Drivers dialog

Name Allows you to name the new data source driver.

Type Select data source type from the supported driver types.

Help Open the User Manual at the list of the sections where the configuration of supported
data sources is explained and the URLs for downloading the database drivers are spe-
cified.

Driver Class Provide the Driver Class for the data source driver

Add Adds the driver class library.

Remove Removes driver class library from the list.

Detect Detects driver candidates.

Stop Stops the detection of the driver candidates.

Edit Opens the Data Sources Drivers dialog, allowing you to edit the selected driver. See above the specifications
for the Data Sources Drivers dialog (in order to edit a data source , there must be no connections using that
data source driver).

Delete Deletes the selected Data Source Driver (in order to delete a data source , there must be no connections
using that data source driver).
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Figure 18.52. The Connections preferences panel

Note

Checked connections will be visible in the Database Explorer View.

For performance issues, you can set the maximum number of cells that will be displayed in the Table Explorer view.
Leave the field Limit the number of cells empty if you want the entire content of the table to be displayed. By default
this field is set to 2,000. If a table having more cells than the value set here is displayed in the Table Explorer view, a
warning dialog will inform you that the table is only partially shown.

In Oracle XML and Tamino databases a container can hold millions of resources. If the node corresponding to such a
container in the Database Explorer view would display all the contained resources at the same time the performance
of the view would be very slow. To prevent such a situation only a limited number of the contained resources is displayed
as child nodes of the container node. Navigation to other contained resources from the same container is enabled by
the Up and Down buttons of the Database Explorer view. This limited number is set in the option Maximum number
of children for container nodes. The default value is 200 nodes.

New Opens the Connection dialog.
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Figure 18.53. The Connection dialog

Name Allows you to name the new connection.

Data Source Select data source defined in the Data Source Drivers dialog.

Depending upon the selected Data Source, you can set some of the following parameters in the Connection
details area:

URL: The URL used to connect.

User: Provide the database user .

Password: Provide the database password.

Host: Provide the host address.

Port: Provide a port to connect.

XML DB URI: Provide the database URI to connect.

Database: Provide the initial database.

Collection: Select one of the available collections for the specified data source.

Environment home directory: Specify the home directory for a Berkeley database.

Verbosity: Set the verbosity level for a Berkeley database.

Edit Opens the Connection dialog, allowing you to edit the selected connection. See above the specifications
for the Connection dialog.

Delete Deletes the selected connection.
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Download links for database drivers

You can find below the locations where you have to go to get the drivers necessary for accessing databases in <oXygen/>

Berkeley DB XML database Copy the jar files from the Berkeley database install directory to the <oXygen/>
install directory as described in the procedure for configuring a Berkeley DB
data source.

IBM DB2 Pure XML database Go to the IBM website: http://www-306.ibm.com/software/data/db2/ex-
p r e s s / d o w n l o a d . h t m l
[http://www-306.ibm.com/software/data/db2/express/download.html], in the
DB2 Clients and Development Tools category select the DB2 Driver for JDBC
and SQLJ download link, fill the download form and download the zip file.
Unzip the zip file and use the db2jcc.jar and db2jcc_license_cu.jar files in
<oXygen/> for configuring a DB2 data source.

eXist database Copy the jar files from the eXist database install directory to the <oXygen/>
install directory as described in the procedure for configuring an eXist data
source.

MarkLogic database Download Java and .NET XCC distributions (XCC Connectivity Packages)
from http://xqzone.marklogic.com/download/#XCC. Details about configuring
a MarkLogic data source are here.

Microsoft SQL Server 2005 / 2008
database

Both SQL Server 2005 and SQL Server 2008 are supported. Download the SQL
Server 2005 JDBC driver called sqljdbc.jar from the Microsoft website:
http://www.microsoft.com/downloads/details.aspx?familyid=C47053EB-3B64-
4794-950D-81E1EC91C1BA&displaylang=en and use it for configuring an
SQL Server data source. Download the SQL Server 2008 JDBC driver called
sqljdbc4.jar from the Microsoft website: http://www.microsoft.com/down-
loads/details.aspx?familyid=f914793a-6fb4-475f-9537-b8fcb776befd&display-
lang=en and use it for configuring an SQL Server data source.

Oracle 11g database Download the Oracle 11g JDBC driver called ojdbc5.jar from the Oracle website:
http://www.oracle.com/technology/software/tech/java/sqlj_jdbc/htdocs/jd-
bc_111060.html  [http://www.oracle.com/technology/software/tech/
java/sqlj_jdbc/htdocs/jdbc_111060.html] and use it for configuring an Oracle
data source.

PostgreSQL 8.3 database Download the PostgreSQL 8.3 JDBC driver called postgresql-8.3-603.jdbc3.jar
from the PostgreSQL website: http://jdbc.postgresql.org/download.html and use
it for configuring a PostgreSQL data source.

RainingData TigerLogic XDMS
database

Copy the jar files from the TigerLogic JDK lib directory from the server side
to the <oXygen/> install directory as described in the procedure for configuring
a TigerLogic data source.

SoftwareAG Tamino database Copy the jar files from the SDK\TaminoAPI4J\lib subdirectory of the Tamino
database install directory to the <oXygen/> install directory as described in the
procedure for configuring a Tamino data source.

Documentum xDb (X-Hive/DB)
XML database

Copy the jar files from the Documentum xDb (X-Hive/DB) database install
directory to the <oXygen/> install directory as described in the procedure for
configuring an XHive data source.
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MySQL database A MySQL driver file is included in the Oxygen kit. The installer creates the file
mysql.jar in the folder [Oxygen-install-folder]/lib. When creating
a new data source select the type Generic JDBC and add the file [Oxygen-
install-folder]/lib/mysql.jar in Driver files. If you want to connect
to a MySQL 5 server you may need the latest driver from the MySQL website:
http://dev.mysql.com/downloads/connector/j/5.1.html

Table Filters

The Table Filters preferences panel is opened from menu Options → Preferences+Data Sources+Table Filters

Here you can choose which of the table types will be displayed in the Database Explorer view.

Figure 18.54. Table Filters Preferences Page

Note

Table types filtering depends on the driver implementation.

Diff
<oXygen/> offers both directory and file comparison, six different diff algorithms to choose from for file comparison
and multiple levels of comparison.

The complete diff solution includes two XML diff algorithms (XML Fast and XML Accurate), one Syntax Aware al-
gorithm that gives very good results on all file types known by <oXygen/> and three all-purpose algorithms: line based,
word based and character based. Any algorithm can be used to perform differences on request, but <oXygen/> offers
also an automatic selection of the algorithm, selecting the most appropriate one based on the files' content and size.

The Diff preferences panel is opened from menu Options → Preferences+Diff
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Figure 18.55. The Diff preferences panel

Perform diff with <oXygen/> If enabled <oXygen/>'s Diff tool will be used for all diff operations performed
on XML documents. Disabling this option will disable <oXygen/>'s Diff tool

Default algorithm Select from the list the algorithm that will be used as default when you open the
Compare files dialog

• Auto makes an automatic selection of the diff algorithm, based on the files'
content and size.

• Characters computes the differences at character level.

• Words computes the differences at word level..

• Lines computes the differences at line level.

• Syntax aware : for the file types known by <oXygen/>, this algorithm com-
putes the differences taking into consideration the syntax of the documents.

• XML Fast is designed for XML documents. It works better than XML Accurate
on large files, but it is less precise.

• XML Accurate is designed for XML documents. It works best on smaller
XML files and it is most precise.
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Note

XML Fast and XML Accurate work for XML documents. If you'll try to use them for other types of files, you'll
be prompted with the message "content not allowed in prolog"

Ignore whitespaces This option, if checked, allows the diff algorithm to ignore the whitespaces. Ig-
noring whitespace means that before the strings are compared they are first
normalized and then the whitespace at the beginning and the end of the strings
is trimmed.

LCS - Maximum number of differ-
ences

This option allows you to specify the maximum number of differences between
your documents that you might be interested to see (using the Longest Common
Subsequence Algorithm). If the number of differences is larger than the one
specified here, you'll be notified by the message "Too many differences".

XML Diff Options This set of options allows you to specify the types of differences that will be
ignored in the XML Fast and XML Accurate algorithms:

• in node / type:

• Processing instructions

• Comments

• CDATA

• DOCTYPE

• Text

• in namespaces / prefixes

• Namespaces

• Prefixes

• Namespace declarations

• in the attributes order

Merge adjacent differences If checked, it considers adjacent differences as one and they are presented in
this way in the side-by-side editors. If unchecked, every difference is represented
separately.

Mark end tags as different for modi-
fied elements

If checked, end tags of modified elements are presented as differences.

Ignore expansion state for empty
elements

If checked, empty elements in both expansion states are considered matched.

For the directories comparison you can specify the criterion for the component files comparison and a default file filter.

Look in archives: If checked, the Diff directories comparator will treat archives known by <oXygen/> as
directories and show differences also between files inside them.

Compare files by: Content•
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• Timestamp (last modified date/time)

Default file filter specifies the file filter that is set by default in the File filter combo box of the Compare
Directories window each time this window is opened from the Tools menu.

Diff Appearance
The Diff Appearance preferences panel is opened from menu Options → Preferences+Diff+Appearance

Figure 18.56. The Diff appearance preferences panel

Line wrap If checked the lines presented in the two diff panels are wrapped at the right margin of each
panel so that no horizontal scrollbar is necessary.

Incoming color The color used for incoming changes on the vertical bar that shows the differences between
the files compared.

Outgoing color The color used for outgoing changes on the vertical bar that shows the differences between the
files compared.

Conflict color The color used for conflicts on the vertical bar that shows the differences between the files
compared.

Archive
The Archive preferences panel is opened from menu Options → Preferences+Archive
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Figure 18.57. The Archive preferences panel

The following options are available in the Archive preferences page:

The following archive backup op-
tions are considered default options

No backup Perform no backup of the archive before save.
This means that the file will be saved directly in
the archive without any additional precautions.for backup in the Archive Backup

dialog.
Single file backup Before any operation which modifies the archive

is performed, the archive contents will be duplic-
ated. The duplicate file name will be origin-
alArchiveFileName.bak and will be saved
in the same directory.

Incremental backup Before each operation which modifies the archive
is performed, the archive contents will be duplic-
ated. The duplicate file names will be origin-
alArchiveFileName.bak#dupNo and the
files will be saved in the same directory.

Archive types table This table contains all known archive extensions mapped to known archive
formats. You can edit the table to modify existing mappings or add your own
extensions to the list of known archive extensions.

Figure 18.58. Edit the Archive extension mappings

You can map a list of extensions to an archive type supported in <oXygen/>.
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Important

You have to restart <oXygen/> after removing an extension from the table
in order for that extension to not be recognised anymore as an archive
extension.

Plugins
<oXygen/> provides the ability to add plugins that extend the functionality of the application. The plugins are shipped
as separate packages; check for new plugins on <oXygen/> site: http://www.oxygenxml.com.

One plugin consists of a separate sub-folder in the Plugins folder in the <oXygen/> installation folder. This sub-folder
must contain a valid plugin.xml in accordance with the plugin.dtd file from the Plugins folder.

<oXygen/> automatically detects and loads plugins correctly installed in the Plugins folder and displays them in the
Plugin option from the Preferences dialog.

The Plugins preferences panel is opened from menu Options → Preferences+Plugins

Figure 18.59. The Plugins preferences panel

A short description of the plugin can be obtained with a click on the plugin name.

External Tools
The External Tools preferences panel is opened from menu Options → Preferences+External Tools

The user can run within <oXygen/> other tools as if from the command line of the operating system shell. The config-
uration of such a tool is done in the following dialog.
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Figure 18.60. The external tools configuration dialog

Name The name of the menu entry corresponding to this tool that will be displayed in the External
Tools menu and in the external tools combo box on the toolbar.

Description The description of the tool displayed in the Preferences->External Tools option.

Output Encoding The encoding that <oXygen/> uses to read the output stream data of the external tool.

Error Encoding The encoding that <oXygen/> uses to read the error stream data of the external tool.

Shortcut key The keyboard shortcut that launches the external tool.

Working directory The directory the external tool will use to store intermediate and final results. Here you
can use one of the following editor variables:

${homeDir} The path to user home directory.

${cfd} The path of current file directory.

${pd} The project directory.

${oxygenInstallDir} The installation directory of <oXygen/>.

Command line The command line that will start the external tool. Here you can use one of the following
editor variables:

${dbgXML} The path to the current Debugger source selection.
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${dbgXSL} The path to the current Debugger stylesheet selec-
tion.

${homeDir} The path to user home directory.

${cfn} The current file name without extension.

${cfne} The current file name with extension.

${cf} The path of the currently edited file.

${cfd} The path of current file directory.

${tsf} Transformation result file.

${pd} The project directory.

${oxygenInstallDir} The installation directory of the application.

${frameworksDir} The directory where the <oXygen/> frameworks
are located.

${ps} The separator which can be used on different oper-
ating systems between libraries specified in the class
path.

${timeStamp} Time Stamp - The current Unix time on the com-
puter which can be used to save transformation
results in different output files on each transform.

Note

The quote character (") is used to delimit parameters and files that have spaces in their names.

 cmd /c dir "c:\samples\dir with spaces"                                         

Note

There are cases in which you need to specify in the command line a parameter that contains a quote. You will
need to escape the quote by using the character:^.

 cmd /c dir "c:\samples\dir with ^"quotes^" and spaces"                                         

Menu Shortcut Keys
The user can configure in one place the keyboard shortcuts available for menu items available in <oXygen/> XML
Author . The current shortcuts assigned to menu items are displayed in the following table.

The user can search an operation using the filter field by the operation's description, category or shortcut key.

The Menu Shortcut Keys preferences panel is opened from menu Options → Preferences+Menu Shortcut Keys
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Figure 18.61. The Menu Shortcut Keys preferences panel

Description A short description of the menu item operation.

Category The shortcuts are classified in categories for easier management. For example
the "Cut" operation for the source view is distinguished from the tree view one
by assigning it to a separate category.

Shortcut key The keyboard shortcut that launches the operation. Double-clicking on a table
row or pressing the "Edit" button allows the user to register a new shortcut for
the operation displayed on that row.

'Home' and 'End' keys are applied at
line level

Option available only on the Mac OS X and controls the way the HOME and
END keys are interpreted. If checked the default behaviour of the Mac OS X
HOME and END keys will be overridden and the caret will move only on the
current line. The default on the Mac is to move the caret to the beginning or end
of the document.

File Types
<oXygen/> offers support for a wide variety of file types, but users are free to add new file types specified by extension
and associate them with the editor type which fits better. The associations set here between a file extension and the
type of editor which opens the file for editing have precedence over the default associations available in the File →
Newdialog.

The File Types preferences panel is opened from menu Options → Preferences+File Types
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Figure 18.62. The File Types preferences panel

Extension The new file types.

Editor The type of editor which the extensions will be associated with. Some editors provide easy access to
frequent operations via toolbars (e.g. XML editor, XSL editor, DTD editor) while other provide just
a syntax highlight scheme (e.g. Java editor, SQL editor, Shell editor, etc.)

If the editor set here is not the XML Editor then the encoding set in the preference Encoding for non
XML files is used for opening and saving a file of this type. This is necessary because in case of XML
files the encoding is usually declared at the beginning of the XML file in a special declaration or it
assumes the default value UTF-8 but in case of non XML files there is no standard mechanism for
declaring the encoding of the file.

SVN File Editors
Each type of file is associated with an editor which opens files of that type for editing. The editor can be the built-in
one specially provided for the file type (for example the internal XML editor, the internal XSLT editor, the internal
XSL-FO editor, etc) or an external application installed on the computer, either the default system application associated
with that file type in the operating system or other particular application specified by the path to its executable file.
The list of all the associations file type - editor is displayed in the panel SVN File Editors.

The SVN File Editors preferences panel is opened from menu Options → Preferences+SVN File Editors
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Figure 18.63. The SVN File Editors preferences panel

The Edit button under the table or a double click on a table row opens a dialog for specifying the editor associated with
the file type.

The same dialog is displayed and after an Open with action on a selected file from Syncro SVN Client.

Figure 18.64. The Open With dialog for file type - editor associations

In this dialog are offered three options for opening a file:
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• System default application - this option allows you to open the selected file using the application that is associated
with that file extension by default in your operating system;

• System application - opens the selected file using an external application that you have to specify by the path of its
executable file. Also, you can specify some arguments for that application, if they are needed. This option also works
for directories, if you wish to choose a file browser other than the system default.

• Internal editor - this options allows you to select an editor type from the built in editors that Syncro SVN Client
comes with. By default, this option is disabled when selecting directories.

Note

For opening a directory, you can choose one of the first two options. The System default application will be used
to open that directory in the system built-in file browser (i.e. Windows Explorer for Windows, Finder for Max
OS X etc.), and the second one for opening that directory using a file browser other than the system default.

If a file type is associated with an internal editor other than the XML Editor then the encoding set in the preference
Encoding for non XML files is used for opening and saving a file of that type. This is necessary because in case of
XML files the encoding is usually declared at the beginning of the XML file in a special declaration or it assumes the
default value UTF-8 but in case of non XML files there is no standard mechanism for declaring the encoding of the
file.

HTTP(S) / (S)FTP / Proxy Configuration
Some networks use Proxy servers to provide Internet Services to LAN Clients. Clients behind the Proxy may therefore,
only connect to the Internet via the Proxy Service. The Proxy Configuration dialog enables this configuration. If you
are not sure whether your computer is required to use a Proxy server to connect to the Internet or the values required
by the Proxy Configuration dialog, please consult your Network Administrator.

Open the HTTP(S) / (S)FTP / Proxy Configuration panel by selecting Options → Preferences+HTTP / HTTPS / FTP
/ SFTP / Proxy Configuration.
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Figure 18.65. The HTTP(S) / (S)FTP / Proxy Configuration preferences panel

Complete the dialog as follows:

Direct connection When checked the HTTP and HTTPS connections go directly to the target host
without going through a proxy server.

Use system settings When checked the HTTP and HTTPS connections go through the proxy server
set in the operating system. For example on Windows the proxy settings are the
ones available in Internet Explorer.

Warning

The system settings for the proxy cannot be read correctly from the oper-
ating system on some Linux systems. The system settings option should
work properly on Gnome based Linux systems but it does not work yet
on KDE based ones as the Java virtual machine does not offer the necessary
s u p p o r t  y e t
[http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6385839].

Manual proxy configuration When checked the HTTP and HTTPS connections go through the proxy server
specified in the fields Address and Port of the section Web Proxy (HTTP / HT-
TPS). Also this section specifies the hosts to which the connections must not go
through a proxy server.
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Web Proxy authentication (HTTP /
HTTPS)

In this section one must set the user and password necessary for authentication
with the proxy server. The user and password set here will be used both in case
of manual proxy configuration and in case of system settings selected above.

SOCKS Proxy In this section one must set host and port of a SOCKS proxy through which all
the connections must pass. If the Address field is empty the connections will
use no SOCKS proxy.

Lock WebDAV files on open If checked the files opened through WebDAV are locked on the server so that
they cannot be edited by other users while the lock placed by the current user
still exists.

SSL authentication with client certi-
ficate

If checked and the SVN server accessed by the https protocol requires a digital
certificate then the user is asked to specify the file containing a certificate in the
PKCS format for accessing that server.

Advanced HTTP Settings

Open the Advanced HTTP Settings preferences panel by selecting Options → Preferences → HTTP(S) / (S)FTP /
Proxy Configuration+Advanced HTTP Settings.

Figure 18.66. The Advanced HTTP Settings preferences panel

Automatic retry on recoverable error If enabled, if a HTTP error occurs when <oXygen/> communicates with a
server via HTTP, for example sending/receiving a SOAP request/response
to/from a Web services server, and the error is recoverable, <oXygen/> tries to
send again the request to the server.

Enable HTTP 'Expect: 100-continue
' handshake for HTTP/1.1 protocol

Activates 'Expect: 100-Continue' handshake. The purpose of the 'Expect: 100-
Continue' handshake is to allow a client that is sending a request message with
a request body to determine if the origin server is willing to accept the request
(based on the request headers) before the client sends the request body. The use
of the 'Expect: 100-continue' handshake can result in noticeable performance
improvement when working with databases. 'Expect: 100-continue' handshake
should be used with caution, as it may cause problems with HTTP servers and
proxies that do not support HTTP/1.1 protocol.

Read Timeout (s) The period in seconds after which the application will consider a HTTP server
is unreachable if it does not receive any response to a request sent to that server.

Tip

If the Automatic retry on recoverable error option is checked the HTTP
client will try to establish the connection twice so the timeout will be
double the timeout specified here.
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(S)FTP

Open the (S)FTP preferences panel by selecting Options → Preferences → HTTP(S) / (S)FTP / Proxy Configura-
tion+(S)FTP.

Figure 18.67. The (S)FTP Configuration preferences panel

Encoding for FTP control connection The encoding used to communicate with FTP servers. It is one of ISO-8859-1
and UTF-8. If the server supports the UTF-8 encoding <oXygen/> will use it
for communication. Otherwise it will use ISO-8859-1.

Private key file The path to the file containing the private key used for the private key method
of authentication of the secure FTP (SFTP) protocol. The user/password method
of authentication has precedence if it is used in the Open URL dialog.

Passphrase The passphrase used for the private key method of authentication of the secure
FTP (SFTP) protocol. The user/password method of authentication has preced-
ence if it is used in the Open URL dialog.

Certificates
In <oXygen/> there are provided two types of Keystores: Java KeyStore (JKS) and Public-Key Cryptography Standards
version 12 (PKCS-12). A keystore file is protected by a password.

The Certificates preferences panel is opened from menu Options → Preferences+Certificates

Figure 18.68. The Certificates preferences panel

Keystore type Represents the type of keystore to be used.
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Keystore file Represents the location of the file to be imported.

Keystore password The password which is used to protect the privacy of the stored keys.

Certificate alias The alias to be used to store the key entry (the certificate and /or the private key) inside
the keystore.

Private key password It is only necessary in case of JKS keystore. It represents the certificate's private key
password.

Validate Verifies the entries from the fields; assures that the certificate is valid.

Outline
The Outline preferences panel is opened from menu Options → Preferences+Outline

Figure 18.69. The Outline preferences panel

Preferred attribute names for display The attribute names which should be preferred when displaying element's attrib-
utes in the outline view. If there is no preferred attribute name specified the first
attribute of an element is displayed in the outline view.

Enable outline drag and drop When drag and drop is disabled for the tree displayed by the outline view there
is no possibility to accidentally change the structure of the document.

View
The View preferences panel is opened from menu Options → Preferences+View

Figure 18.70. The View preferences panel
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Maximum number of lines This option sets the maximum number of lines of the output console where the
external tools place their output.

Enable project drag and drop This option enables the drag and drop support in Project view. When it is disabled
there is no possibility to accidentally change the structure of the project.

Messages
The Messages preferences panel is opened from menu Options → Preferences+Messages

Figure 18.71. The Messages preferences panel

This page allows disabling warning messages which may appear in the application.

Show the XML Schema namespaces
chooser dialog

If checked, the dialog appear when create a new XML schema file.

Show the stylesheet version chooser
dialog

If checked, the version chooser dialog will be shown when creating a new
stylesheet file.

Show the schematron version
chooser dialog

If checked, the version chooser dialog will be shown when creating a new
schematron file.

Show SFTP Warning dialog If checked, a warning dialog will be shown each time when the authenticity of
the host cannot be established.
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Show warning when switching to
XPath builder

If checked, a warning dialog will be shown when the XPath toolbar contains a
long expression and the user is advised to use the XPath Builder instead.

Show BIDI limit warning If checked, a warning dialog will be shown when the opened file which contains
bidirectional characters is too large and bidirectional support is disabled.

Show warning dialog when editing
conflicts

If checked, when the Edit Conflicts action is executed in the SVN Client, a dialog
will be shown that warns you that the action will overwrite the conflicted version
of the file created by an update operation. The conflicted file will be overwritten
with the version of the same file which existed in the working copy before the
update operation and then proceeds with the visual editing of the conflict file.
If the button Cancel is pressed in this warning dialog the Edit Conflicts action
is aborted.

Show confirmation dialog for drag
and drop actions in Working Copy

Set this option to avoid doing a drag and drop when you just want to select
multiple files in the Working Copy view and run the same action on all selected
files, for example a Copy or a Commit.

Show warning if files are already
added to project

If checked, a dialog will be shown warning the user if he wants to add to project
an already existing file.

Show archive backup dialog If checked, a dialog will be shown allowing the user different backup options
before modifying an archive's content.

Convert DB Structure to XML
Schema - when expanding other
database schema

When tables from a database schema are selected in the Select database table
dialog, after the Convert DB Structure to XML Schema is invoked, and another
database schema is expanded a confirmation is needed because the previous
selection will be discarded. The option controls whether the user should always
be asked about the next action, the other database schema will always be expan-
ded or it will never be expanded.

Show warning when switching
between Project and Global options
in Preferences dialog

If checked, a warning dialog will be shown about uncommitted changes when
switching between Project and Global options in a page.

Show warning when switching
between Project and Global options

If checked, a warning dialog will be shown about uncommitted changes when
switching between Project and Global options in the transformation scenarios
edit dialog.in Configure Transformation Scen-

ario dialog

Show warning when switching
between Project and Global options

If checked, a warning dialog will be shown about uncommitted changes when
switching between Project and Global options in the validation scenarios edit
dialog.in Configure Validation Scenario

dialog

SVN
The SVN preferences panel is opened from menu Options → Preferences+SVN and it is the place where the user
preferences for the embedded SVN client tool are configured. More preferences that configure how the embedded
SVN client tool works can be set in the global files called 'config' and 'servers', that is the files with parameters that
act as defaults applied to all the SVN client tools that are used by the same user on his login account on the computer.
These files can be opened for editing with the two edit actions available in the SVN client tool on the Global Runtime
Configuration submenu of the Options menu.
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Figure 18.72. The SVN preferences panel

• Automatically upgrade working copies to the client's version - if this option is checked and a working copy stored
locally on disk using an old SVN format (for example the SVN 1.3 one) is loaded in the Working Copy view then
the working copy is automatically converted by Syncro SVN Client to the most recent SVN format. If the option is
not checked a confirmation dialog will be displayed when such a working copy is loaded in the Working Copy view.

• Enable symbolic link support (available only on Mac OS X and Linux) - Subversion has the ability to put a symbolic
link under version control, via the usual SVN add command. The Subversion repository has no internal concept of
a symbolic link, it stores a "versioned symbolic link" as an ordinary file with a 'svn:special' property attached. The
SVN client (on Unix) sees the property and translates the file into a symbolic link in the working copy.

Note

Win32 has no symbolic links, so a Win32 client won't do any such translation: the object appears as a normal
file.

If the symbolic link support is disabled then the versioned symbolic links, on Linux and OS X, are supported in the
same way as on Windows - i.e. a text file instead of symbolic link is created.

Important

We recommend to disable symbolic links support if you do not have versioned symbolic links in your repos-
itory, because the SVN operations will work faster. However, you should not disable this option when you do
have versioned symbolic links in repository. In that case a workaround would be to refer to working copy by
its "real" path, not path that includes a symbolic link.
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• Show tooltip on Working Copy and Synchronize trees - For each file and folder a tooltip is displayed with details
like SVN status, full path, current revision number, last changed date, etc. If the tooltips seem annoying by covering
useful information they can be disabled with this option.

• Use unsafe copy operations - Sometimes when the working copy is accessed through Samba and SVN client cannot
make a safe copy of the committed file due to a delay in getting write permission the result is that the committed
file will be saved with zero length (the content is removed) and an error will be reported. In this case this option
should be selected so that SVN client does not try to make the safe copy.

• Working copy administrative directory - allows you to customize the directory name where the svn entries are kept
for each directory in the working copy.

• Application global ignores - allows setting file patterns that may include the wildcard * and ? for unversioned files
and folders that must be ignored when displaying the working copy resources in the Working Copy view.

• SSH - here you can specify the command line for an external SSH client which will be used when connecting to a
SVN+SSH repository. Absolute paths are recommended for the SSH client executable and the file paths given as
arguments(if any). Depending on the SSH client used and your SSH server configuration you may need to specify
in the command line the username and/or privatekey/passphrase. Here you can also choose if the default SVN user
will be used(the same as the SSH client user) or you should be prompted for a user whenever SVN authentication
is required.

• Compare - allows you to specify if you want to see pseudo-conflicts in the Compare view. You can also change the
maximum number of differences allowed in the view and to specify an external application to be launched for
compare operations in the following cases: when two history revisions are compared, when the working copy file
is compared with a history revision, when a conflict is edited. The parameters ${firstFile} and ${secondFile} specify
the positions of the two compared files in the command line for the external diff application. There is also available
a link to quickly customize the used compare colors.

• Results Console - here you can specify the maximum number of lines displayed in the Console View and if the
Console view should come to the foreground when there is some output that is displayed in this view.

• Annotations View - here you can set the color used for highlighting in the editor panel all the changes contributed
to a resource by the revision selected in the Annotations view.

• Revision Graph - here you can enable caching for the action of computing a revision graph. When a new revision
graph is requested one of the caches from the previous actions may be used which will avoid running the whole
query again on the SVN server which will finish the action much faster.

SVN Diff
The SVN Diff preferences panel is opened from menu Options → Preferences+SVN+Diff and it allows you set the
compare options for SVN.
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Figure 18.73. The SVN Diff preferences panel

• Show pseudo conflicts - it allows you to specify if you want to see pseudo-conflicts in the Compare view. A pseudo
conflict occurs when two developers make the same change, for example when both add or remove the same line
of code.

• Compare With External Application - you can specify an external application to be launched for compare operations
in the following cases: when two history revisions are compared, when the working copy file is compared with a
history revision or when a conflict is edited. The parameters ${firstFile} and ${secondFile} specify the positions
of the two compared files in the command line for the external diff application.

• Maximum number of differences - you can change the maximum number of differences allowed in the view.

Sharing Preferences
By default all the settings are global and are stored in the user home directory.

Figure 18.74. Controlling the Storage of the Preferences

The values from each preference page can also be stored in the current project file. This allows you to create and share
with your team an <oXygen/> project already configured. For instance you may decide that the default schema associ-
ations and catalogs must be shared. In this case you simply click the radio button "Project options", edit the values and
then save your project. If you want to drop a option page from being stored into the project, you select the radio button
"Global options".

Note

The project settings have precedence over the global ones.

For instance, if you have changed a global option value, let say the line width used for pretty-print, and then you
load a project that also defines a different line width for the pretty-print, <oXygen/> will use the value from the
project.

Note

If you change the global options and decide to move the current page to the project level, you need to press Apply
to save your current changes. Otherwise, the current changes will be lost from the global options.
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Note

If you select "Global options" on a page that was at the project level, then the option values are removed from
the project file when the project is saved.

Automatically importing the preferences from
the other distribution
If you want to use the settings from “standalone” in the Eclipse plugin just delete the file with the Eclipse plugin settings
[user-home-dir]/Application Data/com.oxygenxml.author/oxyAuthorOptionsEc10.3.xml
on Windows / [user-home-dir]/.com.oxygenxml.author/oxyAuthorOptionsEc10.3.xml on
Linux, start Eclipse and the “standalone” settings will be automatically imported in Eclipse. The same for importing
the Eclipse plugin settings in “standalone”: delete the file [user-home-dir]/com.oxygenxml.author/oxyAu-
thorOptionsSa10.3.xml, start the <oXygen/> “standalone” distribution and the Eclipse settings will be automat-
ically imported.

Reset Global Options
To reset all custom user settings of the application that are stored in a local file (not in the project), to the installation
defaults go to: Options → Reset Global Options The list of transformation scenarios will be reset to the default scen-
arios.

Scenarios Management
You can import, export and reset the scenarios stored in the global options.

• The action Options → Import Global Transformation Scenarios loads a properties file with scenarios.

• The action Options → Export Global Transformation Scenarios stores all the scenarios in a separate properties file.

The option to Export Transformation Scenarios is used to store all the scenarios in a separate file , a properties file.
In this file will also be saved the associations between document URLs and scenarios. The saved URLs are absolute.
You can load the saved scenarios using Import Transformation Scenarios option. All the imported scenarios will
have added to the name the word 'import'.

Note

The scenarios are exported/imported from/in the global options, not from the project options. So be aware that
the list of scenarios kept at the project level are not affected.

Note

Starting with version 8, there is support for project level options. In this way sharing the options and scenarios
with your team becomes simpler, as you can choose to store the settings directly into the project file, with no
need for export/import operations. We recommend to use the project level options. See the Preferences Sharing
and Sharing the Transformation Scenarios sections for more details.
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Editor variables
An editor variable is a shorthand notation for a file path or directory path. It is used in the definition of a command
(the input URL of a transformation, the output file path of a transformation, the command line of an external tool, etc.)
to make the command generic. When the same command is applied the notation is expanded so that the same command
has different effects depending on the actual value of the notation.

The following editor variables can be used in <oXygen/> commands:

${oxygenHome} Oxygen installation directory as URL

${oxygenInstallDir} Oxygen installation directory

${frameworks} the path of the frameworks subdirectory of the <oXygen/> install directory
as URL

${frameworksDir} the path of the frameworks subdirectory of the <oXygen/> install directory

${home} the path of the user home directory as URL

${homeDir} the path of the user home directory

${pdu} Project directory as URL

${pd} project directory - the path of the current project directory

${pn} project name- the name of the current project

${cfdu} current file directory url - the path of the current edited document up to the name
of the parent directory as URL

${cfd} current file directory - the path of the current edited document up to the name
of the parent directory

${cfn} current file name - the name of the current edited document without extension
and parent directory

${cf} current file - the absolute file path of the current edited document

${currentFileURL} current file as URL - the absolute file path of the current edited document as
URL

${ps} Path Separator - The separator which can be used on different operating systems
between libraries specified in the class path.

${timeStamp} Time Stamp - The current Unix time on the computer which can be used to save
transformation results in different output files on each transform.
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on a file in Windows Explorer, selecting Open With -> Choose Program and browsing to the file oxy-
gen.exe. When I select the file oxygen.exe in the Windows file browser dialog and I click the Open
button of the dialog the <oXygen/> application is not added to the list of applications in the Open With
dialog of Windows. What can I do? ............................................................................................ 552

19.11. When I close the <oXygen/> application with multiple files open and then restart it, every file opens in
a split panel of the editing area instead of a tab sharing with the other opened files the same editing area
which organizes the editors in a tabbed pane. I want to have the files arranged as a tabbed pane as they
used to be arranged before this restart of <oXygen/>. .................................................................... 552

19.12. I try to run <oXygen/> on Linux with the Compiz / Beryl window manager but I get only a grey window
which does not respond to user actions / after opening and closing an <oXygen/> dialog or after resizing
the <oXygen/> window or a view of the <oXygen/> window the content of this window becomes grey
and it does not respond to user actions. What is wrong? ................................................................. 552

19.13. <oXygen/> hangs about a minute at 2% of the startup progress bar and also when I open the file open/file
save dialog from the File toolbar or from the File menu. Why do I get this slow actions? ...................... 552

19.14. When I try to drag with the mouse an unselected resource from the Project View/DITA Maps Manager,
the drag never starts, it only selects the resource. I need to drag the resource again after it becomes selected.
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19.15. How do I set the version X of the Java virtual machine for <oXygen/> on Mac OS X? .......................... 552
19.16. On my Mac OS X machine when I double-click on the <oXygen/> icon the application doesn't start /
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19.1. <oXygen/> opens a XML document after a long time. Why does it happen?

All the content of your document is on a single line or the document is very large. If the content is on a single
line please enable the Format and indent the document on open preference from  Options → Preferences+Editor
/ Format / XML  before opening the document. If the document is very large (above 10 MB) you should increase
the memory available to <oXygen/>.
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19.2. I am trying to open a file larger than 70 MB for editing in <oXygen/> but it keeps telling me it runs out of
memory. What can I do?

Files larger than 70 MB should not be opened in <oXygen/>for editing as this requires a very large amount of
memory which exceeds the maximum amount of memory allowed for a Java process. Such files should be opened
only for viewing (read-only access) using the Large File Viewer tool available both in the <oXygen/> application
on the Tools menu and as a standalone tool on the shortcuts menu together with the <oXygen/> shortcut.

19.3. My file was created with other application and it contains special characters like é, ©, ®, etc. Why does <oXygen/>
display a square for these characters?

You must set a font able to render the special characters from Font preferences. If it is a text file you must set
also the encoding used for non XML files. If a TrueType font installed on the computer is not accessible in the
Font preferences the Java virtual machine is not able to load the system fonts. It is a problem of the Java virtual
machine and a possible solution is to copy the files of the font in the [JVM-home-folder]/lib/fonts
folder.

19.4. When I start <oXygen/> XML Author on Windows XP I get the following error. What can I do?

Cannot start <oXygen/>.
Due to:java.lang.NullPointerException
java.lang.NullPointerException
at com.sun.java.swing.plaf.windows.XPStyle.getString(Unknown Source)
at com.sun.java.swing.plaf.windows.XPStyle.getString(Unknown Source)
at com.sun.java.swing.plaf.windows.XPStyle.getDimension(Unknown Source)
at com.sun.java.swing.plaf.windows.WindowsProgressBarUI.
getPreferredInnerHorizontal(Unknown Source)

The error is cause by a a bug in the Java runtime from Sun Microsystems
[http://bugs.sun.com/bugdatabase/view_bug.do;jsessionid=1068feedb408f5f279405ff0c75:YfiG?bug_id=6342514].
You can avoid it by setting the Java system property com.oxygenxml.no.xp.theme to the value true in the startup
script. If you start <oXygen/> XML Author with the author.bat script just add the parameter

-Dcom.oxygenxml.no.xp.theme=true

to the java command in the script. If you start <oXygen/> XML Author from the Start menu shortcut add the
same parameter on a new line in the file [oXygen-install-folder]\author.vmoptions.

19.5. I tried to start <oXygen/> on Windows but it crashed with an error message about “Fault Module Name:
nvoglv32.dll”. How can I start <oXygen/> on my computer?

It is an OpenGL driver issue that can be avoided by creating an empty file called opengl32.dll in the
<oXygen/> install folder if you start it with the shortcut created by the installer on the Start menu or on Desktop
or in the subfolder bin of the home folder of the default Java virtual machine if you start <oXygen/> with the
oxygen.bat script. The default Java virtual machine is the one that is started by a command

java -version

executed in a command line console.

19.6. <oXygen/> crashed the Apple JVM/<oXygen/> could not start up on my Mac OS X computer due to a JVM
crash. What can I do?
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Usually it is an incompatibility between the JVM and a native library of the host system. Depending on your
platform, a crash log file is generated with more data about the problem. For Unix type systems you will get an
error in the console. For Windows and Mac OS X the path of the crash log file is displayed on screen.

On Mac OS X 10.5 and later there is an more stable JVM called SoyLatte
[http://landonf.bikemonkey.org/static/soylatte/] that can be downloaded and installed for avoiding the crash. For
running <oXygen/> with the SoyLatte JVM just set the path to the JVM startup executable (SoyLatte-in-
stall-folder/bin/java) in the java command at the end of the script oxygenMac.sh and start
<oXygen/> from a command line with the command:

sh oxygenMac.sh

19.7. When I do a keyword search in the User Manual the search highlights the wrong word in the text, often several
words after the keyword. Is this a bug?

You get wrong highlights when <oXygen/> runs with some Java virtual machines. The search highlights are
correct when <oXygen/> runs with a stable Java 1.6 virtual machine. It is a problem of the JavaHelp indexer
supplied by Sun Microsystems. In order to see correct highlights we recommend to use Java 1.6.0_01.

19.8. The keyboard shortcuts listed in Options -> Preferences -> Menu Shortcut Keys do not work. What can I do?

Usually this happens when a special keyboard layout is set in the operating system which generates other char-
acters than the usual ones for the keys of a standard keyboard. For example if you set the extended Greek layout
for your keyboard you should return to the default Greek layout or to the English one. Otherwise the Java virtual
machine that runs the application will receive other key codes than the usual ones for a standard keyboard.

19.9. Before installing Oxygen XML Editor/Author I had no problems viewing XML files in Internet Explorer but
now Internet Explorer opens an XML file in Oxygen XML Editor/Author. How can I view XML files in Internet
Explorer again?

XML files are opened in Oxygen because Internet Explorer uses the Windows file associations for opening files
and you associated XML files with Oxygen XML Editor/Author in the installer panel called File Associations.
This installer panel displays a warning above the XML file association that XML files will not be viewed correctly
in Internet Explorer if you associate them with Oxygen XML Editor/Author.

For viewing XML files in Internet Explorer again you have to associate XML files with IE by right-clicking on
an XML file in Windows Explorer, selecting Open With -> Choose Program, selecting IE in the list of applications
and checking the checkbox "Always use the selected program". Also you have to run the following command
from a command line:

wscript revert.vbs

where revert.vbs is a text file with the following content:

  function revert()
    Set objShell = CreateObject("WScript.Shell")
    objShell.RegWrite "HKCR\.xml\", "xmlfile", "REG_SZ"
    objShell.RegWrite "HKCR\.xml\Content Type", "text/xml", "REG_SZ"
  end function

  revert()
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19.10. I cannot associate the <oXygen/> application with a file type on my Windows computer by right clicking on a
file in Windows Explorer, selecting Open With -> Choose Program and browsing to the file oxygen.exe.
When I select the file oxygen.exe in the Windows file browser dialog and I click the Open button of the
dialog the <oXygen/> application is not added to the list of applications in the Open With dialog of Windows.
What can I do?

The problem is due to some garbage Windows registry entries remained from old versions of <oXygen/> Please
uninstall all your installed versions of <oXygen/> and run a registry cleaner application for cleaning these entries.
Reinstalling a recent version of <oXygen/> will not generate this problem anymore.

19.11. When I close the <oXygen/> application with multiple files open and then restart it, every file opens in a split
panel of the editing area instead of a tab sharing with the other opened files the same editing area which organizes
the editors in a tabbed pane. I want to have the files arranged as a tabbed pane as they used to be arranged before
this restart of <oXygen/>.

This happens randomly when several files are opened automatically on startup. It is a problem of the JIDE
docking views library used in <oXygen/> for docking and floatable views. The workaround is to run the action
Perspectives → Reset Layout. If you have a specific layout of the <oXygen/> views which you want to preserve
when running this action you should set your layout in Options → Preferences+Perspectives Layout+Use fixed
layout.

19.12. I try to run <oXygen/> on Linux with the Compiz / Beryl window manager but I get only a grey window which
does not respond to user actions / after opening and closing an <oXygen/> dialog or after resizing the <oXygen/>
window or a view of the <oXygen/> window the content of this window becomes grey and it does not respond
to user actions. What is wrong?

Sun Microsystems' Java virtual machine does not support the Compiz window manager and the Beryl one very
well [http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6429775]. We are expecting better support for
Compiz / Beryl in future versions of their Java virtual machine. You should turn off the special effects of the
Compiz / Beryl window manager before starting the <oXygen/> application or switch to other window manager.

19.13. <oXygen/> hangs about a minute at 2% of the startup progress bar and also when I open the file open/file save
dialog from the File toolbar or from the File menu. Why do I get this slow actions?

This happens with the Sun's Java virtual machine version 1.6.0_02 and later due to a bug
[http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6578753] introduced by JVM 1.6.0_02. Please run the
<oXygen/> application with a different JVM version. See the installation instructions for setting a specific JVM
version for running the <oXygen/> application.

19.14. When I try to drag with the mouse an unselected resource from the Project View/DITA Maps Manager, the drag
never starts, it only selects the resource. I need to drag the resource again after it becomes selected. As a result
any drag and drop without initial selection becomes a two step operation. How can I fix this?

This is a bug [http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4521075] present in JVM versions prior
to 1.5.0_09. This issue is fixed in 1.5.0_09 and newer versions(including 1.6). See the installation instructions
for setting a specific JVM version for running the <oXygen/> application.

19.15. How do I set the version X of the Java virtual machine for <oXygen/> on Mac OS X?

<oXygen/> uses the first JVM from the list of preferred JVM versions set on your Mac computer that has the
version number not less than 1.5.0. You can move your desired JVM version up in the preferred list by dragging
it with the mouse on a higher position in the list of JVMs available from Applications -> Utilities -> Java ->
Java Preferences.
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19.16. On my Mac OS X machine when I double-click on the <oXygen/> icon the application doesn't start / gives a
Segmentation fault error.

Install the latest Java update from the Apple website. If that doesn't solve the problem copy the file JavaAp-
plicationStub from the /System/Frameworks folder to the oxygen.app/Contents/MacOS
folder. For browsing the folder oxygen.app Meta + click on the <oXygen/> icon and select Show Package
Contents

19.17. After upgrading my OS X version to 10.4.x / my <oXygen/> version to 6.x <oXygen/> is not associated to the
file types XML, XSL, XSD, etc. This worked in the previous version of <oXygen/>.

The upgrade damaged the file associations in the LaunchService Database on your Mac OS X machine. Please
rebuild the LaunchService Database with the following procedure. This will reset all file associations and will
rescan the entire file system searching for applications that declare file associations and collecting them in a
database used by Finder.

Procedure 19.1. Rebuild file associations of the LaunchService Database

1. Find all the <oXygen/> installations on your hard drive.

2. Delete them by dragging them to the Trash.

3. Clear the Trash.

4. Unpack the installation kit on your desktop.

5. Copy the contents of the archive into the folder /Applications/Oxygen.

6. Run the command

/System/Library/Frameworks/ApplicationServices.framework/Frameworks/ LaunchServices.frame-
work/Support/lsregister -kill -r -domain local -domain system -domain user -dump

from the Terminal.

7. Restart Finder with

killall Finder

from the Terminal.

8. Create a XML or XSD file on your desktop. It should take the <oXygen/> icon.

9. Double click it. After accepting the confirmation dialog <oXygen/> will be start up.

19.18. After upgrading my Mac OS X to version 10.4.1 Tiger I am not able to set all XML files to open with <oXygen/>
when I click Change All in the Get Info dialog. This worked in OS X 10.3.x.

On Mac OS X Tiger you must add an entry to the Info.plist file. Tiger was released after <oXygen/> version
6.0 so we could not include the change in the release. Please close <oXygen/>, press Meta + click on the
<oXygen/> icon, select Show package contents, go to Contents, edit the Info.plist file, add the entry

    <key>CFBundleIdentifier</key>
    <string>ro.sync.exml.Oxygen</string>

553

Common problems



and restart <oXygen/>. Select Change All in the Get Info dialog to make the association.
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Accelerator Shortcut Keys

The Main Editor
File → New (Ctrl+N) : Displays the New dialog from which to select the document file type.

File → Open (Ctrl+O) : Displays the Open dialog used to discover, select and open one or more files.

File → Save (Ctrl+S) : Saves the current document. If the document does not have a file, displays the Save As dialog.

File → Save Results : Displays the Save Results dialog, used to save the result-list of the, currently in focus, message
tab.

File → Open Project (Ctrl+F2) : Displays the Open Project dialog used to discover, select and open a project file.

File → Save Project (Ctrl+F3 (Cmd+G on Mac)) : Saves the current project. If the project does not have a file, displays
the Save Project As dialog.

File → Print (Ctrl+P) : Displays the Page Setup dialog used to define the page size and orientation properties for
printing.

File → Close (Ctrl+W) : Closes only the selected tab. All other tab instances remain.

File → Exit (Ctrl+Q) : Terminates the <oXygen/> XML Editor. Session information such as the current Project, open
Documents and Option settings is made persistent. When the <oXygen/> editor is re-opened, the persistence information
returns to the last saved state.

Edit → Undo (Ctrl+Z) : Reverses, a maximum of 100, editing actions to return to the preceding state.

Edit → Redo (Ctrl+Y for Windows, Ctrl+Shift+Z for Mac OSX and Linux) : Recreates, a maximum of 100, editing
actions that where undone by the Undo function.

Edit → Cut (Ctrl+X) : Removes the current selected node from the document and places it in the clipboard.

Edit → Copy (Ctrl+C) : Places a duplicate copy of the current selection in the clipboard.

Edit → Paste (Ctrl+V) : Places the current clipboard content into the document at the cursor position.

Edit → Select All (Ctrl+A) : Selects the entire body of the current document, including whitespace preceding the first
and following the last character.

Edit → Check Spelling (F4) : Checks the spelling in your document.
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Find → Find/Replace... (Ctrl+F) : Displays the Find/Replace dialog, used to define "search for" or "search for and
replace" operations on the current document. The replace operation can bind Perl 5-like regexp group variables ($1,
$2, etc.) from the find match.

Find → Go to Line (Ctrl+L (Cmd+L on Mac)) : Displays the Go to Line dialog used to move the cursor directly to
the position specified.

Find → Search again (F3) : Performs another search using the last search configuration.

Tree Editor → Show... (Ctrl+T) : Opens the window for editing a document displayed as a structured tree.

Help → Help (F1) : Opens the <oXygen/> XML Editor Online Help System.

Document → Validate document (Ctrl+Shift+V) : Executes the Validation operation on the current document using
a validating parser. Returns an error result-list in the Message panel. Mark-up of current document is checked to conform
with the specified DTD rules.

Document → Check document form (Ctrl+Shift+W) : Executes the XML Form check operation on the current document
using a non-validating parser. Returns an error result-list in the Message panel.

Document → Apply transformation scenario (Ctrl+Shift+T) : Executes the transformation process using the configur-
ation properties defined in the Configure Transformation dialog.

Document+ Transformation → Configure transformation scenario (Ctrl+Shift+C) : Displays the Configure Transform-
ation dialog, used to define properties for conversion of documents to multiple output targets. Also enables saving of
"Scenarios". Each scenario, can store a unique configuration ready to be used in the future.

Document → Format and Indent (Ctrl+Shift+P) : Also referred to as "Pretty Print", Format and Indent performs layout
functions to make mark-up easier to read on screen and in print output.

Document → Learn Structure (Ctrl+Shift+L) : Reads the mark-up structure of the current document so that it can be
saved as a template using the Save Structure option.

Document → Save Structure (Ctrl+Shift+S) : Displays the Save Structure dialog, used to name and create DTD doc-
uments learnt by the Learn Structure function.

Document → Find All (Ctrl+Shift+F) : Finds all occurrences of selected word in current file.

Unicode Character Encoding
The table below provides a matrix from which to match Unicode names with the names shown by the Java Encoder
when it cannot identify encoding.
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Table A.1. Unicode to Java Name Matrix

Java Encoder NameName TypeName in XML filesCommon Name

UTF8IANAUTF-88 bit Unicode

UnicodeIANAUTF-1616 bit Unicode

UnicodeLittleIANAUTF-16LE16 bit Unicode little endian

UnicodeBigIANAUTF-16BE16 bit Unicode big endian

ISO-8859-1MIMEISO-8859-1ISO Latin 1

ISO-8859-2MIMEISO-8859-2ISO Latin 2

ISO-8859-3MIMEISO-8859-3ISO Latin 3

ISO-8859-4MIMEISO-8859-4ISO Latin 4

ISO-8859-5MIMEISO-8859-5ISO Latin Cyrillic

ISO-8859-6MIMEISO-8859-6ISO Latin Arabic

ISO-8859-7MIMEISO-8859-7ISO Latin Greek

ISO-8859-8MIMEISO-8859-8ISO Latin Hebrew

ISO-8859-9MIMEISO-8859-9ISO Latin 5

cp037IANAebcdic-cp-usEBCDIC: US

cp037IANAebcdic-cp-caEBCDIC: Canada

cp037IANAebcdic-cp-nlEBCDIC: Netherlands

cp277IANAebcdic-cp-dkEBCDIC: Denmark

cp277IANAebcdic-cp-noEBCDIC: Norway

cp278IANAebcdic-cp-fiEBCDIC: Finland

cp278IANAebcdic-cp-seEBCDIC: Sweden

cp280IANAebcdic-cp-itEBCDIC: Italy

cp284IANAebcdic-cp-esEBCDIC: Spain, Latin America

cp285IANAebcdic-cp-gbEBCDIC: Great Britain

cp297IANAebcdic-cp-frEBCDIC: France

cp420IANAebcdic-cp-ar1EBCDIC: Arabic

cp424IANAebcdic-cp-heEBCDIC: Hebrew

cp500IANAebcdic-cp-chEBCDIC: Switzerland

cp870IANAebcdic-cp-roeceEBCDIC: Roece

cp870IANAebcdic-cp-yuEBCDIC: Yugoslavia

cp871IANAebcdic-cp-isEBCDIC: Iceland

cp918IANAebcdic-cp-ar2EBCDIC: Urdu

GB2312MIMEgb2312Chinese for PRC, mixed 1/2 byte

eucjisMIMEeuc-jpExtended Unix Code, packed for Japanese

JISMIMEiso-2020-jpJapanese: iso-2022-jp

SJISMIMEShift_JISJapanese: Shift JIS

Big5MIMEBig5Chinese: Big5

iso2022krMIMEeuc-krExtended Unix Code, packed for Korean
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Java Encoder NameName TypeName in XML filesCommon Name

koi8-rMIMEkoi8-rCyrillic

References
Organization for the Advancement of Structured Information Standards (OASIS)
[http://www.oasis-open.org/home/index.php]

OASIS is a not-for-profit, global consortium that drives the development, convergence and adoption of e-business
standards. Members themselves set the OASIS technical agenda, using a lightweight, open process expressly designed
to promote industry consensus and unite disparate efforts. OASIS produces worldwide standards for security, Web
services, XML conformance, business transactions, electronic publishing, topic maps and interoperability within and
between marketplaces.

World Wide Web Consortium (W3C) XML Specifications [http://www.w3.org/]

The World Wide Web Consortium (W3C) develops inter operable technologies (specifications, guidelines, software,
and tools) to lead the Web to its full potential. W3C is a forum for information, commerce, communication, and col-
lective understanding.

DocBook [http://www.docbook.org/]

DocBook is an XML/SGML vocabulary particularly well suited to books and papers about computer hardware and
software (though it is by no means limited to these applications). DocBook is officially available as a Document Type
Definition (DTD) for both XML and SGML and enjoys the support of a broad user base throughout 100's of organizations
around the world.

IBM Developer Works XML Zone [http://www-106.ibm.com/developerworks/xml/]

A gateway to all things XML and home of the Darwin Information Typing Architecture (DITA)
[http://www-106.ibm.com/developerworks/xml/library/x-dita1/] is an XML-based, end-to-end architecture for authoring,
producing, and delivering technical information. This architecture consists of a set of design principles for creating
"information-typed" modules at a topic level and for using that content in delivery modes such as online help and
product support portals on the Web.

The Unicode Consortium [http://www.unicode.org]

The Unicode Consortium is responsible for defining the behavior and relationships between Unicode characters, and
providing technical information to implementers.  The Consortium cooperates with ISO in refining the specification
and expanding the character set.  It has liaison status "C" with ISO/IEC/JTC 1/SC2/WG2, which is responsible for
ISO/IEC 10646.
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